Űrlapadatok elküldése webszolgáltatásnak

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Ha azt szeretné, hogy a felhasználók webszolgáltatásnak is elküldhessék az űrlap adatait, akkor másodlagos adatkapcsolatként is hozzárendelhet egy küldési adatkapcsolatot az űrlapsablonhoz. Attól függően, hogy a webszolgáltatás milyen típusú adatokat képes fogadni, beállíthatja úgy a küldési adatkapcsolatot, hogy csak egy megadott mező adatait, egy adott csoport összes mezőjének adatait vagy pedig az űrlap összes adatát küldje el.

A küldési adatkapcsolat hozzárendelése után konfigurálhatja úgy az űrlapsablont, hogy a felhasználók elküldhessék adataikat a webszolgáltatás számára. Ennek eredményeképpen a Microsoft Office InfoPath hozzáad egy Küldés gombot a Szokásos eszköztárhoz, valamint egy Küldés parancsot az űrlap Fájl menüjéhez. Az űrlapsablon számára testreszabhatja a küldési lehetőségeket is a következők szerint:

  • Módosíthatja a Küldés gomb szövegét a Szokásos eszköztáron, és a Küldés parancs szövegét a Fájl menüben.

  • Módosíthatja a Küldés gomb billentyűparancsát a Szokásos eszköztáron, és a Küldés parancs billentyűparancsát a Fájl menüben.

  • Létrehozhatja az űrlap elküldésekor a felhasználók számára megjelenítendő üzenetet.

  • Meghatározhatja, hogy az űrlap elküldése után az űrlap nyitva maradjon vagy bezáródjon, illetve hogy egy üres űrlap megnyíljon-e.

Küldési adatkapcsolat hozzáadása

  1. Kattintson az Eszközök menü Küldés beállításai elemére.

  2. A Küldés beállításai párbeszédpanelen jelölje be az Űrlap küldésének engedélyezése a felhasználóknak jelölőnégyzetet.

  3. Kattintson az Űrlapadatok küldése egyetlen cél megjelölésével menüpontra, majd a listából a Webszolgáltatás lehetőségre.

  4. Kattintson a Hozzáadás gombra.

  5. Az Adatkapcsolat varázslóban írja be annak a webszolgáltatásnak az elérési helyét, ahová a felhasználók elküldhetik majd adataikat, majd kattintson a Tovább gombra.

    Tipp : Ha a webszolgáltatást egy Universal Description, Discovery, and Integration (UDDI) kiszolgálón szeretné keresni, kattintson az UDDI keresésegombra, írja be annak az UDDI kiszolgálónak az elérését, amelyen keresni szeretne, majd adja meg, hogy a szolgáltatók vagy a nyújtott szolgáltatások szerint szeretne-e keresni, írjon be kulcsszót a kereséshez, végül kattintson a Keresés gombra. A kulcsszónak megfelelő webszolgáltatások megjelennek a Keresési eredmények listában.

  6. A varázsló következő lapján a Művelet kiválasztása listából kattintson arra a webszolgáltatásra, amelyből az űrlapadatokat fogadni szeretné, majd kattintson a Tovább gombra.

  7. A varázsló következő lapján válassza ki, melyik adatokat szeretné elküldeni a webszolgáltatás egyes paraméterei számára, a következők szerint:

    Mezőben vagy csoportban található adatok elküldése

    1. A Paraméterek listából kattintson a webszolgáltatás azon paraméterére, amely az űrlap adatait fogja fogadni.

    2. A Paraméterbeállítások lehetőségben kattintson a Mező vagy csoport elemre.

    3. Kattintson a Gombkép módosításagombra.

    4. A Mező vagy csoport kijelölése párbeszédpanelen kattintson arra a mezőre vagy csoportra, amelynek az adatait el szeretné küldeni, majd kattintson az OK gombra.

    5. A Tartalom mezőben kattintson a Csak szöveg és gyermekelemek elemre, ha csak ennek a mezőnek az adatait és a mező vagy csoport gyermekelemeit szeretné elküldeni, illetve az XML-részfa a kijelölt elemmel együtt elemre, ha a mezőnevet, a mező adatait és a mező vagy csoport gyermekelemeit szeretné elküldeni.

    Az űrlapban található összes adat elküldése

    1. A Paraméterek listából kattintson a webszolgáltatás azon paraméterére, amely az űrlap adatait fogja fogadni.

    2. A Paraméterbeállítások csoportban jelölje be a Teljes űrlap (XML-dokumentum a feldolgozási utasításokkal együtt) választógombot.

    Adatok küldése karakterláncként

    1. A Paraméterek listából kattintson a webszolgáltatás azon paraméterére, amely az űrlap adatait fogja fogadni.

    2. A Paraméterbeállítások csoportban jelölje be a Teljes űrlap (XML-dokumentum a feldolgozási utasításokkal együtt) választógombot.

    3. Jelölje be az Adatok küldése karakterláncként jelölőnégyzetet.

      Megjegyzés : Ezt a jelölőnégyzetet digitálisan aláírt adatok küldésekor jelölje be. A legtöbb esetben a négyzetet nem szükséges bejelölnie.

    Technikai részletek a Microsoft ADO.NET DataSet-objektumokról

    Ha a webszolgáltatás ADO.NET DataSet-objektumot igényel, válasszon ki egy DataSet-csomópontot az adatkapcsolat konfigurálása során. Ha más típusú csomópontot használ az olyan webszolgáltatással való adatkapcsolatnál , amely ADO DataSet-objektumot igényel, akkor a küldési művelet meghiúsul.

  8. Kattintson a Tovább gombra.

  9. A varázsló következő lapján, az Adja meg az adatkapcsolat nevét mezőben adjon meg leíró nevet ehhez az adatküldési kapcsolatnak.

    1. Ha más nevet szeretne adni az űrlapküldéskor a Szokásos eszköztáron látható Küldés gombnak, valamint a Fájl menüben megjelenő Küldés parancsnak, írja be az új nevet a Küldés beállításai párbeszédpanel Felirat mezőjébe.

      Tipp : Ha billentyűparancsot kíván rendelni ehhez a gombhoz és a parancshoz, írjon egy „és” (&) jelet a billentyűparancsként használandó karakter elé (az ALT+D billentyűkombináció választása esetén például írja a Küldés nevet Kül&dés formában).

  10. Az Összegzés szakaszban ellenőrizze, hogy minden adat helyes legyen, majd kattintson a Befejezés gombra.

  11. Ha engedélyezni szeretné a felhasználónak a Küldés parancs vagy a Szokásos eszköztár Küldés gombjának használatát az űrlap kitöltése közben, akkor jelölje be A Küldés menüpont és a Küldés eszköztárgomb megjelenítése jelölőnégyzetet.

    1. Az InfoPath az űrlapok elküldését követően alapértelmezés szerint megnyitva tartja az űrlapot, és megjelenít egy, az űrlap sikeres elküldéséről szóló üzenetet. Ennek az alapértelmezett működésnek a módosításához kattintson a Speciális gombra, majd hajtsa végre az alábbiak egyikét:

      1. Ha azt szeretné, hogy a kitöltött űrlap elküldése után a program bezárja az űrlapot vagy egy új, üres űrlapot hozzon létre, jelölje ki az Elküldést követően lista kívánt elemét.

      2. Ha az elküldés sikerességét egy egyéni üzenettel kívánja jelezni, jelölje be az Egyéni üzenetek használata jelölőnégyzetet, majd írja be a kívánt szöveget a Siker esetén és Sikertelenség esetén mezőbe.

        Tipp : A Sikertelenség esetén mezőbe az elküldés sikertelensége esetén elvégzendő lépéseket írja; javasolhatja például a felhasználóknak, hogy mentsék az űrlapot, és lépjenek kapcsolatba a megfelelő személlyel a további utasítások végett.

      3. Ha nem kíván semmilyen üzenetet megjeleníteni az űrlap elküldését követően, törölje az Üzenetek megjelenítése a sikeres és a sikertelen végrehajtásról jelölőnégyzet jelölését.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×