Űrlap adatainak tárolása dokumentumtárban

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

A felhasználók összes adata tárolható és rendszerezhető egy dokumentumtárban olyan kiszolgálón, amelyen a Microsoft Windows SharePoint Services fut. A dokumentumtárban a felhasználók kitölthetik az űrlapsablonon alapuló űrlapokat, a kitöltött űrlap adatait exportálhatják Microsoft Office Excel 2003 alkalmazásba vagy Microsoft Office Excel 2007 programba, illetve össze is vonhatják több űrlap adatait.

Ahhoz, hogy a felhasználók az űrlapsablonra alapuló űrlapokat küldhessenek be a dokumentumtárba, hozzá kell adnia egy másodlagos adatkapcsolatot ahhoz az űrlapsablonhoz, amely az adatok beküldését végzi. A küldési adatkapcsolat hozzáadása után az űrlapsablon beállításával engedélyeznie kell, hogy a felhasználók beküldhessék az űrlap adatait a dokumentumtárba. Ilyenkor a Microsoft Office InfoPath hozzáad egy Küldés gombot a Szokásos eszköztárhoz, valamint egy Küldés parancsot az űrlap Fájl menüjéhez. Az űrlapsablon leadási lehetőségei testre is szabhatók a következők szerint:

  • Módosíthatja a Küldés gomb szövegét a Szokásos eszköztáron, és a Küldés parancs szövegét a Fájl menüben.

  • Módosíthatja a Küldés gomb billentyűparancsát a Szokásos eszköztáron, és a Küldés parancs billentyűparancsát a Fájl menüben.

  • Létrehozhatja az űrlap elküldésekor a felhasználók számára megjelenítendő üzenetet.

  • Meghatározhatja, hogy az űrlap elküldése után az űrlap nyitva maradjon vagy bezáródjon, illetve hogy egy üres űrlap megnyíljon-e.

Küldési adatkapcsolat hozzáadása

  1. Kattintson az Eszközök menü Küldés beállításai elemére.

  2. A Küldés beállításai párbeszédpanelen jelölje be az Űrlap küldésének engedélyezése a felhasználóknak jelölőnégyzetet.

  3. Kattintson az Űrlapadatok küldése egyetlen cél megjelölésével menüpontra, majd kattintson a lista SharePoint-dokumentumtár pontjára.

  4. Kattintson a Hozzáadás gombra.

  5. Az Adatkapcsolat varázsló Dokumentumtár mezőjébe írja be a SharePoint-dokumentumtár elérési helyét.

  6. A Fájlnév mezőbe pedig írja be azt a nevet, amellyel az űrlapra lehet majd hivatkozni a dokumentumtárban.

    Tipp : Használhat képletet is annak biztosítására, hogy minden űrlapnév egyedi legyen.

    Hogyan?

    1. Kattintson a Képlet beszúrása Gombkép gombra.

    2. A Képlet beszúrása párbeszédpanelen a következőket teheti:

      • Ha a képletben egy mezőt szeretne használni, kattintson a Mező vagy csoport beszúrása lehetőségre, majd a Mező vagy csoport kijelölése párbeszédpanelen arra a mezőre, amelyiket használni szeretné, végül az OK gombra.

      • Ha a képletben függvényt szeretne használni, kattintson a Függvény beszúrása lehetőségre, majd a Függvény beszúrása párbeszédpanelen arra a függvényre, amelyiket használni szeretné, végül az OK gombra

        Tipp : Ha a függvény paramétereket igényel, jelölje ki a függvényt a Függvény beszúrása párbeszédpanelen, kattintson az OK gombra, majd a Függvény beszúrása párbeszédpanel Képlet mezőjében kattintson duplán a hozzáadott függvényre, majd kattintson a mezőre vagy csoportra. A függvényekről további információt a Lásd még szakasz hivatkozásai révén kaphat.

      • Ha értéket vagy matematikai műveleti jelet szeretne a képletbe illeszteni, írja az értéket vagy a műveleti jelet a Képlet mezőbe.

    Művelet

    Szimbólum

    Hozzáadás

    +

    Kivonás

    -

    Szorzás

    *

    Osztás

    /

    • Megjegyzés : Ha a képletben az osztás (/) operátor szerepel, ellenőrizze, hogy előtte és utána is legyen szóköz. Ha az operátor nem szóközök között szerepel, akkor az InfoPath a „/” jelet XPath elérési útvonalat határoló jelként értelmezi.

    • Ha a képlet szintakszisának helyességét szeretné ellenőrizni, kattintson a Képlet beszúrása párbeszédpanel Képlet ellenőrzése gombjára.

      A képletekről további információt a Lásd még szakasz hivatkozásait követve kaphat.

  7. Ha engedélyezni szeretné a dokumentumtárban található azonos nevű űrlapok felülírását, jelölje be a Felülírás engedélyezése, ha a fájl már létezik jelölőnégyzetet.

  8. Kattintson a Tovább gombra.

  9. A varázsló következő lapján, az Adja meg az adatkapcsolat nevét mezőben adjon meg leíró nevet ehhez az adatküldési kapcsolatnak.

  10. Az Összegzés szakaszban ellenőrizze, hogy minden adat helyes-e, majd kattintson a Befejezés gombra.

    1. Ha más nevet szeretne adni az űrlapküldéskor a Szokásos eszköztáron látható Küldés gombnak, valamint a Fájl menüben megjelenő Küldés parancsnak, írja be az új nevet a Küldés beállításai párbeszédpanel Felirat mezőjébe.

      Tipp : Ha billentyűparancsot kíván rendelni ehhez a gombhoz és a parancshoz, írjon egy „és” (&) jelet a billentyűparancsként használandó karakter elé (az ALT+D billentyűkombináció választása esetén például írja a Küldés nevet Kül&dés formában).

  11. Ha nem szeretné, hogy a felhasználók a Küldés parancsot vagy a Szokásos eszköztár Küldés gombját használják az űrlap kitöltésekor, akkor törölje A Küldés menüpont és a Küldés eszköztárgomb megjelenítése jelölőnégyzet jelölését.

    1. Az InfoPath az űrlapok elküldését követően alapértelmezés szerint megnyitva tartja az űrlapot, és megjelenít egy, az űrlap sikeres elküldéséről szóló üzenetet. Ennek az alapértelmezett működésnek a módosításához kattintson a Speciális gombra, majd hajtsa végre az alábbiak egyikét:

      1. Ha azt szeretné, hogy a kitöltött űrlap elküldése után a program bezárja az űrlapot vagy egy új, üres űrlapot hozzon létre, jelölje ki az Elküldést követően lista kívánt elemét.

      2. Ha az elküldés sikerességét egy egyéni üzenettel kívánja jelezni, jelölje be az Egyéni üzenetek használata jelölőnégyzetet, majd írja be a kívánt szöveget a Siker esetén és Sikertelenség esetén mezőbe.

        Tipp : A Sikertelenség esetén mezőbe az elküldés sikertelensége esetén elvégzendő lépéseket írja; javasolhatja például a felhasználóknak, hogy mentsék az űrlapot, és lépjenek kapcsolatba a megfelelő személlyel a további utasítások végett.

      3. Ha nem kíván semmilyen üzenetet megjeleníteni az űrlap elküldését követően, törölje az Üzenetek megjelenítése a sikeres és a sikertelen végrehajtásról jelölőnégyzet jelölését.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×