Írásvédett nézetek tervezése

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

A Microsoft Office InfoPath programban számos különböző nézetet hozhat létre egyazon űrlapsablonhoz. A nézet az űrlapsablonban lévő adatok megjelenítésének egy eltérő módját határozza meg. Az űrlapsablonon alapuló űrlapok kitöltésekor a felhasználók a nézetek közötti váltással akár az űrlapon megjelenített információk mennyiségét is megszabhatják. Egy állapotjelentésről szóló űrlapsablon esetén például a részletes nézet mellé tervezhet egy összegző nézetet is; ily módon a felhasználók az általuk szükségesnek tartott adatok alapján könnyedén eldönthetik, melyik nézetet kívánják használni.

Ez a cikk azt ismerteti, hogy miként tervezhetők olyan nézetek, amelyeket a felhasználók nem módosíthatnak. Bemutatja azt is, hogy szabályok alkalmazásával hogyan lehet automatikusan az űrlapok írásvédett nézetére váltani, ha a felhasználó egy szerkeszthető nézetben adott gombra kattint.

Tartalom

Írásvédett nézetek tervezése

Szerkeszthető és írásvédett nézet közötti váltásra szolgáló gomb beszúrása

Az űrlapok elküldésekor írásvédett nézetre váltó gomb beszúrása

Írásvédett nézetek tervezése

Írásvédett nézetek alkalmazása akkor hasznos, ha az űrlapra bevitt adatokat össze szeretné foglalni a felhasználóknak, de nem szeretné, ha ilyenkor azokat véletlenül módosítanák. Tegyük fel például, hogy meg szeretné akadályozni, hogy a felhasználók módosítsák a kitöltött űrlapok adatait, miután elküldték azt egy webszolgáltatásba. Az űrlapsablonban beállíthatja, hogy amikor a felhasználó az űrlap Küldés gombjára kattint, az űrlap szerkeszthető nézetről írásvédett nézetre váltson. Ezzel lehetővé teheti az elküldött adatok áttekintését, de módosítását megakadályozhatja.

  1. Válassza a Nézet menü Nézetek kezelése parancsát.

  2. A Műveletek csoportban kattintson az Új nézet hozzáadása hivatkozásra.

  3. Írja be a nézet nevét a Nézet hozzáadása párbeszédpanelen, majd kattintson az OK gombra.

  4. Elrendezési táblázatok és vezérlők felvételével alakítsa ki a nézetet.

    Tipp : Ha meglévő nézet alapján szeretné megtervezni az új nézetet, nyissa meg a meglévő nézetet, nyomja le a CTRL+A billentyűkombinációt a nézet minden elemének kijelöléséhez, majd a CTRL+C billentyűkombinációval másolja a kijelölt részeket a Vágólapra. A Nézetek munkaablakban váltson át az új nézetre, majd nyomja le a CTRL+V billentyűkombinációt a kijelölt rész új nézetbe történő beillesztéséhez. Ekkor törölheti azokat a vezérlőket vagy elrendezési elemeket, amelyekre nincs szüksége az új nézetben.

  5. Kattintson a Nézetek munkaablak Nézet tulajdonságai gombjára.

  6. Kattintson az Általános fülre.

  7. A Nézet beállításai csoportban jelölje be az Írásvédett jelölőnégyzetet, majd kattintson az OK gombra.

  8. A nézet írásvédett voltának ellenőrzéséhez a Szokásos eszköztáron kattintson a Megjelenítés gombra.

  9. Az előnézeti ablakban győződjön meg arról, hogy nem lehet adatokat beírni az űrlapra.

  10. A tervező módba való visszatéréshez kattintson a Szokásos eszköztár Minta bezárása gombjára.

Vissza a lap tetejére

Szerkeszthető és írásvédett nézet közötti váltásra szolgáló gomb beszúrása

A nézetek gyakran gombokkal és szabályokkal működnek; ennek köszönhetően az űrlapsablonban az űrlapot kitöltő személyek által kezdeményezett eseményekre vagy műveletekre válaszul adott egyes feladatok automatizálhatók. Beszúrhat például egy gombot a sablonba, majd létrehozhat egy szabályt, amely a gombra kattintva másik nézetre vált. A következő példában az űrlaptervező létrehozott egy olyan szabályt a Szabály párbeszédpanelen, amely írásvédett összefoglaló nézetre vált. A szabály akkor fut le, amikor a felhasználó a gombra kattint az űrlapon.

A Szabály párbeszédpanel részlete

Nézetek között váltó gomb beszúrása

  1. Válassza a Nézet menü Nézetek kezelése parancsát.

  2. A Nézet kiválasztása listában jelölje ki azt a szerkeszthető nézetet, amelybe a gombot be szeretné szúrni.

  3. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  4. Helyezze az egérmutatót az űrlapsablon azon pontjára, ahová be szeretné szúrni a gombot.

  5. A Vezérlők beszúrása listában kattintson a Gomb elemre.

  6. Az űrlapsablonban kattintson duplán a beszúrt gombra.

  7. Kattintson az Általános fülre.

  8. A Művelet listában válassza a Szabályok és egyéni kód elemet.

  9. A Címke mezőbe írja be a gombon megjeleníteni kívánt szöveget.

  10. Kattintson a Szabályok gombra.

  11. A Szabályok párbeszédpanelen kattintson a Hozzáadás gombra.

  12. A Név mezőbe írja be a szabály nevét.

  13. Kattintson a Művelet hozzáadása gombra.

  14. A Művelet listában válassza a Nézetváltás lehetőséget.

  15. A Nézet listában jelölje ki azt a nézetet, amelyre a gombbal váltani szeretne, majd kattintson az OK gombra.

  16. Az OK gombra kattintva zárja be az összes megnyitott párbeszédpanelt.

  17. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

  18. Az előnézeti ablakban kattintson a gombra.

    Megnyílik a 15. lépésben definiált nézet.

  19. A tervező módba való visszatéréshez kattintson a Szokásos eszköztár Minta bezárása gombjára.

  20. Ha az írásvédett nézethez egy másik gombot – és szabályt – szeretne adni, amelyre kattintva a felhasználó visszaléphet a szerkeszthető nézetre, nyissa meg az írásvédett nézetet, és ismételje meg a 3–19. lépést.

Vissza a lap tetejére

Az űrlapok elküldésekor írásvédett nézetre váltó gomb beszúrása

Az alábbi eljárás azt ismerteti, hogy miként vehet fel olyan gombot az űrlapsablonba, amely az elküldött adatok írásvédett nézetét jeleníti meg. Ilyen gombra például állapotjelentéseken lehet szükség, amelyeken lehetővé szeretné tenni a felhasználóknak, hogy az alapértelmezett nézetről írásvédett, összefoglaló nézetre váltsanak, és megtekintsék az űrlap adatait.

Megjegyzés : Ez az eljárás csak akkor működik, ha az űrlapsablon az űrlapadatok elküldéséhez már rendelkezik adatkapcsolat. Ha még nem állított be adatkapcsolatot az adatok elküldéséhez, az eljárás elvégzése előtt ezt meg kell tennie, ellenkező esetben a lépések nem hozzák meg a kívánt eredményt. Az adatkapcsolatokra vonatkozó további információkra mutató hivatkozásokat a Lásd még szakaszban talál.

  1. Válassza a Nézet menü Nézetek kezelése parancsát.

  2. A Nézet kiválasztása listában jelölje ki azt a nézetet, amelyben a Küldés gombot el szeretné helyezni.

  3. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  4. Helyezze az egérmutatót az űrlapsablon azon pontjára, ahová be szeretné szúrni a gombot.

  5. A Vezérlők beszúrása listában kattintson a Gomb elemre.

  6. Az űrlapsablonban kattintson duplán a beszúrt gombra.

  7. Kattintson az Általános fülre.

  8. A Művelet listában válassza a Küldés lehetőséget.

  9. Ha a gombon más feliratot szeretne megjeleníteni (nem azt, hogy „Küldés”), a Címke mezőbe írja be a kívánt szöveget.

  10. Kattintson a Küldés beállításai gombra.

  11. A Küldés beállításai párbeszédpanelen jelölje be az Űrlap küldésének engedélyezése a felhasználóknak jelölőnégyzetet.

  12. Jelölje be az Egyéni műveletek végrehajtása szabályok használatával választógombot, majd kattintson a Szabályok gombra.

  13. Az Űrlapok elküldésére vonatkozó szabályok párbeszédpanelen kattintson a Hozzáadás gombra.

  14. Írja be a Név mezőbe a szabály nevét, majd kattintson a Művelet hozzáadása gombra.

  15. A Művelet listában válassza a Nézetváltás lehetőséget.

  16. A Nézet listában jelölje ki azt az írásvédett nézetet, amelyre a gombbal váltani szeretne, majd kattintson az OK gombra.

  17. Az OK gombra kattintva zárja be az összes megnyitott párbeszédpanelt.

  18. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

  19. Az előnézeti ablakban kattintson az űrlap elküldésére szolgáló gombra.

    Megnyílik az írásvédett nézet.

  20. A tervező módba való visszatéréshez kattintson a Szokásos eszköztár Minta bezárása gombjára.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×