Írásvédett nézetek tervezése

Megjegyzés:  Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja .

A Microsoft Office InfoPath űrlapsablon megegyezik a különböző nézeteinek is létrehozhat. Nézet használata alternatív módszer adatok ábrázolása űrlapsablon. A sablonon alapuló űrlapok kitöltése, amikor a felhasználó választhatja ki a képernyőn látható adatok mennyiségét nézet közötti válthat. Például állapot jelentés űrlapsablon, tervezhet összegzés nézet részletes áttekintést adnak mellett. Felhasználók majd választhatnak melyik nézetben azok a szeretné tekinteni, attól függően, hogy milyen típusú információkat szükség.

Ez a cikk ismerteti, amelyek nem szerkeszthetők a felhasználók-nézet tervezése. Azt is megtudhatja, hogyan szabályok használatára automatikusan nézetre szeretne váltani egy csak olvasható űrlap, amikor a felhasználó az írási és olvasási nézetben egy gombra kattint.

Kapcsolódó műveletek

Írásvédett nézetek tervezése

Csak olvasható és írási és olvasási nézet közötti váltás gomb beszúrása

Az űrlap elküldése után – a csak olvasható nézetre váltja gomb beszúrása

Írásvédett nézetek tervezése

Írásvédett nézetek hasznosak, ha szeretné összesíteni űrlapadatok felhasználók számára, és nem szeretne velük véletlenül se módosítsa az adatokat. Tegyük fel például, hogy szeretne-e felvételével megelőzheti, hogy a felhasználók ne módosíthassák a egy űrlap adatainak elküldése webszolgáltatásnak után. Kattintáskor az űrlapon Küldés gomb, beállíthatja a űrlapsablon nézetre szeretne váltani az adatok írási és olvasási nézet egy írásvédett. Lehetővé teszi a felhasználóknak, hogy az általuk beküldött adatok megtekintéséhez, de segít megakadályozza, hogy a azokat meg módosítása.

  1. A Nézet menüben kattintson a Nézetek kezeléseparancsra.

  2. A Műveletekcsoportban kattintson az Új nézet hozzáadásagombra.

  3. Nézet hozzáadása párbeszédpanelen írja be a nézet nevét, és kattintson az OKgombra.

  4. A nézet Tervező elrendezéstáblázatok és vezérlőelemek hozzáadásával rá.

    Tipp: Ha szeretne egy új nézetet meglévő nézet alapján, a meglévő nézet megnyitásához nyomja le a CTRL + A billentyűkombinációval jelölje ki a nézet tartalmát, és nyomja le a CTRL + C billentyűkombinációval másolja a kijelölést a vágólapra. A nézetek munkaablak az új nézetet, és nyomja le a CTRL + V billentyűkombinációval illessze be az új nézet a kijelölés. Ezen a ponton törölhet bármely vezérlők vagy elrendezési elemeit, amelyre nincs szüksége a az új nézet.

  5. A nézetek munkaablak kattintson a Tulajdonságok megtekintéseelemre.

  6. Kattintson az Általános fülre.

  7. A Nézet beállításaicsoportban jelölje be a csak olvasható jelölőnégyzetet, és kattintson az OKgombra.

  8. Ellenőrizze, hogy a nézet csak olvasható, kattintson a szokásos eszköztáron az Előnézet gombra.

  9. Az előnézeti ablakban győződjön meg arról, hogy nem adhat meg adatokat az űrlapon.

  10. Tervező módban való visszatéréshez kattintson a Kép bezárása gombra a szokásos eszköztáron.

Vissza a lap tetejére

Csak olvasható és írási és olvasási nézet közötti váltás gomb beszúrása

Nézetek használata a gombok és szabályok, amelyek lehetővé teszi, hogy az egyes műveletek automatizálhatók a eseményekre vagy az űrlapot kitöltő felhasználó által kezdeményezett műveletek az űrlapsablon gyakran szolgálnak. Ha például-gomb beszúrása az űrlapon, és majd hozzon létre egy szabályt, amely a nézetet vált, hogy gombra kattintáskor. A következő példában az űrlap tervezőjének a szabály párbeszédpanel, amely csak olvasható összegzés nézet – Váltás a szabály hozott létre. Ez a szabály fut, amikor a felhasználók egy gombra a képernyőn.

A Szabály párbeszédpanel részlete

Nézetek közötti váltás gomb beszúrása

  1. A Nézet menüben kattintson a Nézetek kezeléseparancsra.

  2. Jelöljön ki egy nézetet, csoportban kattintson az írási és olvasási nézet hozzáadása gomb a kívánt.

  3. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  4. Az űrlapsablonon helyezze a kurzort, ahová beszúrása a gombra.

  5. A Vezérlők beszúrásacsoportjában kattintson a gombra.

  6. Az űrlapsablonon kattintson duplán az imént beszúrt gombra.

  7. Kattintson az Általános fülre.

  8. A művelet listában kattintson a szabályok és egyéni kódelemre.

  9. A címke mezőbe írja be a szöveget, amelyet meg szeretné jeleníteni a gombra.

  10. Kattintson a szabályokelemre.

  11. A szabályok párbeszédpanelen kattintson a Hozzáadásgombra.

  12. A név mezőbe írja be a szabály nevét.

  13. Kattintson a művelet hozzáadásagombra.

  14. A művelet listában kattintson a Nézetváltás.

  15. A Nézet listában kattintson arra a nézetre, amelyet váltani szeretne, és kattintson az OKgombra.

  16. Kattintson az OK gombra az összes megnyitott párbeszédpanel bezárásához.

  17. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

  18. Az előnézeti ablakban kattintson a gombra.

    A nézet 15 lépésben megadott nyíljon meg.

  19. Tervező módban való visszatéréshez kattintson a Kép bezárása gombra a szokásos eszköztáron.

  20. Egy második hozzáadása gomb és a szabályt, amely az írásvédett nézetek, hogy a felhasználók válthat az írási és olvasási nézethez való visszatéréshez a csak olvasható nézet megnyitásához, és ezután ismételje meg a 3 – 19.

Vissza a lap tetejére

Az űrlap elküldése után – a csak olvasható nézetre váltja gomb beszúrása

Az alábbi eljárás gomb felvétele a beküldött adatok csak olvasható nézetének megjelenítő űrlapsablon ismerteti. Előfordulhat, hogy ezt megteheti a egy – állapotjelentő űrlap, ha engedélyezése a felhasználóknak az űrlap adatainak csak olvasható összefoglaló nézete egy alapértelmezett nézet váltani szeretne.

Megjegyzés: Ez az eljárás csak akkor, ha az űrlapsablon tartalmaz egy meglévő adatkapcsolat az űrlapadatok működik. Ha még a Küldés adatkapcsolat még nem konfigurálta, ez az eljárás befejezése előtt kell megtennie, vagy az alábbi lépések nem használhatók. Adatkapcsolatok kapcsolatban további információkat a Lásd még című szakaszban találhat.

  1. A Nézet menüben kattintson a Nézetek kezeléseparancsra.

  2. Jelöljön ki egy nézetet, csoportban kattintson a használni kívánt tartalmazzák, a Küldés gomb megtekintése.

  3. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  4. Az űrlapsablonon helyezze a kurzort, ahová beszúrása a gombra.

  5. A Vezérlők beszúrásacsoportjában kattintson a gombra.

  6. Az űrlapsablonon kattintson duplán az imént beszúrt gombra.

  7. Kattintson az Általános fülre.

  8. A művelet listában kattintson a Küldés gombra.

  9. Ha azt szeretné, hogy nem jelennek meg a gomb felirata a "Küldés" szöveg, írja be a szöveget, amelyet a felirat mezőbe.

  10. Kattintson a Küldés a beállításokgombra.

  11. A Küldés beállításai párbeszédpanelen győződjön meg arról, hogy a engedélyezése a felhasználók számára nyújt a képernyőn jelölőnégyzet be van-e jelölve.

  12. Kattintson a szabályok használatával egyéni művelet végrehajtása, és kattintson a szabályokgombra.

  13. Űrlapok elküldése szabályai párbeszédpanelen kattintson a Hozzáadásgombra.

  14. A név mezőbe írja be a szabály nevét, és válassza a Művelet hozzáadása.

  15. A művelet listában kattintson a Nézetváltás.

  16. A Nézet listában kattintson a csak olvasható nézetre, amelyet váltani szeretne, és kattintson az OKgombra.

  17. Kattintson az OK gombra az összes megnyitott párbeszédpanel bezárásához.

  18. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

  19. A betekintő ablakban kattintson a gombra, használja az űrlap elküldéséhez.

    A csak olvasható nézetben nyílik meg.

  20. Tervező módban való visszatéréshez kattintson a Kép bezárása gombra a szokásos eszköztáron.

Vissza a lap tetejére

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×