Értékek kikeresése az FKERES, az INDEX és a HOL.VAN függvénnyel

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Tegyük fel, hogy van egy irodaszámokat tartalmazó listája, és szeretné kikeresni, hogy kik dolgoznak az egyes irodákban. Mit tehet, ha a számolótábla nagyon nagy? Egy keresőfüggvényt használhat. Az FKERES és VKERES függvény csak kettő a leghasznosabbak közül, de ilyen az INDEX és a HOL.VAN függvény is.

Megjegyzés :  Ha a Keresés varázslót próbálja megtalálni, ne tegye: ez a funkció már nem része az Excelnek.

Az alábbiakban gyorsan felidézzük, hogyan használhatja az FKERES függvényt.

=FKERES(B2;C2:E7;3;IGAZ)

Az első argumentum – olyan adat, amely a függvény működéséhez szükséges – a keresett érték. Ez megadható cellahivatkozással vagy a pontos értékkel is, például mint „Lukács” vagy 21 000. A második argumentum az a cellatartomány, amely várhatóan tartalmazza a keresett értéket. Ebben a példában ez a C2-C7 sor. A harmadik argumentum a cellatartománynak azt az oszlopát adja meg, amely a megjeleníteni kívánt értéket tartalmazza.

A negyedik argumentumot nem kötelező megadni. Ennek Igaz és Hamis értéke lehet. Ha IGAZ értéket ad meg, vagy üresen hagyja az argumentumot, akkor a függvény az első argumentumként megadott értékhez közelítő találatot ad eredményül. Ha a HAMIS értéket adja meg, akkor a függvény csak az első argumentummal pontosan megegyező értéket veszi figyelembe. Más szóval ha nem adja meg a negyedik argumentumot, vagy IGAZ értéket ad meg, akkor rugalmasabban kereshet.

Az alábbi példa bemutatja, hogyan működik a függvény. Amikor megad egy értéket a B2 cellában (első argumentum), az FKERES keresést végez a C2-E7 tartományban (második argumentum), majd visszaadja a legközelebb eső találatot a tartomány harmadik oszlopából, az E oszlopból (harmadik argumentum).

Az FKERES függvény jellemző használata

A negyedik argumentum üres, így a függvény körülbelüli találatot ad eredményül. Ha nem adna eredményt, akkor a C vagy D oszlop értékeinek egyikét kell megadnia, hogy a keresésnek egyáltalán legyen eredménye.

Ha már magabiztosan használja az FKERES függvényt, akkor a VKERES függvény használata sem okozhat gondot. Ugyanezeket az argumentumokat kell megadnia, csak a függvény nem oszlopokban, hanem sorokban keresi meg az értékeket.

Tegyen egy próbát!

Ha el szeretne kicsit játszani a keresési függvényekkel, mielőtt a saját adatain kipróbálná őket, használja az alábbi mintaadatokat. Egyesek az FKERES és a VKERES, mások az INDEX és a HOL.VAN függvény együttes használatát részesítik előnyben. Próbálja ki mindegyiket, és döntse el, melyik tetszik a legjobban.

Példa az FKERES függvényre

Másolja a táblázat összes celláját a vágólapra, és illessze be egy üres Excel-munkalapra az A1 cellába.

Tipp:    Mielőtt beillesztené az adatokat az Excelben, állítsa az A, a B és a C oszlop szélességét 250 képpontra, majd kattintson a Sortöréssel több sorba gombra (Kezdőlap lap, Igazítás csoport).

Sűrűség

Viszkozitás

Hőmérséklet

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Képlet

Leírás

Eredmény

'=FKERES(1;A2:C10;2)

Közelítő egyezést használva megkeresi az A oszlopban az 1 értéket, majd ugyanebben az oszlopban az egynél nem nagyobb legnagyobb értéket (0,946), és ugyanebben a sorban megjeleníti a B oszlopbeli értéket.

=FKERES(1;A2:C10;2)

'=FKERES(1;A2:C10;3;IGAZ)

Közelítő egyezést használva megkeresi az A oszlopban az 1 értéket, majd ugyanebben az oszlopban az egynél nem nagyobb legnagyobb értéket (0,946), és ugyanebben a sorban megjeleníti a C oszlopbeli értéket.

=FKERES(1;A2:C10;3;IGAZ)

'=FKERES(0,7;A2:C10;3;HAMIS)

Pontos egyezést használva megkeresi a 0,7 értéket az A oszlopban. Mivel ez az oszlop nem tartalmaz pontos egyezést, a művelet hibát ad vissza.

=FKERES(0,7;A2:C10;3;HAMIS)

'=FKERES(0,1;A2:C10;2;IGAZ)

Közelítő egyezést használva megkeresi a 0,1 értéket az A oszlopban. Mivel ez az érték kisebb az A oszlop legkisebb értékénél, a művelet hibát ad vissza.

=FKERES(0,1;A2:C10;2;IGAZ)

'=FKERES(2;A2:C10;2;IGAZ)

Közelítő egyezést használva megkeresi az A oszlopban a 2 értéket, majd ugyanebben az oszlopban a kettőnél nem nagyobb legnagyobb értéket (1,29), és ugyanebben a sorban megjeleníti a B oszlopbeli értéket.

=FKERES(2;A2:C10;2;IGAZ)

Példa a VKERES függvényre

Másolja a táblázat összes celláját a vágólapra, és illessze be egy üres Excel-munkalapra az A1 cellába.

Tipp:    Mielőtt beillesztené az adatokat az Excelben, állítsa az A, a B és a C oszlop szélességét 250 képpontra, majd kattintson a Sortöréssel több sorba gombra (Kezdőlap lap, Igazítás csoport).

Tengelyek

Csapágyak

Csapszegek

4

4

9

5

7

10

6

8

11

Képlet

Leírás

Eredmény

'=VKERES("Tengelyek";A1:C4;2;IGAZ)

A „Tengelyek” szó megkeresése az 1. sorban, majd az ugyanazon oszlop (A oszlop) 2. sorában lévő érték visszaadása

=VKERES("Tengelyek";A1:C4;2;IGAZ)

'=VKERES("Csapágyak"; A1:C4; 3; HAMIS)

A „Csapágyak” szó megkeresése az 1. sorban, majd az ugyanazon oszlop (B oszlop) 3. sorában lévő érték visszaadása

=VKERES("Csapágyak";A1:C4;3;HAMIS)

'=VKERES("B"; A1:C4; 3; IGAZ)

A „D” érték keresése az 1. sorban, majd az ugyanazon oszlop 3. sorában lévő érték visszaadása. Mivel nem található pontos találat a „D” értékre, a „D”-nél kisebb legnagyobb értéket („Csapágyak”) adja vissza a B oszlopban

=VKERES("B";A1:C4;3;IGAZ)

'=VKERES("Csapszegek";A1:C4;4)

A „Csapszegek” szó megkeresése az 1. sorban, majd az ugyanazon oszlop (C oszlop) 4. sorában lévő érték visszaadása

=VKERES("Csapszegek";A1:C4;4)

'=VKERES(3; {1;2;3;"a";"b";"c";"d";"e";"f"};2;IGAZ)

A 3 érték keresése a háromsoros tömbállandóban, és ugyanazon oszlop (ebben az esetben a 3. oszlop) 2. sorában lévő érték visszaadása. A tömbállandóban három, egymástól pontosvesszővel (;) elválasztott értéksor található. Mivel a „c” megtalálható a 2. sorban és ugyanabban az oszlopban, mint a 3., a visszaadott érték a „c”.

=VKERES(3;{1;2;3;"a";"b";"c";"d";"e";"f"};2;IGAZ)

Példa az INDEX és a HOL.VAN függvényre

Ebben a példában az INDEX és a HOL.VAN függvényt együtt alkalmazva szeretnénk megjeleníteni a legrégebbi számlaszámot és a hozzá tartozó dátumot mind az öt településhez. Mivel a dátum számként jelenik meg, a SZÖVEG függvénnyel dátumként formázzuk. Az INDEX függvény a HOL.VAN függvény eredményét használja argumentumként. Az INDEX és a HOL.VAN függvény kombinációját mindegyik képletben kétszer használjuk: először a számlaszám megjelenítéséhez, másodszor pedig a dátum kiszámításához.

Másolja a táblázat összes celláját a vágólapra, és illessze be egy üres Excel-munkalapra az A1 cellába.

Tipp:    Mielőtt beillesztené az adatokat az Excelben, állítsa az A, a B, a C és a D oszlop szélességét 250 képpontra, majd kattintson a Sortöréssel több sorba gombra (Kezdőlap lap, Igazítás csoport).

Számla

Település

Számla dátuma

Legrégebbi számla település szerint, dátummal

3115

Ajka

2012. április 7.

="Ajka = "&INDEX($A$2:$C$33;HOL.VAN("Ajka";$B$2:$B$33;0);1)& "; Számla dátuma: " & SZÖVEG(INDEX($A$2:$C$33;HOL.VAN("Ajka";$B$2:$B$33;0);3);"yyyy/mm/d")

3137

Ajka

2012. április 9.

="Kőszeg = "&INDEX($A$2:$C$33;HOL.VAN("Kőszeg";$B$2:$B$33;0);1)& "; Számla dátuma: " & SZÖVEG(INDEX($A$2:$C$33;HOL.VAN("Kőszeg";$B$2:$B$33;0);3);"yyyy/mm/d")

3154

Ajka

2012. április 11.

="Hatvan = "&INDEX($A$2:$C$33;HOL.VAN("Hatvan";$B$2:$B$33;0);1)& "; Számla dátuma: " & SZÖVEG(INDEX($A$2:$C$33;HOL.VAN("Hatvan";$B$2:$B$33;0);3);"yyyy/mm/d")

3191

Ajka

2012. április 21.

="Tiszacsege = "&INDEX($A$2:$C$33;HOL.VAN("Tiszacsege";$B$2:$B$33;0);1)& "; Számla dátuma: " & SZÖVEG(INDEX($A$2:$C$33;HOL.VAN("Tiszacsege";$B$2:$B$33;0);3);"yyyy/mm/d")

3293

Ajka

2012. április 25.

="Gyula = "&INDEX($A$2:$C$33;HOL.VAN("Gyula";$B$2:$B$33;0);1)& "; Számla dátuma: " & SZÖVEG(INDEX($A$2:$C$33;HOL.VAN("Gyula";$B$2:$B$33;0);3);"yyyy/mm/d")

3331

Ajka

2012. április 27.

3350

Ajka

2012. április 28.

3390

Ajka

2012. május 1.

3441

Ajka

2012. május 2.

3517

Ajka

2012. május 8.

3124

Kőszeg

2012. április 9.

3155

Kőszeg

2012. április 11.

3177

Kőszeg

2012. április 19.

3357

Kőszeg

2012. április 28.

3492

Kőszeg

2012. május 6.

3316

Hatvan

2012. április 25.

3346

Hatvan

2012. április 28.

3372-es

Hatvan

2012. május 1.

3414

Hatvan

2012. május 1.

3451

Hatvan

2012. május 2.

3467

Hatvan

2012. május 2.

3474

Hatvan

2012. május 4.

3490-es

Hatvan

2012. május 5.

3503

Hatvan

2012. május 8.

3151

Tiszacsege

2012. április 9.

3438

Tiszacsege

2012. május 2.

3471

Tiszacsege

2012. május 4.

3160

Gyula

2012. április 18.

3328

Gyula

2012. április 26.

3368

Gyula

2012. április 29.

3420

Gyula

2012. május 1.

3501

Gyula

2012. május 6.

További tudnivalók a keresőfüggvényekről

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×