Értékek kikeresése az FKERES, az INDEX és a HOL.VAN függvénnyel

Megjegyzés:  Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja .

Tegyük fel, hogy office hely szám van, és kell tudnia, hogy mely alkalmazottak vannak az egyes office-ban. A számolótábla is nagyon nagy, ezért gondolná, azt nem könnyű feladat feladatot. Használata ténylegesen meglehetősen egyszerű a keres függvényt.

Az FKERES és VKERES , INDEX és Hol.van,valamint ezek a függvények a leghasznosabb függvények az Excelben.

Megjegyzés: A Keresés varázsló szolgáltatás már nem érhető el az Excel programban.

Íme egy példa bemutatja, hogyan használhatja az FKERES FÜGGVÉNYT.

=FKERES(B2;C2:E7;3;IGAZ)

Ebben a példában a B2 értéke az első argumentum– az adatok, a függvény elvégzendő munka valamelyik elemét. Az FKERES FÜGGVÉNY Ez az első argumentum értéke, amely a keresett. Ez az argumentum lehet cellahivatkozás vagy egy rögzített értéket, például "Kovács" és az ebből 21 000. A második argumentum az a cellatartomány, amelyben a keresett érték C2-:E7. A harmadik argumentum az a oszlopban az adott kér értéket tartalmazó cellatartományt.

A negyedik argumentum elhagyható. Adja meg az IGAZ vagy hamis. Ha igaz értéket adja meg, vagy hagyja üresen az argumentumot, a függvény megközelítő találatot ad meg az első argumentum értéke. Ha hamis értéket ad meg, a függvény egyezik-e a értéket adja meg az első argumentumban. Más szóval, hagyja a negyedik argumentum üresen – vagy írjon be igaz – további rugalmasságot biztosít.

Ebben a példában megtudhatja, hogy miként működik a függvény. Amikor megadja a B2 cella értéke (az első argumentum), az FKERES a cellák keres, a tartomány C2:E7 (2nd argumentum) és a legközelebbi megközelítő találatot ad vissza a tartományt, az e oszlop tömbképlettel harmadik oszlopának (3 argumentum).

Az FKERES függvény jellemző használata

A negyedik argumentum üres, így a függvény megközelítő találatot ad vissza. Ha nem, akkor kellene oszlopokat, C D egyáltalán jelenik meg az eredményt adja meg az értékek közül.

Ha nem okoz gondot az FKERES, a VKERES függvényt egyaránt könnyen használható. Beírt ugyanazokkal az argumentumokkal, de azt keresi, az oszlopok helyett sorok. "

Tegyen egy próbát!

Ha kísérletezni keresőfüggvényekről, mielőtt kipróbálná őket a saját adatain, az alábbiakban mintaadatokat tartalmaz. Egyes Excel-felhasználók, mint az FKERES és VKERES; mások inkább az INDEX és hol.van együttes használata. Mindegyik módszernek próbálkozzon, és ellenőrizze, melyeket, amely a legjobban tetszik.

FKERES-példa munkahelyi

Az alábbi adatokat másolja egy üres táblázatba.

Tipp:    Mielőtt beillesztené az adatokat az Excelben, állítsa az a és a C oszlop szélességét 250 képpontra, és kattintson a Szöveg körbefuttatása (Kezdőlap lap, Igazítás csoport).

Sűrűség

Viszkozitás

Hőmérséklet

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Képlet

Leírás

Eredmény

=FKERES(1,A2:C10,2)

Közelítő egyezést használva megkeresi az A oszlopban az 1 értéket, majd ugyanebben az oszlopban az egynél nem nagyobb legnagyobb értéket (0,946), és ugyanebben a sorban megjeleníti a B oszlopbeli értéket.

2,17

=FKERES(1,A2:C10,3,IGAZ)

Közelítő egyezést használva megkeresi az A oszlopban az 1 értéket, majd ugyanebben az oszlopban az egynél nem nagyobb legnagyobb értéket (0,946), és ugyanebben a sorban megjeleníti a C oszlopbeli értéket.

100

=FKERES(0,7,A2:C10,3,HAMIS)

Pontos egyezést használva megkeresi a 0,7 értéket az A oszlopban. Mivel ez az oszlop nem tartalmaz pontos egyezést, a művelet hibát ad vissza.

#HIÁNYZIK

=FKERES(0,1,A2:C10,2,IGAZ)

Közelítő egyezést használva megkeresi a 0,1 értéket az A oszlopban. Mivel ez az érték kisebb az A oszlop legkisebb értékénél, a művelet hibát ad vissza.

#HIÁNYZIK

=FKERES(2,A2:C10,2,IGAZ)

Közelítő egyezést használva megkeresi az A oszlopban a 2 értéket, majd ugyanebben az oszlopban a kettőnél nem nagyobb legnagyobb értéket (1,29), és ugyanebben a sorban megjeleníti a B oszlopbeli értéket.

1,71

Példa a VKERES FÜGGVÉNY

Másolja a táblázat összes celláját a vágólapra, és illessze be egy üres Excel-munkalapra az A1 cellába.

Tipp:    Mielőtt beillesztené az adatokat az Excelben, állítsa az a és a C oszlop szélességét 250 képpontra, és kattintson a Szöveg körbefuttatása (Kezdőlap lap, Igazítás csoport).

Tengelyek

Csapágyak

Csapszegek

4

4

9

5

7

10

6

8

11

Képlet

Leírás

Eredmény

=VKERES("Tengelyek";A1:C4;2;IGAZ)

A „Tengelyek” szó megkeresése az 1. sorban, majd az ugyanazon oszlop (A oszlop) 2. sorában lévő érték visszaadása

4

=VKERES("Csapágyak";A1:C4;3;HAMIS)

A „Csapágyak” szó megkeresése az 1. sorban, majd az ugyanazon oszlop (B oszlop) 3. sorában lévő érték visszaadása

7

=VKERES("D";A1:C4;3;IGAZ)

A „D” érték keresése az 1. sorban, majd az ugyanazon oszlop 3. sorában lévő érték visszaadása. Mivel nem található pontos találat a „D” értékre, a „D”-nél kisebb legnagyobb értéket („Csapágyak”) adja vissza a B oszlopban

5

=VKERES("Csapszegek";A1:C4;4)

A „Csapszegek” szó megkeresése az 1. sorban, majd az ugyanazon oszlop (C oszlop) 4. sorában lévő érték visszaadása

11

=VKERES(3; {1;2;3;"a";"b";"c";"d";"e";"f"};2;IGAZ)

A 3 érték keresése a háromsoros tömbállandóban, és ugyanazon oszlop (ebben az esetben a 3. oszlop) 2. sorában lévő érték visszaadása. A tömbállandóban három, egymástól pontosvesszővel (;) elválasztott értéksor található. Mivel a „c” megtalálható a 2. sorban és ugyanabban az oszlopban, mint a 3., a visszaadott érték a „c”.

c

INDEX és hol.van példák

Ez az utolsó példa az INDEX és hol.van függvények közös a legkorábbi számla száma és az egyes beállítható öt várost megfelelő dátuma visszatérési alkalmaz. A dátum számként ad vissza, mert a szöveg függvényt használjuk dátumként formázandó. Az INDEX függvény ténylegesen használ a hol.van függvény argumentumként. Az INDEX és hol.van függvény kombinációját használt kétszer mindegyik képletnek – először számla számát adja vissza, és jelölje be a dátumot ad eredményül.

Másolja a táblázat összes celláját a vágólapra, és illessze be egy üres Excel-munkalapra az A1 cellába.

Tipp:    Mielőtt beillesztené az adatokat az Excelben, állítsa az a és a D oszlop szélességét 250 képpontra, és kattintson a Szöveg körbefuttatása (Kezdőlap lap, Igazítás csoport).

Értékesítés

Város

Számla dátuma

Legrégebbi számla település szerint, dátummal

3115

Ajka

2012. április 7.

="Ajka = "&INDEX($A$2:$C$33;HOL.VAN("Ajka";$B$2:$B$33;0);1)& "; Számla dátuma: " & SZÖVEG(INDEX($A$2:$C$33;HOL.VAN("Ajka";$B$2:$B$33;0);3);"yyyy/mm/d")

3137

Ajka

2012. április 9.

="Kőszeg = "&INDEX($A$2:$C$33;HOL.VAN("Kőszeg";$B$2:$B$33;0);1)& "; Számla dátuma: " & SZÖVEG(INDEX($A$2:$C$33;HOL.VAN("Kőszeg";$B$2:$B$33;0);3);"yyyy/mm/d")

3154

Ajka

2012. április 11.

="Hatvan = "&INDEX($A$2:$C$33;HOL.VAN("Hatvan";$B$2:$B$33;0);1)& "; Számla dátuma: " & SZÖVEG(INDEX($A$2:$C$33;HOL.VAN("Hatvan";$B$2:$B$33;0);3);"yyyy/mm/d")

3191

Ajka

2012. április 21.

="Tiszacsege = "&INDEX($A$2:$C$33;HOL.VAN("Tiszacsege";$B$2:$B$33;0);1)& "; Számla dátuma: " & SZÖVEG(INDEX($A$2:$C$33;HOL.VAN("Tiszacsege";$B$2:$B$33;0);3);"yyyy/mm/d")

3293

Ajka

2012. április 25.

="Gyula = "&INDEX($A$2:$C$33;HOL.VAN("Gyula";$B$2:$B$33;0);1)& "; Számla dátuma: " & SZÖVEG(INDEX($A$2:$C$33;HOL.VAN("Gyula";$B$2:$B$33;0);3);"yyyy/mm/d")

3331

Ajka

2012. április 27.

3350

Ajka

2012. április 28.

3390

Ajka

2012. május 1.

3441

Ajka

2012. május 2.

3517

Ajka

2012. május 8.

3124

Kőszeg

2012. április 9.

3155

Kőszeg

2012. április 11.

3177

Kőszeg

2012. április 19.

3357

Kőszeg

2012. április 28.

3492

Kőszeg

2012. május 6.

3316

Hatvan

2012. április 25.

3346

Hatvan

2012. április 28.

3372-es

Hatvan

2012. május 1.

3414

Hatvan

2012. május 1.

3451

Hatvan

2012. május 2.

3467

Hatvan

2012. május 2.

3474

Hatvan

2012. május 4.

3490-es

Hatvan

2012. május 5.

3503

Hatvan

2012. május 8.

3151

Tiszacsege

2012. április 9.

3438

Tiszacsege

2012. május 2.

3471

Tiszacsege

2012. május 4.

3160

Gyula

2012. április 18.

3328

Gyula

2012. április 26.

3368

Gyula

2012. április 29.

3420

Gyula

2012. május 1.

3501

Gyula

2012. május 6.

További tudnivalók a keresőfüggvényekről

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×