Érték előfordulásainak megszámolása

Számos munkalapfüggvényt használhat annak megszámlálásához, hogy egy adott szöveg vagy számérték hányszor fordul elő egy cellatartományban. A DARABTELI függvénnyel például megszámlálhatja, hogy egy adott érték hányszor fordul elő, ahogyan az az alábbi példában látható.

Példa

Üzletkötő

Számla

Harmath

15 000

Harmath

9000

Kiss

8000

Kiss

20000

Harmath

5000

Lukács

22 500

Képlet

Leírás

Eredmény

=DARABTELI(A2:A7;"Harmath")

Harmath bejegyzéseinek száma (3)

3

=DARABTELI(A2:A7;A4)

Kiss bejegyzéseinek száma (2)

2

=DARABTELI(B2:B7;"< 20000")

A 20 000-nél kisebb számlaérték előfordulásainak száma (4)

4

=DARABTELI(B2:B7;">="&B5)

A 20 000-nél nagyobb vagy azzal egyenlő értékű számlák előfordulásainak száma (2)

2

Értékek megszámlálása több feltétel alapján a DARABHATÖBB függvénnyel

DARABHATÖBB függvény egy fontos kivételtől eltekintve hasonló a DARABTELI függvényhez: a DARABHATÖBB függvénnyel több tartomány celláira is meghatározhatók feltételek, így megszámlálhatók azok az előfordulások, amelyek minden feltételnek megfelelnek a tartományokban. A DARABHATÖBB függvényben legfeljebb 127 tartomány–feltétel pár határozható meg. A függvény szintaxisa:

DARABHATÖBB(kritériumtartomány1; kritérium1; [kritériumtartomány2; kritérium2];…)

Példa

Alkalmazottkód

Régió száma

Részleg

20552

2

Értékesítés

21268

2

Pénzügy

23949

1

Adminisztráció

24522

4

Adminisztráció

28010

3

Informatika

29546

4

Értékesítés

31634

3

Informatika

32131

1

Informatika

35106

4

Pénzügy

40499

1

HR

42051

1

Értékesítés

43068

2

HR

45382

2

Pénzügy

47971

1

IT

Képlet

Leírás

Eredmény

=DARABHATÖBB(B2:B15;"2";C2:C15;"Pénzügy")

Az alkalmazottak száma a 2. régióban és a pénzügyi osztályon

2

Az első feltételtartomány tartalmazza az összes régiószámot és a második feltételtartomány az összes részlegnevet. Az első feltételtartomány esetében a „2” a feltétel, a második tartománynál a „Pénzügy”. A DARABHATÖBB függvény ellenőrzi, hogy mindkét feltétel teljesül-e.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×