Érték előfordulásainak megszámolása az Excelben

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Tegyük fel, szeretné megtudni, hogy egy adott szöveg vagy szám hányszor fordul elő egy cellatartományban. Például:

  • Ha egy tartomány, például az A2:D20 tartomány az 5, 6, 7 és 6 számokat tartalmazza, akkor a tartományban a 6-os szám kétszer szerepel.

  • Ha egy oszlopban a következők szerepelnek: „Harmath”, „Lukács”, „Lukács”, és „Lukács”, akkor itt a „Lukács” háromszor fordul elő.

Egy érték előfordulásait többféle módon megszámolhatja.

Kapcsolódó műveletek

Egyetlen érték előfordulásainak megszámolása függvény segítségével

Előfordulások megszámlálása több feltétel alapján a DARABHATÖBB függvénnyel

Előfordulások megszámlálása a DARAB és a HA függvény együttes alkalmazásával meghatározott feltételek alapján

Több számérték vagy szöveg előfordulásainak megszámolása a SZUM és a HA függvény együttes alkalmazásával

Több érték előfordulásainak megszámolása kimutatás segítségével

Egyetlen érték előfordulásainak megszámolása függvény segítségével

A feladat végrehajtásához használja a DARABTELI függvényt.

Példa

Másolja a mintaadatokat az alábbi táblázatból, és illessze be őket egy új Excel-munkalap A1 cellájába. Ha azt szeretné, hogy a képletek megjelenítsék az eredményt, jelölje ki őket, és nyomja le az F2, majd az Enter billentyűt. Szükség esetén módosíthatja az oszlopok szélességét, hogy az összes adat látható legyen.

Üzletkötő

Számla

Harmath

15 000

Harmath

a 9000

Kiss

8000 dollár

Kiss

20 000

Harmath

5000

Lukács

22 500

Képlet

Leírás

Eredmény

'=DARABTELI(A2:A7;"Harmath")

Harmath bejegyzéseinek száma (3)

=DARABTELI(A2:A7;"Harmath")

'=DARABTELI(A2:A7;A4)

Lukács bejegyzéseinek száma (2)

=DARABTELI(A2:A7;A4)

'=DARABTELI(B2:B7;"< 20000")

A 20 000-nél kisebb számlaérték előfordulásainak száma (4)

=DARABTELI(B2:B7;"< 20000")

'=DARABTELI(B2:B7;">="&B5)

A 20 000-nél nagyobb vagy azzal egyenlő értékű számlák előfordulásainak száma (2)

=DARABTELI(B2:B7;">="&B5)

A függvény használatával kapcsolatos további tudnivalók a DARABTELI függvény című témakörben olvashatók.

Vissza a lap tetejére

Előfordulások megszámlálása több feltétel alapján a DARABHATÖBB függvénnyel

Az Excel 2007 alkalmazással bevezetett DARABHATÖBB függvény egy fontos kivételtől eltekintve hasonló a DARABTELI függvényhez: a DARABHATÖBB függvénnyel több tartomány celláira is meghatározhatók feltételek, így megszámlálhatók azok az előfordulások, amelyek minden feltételnek megfelelnek a tartományokban. A DARABHATÖBB függvényben legfeljebb 127 tartomány–feltétel pár határozható meg. A függvény szintaxisa:

DARABHATÖBB(feltétel_tartomány1; feltétel1, [feltétel_tartomány2; feltétel2];…)

Példa

Alkalmazottkód

Régió száma

Részleg

20552

2

Értékesítés

21268

2

Pénzügy

23949

1

Adminisztráció

24522

4

Adminisztráció

28010

3

Informatika

29546

4

Értékesítés

31634

3

Informatika

32131

1

Informatika

35106

4

Pénzügy

40499

1

HR

42051

1

Értékesítés

43068

2

HR

45382

2

Pénzügy

47971

1

Informatika

Hány alkalmazott dolgozik a 2. régióban a pénzügyi osztályon?

'=DARABHATÖBB(B2:B15;"2";C2:C15;"Pénzügy")

=DARABHATÖBB(B2:B15;"2";C2:C15;"Pénzügy")

Az első feltételtartomány a régió száma, a második feltételtartomány a részleg neve. Az első feltételtartomány esetében a „2” a feltétel, a második tartománynál a „Pénzügy”. A DARABHATÖBB függvény ellenőrzi, hogy mindkét feltétel teljesül-e.

Ha ezzel a függvénnyel több tartományban, különböző feltételek alapján szeretné meghatározni az előfordulások számát, akkor olvassa el a DARABHATÖBB függvény című témakört.

Vissza a lap tetejére

Előfordulások megszámlálása a DARAB és a HA függvény együttes alkalmazásával meghatározott feltételek alapján

Tegyük fel, hogy meg kell határoznia, hány üzletkötő adott el egy bizonyos terméket egy adott tartományban, vagy hogy az egyes üzletkötők közül ki mennyi eladást teljesített egy bizonyos érték fölött. A feladatot a HA és a DARAB függvény együttes használatával oldhatja meg: először a HA függvénnyel vizsgálja a feltételt, és csak akkor alkalmazza a DARAB függvényt a cellák megszámlálására, ha a HA függvény igaz értéket adott vissza.

Példák

Régió

Üzletkötő

Típus

Értékesítés

Dél

Harmath

Italok

3571

Nyugat

Bedecs

Tejtermék

3338

Kelet

Kiss

Italok

5122

Észak

Kiss

Tejtermék

6239

Dél

Lukács

Termény

8677

Dél

Bedecs

Hús

450

Dél

Bedecs

Hús

7673

Kelet

Kiss

Termény

664

Észak

Bedecs

Termény

1500

Dél

Lukács

Hús

6596

Képlet

Leírás

Eredmény

=DARAB(HA((A2:A11="Dél")*(C2:C11="Hús");D2:D11))

A húseladások száma a déli régióban. (3)

=DARAB(HA((A2:A11="Dél")*(C2:C11="Hús");D2:D11))

=DARAB(HA((B2:B11="Lukács")*(D2:D11>=100000);D2:D11))

Kiss 100 000 forintnál nagyobb összegű értékesítései. (2)

=DARAB(HA((B2:B11="Lukács")*(D2:D11>=100000);D2:D11))

Megjegyzés : 

  • A példában szereplő képleteket tömbképletként kell beírnia. Ha a munkafüzetet az asztali Excel programban nyitotta meg, és módosítani szeretné a képletet, vagy hasonló képletet szeretne létrehozni, akkor nyomja le az F2 billentyűt, majd a Ctrl+Shift+Enter billentyűkombinációt a várt eredmények visszaadásához.

  • Ez a függvény csak akkor működik, ha a HA függvény második argumentuma szám.

A DARAB függvény számba veszi a számokat tartalmazó cellákat, majd azon belül megszámlálja, hogy hány cellában szerepelnek az argumentumlistában megadott számok. A HA függvény egy értéket ad vissza, ha a megadott feltétel teljesül, és egy másik értéket, ha a megadott feltétel nem teljesül.

Az előbbi függvényekkel kapcsolatos további tudnivalók a DARAB függvény és a HA függvény című témakörben olvashatók.

Vissza a lap tetejére

Több számérték vagy szöveg előfordulásainak megszámolása a SZUM és a HA függvény együttes alkalmazásával

A következő példák a HA és a SZUM függvény együttes használatát mutatják be. Az első lépésben a HA függvény vizsgálja a cellákban szereplő értékeket, majd a SZUM függvény összegzi azokat az értékeket, amelyek teljesítették a feltételeket.

Példák

Üzletkötő

Számla

Harmath

15000-ből

Harmath

9000

Lukács

8000

Lukács

20000

Harmath

5000

Kiss

22500

Képlet

Leírás

Eredmény

=SZUM(HA((A2:A7="Harmath")+(A2:A7="Kiss");1;0))

Harmath és Kiss számláinak száma

=SZUM(HA((A2:A7="Harmath")+(A2:A7="Kiss");1;0))

=SZUM(HA((B2:B7<900000)+(B2:B7>1900000);1;0))

A 900000-nél kisebb és a 1900000-nél nagyobb értékű számlák előfordulásainak száma (4)

=SZUM(HA((B2:B7<900000)+(B2:B7>1900000);1;0))

=SZUM(HA(A2:A7="Harmath";HA(B2:B7<900000;1;0)))

Lukács 900000-nél kisebb összegű számláinak száma

=SZUM(HA(A2:A7="Harmath";HA(B2:B7<900000;1;0)))

Megjegyzés : A példában szereplő képleteket tömbképletként kell beírnia. Ha a munkafüzetet az asztali Excel programban nyitotta meg, és módosítani szeretné a képletet, vagy hasonló képletet szeretne létrehozni, akkor nyomja le az F2 billentyűt, majd a Ctrl+Shift+Enter billentyűkombinációt a várt eredmények visszaadásához.

Vissza a lap tetejére

Több érték előfordulásainak megszámolása kimutatás segítségével

A kimutatás segítségével összegeket jeleníthet meg, és meghatározhatja bizonyos értékek előfordulásainak számát. A kimutatás egy interaktív eszköz, amely lehetővé teszi nagy mennyiségű adat összesítését. A kimutatásban az egyes összegzési szintek kibontásával és összecsukásával mindig a kívánt eredményre irányíthatja a figyelmet, majd az összegző adatokat részleteit kibontva kiemelheti az érdeklődésre számot tartó területeket. Ezenkívül a sorokat oszlopokba, az oszlopokat pedig sorokba szervezve („forgatva") a forrásadatok különféle összegzéseit jelenítheti meg.

Forrásadatok és az eredményül kapott kimutatás – példa

1   Forrásadatok (jelen esetben egy munkalapról)

2   A kimutatás golf kategóriájának 3. negyedéves forrásadatai

3   A teljes kimutatás

4   A forrásadatok C2 és C8 cellájában szereplő forrásértékek összegzése

Kimutatás létrehozása

  1. Jelölje ki az adatokat tartalmazó oszlopot.
    Ellenőrizze, hogy az oszlopnak van-e oszlopfelirata.

  2. Beszúrás lap Táblázatok csoportjában kattintson a Kimutatás gombra.
    Megjelenik a Kimutatás létrehozása párbeszédpanel.

  3. Kattintson a Táblázat vagy tartomány kijelölése választógombra.

  4. Helyezze a kimutatást egy új munkalapra az A1-es cellával kezdődően. Ehhez válassza az Új munkalapra lehetőséget.

  5. Kattintson az OK gombra.
    Létrejön egy üres kimutatás a megjelenő Kimutatás mezőlistával meghatározott helyen.

  6. Kattintson a mezőnévre a Kimutatás mezőlista tetején található mezőszakaszban, tartsa lenyomva az egérgombot, és húzza a mezőt a Kimutatás mezőlista alján található elrendezési szakasz Sorcímkék mezőjébe.

  7. Kattintson ugyanarra a mezőnévre a Kimutatás mezőlista tetején található mező részben, és tartsa lenyomva az egérgombot; húzza a mezőt a Kimutatás mezőlista alján található elrendezési rész Értékek mezőjébe.

Megjegyzés : Ha az adatok számokat tartalmaznak, a kimutatás az előfordulások számának meghatározása helyett összegzi a bejegyzéseket. Ha a SZUM összegzőfüggvényről a DARAB függvényre szeretne váltani, jelölje ki az oszlop egyik celláját, majd kattintson az Elemzés lap Aktív mező csoportjában a Mezőbeállítások gombra. Kattintson a Mezőstatisztika lap Darab elemére, majd az OK gombra.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×