Map XML elements to cells in an XML Map

To import and export XML data in Excel, an XML Map that associates XML elements with data in cells to get the results you want will be useful. To create one, you need to have an XML schema file (.xsd) and an XML data file (.xml). After creating the XML Map, you can map XML elements the way you want.

युक्ति: You'll find more information about using XML with Excel in this overview of XML in Excel.

Locate or create XML schema and XML data files

Use sample XML schema and XML data files

कोई XML मैप बनाना

XML तत्व मैप करना

Locate or create XML schema and XML data files

If another database or application created an XML schema or XML data file, you might already have them available. For example, you might have a line-of-business application that exports data into these XML file formats, a commercial web site or web service that supplies these XML files, or a custom application developed by your IT department that automatically creates these XML files.

If you don’t have the necessary XML files, you can create them by saving the data you want to use as a text file. You can then use both Access and Excel to convert that text file to the XML files you need. Here’s how:

Access

  1. Import the text file you want to convert and link it to a new table.

    1. फ़ाइल > खोलें क्लिक करें.

    2. In the Open dialog box, select and open the database in which you want to create a new table.

    3. Click External Data > Text File, and follow the instructions for each step, making sure that you link the table to the text file.

      Access creates the new table and displays it in the Navigation Pane.

  2. किसी XML डेटा फ़ाइल और किसी XML स्कीमा फ़ाइल के लिए लिंक की गई तालिका से डेटा निर्यात करें.

    1. Click External Data > XML File (in the Export group).

    2. In the Export - XML File dialog box, specify the file name and format, and click OK.

  3. Access से बाहर आएँ.

Excel

  1. Create an XML Map based on the XML schema file you exported from Access.

    If the Multiple Roots dialog box appears, make sure you choose dataroot so you can create an XML table.

  2. Create an XML table by mapping the dataroot element. See Map XML elements for more information.

  3. Import the XML file you exported from Access.

नोट्स: 

  • There are several types of XML schema element constructs Excel doesn't support. The following XML schema element constructs can't be imported into Excel:

  • <any>    यह तत्व आपको स्कीमा द्वारा घोषित नहीं किए गए तत्वों को शामिल करने की अनुमति देता है.

  • <anyAttribute>    यह तत्व आपको स्कीमा द्वारा घोषित नहीं किए गए गुणों को शामिल करने की अनुमति देता है.

  • Recursive structures    A common example of a recursive structure is a hierarchy of employees and managers in which the same XML elements are nested several levels. Excel doesn't support recursive structures more than one level deep.

  • अमूर्त तत्व    ये तत्व स्कीमा में घोषित किए जाने के लिए होते हैं, लेकिन तत्वों के रूप में कभी उपयोग नहीं किए जाते हैं. अमूर्त तत्व, अमूर्त तत्व पर प्रतिस्थापित किए जाने के लिए अन्य तत्वों पर निर्भर रहते हैं.

  • प्रतिस्थापन समूह    जब भी अ‍न्य तत्व को संदर्भित किया जाता है, तो ये समूह किसी तत्व को स्वैप किए जाने की अनुमति देते हैं. कोई तत्व इंगित करता है कि यह <substitutionGroup> वि‍शेषता के माध्‍यम से अन्य तत्व के प्रतिस्थापन समूह का कोई सदस्य है.

  • मिश्रित सामग्री    किसी जटिल प्रकार परिभाषा पर mixed="true" का उपयोग करते हुए इस सामग्री की घोषणा की जाती है. Excel जटिल प्रकार की साधारण सामग्री का समर्थन नहीं करता है, लेकिन उस जटिल प्रकार में परिभाषित चाइल्ड टैग्स और विशेषताओं का समर्थन करता है.

Use sample XML schema and XML data files

The following sample data has basic XML elements and structures you can use to test XML mapping if you don't have XML files or text files to create the XML files. Here’s how you can save this sample data to files on your computer:

  1. Select the sample text of the file you want to copy, and press Ctrl+C.

  2. Start Notepad, and press Ctrl+V to paste the sample text.

  3. Press Ctrl+S to save the file with the file name and extension of the sample data you copied.

  4. Press Ctrl+N in Notepad and repeat step 1-3 to create a file for the second sample text.

  5. नोटपैड से बाहर आएँ.

नमूना XML डेटा (Expenses.xml)

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<Root>
<EmployeeInfo>
<Name>Jane Winston</Name>
<Date>2001-01-01</Date>
<Code>0001</Code>
</EmployeeInfo>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Airfare</Description>
<Amount>500.34</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Hotel</Description>
<Amount>200</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Taxi Fare</Description>
<Amount>100.00</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Long Distance Phone Charges</Description>
<Amount>57.89</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Food</Description>
<Amount>82.19</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-02</Date>
<Description>Food</Description>
<Amount>17.89</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-02</Date>
<Description>Personal Items</Description>
<Amount>32.54</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-03</Date>
<Description>Taxi Fare</Description>
<Amount>75.00</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-03</Date>
<Description>Food</Description>
<Amount>36.45</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-03</Date>
<Description>New Suit</Description>
<Amount>750.00</Amount>
</ExpenseItem>
</Root>

नमूना XML स्कीमा (Expenses.xsd)

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<xsd:element name="Root">
<xsd:complexType>
<xsd:sequence>
<xsd:element minOccurs="0" maxOccurs="1" name="EmployeeInfo">
<xsd:complexType>
<xsd:all>
<xsd:element minOccurs="0" maxOccurs="1" name="Name" />
<xsd:element minOccurs="0" maxOccurs="1" name="Date" />
<xsd:element minOccurs="0" maxOccurs="1" name="Code" />
</xsd:all>
</xsd:complexType>
</xsd:element>
<xsd:element minOccurs="0" maxOccurs="unbounded" name="ExpenseItem">
<xsd:complexType>
<xsd:sequence>
<xsd:element name="Date" type="xsd:date"/>
<xsd:element name="Description" type="xsd:string"/>
<xsd:element name="Amount" type="xsd:decimal" />
</xsd:sequence>
</xsd:complexType>
</xsd:element>
</xsd:sequence>
</xsd:complexType>
</xsd:element>
</xsd:schema>

कोई XML मैप बनाना

You create an XML Map by adding an XML schema to a workbook. The schema can be copied from an XML schema file (.xsd), or Excel can try to infer one from an XML data file (.xml).

  1. Click Developer > Source.

    डेवलपर टैब पर XML आदेश

    यदि आप डेवलपर टैब नहीं देख पाते हैं, तो डेवलपर टैब दिखाना देखें.

  2. In the XML Source task pane, click XML Maps, and then click Add.

  3. इसमें देखें सूची में, उस ड्राइव, फ़ोल्डर या इंटरनेट स्थान पर क्लिक करें, जिसमें खोलने के लिए इच्छित फ़ाइल हो.

  4. फ़ाइल पर क्लिक करें और फिर खोलें पर क्लिक करें.

    • For an XML schema file, XML will create an XML Map based on the XML schema. If the Multiple Roots dialog box appears, choose one of the root nodes defined in the XML schema file.

    • For an XML data file, Excel will try to infer the XML schema from the XML data, and then creates an XML Map.

  5. ठीक पर क्लिक करें.

    The XML Map appears in the XML Source task pane.

XML तत्व मैप करना

XML तालिकाओं में आप एकल-मैप किए गए कक्षों और पुनरावर्ती कक्षों में XML तत्वों को मैप करते हैं, ताकि आप XML स्कीमा में कक्ष और XML डेटा के बीच संबंध बना सकें.

  1. Click Developer > Source.

    डेवलपर टैब पर XML आदेश

    यदि आप डेवलपर टैब नहीं देख पाते हैं, तो डेवलपर टैब दिखाना देखें.

  2. In the XML Source task pane, select the elements you want to map.

    To select nonadjacent elements, click one element, and then hold down Ctrl and click each element you want to map.

  3. तत्वों को मैप करने के लिए, निम्न कार्य करें:

    1. Right-click the selected elements, and click Map element.

    2. In the Map XML elements dialog box, select a cell and click OK.

      युक्ति: आप चयनित तत्वों को उस कार्यपत्रक स्थान पर खींच भी सकते हैं, जहाँ आप उन्हें प्रकट करना चाहते हैं.

      यह इंगित करने के लिए कि तत्व को मैप किया गया है, प्रत्येक तत्व XML स्रोत कार्य फलक में बोल्ड प्रकार में प्रकट होता है.

  4. निर्धारित करें कि आप लेबल्स और स्तंभ शीर्षकों को कैसे हैंडल करना चाहते हैं:

    • कोई सिंगल-मैप्ड कक्ष बनाने हेतु जब आप किसी न दोहराए जाने वाले XML तत्व को कार्यपत्रक पर खींचते हैं, तो तीन आदेशों वाला एक स्मार्ट टैग प्रदर्शित होता है, जिसका उपयोग आप शीर्ष या लेबल की जमावट को नियंत्रित करने के लिए कर सकते हैं:

      मेरे डेटा में पहले से ही शीर्ष है    XML तत्व शीर्ष पर ध्‍यान न देने के लिए इस विकल्प पर क्लिक करें, क्योंकि कक्ष में पहले से ही शीर्ष है (डेटा के बाईं ओर या डेटा के ऊपर).

      XML शीर्ष को बाईं ओर रखें    XML तत्व शीर्ष का उपयोग कक्ष लेबल के रूप में करने के लिए इस विकल्प पर क्लिक करें (डेटा के बाईं ओर).

      XML शीर्ष को ऊपर रखें    XML तत्व शीर्ष का उपयोग कक्ष शीर्ष के रूप में करने के लिए इस विकल्प पर क्लिक करें (डेटा के ऊपर).

    • जब आप किसी XML तालिका में दोहराए जाने वाले कक्ष बनाने के लिए किसी दोहराए जाने वाले XML तत्व को कार्यपत्रक पर खींचते हैं, तो XML तत्व नाम स्वचालित रूप से तालिका के लिए स्तंभ शीर्ष के रूप में उपयोग किए जाते हैं. हालाँकि, आप स्तंभ शीर्ष लेख कक्षों को संपादित करके आप स्तंभ शीर्ष को किसी भी इच्छित शीर्ष पर परिवर्तित कर सकते हैं.

      XML स्रोत कार्य फलक में, XML तालिका व्यवहार को और अधिक नियंत्रित करने के लिए आप विकल्प पर क्लिक कर सकते हैं:

      मैप करते समय तत्वों को स्वचालित रूप से मर्ज करें    इस चेक बॉक्स का चयन किए जाने पर, जब आप किसी तत्व को XML तालिका के सन्निकट कक्ष पर खींचते हैं, तो तालिकाएँ स्वचालित रूप से विस्तृत होती है.

      मेरे डेटा में शीर्ष हैं    इस चेक बॉक्स का चयन किए जाने पर, जब आप दोहराए जाने वाले तत्वों को अपने कार्यपत्रक में मैप करते हैं, तो मौजूदा डेटा को स्तंभ शीर्ष के रूप में उपयोग किया जा सकता है.

      नोट्स: 

      • If all XML commands are dimmed, and you can't map XML elements to any cells, the workbook might be shared. Click Review > Share Workbook to verify that and to remove it from shared use as needed.

        If you want to map XML elements in a workbook you want to share, map the XML elements to the cells you want, import the XML data, remove all of the XML maps, and then share the workbook.

      • If you can't copy an XML table that contains data to another workbook, the XML table might have an associated XML Map that defines the data structure. This XML Map is stored in the workbook, but when you copy the XML table to a new workbook, the XML Map isn't automatically included. Instead of copying the XML table, Excel creates an Excel table that contains the same data. If you want the new table to be an XML table, do the following:

        1. Add an XML Map to the new workbook by using the .xml or .xsd file you used to create the original XML Map. You should save these files if you want to add XML Maps to other workbooks.

        2. किसी तालिका को XML तालिका बनाने के लिए XML तत्वों को उसमें मैप करें.

      • When you map a repeating XML element to a merged cell, Excel unmerges the cell. This is expected behavior, because repeating elements are designed to work with unmerged cells only.

        You can map single, nonrepeating XML elements to a merged cell, but mapping a repeating XML element (or an element that contains a repeating element) to a merged cell isn't allowed. The cell will be unmerged, and the element will be mapped to the cell where the pointer is located.

युक्तियाँ: 

  • You can unmap XML elements you don't want to use, or to prevent the contents of cells from being overwritten when you import XML data. For example, you could temporarily unmap an XML element from a single cell or repeating cells that have formulas you don't want to overwrite when you import an XML file. When the import is complete, you can map the XML element to the formula cells again, so you can export the results of the formulas to the XML data file.

  • To unmap XML elements, right-click their name in the XML Source task pane, and click Remove element.

डेवलपर टैब दिखाना

यदि आपको डेवलपर टैब दिखाई नहीं देता है, तो इसे प्रदर्शित करने के लिए निम्न कार्य करें:

  • In Excel 2010, 2013 and 2016:

    1. फ़ाइल > विकल्प क्लिक करें.

    2. अनूकूलित करें श्रेणी क्लिक करें.

    3. Under Main Tabs, check the Developer box, and click OK.

  • Excel 2007 में:

    1. Click the Microsoft Office Button बटन छवि > Excel Options.

    2. Click the Popular category.

    3. Under Top options for working with Excel, check the Show Developer tab in the Ribbon box, and click OK.

यह भी देखें

Overview of XML in Excel

Import XML data

Export XML data

अपने कौशल का विस्तार करें
प्रशिक्षण का अन्वेषण करें
पहले नई सुविधाएँ प्राप्त करें
Office प्रतिभागी में शामिल हों

क्या यह जानकारी मददगार थी?

आपकी प्रतिक्रिया के लिए आपको धन्यवाद!

आपकी प्रतिक्रिया के लिए धन्यवाद! ऐसा लगता है आपको हमारे किसी Office सहायता एजेंट से कनेक्ट करना मददगार हो सकता है.

×