יצירה, הרצה, עריכה או מחיקה של מאקרו ב-Office עבור Mac

הערה: אנו מעוניינים לספק לך את תוכן העזרה העדכני ביותר במהירות האפשרית, בשפה שלך. דף זה תורגם באמצעות אוטומציה והוא עשוי לכלול שגיאות דקדוק או אי-דיוקים. מטרתנו היא כי תוכן זה יהיה שימושי עבורך. האם תוכל לספר לנו אם המידע הועיל לך, בחלק התחתון של דף זה? לנוחותך, הנה המאמר באנגלית.

כדי לחסוך זמן במשימות שאתה מבצע לעתים קרובות, באפשרותך להקליט את השלבים של פעילויות אלה כמאקרו. לאחר מכן, כאשר ברצונך לבצע אחת מהמשימות המוקלטות, באפשרותך להפעיל את המאקרו כדי לבצע את השלבים עבורך.

Word

ב-Word 2016 עבור Mac, באפשרותך ליצור מאקרו בעל קיצור מקשים, להפעיל מאקרו ולמחוק מאקרו שאינך זקוק לו עוד.

  1. לחץ על תצוגה > פקודות מאקרו > הקלטת מאקרו.

    בכרטיסיה תצוגה, לחץ על מאקרו ולאחר מכן לחץ על הקלט מאקרו כדי להתחיל ביצירת מאקרו.
  2. הקלד שם עבור המאקרו או קבל את ברירת המחדל שWord מספק.

    הזן שם עבור המאקרו שלך בשם המאקרו או קבל את השם הכללי שמספק Word.
  3. כדי להשתמש במאקרו זה בכל מסמך חדש שאתה יוצר, ודא שכל המסמכים (Normal) נבחרה ברשימה אחסן מאקרו ב .

  4. לחץ על לוח מקשים כדי להקצות שילוב מקשים למאקרו.

    Word מציג את תיבת הדו התאמה אישית של לוח המקשים .

  5. הקלד שילוב של מקשים בתיבה הקשה על קיצור מקשים חדש .

    Word מציג את הפקודה או את המאקרו שכבר הוקצה לצירוף מקשים, אם בכלל, לאחר הקשה על הצירוף.

    בעת הקשה על צירוף מקשים, Word מציג את הפקודה או הפעולה המוקצית כעת לצירוף מקשים זה, אם בכלל.

  6. אם שילוב המקשים שבחרת כבר מוקצה, מחק אותו מהתיבה הקש קיצור מקשים חדש ולאחר מכן בחר שילוב מקשים חדש.

    עבור לשלב הבא לאחר שמצאת שילוב מקשים שלא הוקצה.

    Word מזהה כאשר הקשת שילוב מקשים שעדיין לא הוקצה לפקודה או למאקרו.
  7. כדי להשתמש בקיצור מקשים זה בכל מסמך חדש, ודא שהאפשרות Normal. dotm, התבנית הכללית נבחרה ברשימה שמור שינויים ב .

    בחר Normal. dotm כדי ליצור מאקרו זמין לשימוש במסמכים חדשים שאתה יוצר.
  8. לחץ על הקצה.

  9. כאשר תהיה מוכן להקליט את המאקרו, לחץ על אישור.

  10. לחץ על הפקודות או הקש על המקשים עבור כל שלב במשימה.

    Word מתעד את הלחיצות וההקשות שלך, אך אינו מקליט טקסט שאתה בוחר באמצעות העכבר. כדי לבחור טקסט בעת הקלטת מאקרו, השתמש בלוח המקשים.

  11. כדי לעצור את ההקלטה, לחץ על תצוגה > פקודות מאקרו > עצור הקלטה.

    לחץ על הפסק הקלטה בתפריט פקודות מאקרו כדי להפסיק להקליט מאקרו.

כדי להפעיל מאקרו, הקש על קיצור המקשים שהוקצה לו, או העבר את המאקרו מהרשימה פקודות מאקרו .

  1. לחץ על תצוגה > פקודות מאקרו > הצג פקודות מאקרו.

    לחץ על הצגת פקודות מאקרו כדי להציג ולערוך פקודות מאקרו המשויכות למסמך הנוכחי.
  2. ברשימה תחת שם מאקרו, בחר את המאקרו שברצונך להפעיל.

  3. לחץ על הפעלה.

    לאחר בחירת מאקרו תחת שם מאקרו, לחץ על הופעל כדי להפעילו.

  1. לחץ על תצוגה > פקודות מאקרו > הצג פקודות מאקרו.

    לחץ על הצגת פקודות מאקרו כדי להציג ולערוך פקודות מאקרו המשויכות למסמך הנוכחי.
  2. ודא שהמיקום שצוין באמצעות פקודות מאקרו כולל את מיקום המאקרו שברצונך למחוק.

    בחר את המיקום של פקודות המאקרו שברצונך להציג מתוך הרשימה פקודות מאקרו ב.

    הרשימה תכלול את המסמך הפתוח בחלון הנוכחי וכן את הפקודות ' תבנית כללית ' Word '.

  3. תחת שם מאקרו, בחר את המאקרו שברצונך למחוק ולאחר מכן לחץ על סימן החיסור מתחת לרשימה.

    בחר את המאקרו שברצונך למחוק ולאחר מכן לחץ על סימן החיסור מתחת לרשימה.
  4. כאשר Word יבקש לאשר שברצונך למחוק את המאקרו, לחץ על כן.

Excel

ב-Excel 2016 עבור Mac, באפשרותך ליצור מאקרו הכולל קיצור מקשים, להפעיל מאקרו ולמחוק מאקרו שאינך זקוק לו עוד.

בעת הקלטת מאקרו, מקליט המאקרו מקליט את כל השלבים הנחוצים להשלמת הפעולות שברצונך שהמאקרו יבצע. שלבים אלה יכולים לכלול הקלדת טקסט או מספרים, לחיצה על תאים או פקודות ברצועת הכלים או בתפריטים, עיצוב, בחירה של תאים, של שורות או של עמודות וגרירת העכבר לבחירת תאים בגיליון האלקטרוני.

הערה: הפקודות להקלטה, יצירה ומחיקה של פקודות מאקרו, וכן תכונות מתקדמות אחרות, זמינות גם בכרטיסיה מפתחים ברצועת הכלים. לקבלת מידע נוסף אודות השימוש בכרטיסיה ' מפתחים ', ראה שימוש בכרטיסיה ' מפתחים ' כדי ליצור או למחוק מאקרו ב-Excel 2016 עבור Mac.

  1. בחר כלים ש> מאקרו > Record New.

    בחר כלים ולאחר מכן מאקרו ולאחר מכן הקלט מאקרו חדש

  2. בתיבה שם המאקרו, הזן שם עבור המאקרו.

    הזן שם מאקרו, מיקום ומקש קיצור

  3. כדי ליצור קיצור מקשים עבור המאקרו, הקלד אות בתיבה Option + Cmd .

  4. בחר מיקום עבור המאקרו מהרשימה הנפתחת.

    כדי לשמור את המאקרו

    לחץ על

    במסמך שבו אתה יוצר מאקרו

    חוברת עבודה זו

    בכל המסמכים הפתוחים

    חוברת עבודה חדשה

    יהיה זמין בכל פעם שתשתמש ב- Excel

    חוברת עבודה של מאקרו אישי

  5. אופציונלי הוסף תיאור של המאקרו.

  6. כאשר תהיה מוכן להקליט, לחץ על אישור.

  7. לחץ על הפקודות או הקש על המקשים עבור כל שלב במשימה.

  8. כדי להפסיק את ההקלטה, בחר באפשרות Tools > מאקרו > הפסיק את ההקלטה. (שלב זה לא יירשם במאקרו שלך.)

    בחר הפסק הקלטה

כדי להפעיל מאקרו, הקש על קיצור המקשים שהוקצה לו, או הפעלת המאקרו מתיבת הדו פקודות מאקרו .

  1. בכרטיסיה תצוגה, לחץ על הצגת פקודות מאקרו.

  2. לחץ על פקודות מאקרו בתפריט המוקפץ ובחר חוברת עבודה זו.

  3. בחר את המאקרו מהרשימה ולאחר מכן לחץ על הפעל.

    תיבת הדו-שיח Macros ב- Excel for Mac

  1. בחר כלים ה> פקודותמאקרו של > מאקרו .

    בחר מאקרו ולאחר מכן בחר פקודות מאקרו

  2. בחר את המאקרו שברצונך למחוק ולאחר מכן הקש על סימן החיסור.

    בחר שם מאקרו ולאחר מכן בחר סימן חיסור

  3. תופיע הודעת אישור. לחץ על כן כדי לאשר את המחיקה.

    אישור מחיקה

באפשרותך גם למחוק מאקרו מהכרטיסיה מפתחים.

  1. בכרטיסיה מפתחים, לחץ על פקודות מאקרו.

  2. ברשימה, לחץ על המאקרו שברצונך למחוק ולחץ על לחצן 'מחק'.

    בחר מאקרו ולחץ על סימן החיסור כדי למחוק אותו

Word

כדי להפוך משימה חוזרת לאוטומטית, באפשרותך ליצור במהירות מאקרו ב- Word. באפשרותך גם להשתמש ב- עורך Visual Basic ב- Microsoft Visual Basic for Applications כדי לכתוב קובץ Script של מאקרו משלך או כדי להעתיק מאקרו שלם או חלק ממנו למאקרו חדש.

בעת הקלטת מאקרו, כל השלבים הדרושים כדי להשלים את הפעולות שברצונך שהמאקרו יבצע יוקלטו. עם זאת, ניווט בחזרה לכרטיסיה כדי לעצור את ההקלטה אינו נכלל בשלבים המוקלטים.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על הקלטה.

    הכרטיסיה Word Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. בתיבה שם המאקרו, הזן שם עבור המאקרו.

  3. בתפריט המוקפץ אחסן מאקרו ב, בצע אחת מהפעולות הבאות:

    כדי לשמור את המאקרו

    לחץ על

    במסמך שבו אתה יוצר את המאקרו

    [שם המסמך] (מסמך)

    בכל המסמכים הפתוחים

    כל המסמכים (רגיל)

  4. לחץ על אישור ולאחר מכן בצע את הפעולות שברצונך להקליט.

  5. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על עצירה.

באפשרותך להשתמש בעורך Visual Basic המוכלל כדי ליצור מאקרו.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על עורך.

    הכרטיסיה Word Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. אם עליך להוסיף מודול, בעורך Visual Basic, בתפריט הוספה, לחץ על מודול.

  3. בחלון הקוד של המודול, הקלד או הדבק את קוד המאקרו שבו ברצונך להשתמש.

  4. לאחר שתסיים, בתפריט Word, לחץ על סגור וחזור ל- Microsoft Word.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה Word Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך להפעיל ולאחר מכן לחץ על הפעל.

כדי לערוך מאקרו, עליך להשתמש ב- עורך Visual Basic.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה Word Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך לערוך ולאחר מכן לחץ על ערוך.

    כעת נפתח עורך Visual Basic.

  3. בצע את השינויים הרצויים.

  4. לאחר שתסיים, בתפריט Word, לחץ על סגור וחזור ל- Microsoft Word.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה Word Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך להעתיק ולאחר מכן לחץ על ערוך.

    כעת נפתח עורך Visual Basic.

  3. בחלון הקוד של עורך Visual Basic, בחר את השורות של המאקרו שברצונך להעתיק.

    עצה: כדי להעתיק את המאקרו כולו, כלול את השורות Sub ו- End Sub בבחירה.‏

  4. בתפריט עריכה, לחץ על העתק.

  5. בתיבה פרוייקט של חלון הקוד, לחץ על המודול שבו ברצונך למקם את הקוד.

  6. בתפריט עריכה, לחץ על הדבק.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה Word Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך למחוק, ולאחר מכן לחץ על מחק.

PowerPoint

כדי להפוך משימה חוזרת לאוטומטית, באפשרותך להשתמש ב-Visual basic for applications כדי ליצור מאקרו ב-PowerPoint.

באפשרותך להשתמש בעורך Visual Basic המוכלל כדי ליצור מאקרו.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על עורך.

    הכרטיסיה PowerPoint Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. אם עליך להוסיף מודול, בעורך Visual Basic, בתפריט הוספה, לחץ על מודול.

  3. בחלון הקוד של המודול, הקלד או הדבק את קוד המאקרו שבו ברצונך להשתמש.

  4. לאחר שתסיים, בתפריט PowerPoint, לחץ על סגור וחזור אל Microsoft PowerPoint.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה PowerPoint Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך להפעיל ולאחר מכן לחץ על הפעל.

כדי לערוך מאקרו, עליך להשתמש ב- עורך Visual Basic.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה PowerPoint Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך לערוך ולאחר מכן לחץ על ערוך.

    כעת נפתח עורך Visual Basic.

  3. בצע את השינויים הרצויים.

  4. לאחר שתסיים, בתפריט PowerPoint, לחץ על סגור וחזור אל Microsoft PowerPoint.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה PowerPoint Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך להעתיק ולאחר מכן לחץ על ערוך.

    כעת נפתח עורך Visual Basic.

  3. בחלון הקוד של עורך Visual Basic, בחר את השורות של המאקרו שברצונך להעתיק.

    עצה: כדי להעתיק את המאקרו כולו, כלול את השורות Sub ו- End Sub בבחירה.‏

  4. בתפריט עריכה, לחץ על העתק.

  5. בתיבה פרוייקט של חלון הקוד, לחץ על המודול שבו ברצונך למקם את הקוד.

  6. בתפריט עריכה, לחץ על הדבק.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה PowerPoint Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך למחוק, ולאחר מכן לחץ על מחק.

Excel

כדי להפוך משימה חוזרת לאוטומטית, באפשרותך ליצור במהירות מאקרו ב- Excel. באפשרותך גם להשתמש ב- עורך Visual Basic ב- Microsoft Visual Basic for Applications כדי לכתוב קובץ Script של מאקרו משלך או כדי להעתיק מאקרו שלם או חלק ממנו למאקרו חדש.

כל השלבים הדרושים להשלמת הפעולות שברצונך שהמאקרו שלך יבצע מתועדים. עם זאת, ניווט בחזרה לכרטיסיה כדי לעצור את ההקלטה אינו נכלל בשלבים המוקלטים.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על הקלטה.

    הכרטיסיה 'מפתחים' של Excel, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. בתיבה שם המאקרו, הזן שם עבור המאקרו.

    עצה: כדי ליצור קיצור מקשים עבור המאקרו, הקלד אות בתיבה Option+Cmd+‎.

  3. בתפריט המוקפץ אחסן מאקרו ב, בצע אחת מהפעולות הבאות:

    כדי לשמור את המאקרו

    לחץ על

    במסמך שבו אתה יוצר את המאקרו

    חוברת עבודה זו

    בכל המסמכים הפתוחים

    חוברת עבודה חדשה

    יהיה זמין בכל פעם שתשתמש ב- Excel

    חוברת עבודה של מאקרו אישי

    חוברת המאקרו האישית ממוקמת אצל משתמשים/ username/Library/Application תמיכה/Microsoft/Office/Excel.

  4. לחץ על אישור ולאחר מכן בצע את הפעולות שברצונך להקליט.

  5. בכרטיסיה מפתחים, תחת Visual Basic, לחץ שוב על הקלטה.

באפשרותך להשתמש בעורך Visual Basic המוכלל כדי ליצור מאקרו.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על עורך.

    הכרטיסיה 'מפתחים' של Excel, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. אם עליך להוסיף מודול, בעורך Visual Basic, בתפריט הוספה, לחץ על מודול.

  3. בחלון הקוד של המודול, הקלד או הדבק את קוד המאקרו שבו ברצונך להשתמש.

  4. לאחר שתסיים, בתפריט Excel, לחץ על סגור וחזור אל Microsoft Excel.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה 'מפתחים' של Excel, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך להפעיל ולאחר מכן לחץ על הפעל.

    עצה: כדי להפעיל מאקרו באמצעות קיצור מקשים, הקש OPTION + COMMAND + האות שהקלדת בעת יצירת קיצור המקשים.

כדי לערוך מאקרו, עליך להשתמש ב- עורך Visual Basic.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה 'מפתחים' של Excel, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך לערוך ולאחר מכן לחץ על ערוך.

    כעת נפתח עורך Visual Basic.

  3. בצע את השינויים הרצויים.

  4. לאחר שתסיים, בתפריט Excel, לחץ על סגור וחזור אל Microsoft Excel.

לאחר השלמת הליך זה, המאקרו יופעל בכל פעם שתפתח את חוברת העבודה המכילה את המאקרו.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על הקלטה.

    הכרטיסיה 'מפתחים' של Excel, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. בתיבה שם המאקרו, הקלד Auto_Open.

  3. בתפריט המוקפץ אחסן מאקרו ב, בצע אחת מהפעולות הבאות:

    כדי לשמור את המאקרו

    לחץ על

    במסמך שבו אתה יוצר את המאקרו

    חוברת עבודה זו

    בכל המסמכים הפתוחים

    חוברת עבודה חדשה

    יהיה זמין בכל פעם שתשתמש ב- Excel

    חוברת עבודה של מאקרו אישי

  4. לחץ על אישור ולאחר מכן בצע את הפעולות שברצונך להקליט.

  5. בכרטיסיה מפתחים, תחת Visual Basic, לחץ שוב על הקלטה.

  6. בתפריט קובץ, לחץ על שמירה בשם.

  7. בתפריט המוקפץ עיצוב, לחץ על Excel Macro-Enabled Workbook (.xlsm)‎, ולאחר מכן לחץ על שמור.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה 'מפתחים' של Excel, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך להעתיק ולאחר מכן לחץ על ערוך.

    כעת נפתח עורך Visual Basic.

  3. בחלון הקוד של עורך Visual Basic, בחר את השורות של המאקרו שברצונך להעתיק.

    עצה: כדי להעתיק את המאקרו כולו, כלול את השורות Sub ו- End Sub בבחירה.‏

  4. בתפריט עריכה, לחץ על העתק.

  5. בתיבה פרוייקט של חלון הקוד, לחץ על המודול שבו ברצונך למקם את הקוד.

  6. בתפריט עריכה, לחץ על הדבק.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה 'מפתחים' של Excel, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך למחוק, ולאחר מכן לחץ על מחק.

שפר את הכישורים שלך ב- Office
סייר בהדרכה
קבל תכונות חדשות לפני כולם
הצטרף למשתתפי Office Insider

האם מידע זה היה שימושי?

תודה על המשוב!

תודה על המשוב! נראה שכדאי לקשר אותך לאחד מנציגי התמיכה של Office.

×