יצירה, הפעלה, עריכה או מחיקה של פקודת מאקרו

הערה:  אנו מעוניינים לספק לך את תוכן העזרה העדכני ביותר במהירות האפשרית, בשפה שלך. דף זה תורגם באמצעות אוטומציה והוא עשוי לכלול שגיאות דקדוק או אי-דיוקים. מטרתנו היא כי תוכן זה יהיה שימושי עבורך. האם תוכל לספר לנו אם המידע הועיל לך, בחלק התחתון של דף זה? לנוחותך, הנה המאמר באנגלית .

כדי לחסוך זמן על משימות שיומיומיות, באפשרותך להקליט את השלבים אחת ממשימות אלו של מאקרו. לאחר מכן, כאשר ברצונך לבצע אחת מהפעילויות מוקלט אלה, באפשרותך להפעיל את המאקרו כדי לבצע את השלבים עבורך.

Word

ב- Word 2016 for Mac, באפשרותך ליצור מאקרו אשר יש קיצור מקשים, להפעיל מאקרו, ולמחוק מאקרו שאין לך עוד צורך.

  1. לחץ על תצוגה > פקודות מאקרו > הקלטת מאקרו.

    בכרטיסיה תצוגה, לחץ על המאקרו ולאחר מכן לחץ על הקלטת מאקרו כדי להתחיל ביצירת מאקרו.
  2. הקלד שם עבור המאקרו, או לקבל את ברירת המחדל מספק זה Word.

    הזן שם עבור המאקרו שלך בתיבה שם מאקרו, או קבל את השם כללי שסופקה על-ידי Word.
  3. כדי להשתמש במאקרו זה בכל מסמך חדש שתיצור, ודא כי כל המסמכים (רגיל) נבחרה ברשימה אחסן מאקרו.

  4. לחץ על לוח המקשים כדי להקצות צירוף מקשים למאקרו שלך.

    Word מציג את תיבת הדו-שיח ' התאמה אישית של לוח המקשים.

  5. הקלד צירוף מקשים בתיבה הקש קיצור מקשים חדש.

    Word מציג את הפקודה או המאקרו כבר מוקצית אליהן צירוף מקשים, אם בכלל, לאחר הקשה על צירוף.

    בעת הקשה על שילוב מקשים, Word מציג את הפקודה או הפעולה המוקצית כעת בצירוף מקשים זה, אם בכלל.

  6. אם כבר מוקצית שצירוף שבחרת, מחק אותה בתיבה הקש קיצור מקשים חדש, ולאחר מכן בחר צירוף מקשים חדש.

    המשך לשלב הבא לאחר שאיתרת של שצירוף שלא הוקצו.

    Word מזהה בעת הקשת צירוף מקשים המוקצה שלא עדיין פקודה או מאקרו.
  7. כדי להשתמש בקיצור מקשים זה בכל מסמך חדש, להיות בטוח normal. dotm, התבנית הכללית, נבחרה ברשימה שמור שינויים.

    בחר normal. dotm כדי להפוך מאקרו לזמין לשימוש מסמך חדש שתיצור.
  8. לחץ על הקצה.

  9. כאשר תהיה מוכן להקליט את המאקרו, לחץ על אישור.

  10. לחץ על הפקודות או הקש על מקשי עבור כל שלב במשימה.

    Word רשומות לחיצות והקשות שלך, אך הוא אינו רושם טקסט שאתה בוחר באמצעות העכבר. כדי לבחור טקסט בעת הקלטת מאקרו, השתמש בלוח המקשים.

  11. כדי לעצור את ההקלטה, לחץ על תצוגה > פקודות מאקרו > עצור הקלטה.

    לחץ על עצור הקלטה בכרטיסיה פקודות מאקרו כדי לעצור את הקלטת מאקרו.

כדי להפעיל מאקרו, הקש על קיצור המקשים המוקצים לה או להפעיל את המאקרו מהרשימה פקודות מאקרו.

  1. לחץ על תצוגה > פקודות מאקרו > הצג פקודות מאקרו.

    לחץ על הצג פקודות מאקרו להצגה ועריכה של פקודות מאקרו המשויכים למסמך הנוכחי.
  2. ברשימה תחת שם המאקרו, בחר את המאקרו שברצונך להפעיל.

  3. לחץ על הפעלה.

    לאחר בחירת מאקרו תחת שם המאקרו, לחץ על הפעל כדי להפעיל אותו.

  1. לחץ על תצוגה > פקודות מאקרו > הצג פקודות מאקרו.

    לחץ על הצג פקודות מאקרו להצגה ועריכה של פקודות מאקרו המשויכים למסמך הנוכחי.
  2. ודא כי במיקום שצוין על-ידי פקודות מאקרו בכולל את המיקום של המאקרו שברצונך למחוק.

    בחר את המיקום של פקודות מאקרו שברצונך להציג מתוך פקודות מאקרו ברשימה.

    הרשימה תכלול את המסמך פתוח בלחלון הנוכחי, וכן את תבנית כללית ופקודות Word.

  3. תחת שם המאקרו, בחר את המאקרו שברצונך למחוק, ולאחר מכן לחץ על סימן החיסור מתחת לרשימה.

    בחר את המאקרו שברצונך למחוק, ולאחר מכן לחץ על סימן החיסור תחת הרשימה.
  4. Word שואל לאשר שברצונך למחוק את המאקרו, לחץ על כן.

Excel

ב- Excel 2016 for Mac, באפשרותך ליצור מאקרו אשר יש קיצור מקשים, להפעיל מאקרו, ולמחוק מאקרו שאין לך עוד צורך.

בעת הקלטת מאקרו, הרשומות במקליט המאקרו כל השלבים הדרושה כדי להשלים את הפעולות שברצונך שהמאקרו יבצע שלך. שלבים אלה יכולים לכלול להקליד טקסט או מספרים, לחיצה על תאים או פקודות ברצועת הכלים או בתפריטים, עיצוב, בחירת תאים, שורות או עמודות ולאחר מכן גרירת העכבר כדי לבחור את התאים בגיליון האלקטרוני שלך.

הערה: הפקודות עבור הקלטה, יצירה ומחיקה של פקודות מאקרו, וכן תכונות מתקדמות נוספות, זמינות גם בכרטיסיה ' מפתחים ' ברצועת הכלים. לקבלת מידע נוסף אודות השימוש בהכרטיסיה מפתחים, ראה שימוש הכרטיסיה ' מפתחים ' כדי ליצור או למחוק מאקרו ב- Excel 2016 for Mac.

  1. בחר כלים > מאקרו > רשומה חדשה.

    בחר כלים, לאחר מכן מאקרו, ולאחר מכן הקלטת מאקרו חדש

  2. בתיבה שם המאקרו, הזן שם עבור המאקרו.

    הזן מפתח שמך, את המיקום ואת קיצור של מאקרו

  3. כדי ליצור קיצור מקשים עבור המאקרו, הקלד אות בתיבה Option + Cmd.

  4. בחר מיקום עבור המאקרו מהרשימה הנפתחת.

    כדי לשמור את המאקרו

    לחץ על

    במסמך שאתה יוצר מאקרו ב

    חוברת עבודה זו

    בכל המסמכים הפתוחים

    חוברת עבודה חדשה

    יהיה זמין בכל פעם שתשתמש ב- Excel

    חוברת מאקרו אישית

  5. (אופציונלי) הוסף תיאור של המאקרו שלך.

  6. כאשר תהיה מוכן להקליט, לחץ על אישור.

  7. לחץ על הפקודות או הקש על מקשי עבור כל שלב במשימה.

  8. כדי לעצור את ההקלטה, בחר כלים > מאקרו > עצור הקלטה. (שלב זה לא יתועד במאקרו שלך.)

    בחר עצור הקלטה

כדי להפעיל מאקרו, הקש על קיצור המקשים המוקצים לה או להפעיל את המאקרו מתיבת הדו-שיח פקודות מאקרו.

  1. בכרטיסיה תצוגה, לחץ על הצגת פקודות מאקרו.

  2. לחץ על פקודות מאקרו התפריט המוקפץ ובחר חוברת עבודה זו.

  3. בחר את המאקרו מהרשימה ולאחר מכן לחץ על הפעל.

    תיבת הדו-שיח Macros ב- Excel for Mac

  1. בחר כלים > מאקרו > פקודות מאקרו.

    בחר את המאקרו ולאחר מכן בחר פקודות מאקרו

  2. בחר את המאקרו כדי למחוק, ולאחר מכן הקש על סימן החיסור.

    בחר את שם המאקרו ולאחר מכן בחר סימן חיסור

  3. הודעת אישור תופיע. לחץ על כן כדי לאשר את המחיקה.

    אישור מחיקה

באפשרותך גם למחוק מאקרו מתוך הכרטיסיה מפתחים.

  1. בכרטיסיה מפתחים, לחץ על פקודות מאקרו.

  2. ברשימה, לחץ על המאקרו שברצונך למחוק ולחץ על לחצן 'מחק'.

    בחר מאקרו ולחץ על סימן החיסור כדי למחוק אותו

Word

כדי להפוך משימה חוזרת לאוטומטית, באפשרותך ליצור במהירות מאקרו ב- Word. באפשרותך גם להשתמש ב- עורך Visual Basic ב- Microsoft Visual Basic for Applications כדי לכתוב קובץ Script של מאקרו משלך או כדי להעתיק מאקרו שלם או חלק ממנו למאקרו חדש.

בעת הקלטת מאקרו, נרשמים כל השלבים הדרושים כדי להשלים את הפעולות שברצונך שהמאקרו יבצע שלך. עם זאת, ניווט בחזרה אל הכרטיסיה כדי לעצור את ההקלטה אינה כלולה בשלבים המוקלטים.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על הקלטה.

    הכרטיסיה Word Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. בתיבה שם המאקרו, הזן שם עבור המאקרו.

  3. בתפריט המוקפץ אחסן מאקרו ב, בצע אחת מהפעולות הבאות:

    כדי לשמור את המאקרו

    לחץ על

    במסמך שבו אתה יוצר את המאקרו

    [שם המסמך] (מסמך)

    בכל המסמכים הפתוחים

    כל המסמכים (רגיל)

  4. לחץ על אישור ולאחר מכן בצע את הפעולות שברצונך להקליט.

  5. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על עצירה.

באפשרותך להשתמש בעורך Visual Basic המוכלל כדי ליצור מאקרו.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על עורך.

    הכרטיסיה Word Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. אם עליך להוסיף מודול, בעורך Visual Basic, בתפריט הוספה, לחץ על מודול.

  3. בחלון הקוד של המודול, הקלד או הדבק את קוד המאקרו שבו ברצונך להשתמש.

  4. לאחר שתסיים, בתפריט Word, לחץ על סגור וחזור ל- Microsoft Word.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה Word Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך להפעיל ולאחר מכן לחץ על הפעל.

כדי לערוך מאקרו, עליך להשתמש ב- עורך Visual Basic.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה Word Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך לערוך ולאחר מכן לחץ על ערוך.

    כעת נפתח עורך Visual Basic.

  3. בצע את השינויים הרצויים.

  4. לאחר שתסיים, בתפריט Word, לחץ על סגור וחזור ל- Microsoft Word.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה Word Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך להעתיק ולאחר מכן לחץ על ערוך.

    כעת נפתח עורך Visual Basic.

  3. בחלון הקוד של עורך Visual Basic, בחר את השורות של המאקרו שברצונך להעתיק.

    עצה: כדי להעתיק את המאקרו כולו, כלול את השורות Sub ו- End Sub בבחירה.‏

  4. בתפריט עריכה, לחץ על העתק.

  5. בתיבה פרוייקט של חלון הקוד, לחץ על המודול שבו ברצונך למקם את הקוד.

  6. בתפריט עריכה, לחץ על הדבק.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה Word Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך למחוק, ולאחר מכן לחץ על מחק.

PowerPoint

כדי להפוך משימה חוזרת לאוטומטית, באפשרותך להשתמש ב- Visual Basic for Applications ליצירת של מאקרו ב- PowerPoint.

באפשרותך להשתמש בעורך Visual Basic המוכלל כדי ליצור מאקרו.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על עורך.

    הכרטיסיה PowerPoint Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. אם עליך להוסיף מודול, בעורך Visual Basic, בתפריט הוספה, לחץ על מודול.

  3. בחלון הקוד של המודול, הקלד או הדבק את קוד המאקרו שבו ברצונך להשתמש.

  4. לאחר שתסיים, בתפריט PowerPoint, לחץ על סגור וחזור אל Microsoft PowerPoint.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה PowerPoint Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך להפעיל ולאחר מכן לחץ על הפעל.

כדי לערוך מאקרו, עליך להשתמש ב- עורך Visual Basic.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה PowerPoint Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך לערוך ולאחר מכן לחץ על ערוך.

    כעת נפתח עורך Visual Basic.

  3. בצע את השינויים הרצויים.

  4. לאחר שתסיים, בתפריט PowerPoint, לחץ על סגור וחזור אל Microsoft PowerPoint.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה PowerPoint Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך להעתיק ולאחר מכן לחץ על ערוך.

    כעת נפתח עורך Visual Basic.

  3. בחלון הקוד של עורך Visual Basic, בחר את השורות של המאקרו שברצונך להעתיק.

    עצה: כדי להעתיק את המאקרו כולו, כלול את השורות Sub ו- End Sub בבחירה.‏

  4. בתפריט עריכה, לחץ על העתק.

  5. בתיבה פרוייקט של חלון הקוד, לחץ על המודול שבו ברצונך למקם את הקוד.

  6. בתפריט עריכה, לחץ על הדבק.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה PowerPoint Developer, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך למחוק, ולאחר מכן לחץ על מחק.

Excel

כדי להפוך משימה חוזרת לאוטומטית, באפשרותך ליצור במהירות מאקרו ב- Excel. באפשרותך גם להשתמש ב- עורך Visual Basic ב- Microsoft Visual Basic for Applications כדי לכתוב קובץ Script של מאקרו משלך או כדי להעתיק מאקרו שלם או חלק ממנו למאקרו חדש.

כל השלבים הדרושים להשלמת הפעולות שברצונך שהמאקרו שלך יבצע מתועדים. עם זאת, ניווט בחזרה לכרטיסיה כדי לעצור את ההקלטה אינו נכלל בשלבים המוקלטים.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על הקלטה.

    הכרטיסיה 'מפתחים' של Excel, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. בתיבה שם המאקרו, הזן שם עבור המאקרו.

    עצה: כדי ליצור קיצור מקשים עבור המאקרו, הקלד אות בתיבה Option+Cmd+‎.

  3. בתפריט המוקפץ אחסן מאקרו ב, בצע אחת מהפעולות הבאות:

    כדי לשמור את המאקרו

    לחץ על

    במסמך שבו אתה יוצר את המאקרו

    חוברת עבודה זו

    בכל המסמכים הפתוחים

    חוברת עבודה חדשה

    יהיה זמין בכל פעם שתשתמש ב- Excel

    חוברת עבודה של מאקרו אישי

    חוברת העבודה המאקרו האישית ממוקם במשתמשים / username/ספריה/יישום תומך / Microsoft/Office/Excel.

  4. לחץ על אישור ולאחר מכן בצע את הפעולות שברצונך להקליט.

  5. בכרטיסיה מפתחים, תחת Visual Basic, לחץ שוב על הקלטה.

באפשרותך להשתמש בעורך Visual Basic המוכלל כדי ליצור מאקרו.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על עורך.

    הכרטיסיה 'מפתחים' של Excel, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. אם עליך להוסיף מודול, בעורך Visual Basic, בתפריט הוספה, לחץ על מודול.

  3. בחלון הקוד של המודול, הקלד או הדבק את קוד המאקרו שבו ברצונך להשתמש.

  4. לאחר שתסיים, בתפריט Excel, לחץ על סגור וחזור אל Microsoft Excel.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה 'מפתחים' של Excel, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך להפעיל ולאחר מכן לחץ על הפעל.

    עצה: כדי להפעיל מאקרו באמצעות קיצור מקשים, הקש OPTION + פקודה + האות שהקלדת בעת יצירת קיצור המקשים.

כדי לערוך מאקרו, עליך להשתמש ב- עורך Visual Basic.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה 'מפתחים' של Excel, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך לערוך ולאחר מכן לחץ על ערוך.

    כעת נפתח עורך Visual Basic.

  3. בצע את השינויים הרצויים.

  4. לאחר שתסיים, בתפריט Excel, לחץ על סגור וחזור אל Microsoft Excel.

לאחר השלמת הליך זה, המאקרו יופעל בכל פעם שתפתח את חוברת העבודה המכילה את המאקרו.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על הקלטה.

    הכרטיסיה 'מפתחים' של Excel, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. בתיבה שם המאקרו, הקלד Auto_Open.

  3. בתפריט המוקפץ אחסן מאקרו ב, בצע אחת מהפעולות הבאות:

    כדי לשמור את המאקרו

    לחץ על

    במסמך שבו אתה יוצר את המאקרו

    חוברת עבודה זו

    בכל המסמכים הפתוחים

    חוברת עבודה חדשה

    יהיה זמין בכל פעם שתשתמש ב- Excel

    חוברת עבודה של מאקרו אישי

  4. לחץ על אישור ולאחר מכן בצע את הפעולות שברצונך להקליט.

  5. בכרטיסיה מפתחים, תחת Visual Basic, לחץ שוב על הקלטה.

  6. בתפריט קובץ, לחץ על שמירה בשם.

  7. בתפריט המוקפץ עיצוב, לחץ על Excel Macro-Enabled Workbook (.xlsm)‎, ולאחר מכן לחץ על שמור.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה 'מפתחים' של Excel, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך להעתיק ולאחר מכן לחץ על ערוך.

    כעת נפתח עורך Visual Basic.

  3. בחלון הקוד של עורך Visual Basic, בחר את השורות של המאקרו שברצונך להעתיק.

    עצה: כדי להעתיק את המאקרו כולו, כלול את השורות Sub ו- End Sub בבחירה.‏

  4. בתפריט עריכה, לחץ על העתק.

  5. בתיבה פרוייקט של חלון הקוד, לחץ על המודול שבו ברצונך למקם את הקוד.

  6. בתפריט עריכה, לחץ על הדבק.

  1. בכרטיסיה מפתחים, תחת Visual Basic, לחץ על פקודות מאקרו.

    הכרטיסיה 'מפתחים' של Excel, הקבוצה Visual Basic

    אם הכרטיסיה 'מפתחים' אינה זמינה

    1. בצדה השמאלי של רצועת הכלים, לחץ על תפריט מוקפץ לפעולה ולאחר מכן לחץ על העדפות רצועת הכלים.

    2. תחת התאמה אישית, בחר את תיבת הסימון מפתחים.

  2. ברשימה, לחץ על המאקרו שברצונך למחוק, ולאחר מכן לחץ על מחק.

שפר את הכישורים שלך ב- Office
סייר בהדרכה
קבל תכונות חדשות לפני כולם
הצטרף למשתתפי Office Insider

האם מידע זה היה שימושי?

תודה על המשוב!

תודה על המשוב! נראה שכדאי לקשר אותך לאחד מנציגי התמיכה של Office.

×