העברת תבנית טופס שפורסמה לספריית SharePoint חדשה

הערה:  אנו מעוניינים לספק לך את תוכן העזרה העדכני ביותר במהירות האפשרית, בשפה שלך. דף זה תורגם באמצעות אוטומציה והוא עשוי לכלול שגיאות דקדוק או אי-דיוקים. מטרתנו היא כי תוכן זה יהיה שימושי עבורך. האם תוכל לספר לנו אם המידע הועיל לך, בחלק התחתון של דף זה? לנוחותך, הנה המאמר באנגלית .

במאמר זה

מבט כולל

לפני שתתחיל

קבלת עותק לעבודה של תבנית הטופס שלך

שלב 1: פרסום תבנית הטופס אל ספריית המסמכים החדשה

שלב 2: העתקה וקישור מחדש של הטפסים הקיימים

מבט כולל

לאחר פרסום תבנית טופס לספריית מסמכים עבור המשתמשים שלך יוכלו למלא, ייתכן שתצטרך להעביר תבנית טופס זו לספריית מסמכים אחרת. לדוגמה, ייתכן שיהיה עליך להעביר את תבנית הטופס לשרת עם קיבולת גדולה יותר, כך שמשתמשים יוכלו למלא טפסים בו-זמנית. משתמשים מסוימים ייתכן יש כבר למלא את הטפסים המבוססים על תבנית הטופס שלך המאוחסנת בספריית המסמכים המקורית. כאשר אתה מזיז את תבנית הטופס שלך לספריית מסמכים חדשה, מומלץ להעברת הטפסים הקיימים האלה מדי. אם ברצונך גם לבצע טפסים קיימים אלה יפעלו בספריית המסמכים החדשה לפני אחסון בארכיון או למחוק את ספריית המסמכים הישנה.

עצה: לפני שתעביר תבניות טופס שפורסמו אל ספריית מסמכים חדשה, צור תוכנית הכוללת יידוע המשתמשים שלך הטפסים שלהם הועברו לספריית מסמכים חדשה. אתה מעוניין למשתמשים שלך להשתמש ספריית המסמכים החדשה כדי לאחסן טפסים חדשים או לשנות טפסים קיימים. התוכנית צריכה גם לכלול תהליך לאחסון בארכיון או למחיקה של ספריית המסמכים המקורית.

כדי להעביר תבנית טופס וטפסים קיים ספריית מסמכים חדשה, תחילה עליך לפרסם את העותק לעבודה של תבנית הטופס שלך אל ספריית המסמכים החדשה. העותק לעבודה הוא הגירסה המאוחסנת במחשב שלך או בתוכנית בקרת גירסה, כגון Microsoft Visual SourceSafe.

עצה: אם אין לך עותק לעבודה של תבנית הטופס, באפשרותך לשמור עותק של תבנית הטופס מספריית המסמכים המקורית למחשב שלך שישמש עותק לעבודה.

לאחר שתפרסם את העותק לעבודה אל ספריית המסמכים החדשה, עליך להעתיק את כל הטפסים מספריית המסמכים הישנה לספריית המסמכים החדשה ולאחר מכן לקשר מחדש את הטפסים בספריית המסמכים החדשה לתבנית הטופס שפורסמה לאחרונה.

אם עליך לבצע שינויים כתוצאה מהעברת תבנית הטופס, בצע שינויים אלה לפני פרסום תבנית טופס. לדוגמה, המיקום של מקורות נתונים חיצוניים שבהם נעשה שימוש על-ידי הטפסים המבוססים על תבנית טופס זו עשויה גם לשנות כתוצאה מהעברת תבנית הטופס. במקרה זה, עליך לשנות את חיבור הנתונים בתבנית הטופס למיקום החדש של מקורות הנתונים החיצוניים לפני שתפרסם את תבנית הטופס. חפש קישורים למידע נוסף אודות שינוי חיבורי הנתונים בסעיף למידע נוסף.

הערה: פרסום תבנית טופס אינו זהה לשמירת תבנית טופס. בעת פרסום תבנית טופס, אשף הפרסום הוספת מיקום הפרסום ועיבוד הוראות על תבנית הטופס כך שמשתמשים יוכלו לפתוח טפסים המבוססים על תבנית טופס זו. בעת שמירת תבנית טופס, אתה שומר עותק של תבנית הטופס, בדיוק כפי שאתה עושה בעת שמירת קובץ למחשב שלך. עליך להשתמש תמיד באשף הפרסום כאשר ברצונך להפוך לזמינים עבור המשתמשים שלך יוכלו למלא תבנית הטופס שלך.

לראש הדף

לפני שתתחיל

לפני שתעביר את תבנית הטופס ואת כל הטפסים הקיימים המבוססים על תבנית הטופס לספריית מסמכים חדשה, יהיה עליך את הפעולות הבאות:

  • העותק לעבודה של תבנית הטופס    זהו עותק של תבנית הטופס תשנה ולאחר מכן לפרסם מחדש אל ספריית המסמכים החדשה. ניתן לאחסן את העותק לעבודה במחשב שלך או בתוכנית בקרת גירסה, כגון ב- Visual SourceSafe.

  • המיקומים של מקורות נתונים חיצוניים חדשים    אם הטפסים המבוססים על תבנית הטופס השתמש במקורות נתונים חיצוניים שהשתנו, יהיה עליך המיקומים החדשים של מקורות נתונים חיצוניים. ודא עם מנהל המערכת שלך ולמשתמשים שלך כולל את ההרשאות המתאימות לשימוש במקורות נתונים חיצוניים. אם תבנית הטופס משתמש בהגדרות בקובץ חיבור נתונים כדי להתחבר למקור נתונים חיצוני, ודא כי קובץ חיבור הנתונים עודכן עם המיקום החדש של מקור הנתונים החיצוני.

  • הרשאות מתאימות בשרת שבו פועל Windows SharePoint Services 3.0    יהיה עליך זכויות מתאימות בשרת כדי לפרסם תבנית טופס וכדי להעתיק כל טופס קיים מספריית המסמכים הישנה לספריית המסמכים החדשה. פנה למנהל השרת כדי לוודא שיש לך זכויות אלה.

לראש הדף

קבלת עותק לעבודה של תבנית הטופס שלך

אם ברצונך לשנות תבנית טופס שפורסמה לספריית מסמכים או במיקום משותף ברשת, אין לך עותק לעבודה של תבנית הטופס שלך, באפשרותך לשמור עותק לעבודה של תבנית הטופס ממיקום הפרסום למחשב שלך.

עצה: שקול להשתמש בתוכנית בקרת גירסאות, כגון Microsoft ב- Visual SourceSafe, כדי לנהל את העותקים עבודה של תבניות הטפסים שלך.

שמור עותק של תבנית הטופס מספריית מסמכים של המחשב שלך

  1. בדפדפן אינטרנט, פתח את ספריית המסמכים שבה לפרסם את תבנית הטופס.

  2. בתפריט הגדרות, לחץ על הגדרות ולאחר מכן לחץ על הגדרות ספריית טפסים.

  3. תחת הגדרות כלליות, לחץ על הגדרות מתקדמות.

  4. במקטע תבנית מסמך, לחץ על ערוך תבנית.

    תבנית הטופס ייפתח ב- Microsoft Office InfoPath.

  5. בתיבת הדו-שיח Microsoft Office InfoPath, לחץ על כן.

  6. בתפריט קובץ, לחץ על שמירה בשם.

  7. בתיבת הדו-שיח Microsoft Office InfoPath, לחץ על אישור.

  8. בתיבת הדו-שיח שמירה בשם, עבור אל המיקום שבו ברצונך לשמור עותק של תבנית הטופס ולאחר מכן לחץ על שמור.

שמור עותק של תבנית הטופס מתוך תיקיית הרשת המשותפת במחשב

  1. בתפריט קובץ, לחץ על עיצוב תבנית טופס.

  2. תחת פתיחת תבנית טופס, לחץ על מחשב שלי.

  3. דפדף אל תיקיית הרשת המשותפת של תבנית טופס שפורסמה, לחץ על תבנית הטופס ולאחר מכן לחץ על פתח.

  4. בתפריט קובץ, לחץ על שמירה בשם.

  5. בתיבת הדו-שיח Microsoft Office InfoPath, לחץ על אישור.

  6. בתיבת הדו-שיח שמירה בשם, בחר מיקום שאינה המקורית לפרסם את המיקום שבו ברצונך לשמור עותק לעבודה של תבנית הטופס ולאחר מכן לחץ על שמור.

לראש הדף

שלב 1: פרסום תבנית הטופס אל ספריית המסמכים החדשה

  1. פתח את העותק לעבודה של תבנית הטופס במצב עיצוב.

  2. בתפריט קובץ, לחץ על פרסם.

  3. באשף הפרסום, לחץ כדי SharePoint server עם או בלי InfoPath Forms Services, ולאחר מכן לחץ על הבא.

  4. בתיבה הזן המיקום של אתר SharePoint או ב- InfoPath Forms Services, הקלד את המיקום של אתר SharePoint המכיל את ספריית המסמכים החדשה שברצונך להעביר את תבנית הטופס כדי ולאחר מכן לחץ על הבא.

  5. בעמוד הבא של האשף, לחץ על ספריית מסמכים ולאחר מכן לחץ על הבא.

  6. לחץ על צור ספריית מסמכים חדשה ולאחר מכן לחץ על הבא.

  7. בעמוד הבא של האשף, הקלד שם ותיאור עבור ספריית המסמכים החדשה ולאחר מכן לחץ על הבא.

  8. בחר את השדות בתבנית הטופס שברצונך שיופיעו כעמודות בתצוגת ברירת המחדל של ספריית המסמכים.

    כיצד?

    1. לחץ על הוסף.

    2. בחר את השדה שברצונך להוסיף כעמודה בספריית המסמכים ולאחר מכן בצע אחת מהפעולות הבאות:

      • הקלד שם עבור העמודה בתיבה שם עמודה.

      • בחר את עמודת אתר ברשימה קבוצת עמודות אתר, בחר שם ברשימה שם עמודה ולאחר מכן לחץ על אישור.

        הערה: אם בחרת שדה חוזר להצגת נתונים בספריית המסמכים, באפשרותך להגדיר כיצד ברצונך להציג את השדה בספריית המסמכים על-ידי לחיצה על ערך ברשימה פונקציה. באפשרותך לבחור אם להציג את הערך הראשון השדה, הערך האחרון בשדה, או ספירה של כל המופעים של השדה, או אם עליך למזג יחד את כל הערכים.

    3. לחץ על אישור.

    חפש קישורים למידע נוסף אודות הצגת נתונים בעמודות בספריית מסמכים בסעיף למידע נוסף.

  9. לחץ על הבא.

  10. בעמוד הבא של האשף, ודא שהמידע המוצג נכון ולאחר מכן לחץ על פרסם.

  11. כדי לפתוח את ספריית המסמכים ולבדוק את התהליך עבור מילוי טופס המבוסס על תבנית טופס זו, בחר בתיבת הסימון פתח ספריית מסמכים זו ולאחר מכן לחץ על סגור.

    ספריית המסמכים תיפתח בדפדפן. בעת לחיצה על חדש בסרגל הכלים של הרשימה, טופס המבוסס על תבנית טופס זו ייפתח ב- Microsoft Office InfoPath.

לאחר פרסום תבנית טופס לספריית מסמכים חדשה, באפשרותך להעתיק את הטפסים הקיימים המבוססים על הגירסה הישנה של תבנית הטופס מספריית המסמכים הישנה לספריית המסמכים החדשה. לאחר העתקת הטפסים הקיימים, באפשרותך לקשר מחדש את הטפסים הקיימים לבין הגירסה החדשה של תבנית הטופס. אם לא קישור הטפסים הקיימים, משתמשים לא יוכלו לפתוח טפסים קיימים אלה.

לראש הדף

שלב 2: העתקה וקישור מחדש של הטפסים הקיימים

הליך זה מניח כי שתי ספריות המסמכים נמצאות בשרת שבו פועל Windows SharePoint Services 3.0.

  1. פתח את ספריית המסמכים הישנה בדפדפן אינטרנט.

  2. בתפריט תצוגה, לחץ על תצוגת סייר.

  3. הקש והחזק את מקש CTRL, בחר כל טופס שברצונך להעביר ולאחר מכן לחיצה ימנית אחד מהטפסים.

  4. תיבת הדו-שיח של Internet Explorer, לחץ על כן ולאחר מכן לחץ על העתק בתפריט הקיצור.

  5. פתח את ספריית המסמכים החדשה.

  6. תחת בחר תצוגה, לחץ על תצוגת סייר.

  7. באמצעות לחצן העכבר הימני באזור ריק בחלון התיקיה.

  8. תיבת הדו-שיח של Internet Explorer, לחץ על כן ולאחר מכן לחץ על הדבק בתפריט הקיצור.

  9. בתפריט תצוגה, לחץ על קישור מחדש של מסמכים.

  10. בעמודה קישור מחדש, בחר בתיבת הסימון עבור כל טופס שברצונך לקשר לתבנית טופס חדש.

  11. בסרגל הכלים של הרשימה, לחץ על קישור מחדש של מסמכים נבחרה.

לאחר שתבצע קישור מחדש של הטפסים הקיימים לתבנית הטופס החדשה, המשתמשים שלך יכולים לשנות את הטפסים הקיימים שהעתקת אל ספריית המסמכים החדשה או למלא טפסים חדשים המבוססים על תבנית הטופס שפורסמה לאחרונה.

לראש הדף

שפר את הכישורים שלך ב- Office
סייר בהדרכה
קבל תכונות חדשות לפני כולם
הצטרף למשתתפי Office Insider

האם מידע זה היה שימושי?

תודה על המשוב!

תודה על המשוב! נראה שכדאי לקשר אותך לאחד מנציגי התמיכה של Office.

×