הנדסה לאחור של קוד מקור של Microsoft Visual C++ 6.0

חשוב: מאמר זה תורגם בתרגום מכונה, ראה כתב ויתור. תוכל למצוא את הגרסה באנגלית של המאמר כאן לעיונך.

  1. התאמה אישית של Visual C++‎.

    אופן

    1. ב- Visual C++‎, בתפריט Tools, לחץ על Customize.

    2. בתיבת הדו-שיח Customize, לחץ על הכרטיסיה Add-Ins And Macro Files.

    3. ברשימה Add-Ins And Macro Files, בחר ב- Visio UML Add-In.

      מופיע Visio UML Add-In ולצידו סימן ביקורת.

    4. לחץ על Close.

      מופיע סרגל הכלים הצף Visio UML Add-In בעל חמש הלחצנים.

    5. אם ברצונך שסרגל הכלים יהיה זמין בכל פעם שתפתח את Visual C++‎, עגן את סרגל הכלים על-ידי כך שתגרור אותו אל אזור סרגל הכלים.

      עצה: אם ברצונך ליצור קיצורי מקשים עבור כל לחצן בסרגל הכלים Visio UML Add-In, בתפריט Tools לחץ על Customize, לחץ על הכרטיסיה Keyboard ולאחר מכן בחר את הקטגוריה Add-Ins.

      כדי להמשיך לציין שמערכת הקבצים שברצונך לבצע ביישום הנדסה (MFC, ATL או כלול), לחץ על לחצן אפשרויות של Visio UML תמונת לחצן של אפשרויות UML .

  2. הפקה של קובץ מידע העיון.

    אופן

    1. ב- Visual C++‎, בתפריט Project, לחץ על Settings.

    2. בתיבת הדו-שיח Project Settings, בחר את סוג תצורת ה- Build הרצויה, לחץ על הכרטיסיה C/C++ ולאחר מכן בחר ב- Generate Browse Info.

    3. לחץ על הכרטיסיה Browse Info כדי לציין את השם והמיקום של קובץ מידע העיון, בחר באפשרות Build Browse Info File ולאחר מכן לחץ על OK.

  3. בנה את הפרוייקט ב- Visual C++‎.

    הערה: אם אתה מבצע שינויים לפרוייקט Visual C++‎ אחרי שבוצעה על הפרוייקט הנדסה לאחור, עליך לבנות מחדש את הפרוייקט ולאחר מכן לבצע לו הנדסה לאחור לתוך תוכנית Visio כדי לראות את השינויים.

  4. ב- Visual C++, לחץ על לחצן סרגל הכלים תמונת לחצן 'הנדסה לאחור של UML' מודל UML הנדסה לאחור בסרגל הכלים של Visio UML Add-In.

    אם בסביבת העבודה של Visual C++‎ קיים יותר מפרוייקט אחד, בחר את הפרוייקט שברצונך לבצע עבורו הנדסה לאחור (בתיבת הדו-שיח Select Project) ולאחר מכן לחץ על OK.

    אם בהירארכיית הפרוייקט קיים יותר מקובץ עיון אחד, בחר את קובץ העיון (בתיבת הדו-שיח Select Browse File) ולאחר מכן לחץ על OK.

    חילוץ מידע המחלקה מקובץ מידע העיון עשוי להימשך מספר שניות. כאשר החילוץ יושלם, UML Model Diagram ב- Visio נפתחת עם דף ציור ריק של דיאגרמת מבנה סטטי ותצוגת עץ ב- Model Explorer, רצופה בסמלים המשקפים את הגדרות המחלקה בקוד המקור.

  5. ב- Visio UML Model Diagram, גרור סמלים מתצוגת העץ אל דף הציור כדי ליצור דיאגרמת מבנה סטטי המייצגת תצוגה של המודל.

הערה: כתב ויתור בנוגע לתרגום מכונה: מאמר זה תורגם על-ידי מערכת מחשב, ללא התערבות אדם. Microsoft מציעה את תרגומי המכונה כדי לסייע למשתמשים שאינם דוברי אנגלית ליהנות מתוכן בנושא מוצרים, שירותים וטכנולוגיות של Microsoft. מכיוון שהמאמר תורגם על-ידי מכונה, הוא עלול להכיל שגיאות באוצר המילים, בתחביר או בדקדוק.

הרחב את הכישורים שלך
סייר בהדרכה
קבל תכונות חדשות לפני כולם
הצטרף למשתתפי Office Insider

האם מידע זה היה שימושי?

תודה על המשוב!

תודה על המשוב! נראה שכדאי לקשר אותך לאחד מנציגי התמיכה של Office.

×