Passer directement au contenu principal

XL : création d’un graphique en courbe de Bell

Résumé

Une courbe de cloche est une trace de distribution normale d’un jeu de données donné. Cet article explique comment créer un graphique de courbe de Gauss dans Microsoft Excel.

Informations complémentaires

n dans l’exemple suivant, vous pouvez créer une courbe de données générées par Excel à l’aide de l’outil de génération de nombres aléatoires dans l’utilitaire d’analyse. Lorsque Microsoft Excel génère un ensemble de nombres aléatoires, vous pouvez créer un histogramme en utilisant ces nombres aléatoires et l’outil histogramme à partir de l’utilitaire d’analyse. À partir de l’histogramme, vous pouvez créer un graphique qui représente une courbe de Bell.

Pour créer un exemple de courbe de Gauss, procédez comme suit :

  1. Démarrez Excel.

  2. Entrez les en-têtes de colonne suivants dans une nouvelle

    feuille de calcul :A1:Original B1:Average C1:Bin D1:Random E1:Histogram G1:Histogram

  3. Entrez les données suivantes dans la même feuille de calcul :

    A2: 23   B2:
    A3: 25   B3: STDEV
    A4: 12   B4:
    A5: 24
    A6: 27
    A7: 57
    A8: 45
    A9: 19
  4. Entrez les formules suivantes dans la même feuille de calcul :

    B2: =AVERAGE(A2:A9)
    B3:
    B4: =STDEV(A2:A9)

    Ces formules généreront respectivement la moyenne (moyenne) et l’écart type des données d’origine.

  5. Entrez les formules suivantes pour générer la plage d’emplacements pour l’histogramme :

    C2: =$B$2-3*$B4

    Cela génère la limite inférieure de la plage d’emplacements. Ce nombre représente trois écarts-type inférieurs à la moyenne.

    C3: =C2+$B$4

    Cette formule ajoute un écart type sur le nombre calculé dans la cellule ci-dessus.

  6. Sélectionnez la cellule C3, utilisez la poignée de recopie, puis recopiez la formule de la cellule C3 vers la cellule C8.

  7. Pour générer les données aléatoires qui constituent la base de la courbe de Gauss, procédez comme suit :

    1. Dans le menu Outils, cliquez sur analyse de données.

    2. Dans la boîte de l’outil outils d’analyse, cliquez sur générateur de nombres aléatoires, puis cliquez sur OK.

    3. Dans la zone nombre de variables , tapez 1.

    4. Dans la zone nombre de nombres aléatoires , tapez 2000.

      Remarque : Variant ce numéro augmente ou diminue la précision de la courbe de Gauss.

    5. Dans la zone distribution, sélectionnez normal.

    6. Dans le volet Paramètres, entrez le nombre calculé dans la cellule B2 (29 dans l’exemple) dans la zone moyenne.

    7. Dans la zone écart type, entrez le nombre calculé dans la cellule B4 (14,68722).

    8. Laissez vide la zone Seed aléatoire.

    9. Dans le volet Options de sortie, cliquez sur plage de sortie.

    10. Tapez D2 dans la zone plage de sortie.

      Cela a pour effet de générer des nombres aléatoires de 2 000 qui s’intègrent à une distribution normale.

    11. Cliquez sur OK.

  8. Pour créer un histogramme pour les données aléatoires, procédez comme suit :

    1. Dans le menu Outils, cliquez sur analyse de données.

    2. Dans la boîte de l’outil outils d’analyse, sélectionnez histogramme, puis cliquez sur OK.

    3. Dans la zone plage d’entrée, tapez D2 : D2001.

    4. Dans la zone plage d’emplacements, tapez C2 : C8.

    5. Dans le volet Options de sortie, cliquez sur plage de sortie.

    6. Tapez E2 dans la zone plage de sortie.

    7. Cliquez sur OK.

  9. Pour créer un histogramme pour les données d’origine, procédez comme suit :

    1. Dans le menu Outils, cliquez sur analyse de données.

    2. Cliquez sur histogramme, puis cliquez sur OK.

    3. Dans la zone plage d’entrée, tapez a2 : A9.

    4. Dans la zone plage d’emplacements, tapez C2 : C8.

    5. Dans le volet Options de sortie, cliquez sur plage de sortie.

    6. Tapez G2 dans la zone plage de sortie.

    7. Cliquez sur OK.

  10. Créez des étiquettes pour la légende dans le graphique en entrant la commande suivante :

    E14: =G1&"-"&G2
    E15: =E1&"-"&F2
    E16: =G1&"-"&H2
  11. Sélectionnez la plage de cellules (E2 : H10) dans la feuille de calcul.

  12. Dans le menu Insertion, cliquez sur graphique.

  13. Sous type de graphique, cliquez sur nuages de points (XY).

  14. Sous sous-type de graphique, dans la ligne du milieu, cliquez sur le graphique à droite.

    Remarque : Juste en dessous de ces 5 sous-types, la description indique « nuages de points avec des points de données connectés par des courbes lissées sans marqueurs ».

  15. Cliquez sur Suivant.

  16. Cliquez sur l’onglet série.

  17. Dans la zone Nom, supprimez la référence de cellule, puis sélectionnez cellule E15.

  18. Dans la zone valeurs X, supprimez la référence de la plage, puis sélectionnez la plage E3 : E10.

  19. Dans la zone valeurs Y, supprimez la référence de la plage, puis sélectionnez la plage F3 : F10.

  20. Cliquez sur Ajouter pour ajouter une autre série.

  21. Cliquez sur la zone Nom, puis sélectionnez cellule E14.

  22. Cliquez sur la zone valeurs X, puis sélectionnez la plage E3 : E10.

  23. Dans la zone valeurs Y, supprimez la valeur qui s’y trouve, puis sélectionnez la plage G3 : G10.

  24. Cliquez sur Ajouter pour ajouter une autre série.

  25. Cliquez sur la zone Nom, puis sélectionnez cellule E16.

  26. Cliquez sur la zone valeurs X, puis sélectionnez la plage E3 : E10.

  27. Cliquez sur la zone valeurs Y, supprimez la valeur qui s’y trouve, puis sélectionnez la plage H3 : H10.

  28. Cliquez sur Terminer.

    Le graphique est doté de deux séries courbées et d’une série plate le long de l’axe x.

  29. Double-cliquez sur la deuxième série ; il doit être étiqueté « -bin » dans la légende.

  30. Dans la boîte de dialogue mettre en forme des séries de données, cliquez sur l’onglet axe.

  31. Cliquez sur axe secondaire, puis cliquez sur OK.

Vous avez à présent un graphique qui compare un jeu de données donné à une courbe de Bell.

References

Pour plus d’informations sur la création de graphiques, cliquez sur aide de Microsoft Excel dans le menu aide, tapez créer un graphique dans l’Assistant Office ou l’Assistant réponse, puis cliquez sur Rechercher pour afficher le sujet.

Remarque :  Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez vous nous dire si les informations vous ont été utiles ? Voici l’article en anglais pour référence.

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×