Passer directement au contenu principal
Office

Utiliser des fonctions imbriquées dans une formule

L’utilisation d’une fonction comme argument dans une formule qui utilise une fonction est appelée imbrication, et cette fonction est appelée fonction imbriquée. Par exemple, en imbriquant la fonction MOYENNE et SOMME dans les arguments de la fonction SI, la formule suivante fait la somme d’un ensemble de nombres (G2:G5) uniquement si la moyenne de l’ensemble de nombres (F2:F5) est supérieur à 50. Dans le cas contraire, elles renvoient 0.

Fonctions imbriquées

Les fonctions MOYENNE et SOMME sont imbriquées dans la fonction SI.

Vous pouvez imbriquer jusqu’à 64 niveaux de fonctions dans une formule.

  1. Cliquez sur la cellule dans laquelle vous voulez entrer la formule.

  2. Pour commencer la formule par la fonction, cliquez sur Insérer une fonction Button image dans la barre de formule Image du bouton .

    Excel insère le signe égal (=) pour vous.

  3. Dans la zone Ou sélectionnez une catégorie, sélectionnez Tout.

    Si vous connaissez les catégories de fonctions, vous pouvez également sélectionner une catégorie.

    Si vous avez des doutes quant à la fonction à utiliser, vous pouvez taper une question qui décrit ce que vous souhaitez faire dans la zone Recherchez une fonction (par exemple, « ajouter des nombres » renvoie la fonction SOMME).

  4. Pour entrer une autre fonction en tant qu’argument, tapez la fonction dans la zone d’argument souhaitée.

    Les parties de la formule affichée dans la boîte de dialogue Arguments de la fonction reflètent la fonction que vous avez sélectionnée à l’étape précédente.

    Si vous avez cliqué sur SI, la boîte de dialogue Arguments de la fonction affiche les arguments pour la fonction SI. Pour imbriquer une autre fonction, vous pouvez la taper dans la zone d’argument. Par exemple, vous pouvez taper SOMME(G2:G5) dans la zone Valeur_si_vrai de la fonction SI.

  5. Tapez les arguments supplémentaires nécessaires pour terminer votre formule.

    Au lieu de taper des références de cellules, vous pouvez sélectionner les cellules à référencer. Cliquez sur Button image réduire la boîte de dialogue, sélectionnez les cellules à référencer, puis cliquez sur Image du bouton pour développer de nouveau la boîte de dialogue.

    Conseil : Pour plus d’informations sur la fonction et ses arguments, cliquez sur Aide sur cette fonction.

  6. Après avoir fourni les arguments de la formule, cliquez sur OK.

  1. Cliquez sur la cellule dans laquelle vous voulez entrer la formule.

  2. Pour commencer la formule par la fonction, cliquez sur Insérer une fonction Button image dans la barre de formule Image du bouton .

  3. Dans la boîte de dialogue Insérer une fonction, dans la zone choisir une catégorie , sélectionnez tout.

    Si vous connaissez les catégories de fonctions, vous pouvez également sélectionner une catégorie.

  4. Pour entrer une autre fonction en tant qu’argument, tapez la fonction dans la zone d’argument du concepteur de formule ou directement dans la cellule.

  5. Tapez les arguments supplémentaires nécessaires pour terminer votre formule.

  6. Après avoir terminé les arguments de la formule, appuyez sur entrée.

Exemples

Voici un exemple d’utilisation de fonctions SI imbriquées pour l’attribution d’une note sous forme de lettre à un score de test numérique.

Copiez les données d’exemple dans le tableau suivant, et collez-le dans la cellule A1 d’un nouveau classeur Excel. Pour que les formules affichent des résultats, sélectionnez-les, appuyez sur F2, et sur Entrée. Si nécessaire, vous pouvez modifier la largeur des colonnes pour afficher toutes les données.

Résultat

45

90

78

Formule

Description

Résultat

'=SI(A2>89;"A";SI(A2>79;"B"; SI(A2>69;"C";SI(A2>59,"D";"F"))))

Utilise des conditions SI imbriquées pour attribuer une note sous forme de lettre au résultat de la cellule A2.

=SI(A2>89;"A";SI(A2>79;"B"; SI(A2>69;"C";SI(A2>59,"D";"F"))))

'=SI(A3>89,"A",SI(A3>79,"B", SI(A3>69,"C",SI(A3>59,"D","F"))))

Utilise des conditions SI imbriquées pour attribuer une note sous forme de lettre au résultat de la cellule A3.

=SI(A3>89;"A";SI(A3>79;"B";SI(A3>69;"C";SI(A3>59;"D";"F"))))

'=SI(A4>89;"A";SI(A4>79;"B"; SI(A4>69;"C";SI(A4>59;"D";"F"))))

Utilise des conditions SI imbriquées pour attribuer une note sous forme de lettre au résultat de la cellule A4.

=SI(A4>89;"A";SI(A4>79;"B";SI(A4>69;"C";SI(A4>59;"D";"F"))))

Conseils : 

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Voir aussi

Vidéo : Fonctions SI imbriquées

Remarque :  Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez vous nous dire si les informations vous ont été utiles ? Voici l’article en anglais pour référence.

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×