Utilisation de SI avec les fonctions ET, OU et NON

Remarque : Nous faisons de notre mieux pour vous fournir le contenu d’aide le plus récent aussi rapidement que possible dans votre langue. Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez-vous nous indiquer en bas de page si ces informations vous ont aidé ? Voici l’article en anglais à des fins de référence aisée.

La fonction SI permet d’effectuer une comparaison logique entre une valeur et une hypothèse en testant une condition et en renvoyant un résultat Vrai ou Faux.

  • =SI(quelque chose est vrai, effectuer telle action, sinon effectuer telle autre action)

Que se passe-t-il si vous avez besoin de tester plusieurs conditions, où Supposons que toutes les conditions doivent être vraies ou fausses (et), ou si une condition doit être vrai ou faux (ou), ou si vous voulez vérifier si une condition ne répond pas à vos critères? Toutes les 3 fonctions peuvent être utilisées seules, mais il est beaucoup plus courant de les voir associées aux fonctions si.

Utilisez la fonction SI avec les fonctions ET, OU et NON pour effectuer plusieurs évaluations si les conditions retournent Vrai ou Faux.

Syntaxe

  • SI(ET()) - SI(ET(valeur_logique1, [valeur_logique2],...);valeur_si_vrai;[valeur_si_faux]))

  • SI(OU()) - SI(OU(valeur_logique1, [valeur_logique2],...);valeur_si_vrai;[valeur_si_faux]))

  • SI(NON()) - SI(NON(valeur_logique1);valeur_si_vrai;[valeur_si_faux]))

Argument

Description

test_logique (obligatoire)

Condition que vous souhaitez tester.

valeur_si_vrai (obligatoire)

Valeur que vous voulez retourner si le résultat de test_logique est VRAI.

valeur_si_faux (facultatif)

Valeur que vous voulez retourner si le résultat de test_logique est FAUX.

Voici une vue d'ensemble de la structure et, ou et non des fonctions individuelles. Lorsque vous combinez chacune d'elles avec une instruction si, elles se lisent comme suit:

  • ET – =SI(ET (Une chose est vraie, Une autre est fausse), Valeur si vrai, Valeur si faux)

  • OU – =SI(OU (Une chose est vraie, Une autre est fausse), Valeur si vrai, Valeur si faux)

  • NON – =SI(NON(Une chose est vraie), Valeur si vrai, Valeur si faux)

Exemples

Voici des exemples de certaines instructions si (et ()) imbriquées courantes si (ou ()) et si (non ()). Les fonctions et et ou peuvent prendre en charge jusqu'à 255 conditions individuelles, mais il n'est pas recommandé d'en utiliser plusieurs, car les formules imbriquées complexes peuvent être très difficiles à générer, tester et gérer. La fonction non n'accepte qu'une seule condition.

Exemples d’utilisation de la fonction SI avec les fonctions ET, OU et NON pour évaluer des valeurs numériques et du texte

Voici les formules explicitées en fonction de leur logique :

Formule

Description

=SI(ET(A2>0;B2<100);VRAI;FAUX)

Si la valeur a2 (25) est supérieure à 0, et B2 (75) est inférieure à 100, renvoyer TRUE, sinon renvoyer la valeur FALSe. Dans ce cas, les deux conditions sont vraies, aussi la valeur TRUE est renvoyée.

=SI(ET(A3="Rouge";B3="Vert");VRAI;FAUX)

Si a3 ("Blue") = "Red", et B3 ("Green") égale "Green" puis retournent TRUE, sinon, retourne FALSe. Dans ce cas, seule la première condition est vraie, de sorte que la valeur FALSe est retournée.

=SI(OU(A4>0;B4<50);VRAI;FAUX)

Si a4 (25) est supérieur à 0 ou B4 (75) est inférieur à 50, renvoyer TRUE, sinon renvoyer la valeur FALSe. Dans ce cas, seule la première condition est vraie, mais dans la mesure où un argument est requis pour être vrai, la formule retourne TRUE.

=SI(OU(A5="Rouge";B5="Vert");VRAI;FAUX)

Si a5 («bleu») est égal à «rouge», ou B5 («vert») est égal à «vert», renvoyer la valeur TRUE, sinon renvoyer la valeur FALSe. Dans ce cas, le deuxième argument est true, de sorte que la formule retourne TRUE.

= SI(NON(A6>50);VRAI;FAUX)

Si A6 (25) n'est pas supérieure à 50, renvoyer la valeur TRUE, sinon renvoyer la valeur FALSe. Dans ce cas, 25 n'est pas supérieur à 50, de sorte que la formule retourne TRUE.

=SI(NON(A7="Rouge");VRAI;FAUX)

SI A7 (« Bleu ») est NON égal à « Rouge », retourner VRAI, sinon retourner FAUX.

Notez que tous les exemples comportent une parenthèse fermante après l'entrée de leurs conditions respectives. Les arguments true/false restants sont ensuite laissés dans l'instruction IF externe. Vous pouvez également remplacer du texte ou des valeurs numériques pour les valeurs TRUE/FALSe à renvoyer dans les exemples.

Voici quelques exemples d’utilisation des fonctions ET, OU et NON pour évaluer les dates.

Exemples d’utilisation de la fonction SI avec les fonctions ET, OU et NON pour évaluer des dates

Voici les formules explicitées en fonction de leur logique :

Formule

Description

=SI(A2>B2;VRAI;FAUX)

Si a2 est supérieur à B2, renvoyer la valeur TRUE, sinon renvoyer la valeur FALSe. 03/12/14 est supérieur à 01/01/14, de sorte que la formule retourne TRUE.

=SI(ET(A3>B2;A3<C2);VRAI;FAUX)

Si a3 est supérieur à B2 et que a3 est inférieur à C2, renvoyer la valeur TRUE, sinon renvoyer la valeur FALSe. Dans ce cas, les deux arguments sont vrais, de sorte que la formule retourne TRUE.

=SI(OU(A4>B2;A4<B2+60);VRAI;FAUX)

Si a4 est supérieur à B2 ou a4 est inférieur à B2 + 60, renvoyer la valeur TRUE, sinon renvoyer la valeur FALSe. Dans ce cas, le premier argument est true, mais le deuxième est false. Dans la mesure où l'un des arguments doit être vrai ou seulement, la formule retourne TRUE. Si vous utilisez l'Assistant évaluation de formule dans l'onglet formule, vous verrez comment Excel évalue la formule.

=SI(NON(A5>B2);VRAI;FAUX)

Si a5 n'est pas supérieur à B2, renvoyer la valeur TRUE, sinon renvoyer la valeur FALSe. Dans ce cas, a5 est supérieur à B2, de sorte que la formule retourne FALSe.

Exemple d’utilisation de l’Assistant Évaluer la formule

Utilisation des fonctions ET, OU et NON avec une mise en forme conditionnelle

Vous pouvez également utiliser AND, OR et NOT pour assigner des critères de mise en forme conditionnelle avec l'option Formula. Lorsque vous procédez ainsi, vous pouvez omettre la fonction si et utiliser les fonctions et, ou et pas.

Sous l'onglet Accueil , cliquez sur mise en forme conditionnelle > nouvelle règle. Sélectionnez ensuite l'option «utiliser une formule pour déterminer pour quelles cellules le format», entrez votre formule et appliquez le format de votre choix.

Mise en forme conditionnelle > boîte de dialogue Modifier la règle affichant la méthode Formule

En utilisant l’exemple Dates précédent, voici ce que les formules seraient.

Exemple d’utilisation des fonctions ET, OU et NON en tant que tests de mise en forme conditionnelle

Formule

Description

=A2>B2

Si A2 est supérieur à B2, mettre en forme la cellule, sinon ne rien faire.

=ET(A3>B2;A3<C2)

Si A3 est supérieur à B2 ET A3 est inférieur à C2, mettre en forme la cellule, sinon ne rien faire.

=OU(A4>B2;A4<B2+60)

Si A4 est supérieur à B2 ou A4 est inférieur à B2 plus 60 (jours), mettre en forme la cellule, sinon ne rien faire.

=NON(A5>B2)

Si a5 n'est pas supérieur à B2, mettre en forme la cellule, sinon ne rien faire. Dans ce cas, a5 est supérieur à B2, de sorte que le résultat retourne FALSe. Si vous étiez en train de remplacer la formule par = not (B2>A5) , elle retourne true et la cellule est mise en forme.

Remarque : Une erreur courante consiste à entrer une formule en mise en forme conditionnelle sans le signe égal (=). Si vous procédez ainsi, la boîte de dialogue mise en forme conditionnelle ajoute le signe égal et les guillemets à la formule- = «ou (A4>B2, A4<B2 + 60)», vous devez donc supprimer les guillemets avant que la formule ne réponde correctement.

Haut de la page

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Voir aussi

Regardez une vidéo sur l'utilisation de la fonction si

Découvrir comment utiliser des fonctions imbriquées dans une formule

Fonction SI

ET

OU

NON

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Détecter les erreurs dans les formules

Raccourcis clavier dans Excel pour Windows

Raccourcis clavier dans Excel pour Mac

Fonctions logiques (référence)

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×