Utilisation de fonctions et de fonctions imbriquées dans les formules Excel

Les fonctions sont des formules prédéfinies qui effectuent des calculs en utilisant des valeurs particulières, appelées arguments, dans un certain ordre (ou structure). Les fonctions permettent d’effectuer des calculs simples et complexes. Toutes les fonctions d’Excel se trouvent dans l’onglet Formules du ruban :

L’onglet formules Excel sur le ruban
  • Syntaxe de fonction d’Excel

    L’exemple suivant de la fonction ARRONDI, qui arrondit un nombre dans la cellule A10, illustre la syntaxe d’une fonction.

    Structure d’une fonction

    1. Structure. La structure d’une fonction débute par un signe égal (=), suivi du nom de la fonction, d’une parenthèse ouvrante, des arguments de la fonction séparés par des points-virgules et d’une parenthèse fermante.

    2. Nom de fonction. Pour obtenir la liste des fonctions disponibles, cliquez sur une cellule et appuyez sur Maj+F3. Cela a pour effet d’ouvrir la boîte de dialogue Insérer une fonction.

    Formules Excel - Boîte de dialogue Insertion

    3. Arguments. Les arguments peuvent être des nombres, du texte, des valeurs logiques telles que VRAI ou FAUX, des tableaux, des valeurs d’erreur telles que #N/A ou des références de cellules. L’argument que vous désignez doit produire une valeur valide pour cet argument. Les arguments peuvent également être des constantes, des formules ou d’autres fonctions.

    4. Info-bulle d’argument. Une info-bulle contient la syntaxe et les arguments, et s’affiche lorsque vous tapez la fonction. Par exemple, tapez =ARRONDI( et l’info-bulle s’affiche. Les info-bulles s’affichent uniquement pour les fonctions intégrées.

    Remarque : Vous n’avez pas besoin d’entrer les noms des fonctions entièrement en majuscules (par exemple, =ARRONDI), car Excel les met automatiquement en majuscules à votre place lorsque vous appuyez sur Entrée. Si vous avez mal orthographié le nom d’une fonction (par exemple, =SOME(A1:A10) à la place de =SOMME(A1:A10)), Excel renvoit l’erreur #NOM?.

  • Saisie des fonctions Excel

    Lorsque vous créez une formule qui contient une fonction, vous pouvez utiliser la boîte de dialogue Insérer une fonction pour vous aider à entrer les fonctions de feuille de calcul. Lorsque vous sélectionnez une fonction dans la boîte de dialogue Insérer une fonction, Excel démarre un Assistant de fonction qui affiche le nom de la fonction, chacun de ses arguments, une description de la fonction et de chaque argument, le résultat actuel de la fonction et le résultat actuel de l’intégralité de la formule.

    Assistant de fonction Excel

    Pour faciliter la création et la modification des formules, et pour limiter les erreurs de syntaxe et de frappe, utilisez la fonctionnalité Saisie semi-automatique de formule. Après avoir tapé un = (signe égal) et les premières lettres d’une fonction, Excel affiche une liste déroulante dynamique des fonctions, arguments et noms valides qui correspondent à ces lettres. Vous pouvez ensuite effectuer votre choix dans la liste déroulante pour qu’Excel l’insère à votre place.

    Saisie semi-automatique de formule Excel

  • Imbrication des fonctions Excel

    Dans certains cas, une fonction peut être utilisée comme argument d’une autre fonction. Par exemple, la formule suivante comporte une fonction MOYENNE imbriquée dont elle compare le résultat à la valeur 50.

    Fonctions imbriquées

    1. Les fonctions MOYENNE et SOMME sont imbriquées dans la fonction SI.

    Valeurs renvoyées valides    Lorsqu’une fonction imbriquée est utilisée comme argument, elle doit renvoyer le même type de valeur que l’argument. Si l’argument renvoie la valeur VRAI ou FAUX, par exemple, la fonction imbriquée doit aussi renvoyer ces valeurs. Dans le cas contraire, Excel affiche la valeur d’erreur #VALEUR!.

    Limites des niveaux d’imbrication    Une formule peut contenir jusqu’à sept niveaux d’imbrication. Quand une fonction (que nous appellerons Fonction B) est utilisée comme argument d’une autre fonction (que nous appellerons Fonction A), la fonction B fait office de second niveau. La fonction MOYENNE et la fonction SOMME, par exemple, sont des fonctions de second niveau si elles sont utilisées comme arguments de la fonction SI. Une fonction imbriquée dans la fonction MOYENNE imbriquée est une fonction de troisième niveau, etc.

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×