Formules et fonctions

Fonction SOMME

SOMME (SOMME, fonction)

La fonction SOMME, une des fonctions mathématiques et trigonométriques, permet d’additionner des valeurs. Vous pouvez ajouter des valeurs individuelles, des références ou des plages de cellules, ou une combinaison des trois.

Par exemple :

  • =SOMME(A2:A10)

  • =SOMME(A2:A10; C2:C10)

Votre navigateur ne prend pas en charge la vidéo. Installez Microsoft Silverlight, Adobe Flash Player ou Internet Explorer 9.

SOMME(nombre1;[nombre2];...)

Argument

Description

nombre1    (obligatoire)

Premier nombre à additionner. Le nombre peut être un 4, une référence de cellule comme B6 ou une plage de cellules comme B2:B8.

nombre2-255    (facultatif)

Il s’agit du deuxième nombre à additionner. Vous pouvez spécifier jusqu’à 255 nombres de cette façon.

Cette section vous présente quelques recommandations pour l’utilisation des fonctions SOMME. Qui peuvent également être appliquées à d’autres fonctions.

Méthode =1+2 ou =A+B - Bien que vous puissiez entrer =1+2+3 ou =A1+B1+C2 et obtenir des résultats précis, ces méthodes sont sujettes à des erreurs, et ce pour plusieurs raisons :

  1. Fautes de frappe - Imaginez que vous deviez entrer des valeurs longues telles que celle-ci :

    • =14598,93+65437,90+78496,23

    Essayez ensuite de vérifier l’exactitude de vos entrées. Nous vous conseillons de placer ces valeurs dans des cellules individuelles et d’utiliser une formule SOMME. De plus, vous pouvez mettre en forme les valeurs quand elles se trouvent dans des cellules, ce qui les rend ensuite beaucoup plus lisibles lorsqu’elles sont incluses dans une formule.

    Utilisez la fonction SOMME au lieu de valeurs codées de manière irréversible dans les formules.  La formule incluse dans la cellule D5 est =SOMME(D2:D4)
  2. Erreurs #VALEUR! générées suite au référencement de texte plutôt que de nombres

    Si vous utilisez une formule telle que :

    • =A1+B1+C1 ou =A1+A2+A3

    Exemple d’une construction de formule incorrecte.  La formule incluse dans la cellule D2 est =A2+B2+C2

    Votre formule peut être incorrecte si les cellules référencées incluent des valeurs non numériques (texte) et renvoyer une erreur #VALEUR!. erreur. La fonction SOMME ignore les valeurs de texte et calcule la somme des valeurs numériques uniquement.

    Construction adéquate des formules.  Au lieu de =A2+B2+C2, la formule incluse dans la cellule D2 est =SOMME(A2:C2)
  3. Erreur #REF! générée suite à la suppression de lignes ou de colonnes

    Erreur #REF! causée par la suppression d’une colonne.  La formule a changé en =A2+#REF!+B2

    Si vous supprimez une ligne ou une colonne, la formule ne se mettra pas à jour de manière à exclure la ligne ou la colonne supprimée et renverra une erreur #REF! erreur où une fonction SOMME se mettra à jour automatiquement.

    La fonction SOMME s’ajuste automatiquement en fonction des lignes ou des colonnes insérées ou supprimées
  4. Les formules ne mettront pas à jour les références lors de l’insertion de lignes ou de colonnes

    Les formules =A+B+C ne sont pas mises à jour si vous ajoutez des lignes

    Si vous insérez une ligne ou une colonne, la formule ne sera pas mise à jour de manière à inclure la ligne ajoutée, tandis qu’une fonction SOMME sera mise à jour automatiquement (tant que vous n’êtes pas hors de la plage référencée dans la formule). Ce point est particulièrement important si vous vous attendez à ce que votre formule soit mise à jour et que ce n’est pas le cas, et votre résultat sera incorrect.

    Exemple illustrant une formule SOMME qui s’est développée automatiquement de =SOMME(A2:C2) en =SOMME(A2:D2) lorsqu’une colonne a été insérée
  5. SOMME utilisé avec des références de cellules individuelles et des plages

    En utilisant une formule telle que :

    • =SOMME(A1,A2,A3,B1,B2,B3)

    Pour les mêmes raisons, cette formule est également sujette à des erreurs lors de l’insertion ou de la suppression de lignes au sein de plage référencée. Nous vous conseillons d’utiliser des plages individuelles, par exemple :

    • =SOMME(A1:A3,B1:B3)

    Qui seront mises à jour lors de l’ajout ou de la suppression de lignes.

Problème

Cause

Ma fonction SOMME affiche #####, et non le résultat.

Vérifiez la largeur des colonnes. La valeur ##### indique généralement que la colonne est trop étroite pour afficher le résultat de la formule.

Ma fonction SOMME affiche la formule elle-même sous forme de texte, et non le résultat.

Vérifiez que la cellule n’est pas mise en forme en tant que texte. Sélectionnez la cellule ou plage en question et utilisez Ctrl+1 pour ouvrir la boîte de dialogue Format de cellule, puis cliquez sur l’onglet Nombre et sélectionnez le format souhaité. Si la cellule a été mise en forme en tant que texte et qu’elle ne change pas lorsque vous modifiez le format, vous devrez peut-être utiliser F2 > Entrée pour forcer la modification du format.

Ma fonction SOMME ne se met pas à jour.

Vérifiez que l’option Calcul est définie sur Automatique. Dans l’onglet Formule, accédez auxOptions de calcul. Vous pouvez également utiliser F9 pour forcer la feuille de calcul à effectuer le calcul.

Vérifiez que l’option Calcul est définie sur Automatique.  Dans l’onglet Formule, accédez à Options de calcul.

Certaines valeurs ne sont pas additionnées.

Seules les valeurs numériques dans la référence ou la plage de la fonction peuvent être additionnées. Les cellules vides, les valeurs logiques comme VRAI ou le texte sont ignorés.

L’erreur #NOM? apparaît à la place du résultat attendu.

Cela signifie généralement que la formule est mal orthographiée, par exemple, =some(A1:A10) au lieu de =SOMME(A1:A10).

Ma fonction SOMME affiche un nombre entier alors qu’elle devrait afficher des décimales

Vérifiez la mise en forme de votre cellule pour vous assurer que vous affichez les décimales. Sélectionnez la cellule ou plage en question et utilisez Ctrl+1 pour ouvrir la boîte de dialogue Format de cellule, puis cliquez sur l’onglet Nombre et sélectionnez le format souhaité, en vous assurant d’indiquer le nombre de décimales voulu.

  1. Je souhaite simplement additionner/soustraire/Multiplier/diviser des nombres Consultez cette série de vidéos sur lesopérations mathématiques de base dans Excel, ou utiliser Excel comme une calculatrice.

  2. Comment afficher plus/moins de décimales ? Vous pouvez modifier votre format de nombre. Sélectionnez la cellule ou plage en question et utilisez Ctrl+1 pour ouvrir la boîte de dialogue Format de cellule, puis cliquez sur l’onglet Nombre et sélectionnez le format souhaité, en vous assurant d’indiquer le nombre de décimales voulu.

  3. Comment additionner ou soustraire des heures ? Vous pouvez additionner et soustraire des heures de plusieurs manières. Par exemple, lors du calcul de la paie, pour obtenir la différence entre 08h00 et 12h00, vous utilisez la formule suivante : =("12:00"-"08:00")*24, soit la différence entre l’heure de fin et l’heure de début. Notez qu’Excel calcule les heures en tant que fraction d’une journée, c’est pourquoi vous devez multiplier par 24 pour obtenir le nombre total d’heures. Dans le premier exemple, nous utilisons =((B2-A2)+(D2-C2))*24 pour calculer la somme des heures comprises entre le début et la fin d’une journée, moins le temps consacré à une pause-déjeuner (8,50 heures au total).

    Si vous additionnez simplement des heures et des minutes et souhaitez les afficher de cette manière, vous pouvez effectuer une addition. Dans ce cas, vous n’avez pas besoin de multiplier le résultat obtenu par 24. Dans le deuxième exemple, nous utilisons la formule =SOMME(A6:C6) étant donné que nous souhaitons simplement calculer le nombre total d’heures et de minutes consacrées aux tâches attribuées (5h36, soit 5 heures et 36 minutes).

    Calculer des heures

    Pour plus d’informations, consultez : Additionner ou soustraire des heures

  4. Comment obtenir la différence entre des dates ? Comme pour les heures, vous pouvez additionner et soustraire des dates. Voici un exemple courant de calcul du nombre de jours entre deux dates. Il suffit d’utiliser la formule =B2-A2. Pour travailler avec des heures et des dates, il est important de commencer par Date/Heure de fin et de soustraire la Date/Heure de début.

    Calculer la différence entre des dates

    Pour découvrir d’autres façons de travailler avec des dates, voir : Calculer le nombre de jours entre deux dates.

  5. Comment additionner les cellules visibles uniquement ? Parfois, lorsque vous masquez manuellement des lignes ou lorsque vous utilisez la fonctionnalité Filtre automatique de manière à afficher uniquement certaines données, vous souhaiterez additionner les cellules visibles uniquement. Vous pouvez utiliser la fonction SOUS.TOTAL pour ce faire. Si vous utilisez une ligne de totaux dans un tableau Excel, n’importe quelle cellule que vous sélectionnez dans la liste déroulante Total sera automatiquement entrée en tant que sous-total. Découvrez plus d’informations sur la manière de totaliser les données d’un tableau Excel.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Voir aussi

En savoir plus sur SOMME

La fonction SOMME.SI additionne uniquement les valeurs qui répondent à un critère unique

La fonction SOMME.SI.ENS additionne uniquement les valeurs qui répondent à plusieurs critères

La fonction NB.SI compte uniquement les valeurs qui répondent à un seul critère

La fonction NB.SI.ENS compte uniquement les valeurs qui répondent à plusieurs critères

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Rechercher et corriger les erreurs dans les formules

Raccourcis clavier dans Excel pour Windows

Raccourcis clavier dans Excel pour Mac

Fonctions mathématiques et trigonométriques

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×