SIERREUR (SIERREUR, fonction)

Vous pouvez utiliser la fonction SIERREUR pour intercepter et gérer des erreurs dans une formule. SIERREUR renvoie une valeur que vous spécifiez si une formule génère une erreur; dans le cas contraire, elle renvoie le résultat de la formule.

Syntaxe

SIERREUR(valeur;valeur_si_erreur)

La syntaxe de la fonction SIERREUR contient les arguments suivants :

  • valeur    Obligatoire. Représente l’argument vérifié.

  • value_if_error    Obligatoire. Représente la valeur à renvoyer si une formule génère une erreur. Les types d’erreur suivants sont évalués : #N/A, #VALEUR!, #REF!, #DIV/0!, #NOMBRE!, #NOM?, ou #NUL!.

Remarques

  • Si value ou Value_if_error est une cellule vide, SIERREUR la traite comme une valeur de chaîne vide ("").

  • Si valeur est une formule matricielle, la fonction SIERREUR renvoie une matrice de résultats pour chaque cellule de la plage spécifiée dans l’argument valeur. Voir le second exemple ci-dessous.

Exemples

Copiez les données d’exemple dans le tableau suivant, et collez-le dans la cellule A1 d’un nouveau classeur Excel. Pour que les formules affichent des résultats, sélectionnez-les, appuyez sur F2, et sur Entrée.

Quota

Unités vendues

210

35

55

0

23

Formule

Description

Résultat

=SIERREUR(A2/B2, "Erreur de calcul")

Recherche une erreur dans le premier argument de la formule (divise 210 par 35), ne trouve aucune erreur, puis renvoie le résultat de la formule.

6

=SIERREUR(A3/B3, "Erreur de calcul")

Recherche une erreur dans le premier argument de la formule (divise 55 par 0), trouve une erreur de division par 0, puis renvoie l’argument valeur_si_erreur.

Erreur de calcul

=SIERREUR(A4/B4, "Erreur de calcul")

Recherche une erreur dans le premier argument de la formule (divise "" par 23), ne trouve aucune erreur, puis renvoie le résultat de la formule.

0

Exemple 2

Quota

Unités vendues

Rapport

210

35

6

55

0

Erreur de calcul

23

0

Formule

Description

Résultat

=C2

Recherche une erreur dans le premier argument du premier élément de la matrice de la formule (A2/B2 ou divise 210 par 35), ne trouve aucune erreur, puis renvoie le résultat de la formule.

6

=C3

Recherche une erreur dans le premier argument du second élément de la matrice de la formule (A3/B3 ou divise 55 par 0), trouve une erreur de division par 0, puis renvoie l’argument valeur_si_erreur.

Erreur de calcul

=C4

Recherche une erreur dans le premier argument du troisième élément de la matrice de la formule (A2/B4 ou divise "" par 35), ne trouve aucune erreur, puis renvoie le résultat de la formule.

0

Remarque: Si vous avez une version actuelle d' Office 365, vous pouvez entrer la formule dans la cellule en haut à gauche de la plage de sortie, puis appuyer sur entrée pour confirmer la formule en tant que formule matricielle dynamique. Dans le cas contraire, il est nécessaire d’entrer la formule en tant que formule matricielle héritée en sélectionnant d’abord la plage de sortie, en entrant la formule dans la cellule supérieure gauche de la plage de sortie, puis en appuyant sur CTRL + MAJ + ENTRÉE pour la confirmer. Excel insère des accolades au début et à la fin de la formule. Pour plus d’informations sur les formules de tableau, voir Instructions et exemples de formules de tableau.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Remarque :  Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez vous nous dire si les informations vous ont été utiles ? Voici l’article en anglais pour référence.

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×