Formules et fonctions

Fonction SI

SI (SI, fonction)

La fonction SI est l’une des plus populaires dans Excel. Elle permet d’établir des comparaisons logiques entre une valeur et le résultat attendu.

Une instruction SI peut donc avoir deux résultats. Le premier résultat est appliqué si la comparaison est vérifiée, sinon le deuxième résultat est appliqué.

Par exemple, SI(C2="Oui";1;2) indique SI(C2 = Oui, renvoyer un 1, sinon renvoyer un 2)

Votre navigateur ne prend pas en charge la vidéo. Installez Microsoft Silverlight, Adobe Flash Player ou Internet Explorer 9.

Utilisez la fonction SI, une des fonctions logiques, pour renvoyer une valeur si une condition est vraie et une autre valeur si elle est fausse.

SI(test_logique; valeur_si_vrai; [valeur_si_faux])

Par exemple :

  • =SI(A2>B2;"Dépasse le budget";"OK")

  • =SI(A2=B2;B4-A4;"")

Argument

Description

test_logique    (obligatoire)

Condition que vous souhaitez tester.

valeur_si_vrai    (obligatoire)

Valeur que vous voulez renvoyer si le résultat de test_logique est VRAI.

valeur_si_faux    (facultatif)

Valeur que vous voulez renvoyer si le résultat de test_logique est FAUX.

Exemples simples d’utilisation de la fonction SI

La cellule D2 contient la formule =SI(C2="Oui";1;2)
  • =SI(C2=”Oui”;1;2)

Dans l’exemple ci-dessus, la cellule D2 indique : SI(C2 = Oui, renvoyer la valeur 1, sinon renvoyer la valeur 2)

La cellule D2 contient la formule =SI(C2=1;"OUI";"NON")
  • =SI(C2=1;”Oui”;”Non”)

Dans cet exemple, la formule dans la cellule D2 déclare: SI(C2 = 1, alors renvoi Oui, sinon renvoi Non)Comme vous le voyez, la fonction SI peut être utilisée afin d’évaluer le texte et les valeurs. Elle peut également être utilisée pourévaluer des erreurs. Vous n’êtes pas limité à la vérification si un élément est égal à un autre et au renvoi à un résultat unique, vous pouvez également utiliser les opérateurs mathématiques et exécuter des calculs supplémentaires selon votre critère. Vous pouvez également emboîter des fonctions multiples SI ensemble afin d’exécuter de multiples comparaisons.

La formule dans la cellule D2 est =SI(C2>B2;”Dépasse le budget”;”Cadre dans le budget”)
  • =SI(C2>B2;”Dépasse le budget”;”Cadre dans le budget”)

Dans l’exemple ci-dessus, la fonction SI dans la cellule D2 indique SI(C2 est supérieur à B2, renvoyer « Dépasse le budget », sinon renvoyer « Cadre dans le budget »)

La formule dans la cellule E2 est =SI(C2>B2;C2-B2;"")
  • =SI(C2>B2;C2-B2;0)

Dans l’illustration ci-dessus, au lieu de renvoyer un texte de résultat, nous allons renvoyer un calcul mathématique. La formule dans la cellule E2 a la signification suivante : SI(la valeur Réel est supérieure à la valeur Budget, soustraire le montant de Budget du montant Réel, sinon ne rien renvoyer).

La formule dans la cellule F7 est SI(E7=”Oui”;F5*0,0825;0)
  • =SI(E7=”Oui”;F5*0,0825;0)

Dans cet exemple, la formule dans la cellule F7 indique SI(E7=“Oui”, calculer le montant total dans F5*8,25 %, sinon renvoyer 0 car aucune taxe n’est due)

Remarque : Si vous comptez utiliser du texte dans des formules, vous devez l’entourer de guillemets (par exemple, “Texte”). La seule exception est l’utilisation des valeurs VRAI ou FAUX qui sont comprises automatiquement par Excel.

Problèmes courants

Problème

Cause

O (zéro) dans la cellule

Il n’y a pas de valeur pour l’argument valeur_si_vrai ou valeur_si_faux. Pour afficher la valeur correcte renvoyée, ajoutez le texte de l’argument aux deux arguments, ou ajoutez VRAI ou FAUX à l’argument.

#NOM? dans la cellule

En règle générale, cela signifie que la formule est mal orthographiée.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Voir aussi

Opérateurs de calcul et ordre de priorité dans Excel

Utiliser des fonctions imbriquées dans une formule

Utilisation de la fonction SI pour vérifier si une cellule est vide

Utilisation de la fonction SI pour vérifier si une cellule est vide

Vidéo : Fonctions SI avancées

Fonction SI.CONDITIONS (Office 365, Excel 2016 et versions ultérieures)

Fonctions SI avancées - Utiliser des formules imbriquées et éviter les pièges

Vidéos de formation : Fonctions SI avancées

La fonction NB.SI compte les valeurs sur la base d’un seul critère

La fonction NB.SI.ENS compte les valeurs sur la base de plusieurs critères

La fonction SOMME.SI additionne des valeurs sur la base d’un seul critère

La fonction SOMME.SI.ENS additionne des valeurs sur la base de plusieurs critères

Fonction ET

Fonction OU

Fonction RECHERCHEV

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Détecter les erreurs dans les formules

Fonctions logiques

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×