Office
Se connecter

Se connecter (importer) à des données externes

Remarque :  Nous faisons de notre mieux pour vous fournir le contenu d’aide le plus récent aussi rapidement que possible dans votre langue. Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez-vous nous indiquer en bas de page si ces informations vous ont aidé ? Voici l’article en anglais à des fins de référence aisée.

Lorsque vous vous connectez à des données externes, le principal avantage est que vous pouvez analyser régulièrement ces données dans Microsoft Office Excel sans avoir à les copier à chaque fois, ce qui prend du temps et est sujet à erreur. Après vous être connecté aux données externes, vous pouvez également actualiser (ou mettre à jour) vos classeurs Excel à partir de la source de données d’origine lorsque celle-ci est mise à jour.

Important : Connexions aux données externes peuvent être désactivées sur votre ordinateur. Pour vous connecter aux données lorsque vous ouvrez un classeur, vous devez activer des connexions de données à l’aide de la barre Centre de gestion de la confidentialité ou en plaçant le classeur dans un emplacement approuvé. Pour plus d’informations, voir créer, supprimer ou modifier un emplacement approuvé pour vos fichiers, Ajouter, supprimer ou afficher un éditeur approuvéet Afficher mes paramètres de sécurité dans le centre de gestion de la confidentialité.

  1. Sous l’onglet données, cliquez sur Connexions existantes.

    Image Ruban Excel

  2. Dans la liste déroulante Afficher, effectuez l’une des opérations suivantes :

    • Pour afficher toutes les connexions, cliquez sur Toutes les connexions. Il s’agit de l’option par défaut.

    • Pour afficher uniquement la liste des connexions utilisées récemment, cliquez sur connexions de ce classeur.

      Cette liste est créée à partir de connexions que vous avez déjà définie, que vous avez créé à l’aide de la boîte de dialogue Sélectionner la Source de données de l’Assistant connexion de données ou que vous avez précédemment sélectionné comme une connexion à partir de cette boîte de dialogue .

    • Pour afficher uniquement les connexions disponibles sur votre ordinateur, cliquez sur fichiers de connexion sur cet ordinateur.

      Cette liste est créée à partir du dossier Mes Sources de données qui se trouve généralement dans le dossier Mes Documents sur votre ordinateur.

    • Pour afficher uniquement les connexions sont disponibles à partir d’un fichier de connexion qui n’est accessible à partir du réseau, cliquez sur fichiers de connexion sur le réseau. Cette liste est créée à partir d’un serveur Excel données connexion bibliothèque (DCL) sur un site Microsoft SharePoint Services. ODC est une bibliothèque de documents dans un site SharePoint Services qui contient une collection de fichiers de connexion de données Office (ODC) (.odc). En règle générale, une bibliothèque DCL est configurée par un administrateur du site, qui peut également configurer le site SharePoint pour afficher les fichiers ODC de cette bibliothèque DCL dans la boîte de dialogue Connexions externes. Pour plus d’informations, voir aide Administration centrale SharePoint Services.

      Conseil : Si la connexion désirée n’apparaît pas, créez-en une. Cliquez sur Rechercher d’autres programmes, puis cliquez sur Nouvelle source dans la boîte de dialogue Sélectionner la source de données pour ouvrir l’Assistant Connexion de données et sélectionner la source de données à laquelle vous souhaitez vous connecter.

      Remarque : Si vous choisissez une connexion dans les fichiers de connexion sur le réseau ou les fichiers de connexion de catégories de cet ordinateur, le fichier de connexion est copié dans le classeur en tant que nouvelle connexion du classeur et est alors utilisé comme les nouvelles informations de connexion.

  3. Sélectionnez la connexion voulue et cliquez sur Ouvrir.

  4. Dans la boîte de dialogue Importer les données, sous Sélectionnez la méthode d’affichage de ces données dans votre classeur, procédez de l’une des façons suivantes :

    Important : La section Sélectionner la manière dont vous souhaitez afficher ces données dans votre classeur et ses options, comme indiqué dans la liste suivante, ne sont pas disponibles pour le texte, une requête Web et les connexions de données XML. Si vous vous connectez à ces données, passez à l’étape 5.

    • Pour créer une table de tri et de filtrage simple, cliquez sur Table.

    • Pour créer un rapport de tableau croisé dynamique et faire la synthèse de volumes importants de données en les ajoutant et en calculant le sous-total, cliquez sur Rapport de tableau croisé dynamique.

    • Pour créer un rapport de graphique croisé dynamique et de tableau croisé dynamique afin d’obtenir une synthèse visuelle des données, cliquez sur Rapport de graphique croisé dynamique et de tableau croisé dynamique.

    • Pour stocker la connexion sélectionnée dans le classeur en vue de son utilisation ultérieure, cliquez sur Ne créer que la connexion.

      Utilisez l’option Ne créer que la connexion pour stocker la connexion sélectionnée dans le classeur en vue d’une utilisation ultérieure. Par exemple, si vous vous connectez à une source de données de cube OLAP (Online Analytical Processing) et que vous tentez de convertir des cellules de tableau croisé dynamique en formules de feuilles de calcul à l’aide de la commande Convertir en formules (dans le groupe Outils de l’onglet Options, cliquez sur Outils OLAP), vous pouvez utiliser cette option car vous n’avez pas besoin d’enregistrer le rapport du tableau croisé dynamique.

  5. Sous Insérer les données dans, procédez de l’une des façons suivantes :

    • Pour placer le rapport de tableau ou de graphique croisé dynamique dans une feuille de calcul existante, sélectionnez Feuille de calcul existante et tapez l’adresse de la première cellule de la plage dans laquelle vous voulez placer le rapport.

    • Ou bien, cliquez sur Réduire la boîte de dialogue image du bouton pour masquer temporairement la boîte de dialogue, sélectionnez la cellule de début sur la feuille de calcul et appuyez sur Développer la boîte de dialogue image du bouton .

  6. Pour placer le rapport de tableau croisé dynamique dans une nouvelle feuille à partir de la cellule A1, cliquez sur Nouvelle feuille.

  7. Si vous le souhaitez, vous pouvez modifier les propriétés de connexion en cliquant sur Propriétés, puis effectuez vos modifications dans les boîtes de dialogue Propriétés de connexion, Plage de données externes ou Propriétés du mappage XML, puis sur OK.

  1. Dans le groupe Données externes de l'onglet Données, cliquez sur Connexions existantes.

    Image du ruban Excel

  2. Dans la liste déroulante Afficher de la boîte de dialogue Connexions existantes, procédez de l’une des façons suivantes :

    • Pour afficher toutes les connexions, cliquez sur Toutes les connexions. Il s’agit de l’option par défaut.

    • Pour afficher uniquement la liste des connexions utilisées récemment, cliquez sur Connexions de ce classeur.

      Cette liste est dressée à partir des connexions que vous avez déjà définies en les créant dans la boîte de dialogue Sélectionner la source de données de l'Assistant Connexion de données ou que vous avez sélectionnées en tant que connexion dans cette boîte de dialogue.

    • Pour afficher uniquement les connexions disponibles sur votre ordinateur, cliquez sur Fichiers de connexion de cet ordinateur.

      Cette liste est dressée à partir du dossier Mes sources de données généralement situé dans le dossier Mes documents.

    • Pour afficher uniquement les connexions disponibles à partir d’un fichier de connexion accessible sur le réseau, cliquez sur Fichiers de connexion du réseau.

      Cette liste est créée à partir d’une bibliothèque de connexion de données Excel Services (DCL) sur un site Microsoft Office SharePoint Server 2007. ODC est une bibliothèque de documents dans un site Microsoft Office SharePoint Services 2007 qui contient une collection de fichiers de connexion de données Office (ODC) (.odc). En règle générale, une bibliothèque DCL est configurée par un administrateur du site, qui peut également configurer le site SharePoint pour afficher les fichiers ODC de cette bibliothèque DCL dans la boîte de dialogue Connexions externes. Pour plus d’informations, voir aide Office SharePoint Server 2007 Central Administration.

      Conseil : Si la connexion désirée n’apparaît pas, créez-en une. Cliquez sur Rechercher d’autres programmes, puis cliquez sur Nouvelle source dans la boîte de dialogue Sélectionner la source de données pour ouvrir l’Assistant Connexion de données et sélectionner la source de données à laquelle vous souhaitez vous connecter.

      Remarque : Si vous choisissez une connexion dans les catégories Fichiers de connexion du réseau ou Fichiers de connexion de cet ordinateur, le fichier de connexion est copié dans le classeur en tant que nouvelle connexion de classeur et est utilisé en tant que nouvelles informations de connexion.

  3. Sélectionnez la connexion voulue et cliquez sur Ouvrir.

  4. Dans la boîte de dialogue Importer les données, sous Sélectionnez la méthode d’affichage de ces données dans votre classeur, procédez de l’une des façons suivantes :

    Important : La section Sélectionnez la méthode d’affichage de ces données dans votre classeur et ses options, comme indiqué dans la liste suivante, ne sont pas disponibles pour les connexions de texte, de requête sur le web et de données XML. Si vous vous connectez à ce type de données, passez à l’étape 5.

    • Pour créer une table de tri et de filtrage simple, cliquez sur Table.

    • Pour créer un rapport de tableau croisé dynamique et faire la synthèse de volumes importants de données en les ajoutant et en calculant le sous-total, cliquez sur Rapport de tableau croisé dynamique.

    • Pour créer un rapport de graphique croisé dynamique et de tableau croisé dynamique afin d'obtenir une synthèse visuelle des données, cliquez sur Rapport de graphique croisé dynamique et de tableau croisé dynamique.

    • Pour stocker la connexion sélectionnée dans le classeur en vue de son utilisation ultérieure, cliquez sur Ne créer que la connexion.

      Utilisez l’option Ne créer que la connexion pour stocker la connexion sélectionnée dans le classeur en vue d’une utilisation ultérieure. Par exemple, si vous vous connectez à une source de données de cube OLAP (Online Analytical Processing) et que vous tentez de convertir des cellules de tableau croisé dynamique en formules de feuilles de calcul à l’aide de la commande Convertir en formules (dans le groupe Outils de l’onglet Options, cliquez sur Outils OLAP), vous pouvez utiliser cette option car vous n’avez pas besoin d’enregistrer le rapport du tableau croisé dynamique.

  5. Sous Insérer les données dans, procédez de l'une des façons suivantes :

    • Pour placer le rapport de tableau ou de graphique croisé dynamique dans une feuille de calcul existante, sélectionnez Feuille de calcul existante et cliquez sur la première cellule de la plage dans laquelle vous voulez placer le rapport.

      Ou bien, cliquez sur Réduire la boîte de dialogue image du bouton pour masquer temporairement la boîte de dialogue, sélectionnez la cellule de début sur la feuille de calcul et appuyez sur Développer la boîte de dialogue image du bouton .

  6. Pour placer le rapport de tableau croisé dynamique dans une nouvelle feuille à partir de la cellule A1, cliquez sur Nouvelle feuille.

  7. Vous pouvez également modifier les propriétés de connexion : cliquez sur Propriétés, apportez les modifications souhaitées dans les boîtes de dialogue Propriétés de connexion, Plages de données externes ou Propriétés du mappage XML, puis cliquez sur OK.

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×