Passer directement au contenu principal

Publier un classeur sur un site SharePoint dans Excel pour Windows

Vous pouvez publier un classeur dans une bibliothèque SharePoint de sorte que d’autres utilisateurs puissent le visualiser ou le modifier dans un navigateur web sans qu’Excel soit installé sur leur ordinateur. La publication équivaut plus ou moins à un enregistrement, mais offre en plus certaines options intégrées qui vous permettent de contrôler ce que les utilisateurs voient quand ils ouvrent le classeur dans un navigateur.

L’adoption d’une pratique à l’échelle de l’organisation consistant à enregistrer ou publier un classeur dans un site SharePoint central peut aider à s’assurer que des versions légèrement différentes du même classeur ne circulent pas dans votre organisation lorsque ce classeur est transmis par courrier électronique.

En définissant des options de publication, vous pouvez mettre en évidence des parties spécifiques de votre classeur, telles que des graphiques, ou exclure d’autres parties de l’affichage dans le navigateur. Par exemple, vous pouvez afficher un graphique, mais pas ses données sous-jacentes. Ou bien, vous pouvez afficher uniquement certaines feuilles de calcul aux personnes qui ont besoin de les voir et d’en masquer d’autres.

Cet article vous explique comment publier un classeur à partir d’Excel pour Windows et ne pas aborder la connexion d’un classeur ou de données de classeur à un composant WebPart Excel Web Access sur une page SharePoint.

Lorsque vous publiez un classeur sur un site SharePoint, le classeur entier est enregistré dans SharePoint. Un utilisateur disposant des autorisations SharePoint requises peut visualiser et travailler avec le classeur entier dans le navigateur ou dans le programme bureautique Excel.

Si les applications Office pour le web sont déployées sur SharePoint, l’expérience d’affichage et de manipulation de vos données dans le navigateur est très semblable à celle que vous auriez dans le programme de bureau Excel. En fait, contrairement à ce dernier, plusieurs utilisateurs peuvent modifier simultanément un classeur dans la grille de navigateur. Lorsque vous affichez un classeur dans le navigateur, si le bouton Modifier dans Excel Online est visible, cela signifie qu’Office pour le web est prêt à être utilisé.

Modifier dans Excel Online dans le menu Modifier le classeur

Préparer le classeur

Avant de publier le classeur, vous pouvez choisir de sélectionner uniquement les feuilles de calcul ou éléments que vous souhaitez rendre visibles dans le navigateur. Souvenez-vous que bien qu’il soit possible de limiter ce qui est affichable dans ce mode, le contenu entier du classeur est toujours enregistré sur le serveur SharePoint.

Si vous souhaitez inclure des feuilles de calcul entières comme élément en plus d’autres éléments, tels que des graphiques ou des tableaux croisés dynamiques, définissez l’intégralité de la feuille de calcul en tant que plage nommée. Sélectionnez toute la feuille de calcul, puis définissez une plage nommée. Celle-ci apparaîtra comme élément disponible dans la boîte de dialogue Options de publication lorsque vous serez prêt à effectuer la publication.

Pour permettre aux utilisateurs d’entrer une valeur dans une cellule afin de travailler avec une formule dans une autre cellule, définissez cette cellule comme nom défini dans Excel avant de publier le classeur. Vous pouvez ensuite ajouter ce nom défini en tant que paramètre sous l’onglet Paramètres de la boîte de dialogue Options d’affichage du navigateur.

Par exemple, le graphique suivant montre une cellule D2 qui a le nom défini « Taux ». Dans le navigateur, un utilisateur entre la valeur 5,625 dans la zone Taux du volet Paramètres et clique sur Appliquer. Cette valeur apparaît alors dans la cellule D2 et la formule en A2 utilise la valeur indiquée en D2. Le résultat de la formule est recalculé, comme illustré en A2 : 1 151,31 €.

L’entrée d’un paramètre dans le volet permet de l’utiliser dans la cellule D2

Remarque : Si vous créez des segments pour un tableau Excel et que vous définissez un nom pour la plage de cellules contenant le tableau et les segments, vous ne pourrez pas utiliser les segments pour filtrer le tableau dans le navigateur si vous publiez la plage définie. Si vous publiez le tableau, la feuille de calcul entière ou son classeur, les segments fonctionneront comme prévu dans le navigateur.

Publier le classeur

  1. Cliquez sur l’onglet Fichier, cliquez sur Enregistrer sous, puis cliquez sur SharePoint.

  2. Si vous voyez votre dossier SharePoint sous Actif, Récent ou Plus de trente jours, cliquez sur le dossier souhaité.

    La boîte de dialogue Enregistrer sous s’affiche.


    Dans le cas contraire, cliquez sur Parcourir, entrez l’adresse web du site SharePoint, puis accédez au dossier dans lequel vous voulez publier le classeur.

    Cliquez sur un dossier SharePoint ou cliquez sur Parcourir
  3. Pour sélectionner des feuilles de calcul ou des éléments individuels à publier à partir du classeur, cliquez surOptions d’affichage du navigateur.

    Dans la boîte de dialogue Enregistrer sous, cliquez sur Options d’affichage du navigateur

    L’onglet Affichage et l’onglet Paramètres s’affichent.

  4. Si vous souhaitez seulement publier le classeur entier, cliquez sur Enregistrer. Sinon, effectuez l’une des opérations suivantes :

    • Pour afficher le classeur entier dans le navigateur, sous l’onglet Afficher, sélectionnez Classeur entier dans la zone de liste.

    • Pour afficher uniquement des feuilles de calcul spécifiques dans le navigateur, sous l’onglet Affichage, sélectionnez Feuilles dans la zone de liste, puis décochez les cases des feuilles que vous ne voulez pas masquer dans le navigateur.

      Par défaut, toutes les feuilles sont sélectionnées. Pour rendre rapidement toutes les feuilles visibles après avoir décoché certaines cases, cochez la case Toutes les feuilles.

    • Pour n’afficher que certains éléments dans le navigateur (tels que des plages nommées, des graphiques, des tableaux ou des tableaux croisés dynamiques), sous l’onglet Affichage, sélectionnez Éléments du classeur dans la zone de liste, puis cochez les cases des éléments que vous souhaitez afficher.

    • Sous l’onglet Paramètres, ajoutez les noms définis que vous souhaitez utiliser pour spécifier les cellules qui sont modifiables lorsque les utilisateurs affichent le classeur dans le navigateur, puis cliquez sur OK.

  5. Enregistrez le classeur.

Remarques : 

  • Si vous sélectionnez des éléments de même nom (par exemple un graphique et son tableau de données sous-jacent), un seul de ces éléments sera disponible dans le navigateur. Pour afficher tous les éléments, assurez-vous que chaque élément du classeur possède un nom unique.

  • Vous pouvez renommer les tableaux dans le groupe Propriétés de l’onglet Création, renommer les tableaux croisés dynamiques dans le groupe Tableau croisé dynamique de l’onglet Options et renommer les graphiques ou les graphiques croisés dynamiques dans le groupe Propriétés de l’onglet Disposition. Vous pouvez renommer d’autres éléments dupliqués, tels que des plages nommées, dans le groupe Noms définis sous l’onglet Formules.

Si les applications Office pour le web sont déployées sur SharePoint, l’expérience d’affichage et de manipulation de vos données dans le navigateur est très semblable à celle que vous auriez dans le programme de bureau Excel. En fait, contrairement à ce dernier, plusieurs utilisateurs peuvent modifier simultanément un classeur dans la grille de navigateur. Lorsque vous affichez un classeur dans le navigateur, si le bouton Modifier dans Excel Online est visible, cela signifie qu’Office pour le web est prêt à être utilisé.

Modifier dans Excel Online dans le menu Modifier le classeur

Pour plus d’informations, voir l’article différences entre l’utilisation d’un classeur dans Excel et Excel Services.

Préparer le classeur

Avant de publier le classeur, vous pouvez choisir de sélectionner uniquement les feuilles de calcul ou éléments que vous souhaitez rendre visibles dans le navigateur. Souvenez-vous que bien qu’il soit possible de limiter ce qui est affichable dans ce mode, le contenu entier du classeur est toujours enregistré sur le serveur SharePoint.

Si vous souhaitez inclure des feuilles de calcul entières comme élément en plus d’autres éléments, tels que des graphiques ou des tableaux croisés dynamiques, définissez l’intégralité de la feuille de calcul en tant que plage nommée. Sélectionnez toute la feuille de calcul, puis définissez une plage nommée. Celle-ci apparaîtra comme élément disponible dans la boîte de dialogue Options de publication lorsque vous serez prêt à effectuer la publication.

Pour permettre aux utilisateurs d’entrer une valeur dans une cellule afin de travailler avec une formule dans une autre cellule, définissez cette cellule comme nom défini dans Excel avant de publier le classeur. Vous pouvez ensuite ajouter ce nom défini en tant que paramètre sous l’onglet Paramètres de la boîte de dialogue Options d’affichage du navigateur.

Par exemple, le graphique suivant montre une cellule D2 qui a le nom défini « Taux ». Dans le navigateur, un utilisateur entre une valeur 5,625, dans la zone dans le volet paramètres , puis clique sur appliquer. Cette valeur apparaît alors dans la cellule D2 et la formule en A2 utilise la valeur indiquée en D2. Le résultat de la formule est recalculé, comme illustré en A2 : 1 151,31 €.

Pour plus d’informations sur la façon de définir des plages, voir l’aide d’Excel.

L’entrée d’un paramètre dans le volet permet de l’utiliser dans la cellule D2

Remarque : Si vous créez des segments pour un tableau Excel et que vous définissez un nom pour la plage de cellules contenant le tableau et les segments, vous ne pourrez pas utiliser les segments pour filtrer le tableau dans le navigateur si vous publiez la plage définie. Si vous publiez le tableau, la feuille de calcul entière ou son classeur, les segments fonctionneront comme prévu dans le navigateur.

Publier le classeur

  1. Cliquez sur fichier > Enregistrer sous >SharePoint.

  2. Si vous voyez votre dossier SharePoint sousdossier actuel ou dossiers récents, cliquez sur le dossier de votre choix. Dans le cas contraire, cliquez sur Parcourir et entrez l’adresse Web du site SharePoint. Recherchez ensuite le dossier dans lequel vous voulez publier le classeur. La boîte de dialogue Enregistrer sous s’affiche.

  3. Pour sélectionner des feuilles de calcul ou des éléments individuels à publier à partir du classeur, cliquez surOptions d’affichage du navigateur. Un onglet Afficher et un onglet paramètres s’affichent. Si vous souhaitez seulement publier le classeur entier, cliquez sur Enregistrer. Sinon, effectuez l’une des opérations suivantes :

    • Pour afficher le classeur entier dans le navigateur, sous l’onglet Afficher, sélectionnez Classeur entier dans la zone de liste.

    • Pour afficher uniquement des feuilles de calcul spécifiques dans le navigateur, sous l’onglet affichage , sélectionnez feuilles dans la zone de liste, puis décochez les cases des feuilles que vous ne voulez pas masquer dans le navigateur.

      Par défaut, toutes les feuilles sont sélectionnées. Pour afficher de nouveau rapidement toutes les feuilles après avoir désactivé certaines cases, activez la case à cocher toutes les feuilles .

    • Pour afficher uniquement des éléments spécifiques dans le navigateur (tels que des plages nommées, des graphiques, des tableaux ou des tableaux croisés dynamiques), sous l’onglet Afficher , sélectionnez éléments du classeur dans la zone de liste, puis activez les cases à cocher des éléments que vous voulez afficher.

    • Dans l’onglet paramètres , ajoutez les noms définis que vous souhaitez utiliser pour spécifier les cellules qui sont modifiables lorsque les utilisateurs affichent le classeur dans le navigateur. Puis cliquez sur OK pour fermer la boîte de dialogue.

  4. Enregistrez le classeur.

Remarques : 

  • Si vous sélectionnez des éléments de même nom (par exemple un graphique et son tableau de données sous-jacent), un seul de ces éléments sera disponible dans le navigateur. Pour afficher tous les éléments, assurez-vous que chaque élément du classeur possède un nom unique.

  • Si vous sélectionnez des éléments de même nom (par exemple un graphique et son tableau de données sous-jacent), un seul de ces éléments sera disponible dans le navigateur. Pour afficher tous les éléments, assurez-vous que chaque élément du classeur possède un nom unique.

  • Vous pouvez renommer les tableaux dans le groupe Propriétés de l’onglet Création, renommer les tableaux croisés dynamiques dans le groupe Tableau croisé dynamique de l’onglet Options et renommer les graphiques ou les graphiques croisés dynamiques dans le groupe Propriétés de l’onglet Disposition. Vous pouvez renommer d’autres éléments dupliqués, tels que des plages nommées, dans le groupe Noms définis sous l’onglet Formules.

  • Vous pouvez renommer les tableaux dans le groupe Propriétés de l’onglet Création, renommer les tableaux croisés dynamiques dans le groupe Tableau croisé dynamique de l’onglet Options et renommer les graphiques ou les graphiques croisés dynamiques dans le groupe Propriétés de l’onglet Disposition. Vous pouvez renommer d’autres éléments dupliqués, tels que des plages nommées, dans le groupe Noms définis sous l’onglet Formules.

Pour plus d’informations sur les composants WebPart Excel Web Access, voir l’article afficher un classeur dans un composant WebPart Excel Web Access.

Lorsque vous publiez un classeur sur un serveur SharePoint, tout le contenu du classeur est enregistré sur le serveur et peut être affiché et utilisé si vous ouvrez le classeur dans le programme de bureau Excel. Si les applications Office Web Apps sont déployées sur le serveur SharePoint, l’affichage et l’utilisation de vos données dans le navigateur Web peuvent être très similaires à ceux du programme de bureau Excel. En fait, la modification simultanée d’un classeur est possible dans la grille du navigateur lors du déploiement d’Office Web Apps. Lorsque vous affichez un classeur dans le navigateur, si le bouton modifier dans le navigateur est visible, cela signifie qu’Office Web Apps est disponible.

Bouton Modifier dans le navigateur

Pour plus d’informations, voir l’article différences entre l’utilisation d’un classeur dans Excel et Excel Services.

Préparer le classeur

Avant de publier le classeur, vous avez la possibilité de sélectionner les feuilles de calcul ou éléments que vous souhaitez afficher dans le navigateur lorsque la modification n’est pas activée en cliquant sur le bouton modifier dans le navigateur . N’oubliez pas que bien que vous puissiez sélectionner ce qui est affichable dans ce mode, tout le contenu du classeur est toujours enregistré sur le serveur SharePoint.

Si vous souhaitez inclure des feuilles de calcul entières comme élément en plus d’autres éléments, tels que des graphiques ou des tableaux croisés dynamiques, définissez l’intégralité de la feuille de calcul en tant que plage nommée. Sélectionnez toute la feuille de calcul, puis définissez une plage nommée. Celle-ci apparaîtra comme élément disponible dans la boîte de dialogue Options de publication lorsque vous serez prêt à effectuer la publication.

Si vous voulez autoriser les utilisateurs à fournir un paramètre à une formule lors de l’affichage d’une feuille de calcul dans un navigateur, définissez une cellule en tant que nom défini. Vous pouvez ensuite ajouter ce nom défini en tant que paramètre sous l’onglet paramètres dans la boîte de dialogue options de publication .

Par exemple, dans le graphique suivant qui montre une feuille de calcul dans le navigateur, la cellule D2 a le taux de nom défini. Dans le navigateur, un utilisateur a entré une valeur 5,625, dans la zone dans le volet paramètres , puis cliquez sur appliquer. Cette valeur apparaît alors dans la cellule D2 et la formule en A2 utilise la valeur indiquée en D2. Le résultat de la formule est recalculé, comme illustré en A2 : 1 151,31 €.

Utilisation d’un paramètre dans le navigateur

Pour plus d’informations sur la façon de définir des plages, voir l’aide d’Excel.

Publier le classeur

  1. Cliquez sur l’onglet fichier , puis sur Enregistrer & envoyer.

  2. Cliquez sur enregistrer dans SharePoint.
    Remarque    si la commande enregistrer dans SharePoint n’est pas disponible, vous pouvez tout de même enregistrer le classeur sur un site SharePoint à l’aide de la commande Enregistrer sous . La boîte de dialogue options de publication n’est pas disponible. Vous pouvez également télécharger directement le classeur à partir d’une bibliothèque SharePoint. Les utilisateurs peuvent afficher et modifier le contenu du classeur dans le navigateur en accédant directement au site dans lequel le classeur est enregistré.

    Commande Enregistrer sous

  3. Pour sélectionner des feuilles de calcul ou des éléments individuels à publier dans le classeur, cliquez sur le bouton options de publication . Dans le cas contraire, si vous voulez publier l’intégralité du classeur, passez directement à l’étape 4.
    Sous l’onglet Afficher , procédez comme suit:

    • Pour afficher l’intégralité du classeur dans le navigateur, sélectionnez classeur entier dans la zone de liste.

    • Pour afficher uniquement des feuilles de calcul spécifiques dans le navigateur, sélectionnez feuilles dans la zone de liste, puis désactivez les cases à cocher des feuilles que vous ne souhaitez pas rendre visibles.
      Remarque    par défaut, toutes les feuilles sont sélectionnées. Pour afficher de nouveau rapidement toutes les feuilles après avoir désactivé certaines cases à cocher, vous pouvez activer la case à cocher toutes les feuilles .

    • Pour afficher uniquement des éléments spécifiques dans le navigateur (tels que des plages nommées, des graphiques, des tableaux ou des tableaux croisés dynamiques), sélectionnez les éléments du classeur dans la zone de liste, puis activez les cases à cocher des éléments que vous voulez afficher.
      Remarque si vous sélectionnez des éléments qui portent le même nom (par exemple, un graphique et sa table de données sous-jacente), un seul de ces éléments sera disponible dans le navigateur. Pour afficher tous les éléments, vous devez vous assurer que chaque élément du classeur a un nom unique. Vous pouvez renommer les tableaux dans le groupe Propriétés de l’onglet Création, renommer les tableaux croisés dynamiques dans le groupe Tableau croisé dynamique de l’onglet Options et renommer les graphiques ou les graphiques croisés dynamiques dans le groupe Propriétés de l’onglet Disposition. Les éléments dupliqués, tels que les plages nommées, peuvent être renommés dans l’onglet formules , dans le groupe noms définis .
      Sélection de feuilles de calcul ou d’éléments

    • Dans l’onglet paramètres , ajoutez les noms définis que vous souhaitez utiliser pour spécifier les cellules qui sont modifiables lorsque les utilisateurs affichent le classeur dans le navigateur. Puis cliquez sur OK pour fermer la boîte de dialogue.
      Définition des paramètres

  4. Sélectionnez un emplacement dans lequel vous voulez publier votre classeur.
    Il est possible que les emplacements du serveur soient déjà enregistrés sous emplacement actuel, emplacements récentsou emplacements dans lesquels vous pouvez choisir. S’il n’y a pas de tel emplacement ou si vous voulez l’enregistrer dans un nouvel emplacement, sous emplacements, double-cliquez sur Rechercher un emplacement.

  5. Dans la boîte de dialogue Enregistrer sous , entrez l’adresse Web du site SharePoint, puis accédez au site ou à la bibliothèque dans lequel vous voulez enregistrer votre classeur.

  6. Si vous n’avez pas encore sélectionné des feuilles de calcul ou des éléments individuels ou défini des paramètres, cliquez sur le bouton options de publication .

  7. Dans la zone nom de fichier , acceptez le nom proposé pour le classeur, ou tapez un nouveau nom si vous le souhaitez.

  8. Pour afficher le contenu du classeur dans une fenêtre de navigateur immédiatement après la fin de l’opération de publication, assurez-vous que la case à cocher Ouvrir avec Excel dans le navigateur est activée.

  9. Cliquez sur Enregistrer.

Remarque :  Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez vous nous dire si les informations vous ont été utiles ? Voici l’article en anglais pour référence.

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×