Je ne peux pas enregistrer ma base de données répliquée au format Access 2007

Remarque : Nous faisons de notre mieux pour vous fournir le contenu d’aide le plus récent aussi rapidement que possible dans votre langue. Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez-vous nous indiquer en bas de page si ces informations vous ont aidé ? Voici l’article en anglais à des fins de référence aisée.

Symptômes

Dans Microsoft Office Access 2007, les bases de données répliquées qui ont été créées dans des versions antérieures d'Access (. MDB) ne peut pas être enregistré dans le nouveau format. Format de fichier ACCDB. L'option est grisée (non disponible) lorsque vous essayez d'utiliser la commande enregistrer la base de données sous (cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur la flèche en regard de Enregistrer sous).

Raison

Au. Le format de fichier ACCDB ne prend pas en charge la réplication.

Résolution

Utilisez la base de données répliquée dans le. Format de fichier MDB

Vous pouvez continuer à utiliser votre base de données répliquée dans le. Format de fichier MDB. La fonctionnalité de réPlication est toujours prise en charge pour. Format de fichier MDB.

Recréer manuellement la base de données au format de fichier Office Access 2007

Si vous décidez que le nouveau format de fichier offre des avantages qui dépassent les avantages que vous obtenez de la réplication, vous pouvez créer une nouvelle base de données au format Office Access 2007 et recréer manuellement la base de données répliquée.

Remarque : Cette méthode fonctionnera sur toute base de données répliquée, mais, sauf si vous travaillez avec un réplica complet qui a été synchronisé avec tous les autres réplicas du jeu de réplicas, les données et les projets qui ne se trouvent pas déjà dans votre réplica ne figureront pas dans la nouvelle base de données.

Avant de commencer à recréer votre base de données, veillez à ce que tous les objets masqués et système du réplica soient visibles. Cela permet de s'assurer que vous pouvez accéder aux champs spécifiques au réplica dans le réplica lorsque vous le recréez.

  1. Ouvrez le réplica que vous souhaitez convertir. Vous devez ouvrir le réplica à l'aide de la même version d'Access utilisée initialement pour créer le réplica, pour afficher les champs masqués et système.

  2. Dans le menu Outils, cliquez sur Options. La boîte de dialogue Options s’ouvre.

  3. Sous l'onglet affichage , dans la section Afficher , sélectionnez objets cachés et objets système. Cliquez sur OK pour appliquer les nouveaux paramètres et fermer la boîte de dialogue Options.

Recréez manuellement la base de données.

  1. Créez une base de données vide et ouvrez-la.

    Remarque : Access crée une nouvelle table vide nommée table1. Vous devez supprimer cette table, vous pouvez le faire en la fermant immédiatement avant d'y apporter des modifications. Cliquez avec le bouton droit sur l'onglet de l'objet, puis cliquez sur Fermer dans le menu contextuel.

  2. Dans l’onglet Données externes, accédez au groupe Importer et cliquez sur Access.

    La boîte de dialogue données externes-base de données Access s'affiche.

  3. Cliquez sur Parcourir pour rechercher la base de données répliquée.

  4. Cliquez sur la base de données répliquée qui contient les objets de base de données que vous voulez recréer dans la nouvelle base de données, puis cliquez sur ouvrir.

  5. Dans la boîte de dialogue données externes-base de données Access , cliquez sur importer des tables, des requêtes, des formulaires, des États, des macros et des modules dans la base de données active, puis cliquez sur OK.

  6. Cliquez sur les objets de base de données que vous voulez importer dans la nouvelle base de données. Si vous voulez importer tous les objets, cliquez sur tout sélectionner dans chaque onglet.

    Important    Ne sélectionnez aucune table à ce stade. Vous allez recréer les tables dans une étape ultérieure.

  7. Une fois que vous avez terminé de sélectionner des objets, cliquez sur OK pour les importer.

    Sur la dernière page de l'Assistant, vous avez la possibilité d'enregistrer les étapes d'importation en vue de les réutiliser ultérieurement. Pour ce faire, activez la case à cocher enregistrer les étapes d'importation , entrez les informations appropriées, puis cliquez sur enregistrer l' importation.

  8. Ouvrez la base de données répliquée dans Office Access 2007. Pour chaque table dans la base de données répliquée, créez une requête Création de table qui récupère toutes les données de l'ancienne table et crée une table dans la nouvelle base de données avec les mêmes données.

    Remarque : Si le champ s_GUID est une clé primaire (et que les clés étrangères des autres tables y font référence), vous devez inclure le champ s_GUID dans la nouvelle table. Si le champ s_GUID n'est pas utilisé comme clé primaire, il n'y a aucune raison de le conserver dans la nouvelle table. Ne copiez pas les champs s_Lineage et s_Generation dans la nouvelle table.

    Par défaut, les champs s_GUID, s_Lineage et s_Generation sont masqués. Pour afficher ces champs, utilisez la procédure suivante:

    1. Dans la base de données répliquée, assurez-vous que toutes les tables sont fermées.

    2. Cliquez avec le bouton droit sur le haut du volet de navigation, puis cliquez sur options de navigation. La boîte de dialogue Options de navigation s'ouvre.

    3. Dans la section options d'affichage , sélectionnez Afficher les objets système, puis cliquez sur OK.

      Comment ?

      1. Créez une requête en sélectionnant les tables qui contiennent les enregistrements que vous voulez inclure dans la nouvelle table.

        Comment ?

        1. Sous l’onglet Créer, dans le groupe Autre, cliquez sur Création de requête.

        2. Dans la boîte de dialogue afficher la table , cliquez sur l'onglet qui répertorie les tables dont vous souhaitez utiliser les données.

        3. Double-cliquez sur le nom de chaque objet que vous voulez ajouter à la requête, puis cliquez sur Fermer.

        4. Ajoutez des champs à la ligne champ dans le grille de création.

        5. Pour afficher les résultats de la requête, dans le menu affichage , cliquez sur mode feuillede données.

      2. Dans le mode Création de la requête, sous l'onglet création , dans le groupe type de requête , cliquez sur création de table. La boîte de dialogue Création de table s’affiche.

      3. Dans la zone nom de la table , entrez le nom de la table que vous voulez créer ou remplacer.

      4. Cliquez sur autre base dedonnées, puis tapez le chemin d'accès de la base de données dans laquelle vous voulez placer la nouvelle table ou cliquez sur Parcourir pour rechercher la base de données.

      5. Cliquez sur OK.

      6. Sous l’onglet Créer, dans le groupe Résultats, cliquez sur Exécuter. Cette opération permet de créer la table.

        Remarque : La nouvelle table que vous créez n'hérite pas des propriétés de champ ou du paramètre clé primaire de la table d'origine.

  9. Pour chaque table dans la nouvelle base de données, créez la même index et la même clé primaire que celles utilisées dans la table du réplica.

    Comment ?

    1. Ouvrez une table en mode création.

    2. Dans la partie supérieure de la fenêtre, cliquez sur le champ pour lequel vous voulez créer un index.

    3. Dans la partie inférieure de la fenêtre, cliquez sur la zone de propriété indexé , puis cliquez sur Oui (avec doublons) ou sur Oui (sans doublon).

    4. Sélectionnez le ou les champs qui composent la clé primaire.

    5. Sous l’onglet Création, dans le groupe Outils, cliquez sur Clé primaire.

  10. Pour chaque table dans la nouvelle base de données, créez les relations qui existaient pour la table du réplica.

    Comment ?

    Lorsque vous créez une relation entre des tables, il n'est pas nécessaire que les champs associés aient le même nom. Toutefois, les champs associés doivent avoir le même type de données, sauf si le champ de clé primaire est un champ de type NuméroAuto. Vous pouvez faire correspondre un champ NuméroAuto avec un champ numérique uniquement si la propriété TailleChamp des deux champs correspondants est identique. Par exemple, vous pouvez faire coïncider un champ NuméroAuto et un champ numérique si la propriété TailleChamp des deux champs est entier long. Même si les deux champs correspondants sont des champs numériques, ils doivent avoir le même paramètre de propriété TailleChamp .

    Définir une relation un-à-plusieurs ou un-à-un

    1. Fermez toutes les tables que vous avez ouvertes. Vous ne pouvez pas créer ou modifier des relations entre des tables ouvertes.

    2. Sous l’onglet Outils de base de données, dans le groupe Afficher/Masquer, cliquez sur Relations.

    3. Si vous n'avez pas encore défini de relations dans votre base de données, la boîte de dialogue afficher la table s'affiche automatiquement.

      Si vous avez besoin d'ajouter les tables que vous voulez mettre en relation, et que la boîte de dialogue afficher la table n'est pas affichée, appelez-la: sous l'onglet création , dans le groupe Afficher/masquer , cliquez sur le bouton afficher la table .

    4. Double-cliquez sur le nom des tables que vous voulez mettre en relation, puis fermez la boîte de dialogue afficher la table . Pour créer une relation entre une table et lui-même, ajoutez cette table deux fois.

    5. Faites glisser le champ que vous voulez mettre en relation d'une table vers le champ associé de l'autre table.

      Pour faire glisser plusieurs champs, appuyez sur Ctrl, cliquez sur chaque champ, puis faites-les glisser.

      Dans la plupart des cas, vous faites glisser le champ de clé primaire (affiché en gras) d'une table vers un champ similaire (souvent du même nom) appelé clé étrangère dans l'autre table.

    6. La boîte de dialogue modifier des relations s'affiche. Vérifiez les noms des champs affichés dans les deux colonnes pour vous assurer qu'ils sont corrects. Vous pouvez les modifier si nécessaire.

      Réglez les options de relation, si nécessaire.

    7. Cliquez sur le bouton créer pour créer la relation.

    8. Répétez les étapes 4 à 7 pour chaque paire de tables que vous voulez mettre en relation.

      Lorsque vous fermez le fenêtre Relations, Microsoft Access vous demande si vous souhaitez enregistrer la disposition. Que vous enregistriez ou non la disposition, les relations que vous créez sont enregistrées dans la base de données.

    Définir une relation plusieurs-à-plusieurs

    1. Créez les deux tables qui auront une relation plusieurs à plusieurs.

    2. Créez une troisième table, appelée table de jointure, et ajoutez à la table de jointure de nouveaux champs ayant les mêmes définitions que les champs de clé primaire de chacune des deux autres tables. Dans la table de jointure, les champs de clé primaire fonctionnent comme des clés étrangères. Vous pouvez ajouter d'autres champs à la table de jointure, comme vous le feriez pour n'importe quelle autre table.

    3. Dans la table de jointure, affectez à la clé primaire la valeur inclure les champs de clé primaire des deux autres tables. Par exemple, dans une table de jonction détaillée des commandes, la clé primaire serait composée des champs RéfCommande et ProductID.

      Comment ?

      1. Ouvrez la table en mode création.

      2. Sélectionnez les champs que vous voulez définir en tant que clé primaire.

        Pour sélectionner un champ, cliquez sur le sélecteur de ligne pour le champ de votre choix.

        Pour sélectionner plusieurs champs, maintenez la touche CTRL enfoncée, puis cliquez sur le sélecteur de ligne de chaque champ.

      3. Sous l’onglet Création, dans le groupe Outils, cliquez sur Clé primaire.

        Remarque : Si vous souhaitez que l'ordre des champs d'une clé primaire multichamp soit différent de l'ordre de ces champs dans la table, cliquez sur le bouton index dans le groupe Afficher/masquer pour afficher le fenêtre Index, puis réorganisez les noms des champs pour le index nommé PrimaryKey.

    4. Définissez une relation un-à-plusieurs entre les deux tables principales et la table de jointure.

  11. Enregistrez votre nouvelle base de données.

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×