Office
Se connecter

Fonction VALEURCHAMP

Remarque :  Nous faisons de notre mieux pour vous fournir le contenu d’aide le plus récent aussi rapidement que possible dans votre langue. Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez-vous nous indiquer en bas de page si ces informations vous ont aidé ? Voici l’article en anglais à des fins de référence aisée.

Vous pouvez utiliser la fonction VALEURCHAMP pour récupérer des données de champ à partir de types de données liés tels que Titres boursiers ou Géographie. Il existe des méthodes plus simples pour rédiger des formules faisant référence à des types de données. Par conséquent, la fonction VALEURCHAMP doit être utilisée principalement pour créer des calculs conditionnels basés sur des types de données liés.

Remarque : 12 juin 2018 : Cette fonctionnalité sera disponible pour les clients sur une base progressive sur plusieurs jours ou semaines. Vous devez tout d’abord disponible aux participants Initiés Office et versions ultérieures pour les abonnés Office 365 . Si vous êtes abonné à Office 365, Vérifiez que vous disposez de la dernière version d’Office.

Détails techniques

Syntaxe

=VALEURCHAMP(valeur, nom_champ)

La syntaxe de la fonction VALEURCHAMP contient les arguments suivants :

  • valeur – adresse de la cellule, colonne de tableau ou plage nommée qui contient un type de données lié. 

  • nom_champ – nom du ou des champs que vous voulez extraire du type de données lié

Description

Exemples

Dans l’exemple de base suivant, la formule =VALEURCHAMP(A2,"Prix") extrait le champ Prix à partir du type de données Titres boursiers pour JM Smucker Co.

Récupérer le prix de l’action d’une société avec =VALEURCHAMP(A2,"Prix")

L’exemple suivant est un exemple plus classique de la fonction VALEURCHAMP. Nous utilisons ici la fonction SIERREUR pour rechercher des erreurs. Si la cellule A2 ne contient pas de nom de société, la formule VALEURCHAMP renvoie une erreur. Dans le cas présent, nous ne voulons rien afficher (""). En revanche, si la cellule contient un nom de société, nous voulons retrouver le prix à partir du type de données en A2 avec la formule =SIERREUR(VALEURCHAMP($A2,B$1),"").

Récupérer le prix de l’action d’une société et ignorer les erreurs avec =SIERREUR(VALEURCHAMP($A2,B$1),"")

Notez que la fonction VALEURCHAMP vous permet de faire référence à des cellules de feuille de calcul pour l’argument nom_champ. La formule ci-dessus fait ainsi référence à la cellule B1 pour le prix, ce qui évite d’entrer manuellement « Prix » dans la formule. 

Remarques

Si vous tentez de récupérer des données d’un champ de type de données inexistant, la fonction VALEURCHAMP renvoie l’erreur #CHAMP!. Par exemple, vous pouvez avoir entré « Coût » alors que le champ du type de données est en réalité « Prix ». Vérifiez toujours l’exactitude des noms de champ dans votre formule. Pour afficher une liste des noms de champ associés à un enregistrement, sélectionnez la cellule de celui-ci et appuyez sur Ctrl+Maj+F2.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Voir aussi

Types de données Titres boursiers et Géographie

Rédaction de formules faisant référence à des types de données

Erreur #CHAMP!

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×