Formules et fonctions

Fonction SI

Fonction SI

Remarque : Nous faisons de notre mieux pour vous fournir le contenu d’aide le plus récent aussi rapidement que possible dans votre langue. Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez-vous nous indiquer en bas de page si ces informations vous ont aidé ? Voici l’article en anglais à des fins de référence aisée.

La fonction si est une des fonctions les plus populaires dans Excel, et il vous autorise à apporter des comparaisons logiques entre une valeur et ce que vous attendiez.

Une instruction SI peut donc avoir deux résultats. Le premier résultat est appliqué si la comparaison est vérifiée, sinon le deuxième résultat est appliqué.

Par exemple, SI(C2="Oui";1;2) indique SI(C2 = Oui, renvoyer un 1, sinon renvoyer un 2)

Comment utiliser si :

  1. Sélectionnez une cellule. Type = si et une parenthèse ouvrante (.

  2. Ajouter la condition à tester, puis tapez une point-virgule.

  3. Ajoutez la valeur à renvoyer si la condition est vraie, puis tapez un point-virgule.

  4. Ajoutez la valeur à renvoyer si la condition est fausse, puis tapez une parenthèse droite ).

  5. Appuyez sur Entrée.

  6. Faites glisser la poignée pour appliquer la fonction si pour d’autres lignes si nécessaire.

Exemples simples d’utilisation de la fonction SI

La cellule D2 contient la formule =SI(C2="Oui";1;2)
  • =SI(C2=”Oui”;1;2)

Dans l’exemple ci-dessus, la cellule D2 indique : SI(C2 = Oui, renvoyer la valeur 1, sinon renvoyer la valeur 2)

La cellule D2 contient la formule =SI(C2=1;"OUI";"NON")
  • =SI(C2=1;”Oui”;”Non”)

Dans cet exemple, la formule dans la cellule D2 a l’intitulé : IF(C2 = 1, then return Yes, otherwise return No)comme vous le voir, la fonction si peut servir à évaluer les valeurs et le texte à la fois. Il peut également être utilisé pour évaluer les erreurs. Vous n’êtes pas limités à uniquement vérifier si une chose est égale à un autre et renvoyer un seul résultat, vous pouvez également utiliser les opérateurs mathématiques et effectuer des calculs supplémentaires en fonction de vos critères. Vous pouvez également imbriquer des fonctions si plusieurs ensemble afin d’effectuer des comparaisons de plusieurs.

La formule dans la cellule D2 est =SI(C2>B2;”Dépasse le budget”;”Cadre dans le budget”)
  • =SI(C2>B2;”Dépasse le budget”;”Cadre dans le budget”)

Dans l’exemple ci-dessus, la fonction SI dans la cellule D2 indique SI(C2 est supérieur à B2, renvoyer « Dépasse le budget », sinon renvoyer « Cadre dans le budget »)

La formule dans la cellule E2 est =SI(C2>B2;C2-B2;"")
  • =SI(C2>B2;C2-B2;0)

Dans l’illustration ci-dessus, au lieu de renvoyer un texte de résultat, nous allons renvoyer un calcul mathématique. La formule dans la cellule E2 a la signification suivante : SI(la valeur Réel est supérieure à la valeur Budget, soustraire le montant de Budget du montant Réel, sinon ne rien renvoyer).

La formule dans la cellule F7 est SI(E7=”Oui”;F5*0,0825;0)
  • =SI(E7=”Oui”;F5*0,0825;0)

Dans cet exemple, la formule dans la cellule F7 indique SI(E7=“Oui”, calculer le montant total dans F5*8,25 %, sinon renvoyer 0 car aucune taxe n’est due)

Remarque : Si vous comptez utiliser du texte dans des formules, vous devez l’entourer de guillemets (par exemple, “Texte”). La seule exception est l’utilisation des valeurs VRAI ou FAUX qui sont comprises automatiquement par Excel.

Problèmes courants

Problème

Cause

O (zéro) dans la cellule

Il n’y a pas de valeur pour l’argument valeur_si_vrai ou valeur_si_faux. Pour afficher la valeur correcte renvoyée, ajoutez le texte de l’argument aux deux arguments, ou ajoutez VRAI ou FAUX à l’argument.

#NOM? dans la cellule

En règle générale, cela signifie que la formule est mal orthographiée.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Voir aussi

Opérateurs de calcul et ordre de priorité dans Excel

Utiliser des fonctions imbriquées dans une formule

Utilisation de la fonction SI pour vérifier si une cellule est vide

Vidéo : Fonctions SI avancées

Fonction SI.CONDITIONS (Office 365, Excel 2016 et versions ultérieures)

Fonctions SI avancées - Utiliser des formules imbriquées et éviter les pièges

Vidéos de formation : Fonctions SI avancées

La fonction NB.SI compte les valeurs sur la base d’un seul critère

La fonction NB.SI.ENS compte les valeurs sur la base de plusieurs critères

La fonction SOMME.SI additionne des valeurs sur la base d’un seul critère

La fonction SOMME.SI.ENS additionne des valeurs sur la base de plusieurs critères

Fonction ET

Fonction OU

Fonction RECHERCHEV

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Utiliser la vérification des erreurs pour détecter les erreurs dans les formules

Fonctions logiques

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Tests logiques IF (Aperçu gratuit)

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×