En savoir plus sur SOMME

Remarque : Nous faisons de notre mieux pour vous fournir le contenu d’aide le plus récent aussi rapidement que possible dans votre langue. Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez-vous nous indiquer en bas de page si ces informations vous ont aidé ? Voici l’article en anglais à des fins de référence aisée.

En savoir plus sur la fonction SOMME

Pour connaître rapidement la somme d’une plage de cellules, il vous suffit de sélectionner la plage et de jeter un coup d’œil dans le coin inférieur droit de la fenêtre d’Excel.

Capture d’écran de la sélection d’une plage de cellules, puis recherche dans la barre d’état


Il s'agit de la barre d'État, qui affiche des informations sur ce que vous avez sélectionné, qu'il s'agisse d'une ou plusieurs cellules. Si vous cliquez avec le bouton droit sur la barre d'État, une boîte de dialogue de fonctionnalité s'affiche dans la liste des options que vous pouvez sélectionner. Notez également que les valeurs de la plage sélectionnée s'affichent si vous avez activé ces attributs. 

La manière la plus simple d’ajouter une formule SOMME à votre feuille de calcul est d’utiliser l’Assistant Somme automatique. Sélectionnez une cellule vide directement au-dessus ou en dessous de la plage à additionner, puis dans l’onglet Accueil ou Formules du ruban, appuyez sur Somme automatique > Somme. L’Assistant Somme automatique détecte automatiquement la plage à additionner et crée la formule pour vous. Il peut également fonctionner de manière horizontale si vous sélectionnez une cellule à gauche ou à droite de la plage à additionner. Notez qu’il ne fonctionne pas sur des plages non contiguës, mais nous aborderons le sujet dans la section suivante.

Vous pouvez utiliser l’Assistant Somme automatique pour créer automatiquement une formule SOMME.  Sélectionnez une plage au-dessus/en dessous ou à gauche/à droite de la plage à additionner et accédez à l’onglet Formules du ruban, puis sélectionnez Somme automatique et Somme.


La boîte de dialogue somme automatique vous permet également de sélectionner d'autres fonctions courantes telles que:

Somme automatique de manière verticale

La cellule B6 affiche la formule SOMME via la fonctionnalité Somme automatique : =SOMME(B2:B5)

L’Assistant Somme automatique a détecté automatiquement les cellules B2:B5 en tant que plage à additionner. Il vous suffit d’appuyer sur Entrée pour la confirmer. Si vous devez ajouter/exclure d’autres cellules, maintenez la touche Maj enfoncée et appuyez sur les touches de direction de votre choix jusqu’à ce que la sélection vous convienne, puis appuyez sur Entrée lorsque vous avez terminé.

Repère de fonction IntelliSense : la balise flottante SOMME(nombre1,[nombre2], …) s’affichant sous la fonction est son repère IntelliSense. Si vous cliquez sur SOMME ou le nom de la fonction, il se transforme en lien hypertexte bleu, via lequel vous pouvez accéder à la rubrique d’aide correspondant à cette fonction. Si vous cliquez sur les éléments individuels de la fonction, leur partie représentative dans la formule sera mise en surbrillance. Dans ce cas uniquement, la plage B2:B5 serait mise en surbrillance, car cette formule ne contient qu’une référence de nombre. La balise IntelliSense s’affiche pour n’importe quelle fonction.

Somme automatique de manière horizontale

La cellule D2 affiche la formule SOMME via la fonctionnalité Somme automatique : =SOMME(B2:C2)

Utilisation de SOMME avec des plages non contiguës.  La cellule incluse dans la cellule C8 est =SOMME(C2:C3,C5:C6). Vous pouvez également utiliser des plages nommées de sorte que la formule soit =SOMME(Semaine1,Semaine2).

En règle générale, l'Assistant somme automatique fonctionne uniquement pour les plages contiguës, si bien que vous avez des lignes ou des colonnes vides dans votre plage de somme, Excel va s'arrêter au premier intervalle. Dans ce cas, vous devez calculer la somme par sélection, où vous ajoutez les différentes plages une par une. Dans cet exemple, si vous avez des données dans la cellule B4, Excel générerait = somme (C2: C6) , car elle détecterait une plage contiguë.

Vous pouvez sélectionner plusieurs plages non contiguës en utilisant le raccourci Ctrl+Clic gauche. Tout d’abord, entrez « =SOMME( », puis sélectionnez les plages de votre choix ; Excel ajoute automatiquement un séparateur de virgule entre les plages. Appuyez sur Entrée lorsque vous avez terminé.

CONSEIL : vous pouvez utiliser Alt+= pour ajouter en un clin d’œil la fonction SOMME à une cellule. Il vous suffit ensuite de sélectionner la ou les plages.

Remarque : notez la manière dont Excel a mis en surbrillance les différentes plages de la fonction en utilisant des couleurs, lesquelles sont également utilisées dans la formule elle-même, c’est-à-dire que C2:C3 est d’une couleur et C5:C6 d’une autre couleur. Excel agit de la sorte pour toutes les fonctions, sauf si la plage référencée se trouve dans une autre feuille de calcul ou un autre classeur. Pour optimiser l’accessibilité avec des technologies d’assistance, vous pouvez utiliser des plages nommées, telles que « Semaine1 », « Semaine2 », etc., puis les référencer dans votre formule :

=SOMME(Semaine1,Semaine2)

  1. Vous pouvez combiner SOMME à d’autres fonctions. Voici un exemple qui permet de créer un calcul de moyenne mensuelle :

    Utilisation de SOMME avec d’autres fonctions.  La formule incluse dans la cellule M2 est =SOMME(A2:L2)/NBVAL(A2:L2) .  Remarque : les colonnes Mai-Novembre sont masquées dans un souci de clarté.
    • =SOMME(A2:L2)/NBVAL(A2:L2)

  2. Cette formule calcule la SOMME de la plage A2:L2, puis divise le résultat obtenu par le nombre de cellules non vides en A2:L2 (les cellules de mai à décembre sont vides).

  1. Il peut arriver que vous deviez additionner une cellule particulière dans plusieurs feuilles de calcul. Il est possible que vous deviez cliquer sur chaque feuille et sur la cellule souhaitée et utiliser «+» pour ajouter les valeurs de la cellule, mais cela est fastidieux et risque d'être une erreur.

    • =Feuil1!A1+Feuil2!A1+Feuil3!A1

    Vous pouvez effectuer ce calcul plus simplement avec une SOMME 3D (3 dimensions) :

    SOMME 3D - La formule incluse dans la cellule D2 est =SOMME(Feuil1:Feuil3!A2)
    • SOMME(Feuil1:Feuil3!A1)

    Cela additionne la cellule A1 dans toutes les feuilles de la plage Feuille 1 à Feuille 3.

    C’est particulièrement utile dans les cas où vous avez une seule feuille pour chaque mois (Janvier-Décembre) et où vous avez besoin d’effectuer un addition sur une feuille récapitulative.

    SOMME 3D entre feuilles nommées.  La formule incluse en D2 est =SOMME(Janvier:Décembre!A2)
    • =SOMME(Janvier:Décembre!A2)

    Cette formule additionne la cellule A2 dans chaque feuille pour la plage Janvier à Décembre.

    Remarques : Si vos feuilles de calcul comportent des espaces dans leur nom, par exemple, «ventes du 1er janvier», vous devez utiliser une apostrophe lors du référencement des noms des feuilles dans une formule. Notez l'apostrophe avant le premier nom de la feuille de calcul, puis de nouveau après la dernière.

    • =SOMME('Ventes du mois de janvier:Ventes du mois de décembre'!A2)

    La méthode 3D fonctionne également avec d’autres fonctions, telles que MOYENNE, MIN, MAX, etc. :

    • =MOYENNE(Feuil1:Feuil3!A1)

    • =MIN(Feuil1:Feuil3!A1)

    • =MAX(Feuil1:Feuil3!A1)

Vous pouvez facilement effectuer des opérations mathématiques dans Excel, seules ou conjointement avec des fonctions Excel telles que SOMME. Le tableau suivant répertorie les opérateurs que vous pouvez utiliser, conjointement avec certaines fonctions associées. Vous pouvez entrer les opérateurs à partir de la ligne des chiffres sur votre clavier ou à l’aide du pavé numérique à 10 chiffres si vous en avez un. Par exemple, Maj+8 insère l’astérisque (*) utilisé dans une multiplication.

Opérateur

Opération

Exemples

+

Addition

=1+1

=A1+B1

=SOMME(A1:A10)+10

=SOMME(A1:A10)+B1

-

Soustraction

=1-1

=A1-B1

=SOMME(A1:A10)-10

=SOMME(A1:A10)-B1

*

Multiplication

=1*1

=A1*B1

=SOMME(A1:A10)*10

=SOMME(A1:A10)*B1

=PRODUIT(1,1) - Fonction PRODUIT

/

Division

=1/1

=A1/B1

=SOMME(A1:A10)/10

=SOMME(A1:A10)/B1

=QUOTIENT(1,1) - Fonction QUOTIENT

^

Exposant

=1^1

=A1^B1

=SOMME(A1:A10)^10

=SOMME(A1:A10)^B1

=PUISSANCE(1,1) - Fonction PUISSANCE

Pour plus d’informations, voir Utiliser Excel en tant que calculatrice.

Autres exemples

  1. Imaginons que vous voulez appliquer un pourcentage de remise à une plage de cellules que vous avez additionnées.

    Utilisation d’opérateurs avec SOMME.  La formule incluse dans la cellule B16 est =SOMME(A2:A14)*-25%.  La formule aurait été construite correctement si -25% était une référence de cellule, par exemple, =SOMME(A2:A14)*E2
    • =SOMME(A2:A14)*-25%

    Vous attribuerez 25% de la plage de la somme, toutefois, pour coder en dur les 25% dans la formule, il peut être difficile de trouver plus tard si nécessaire. Il est préférable de placer les 25% dans une cellule et de faire référence à cette valeur à la place, là où elle est ouverte et facilement modifiée, comme suit:

    • =SOMME(A2:A14)*E2

    Pour effectuer une division au lieu d’une multiplication, il vous suffit de remplacer le symbole « * » par « / » : =SOMME(A2:A14)/E2

  2. Addition ou soustraction à partir d’une fonction SOMME

    i. Vous pouvez facilement additionner ou soustraire des nombres dans une fonction SOMME à l’aide de l’opérateur + ou -, comme suit :

    • =SOMME(A1:A10)+E2

    • =SOMME(A1:A10)-E2

Voir aussi

SOMME

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×