Donner une preuve de confiance en ajoutant une signature numérique

Remarque : Nous faisons de notre mieux pour vous fournir le contenu d’aide le plus récent aussi rapidement que possible dans votre langue. Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez-vous nous indiquer en bas de page si ces informations vous ont aidé ? Voici l’article en anglais à des fins de référence aisée.

Vous pouvez montrer que vous pensez qu'une base de données est sécurisée et que son contenu peut être approuvé en ajoutant une signature numérique à la base de données. Cela aide les utilisateurs qui utilisent la base de données à décider s'ils doivent y faire confiance et son contenu.

Le processus que vous utilisez pour signer numériquement une base de données varie selon que la base de données utilise un nouveau format de fichier tel qu'un fichier. accdb ou un format antérieur, tel qu'un fichier. mdb. Toutefois, les deux processus nécessitent d'utiliser un certificat de sécurité.

Vous pouvez utiliser un certificat de sécurité commercial ou vous pouvez en créer un vous-même. Cette rubrique explique comment créer votre propre certificat de sécurité.

Contenu de cet article

Avant de commencer

EmPaqueter, signer et distribuer une base de données Access

Signer numériquement une base de données de version antérieure

Avant de commencer

Pour ajouter une signature numérique, vous devez d'abord obtenir ou créer un certificat de sécurité. Considérez un certificat de sécurité comme un stylet qui vous permet de signer numériquement des éléments ou une languette de cire que vous seul pouvez appliquer.

Si vous n'avez pas de certificat de sécurité, vous pouvez en créer un à l'aide de l'outil SelfCert (inclus dans Microsoft Office).

Créer un certificat auto-signé

  1. Dans Microsoft Windows, cliquez sur le bouton Démarrer , pointez sur tous les programmes, sur Microsoft Office, sur outils Microsoft Office, puis cliquez sur certificat numérique pour les projets VBA.

    -ou-

    Accédez au dossier contenant les fichiers de votre programme Microsoft Office.

    Vous devez localiser le fichier exécutable, SelfCert. exe, et l'emplacement peut varier en fonction de différentes conditions (par exemple, si vous utilisez un système d'exploitation Windows 32 bits ou 64 bits) ou si vous utilisez une version d'abonnement d'Office 365.

    Si vous utilisez Office 2019 ou Office 2016, essayez l'un des emplacements suivants:

    • C:\Program Files\Microsoft Office\Office16

    • C:\Program Files (x86) \Microsoft Office\Office16

    Si vous utilisez Office 365, essayez l'un des emplacements suivants:

    • C:\Program Files\Microsoft Office\root\Office16

    • C:\Program Files (x86)\Microsoft Office\root\Office16

    Si vous utilisez Office 2013, recherchez le dossier Office15 dans les options ci-dessus. Si vous utilisez Office 2010, recherchez le dossier Office14. Si vous utilisez Office 2007, recherchez le dossier Office12.

    Recherchez le dossier approprié, puis double-cliquez sur SelfCert. exe.

    La boîte de dialogue Créer un certificat numérique s’affiche.

  2. Dans la zone Le nom de votre certificat, tapez un nom pour le nouveau certificat de test.

  3. Cliquez sur OK à deux reprises.

Remarque : Si vous ne voyez pas la commande Certificat numérique pour les projets VBA ou si vous ne trouvez pas SelfCert.exe, vous devrez peut-être installer SelfCert.

Installer SelfCert.exe

  1. Démarrez votre CD-ROM d'installation de Microsoft Office ou un autre support d'installation.

  2. Dans Installation, cliquez sur Ajouter ou supprimer des fonctions, puis cliquez sur Continuer.

    Remarque : Si vous travaillez dans un environnement dans lequel Microsoft Office est installé sur des ordinateurs individuels par les administrateurs informatiques plutôt qu’à partir d’un CD-ROM, suivez les étapes ci-après :

    1. Dans Microsoft Windows, cliquez sur le bouton Démarrer, puis sur Panneau de configuration.

    2. Double-cliquez sur Ajouter ou supprimer des programmes.

    3. Sélectionnez votre version de Microsoft Office, puis cliquez sur modifier.

      L’installation démarre.

    4. Cliquez sur Ajouter ou supprimer des composants, puis sur Continuer.

    5. Continuez en suivant les étapes ci-après.

  3. Développez les nœuds Microsoft Office et Fonctions partagées d’Office en cliquant sur les signes plus (+) en regard.

  4. Cliquez sur Certificat numérique pour les projets VBA.

  5. Cliquez sur Exécuter depuis Mon poste de travail.

  6. Cliquez sur Continuer pour installer le composant.

Vous ne devez utiliser SelfCert que pour créer des signatures à utiliser au sein de votre organisation. Si vous voulez signer numériquement une base de données, puis distribuer celle-ci sur le marché, vous devez obtenir un certificat de sécurité commerciale auprès d'une autorité de certification commerciale.

EmPaqueter, signer et distribuer une base de données Access

Access permet de signer et de distribuer facilement et rapidement une base de données. Lorsque vous créez un fichier .accdb ou .accde, vous pouvez packager le fichier, appliquer une signature numérique au package créé, puis envoyer le package signé à d’autres utilisateurs. L’outil Empaqueter et signer place la base de données dans un fichier de déploiement Access (.accdc), signe le fichier, puis place le package signé dans un emplacement que vous choisissez. Les autres utilisateurs peuvent ensuite extraire la base de données du package et travailler directement dans la base (et pas dans le package).

Pendant la procédure, n’oubliez pas ce qui suit :

  • Créer un package et le signer est une technique permettant d’étendre la sécurité. Lorsque vous empaquetez et signez une base de données, votre signature numérique confirme que la base de données n’a pas subi de modifications après avoir créé le package.

  • Une fois que la base de données est extraite du package, il n’y a plus de connexion entre le package signé et la base de données extraite.

  • Vous pouvez utiliser l'outil package et signature uniquement avec des bases de données enregistrées dans un nouveau format de fichier (. accdb,. accde,...). Access fournit également des outils de signature et de distribution de bases de données ayant un format de fichier antérieur. Vous devez utiliser l’outil de signature numérique adapté au format de base de données utilisé.

  • Vous ne pouvez ajouter qu’une seule base de données à un package.

  • Le processus signe numériquement un package qui contient votre base de données complète, pas seulement des macros ou modules.

  • Le fichier de package est compressé pour réduire les temps de téléchargement.

  • Vous pouvez extraire des bases de données de fichiers de package situés sur des serveurs exécutant Windows SharePoint Services 3.0 ou une version ultérieure.

Les étapes des sections suivantes expliquent comment créer un fichier de package signé, et comment extraire et utiliser une base de données à partir d’un fichier de package signé.

Créer un package signé

  1. Ouvrez la base de données dont vous voulez faire un package signé.

  2. Cliquez sur fichier _GT_ Save As > package and Sign

    La boîte de dialogue Sélectionnez un certificat s’affiche.

  3. Sélectionnez un certificat numérique et cliquez sur OK.

    La boîte de dialogue créer un package signé Microsoft Access s'affiche.

  4. Dans la liste Enregistrer dans, sélectionnez un emplacement pour votre package de base de données signé.

  5. Tapez un nom pour le package signé dans la zone Nom de fichier, puis cliquez sur Créer.

    Access crée le fichier .accdc et le place à l’endroit que vous avez choisi.

Extraire et utiliser un package signé

  1. Cliquez sur Fichier > Ouvrir > Parcourir. La boîte de dialogue Ouvrir s’affiche. 

  2. Sélectionnez packages signés Microsoft Access (*. accdc) comme type de fichier.

  3. Recherchez le dossier qui contient votre fichier. accdc, sélectionnez le fichier, puis cliquez sur ouvrir.

  4. Exécutez l’une des procédures suivantes :

    • Si vous avez décidé de faire confiance au certificat de sécurité utilisé pour signer le package de déploiement, la boîte de dialogue Extraire la base de données dans s’affiche. Passez à l’étape suivante.

    • Si vous n’avez pas encore accepté le certificat de sécurité, le message suivant s’affiche.

      Message consultatif

      Si vous avez confiance dans la base de données, cliquez sur Ouvrir. Si vous avez confiance dans tous les certificats de ce fournisseur, cliquez sur Approuver tous à partir de l’éditeur. La boîte de dialogue Extraire la base de données vers s’affiche.

      Remarque : Si vous utilisez un certificat signé automatiquement pour signer un package de base de données, puis cliquez sur Approuver tous à partir de l’éditeur quand vous ouvrez ce package, les packages signés à l’aide de vos certificats signés automatiquement seront toujours approuvés.

  5. Sinon, dans la liste Enregistrer dans, sélectionnez un emplacement pour la base de données extraite puis, dans la zone Nom de fichier, tapez un autre nom pour la base de données extraite.

    Conseil : Si vous procédez à l’extraction de la base de données sur un emplacement approuvé, son contenu sera automatiquement activé dès que vous l’ouvrirez. Si vous choisissez un emplacement non approuvé, certains contenus de la base de données peuvent être désactivés par défaut.

  6. Cliquez sur OK.

Si vous n’êtes pas certain de pouvoir faire confiance à un certificat, l’article Comment savoir si une signature numérique est digne de confiance fournit des informations générales sur la vérification des dates et autres éléments d’un certificat pour permettre de s’assurer de sa validité.

Haut de la page

Signer numériquement une base de données de version antérieure

Important : Les étapes décrites dans cette section ne s'appliquent pas aux bases de données utilisant l'un des nouveaux formats de fichier.

Pour les bases de données utilisant les formats de fichier. mdb ou. mde, vous pouvez appliquer un signature numérique aux composants de la base de données. Une signature numérique confirme que les macros, les modules de code et autres composants exécutables de la base de données ont été créés par le signataire et que personne ne les a modifiés depuis la signature de la base de données.

Pour appliquer une signature à votre base de données, vous devez obtenir un certificat numérique. Si vous créez des bases de données dans un but de distribution commerciale, vous devez obtenir un certificat émis par une autorité de certification. Les autorités de certification ont les moyens de vérifier que les personnes créant du contenu (tel que des bases de données) sont de confiance.

Si vous souhaitez utiliser une base de données pour des scénarios personnels ou de groupe de travail limités, Access fournit un outil permettant de créer un certificat auto-signé. Les étapes des sections suivantes décrivent l’installation et l’utilisation d’un outil appelé SelfCert.exe, qui permet de créer un certificat signé automatiquement.

Signer une base de données par code

Remarque : N'oubliez pas que ces étapes ne s'appliquent que si vous utilisez des bases de données qui utilisent l'un des formats de fichier de base de données antérieurs, tels qu'un fichier. mdb. Pour signer de nouvelles bases de données, voir la section package, signer et distribuer une base de données Access.

  1. Ouvrez la base de données que vous voulez signer.

  2. Sous l’onglet Outils de base de données, dans le groupe Macro, cliquez sur Visual Basic pour démarrer Visual Basic Editor.

    Raccourci clavier  Appuyez sur Alt+F11.

  3. Dans la fenêtre Explorateur de projets, sélectionnez la base de données ou le projet VBA (Visual Basic for Applications) que vous voulez signer.

  4. Dans le menu Outils, cliquez sur Signature numérique.

    La boîte de dialogue Signature numérique s’affiche.

  5. Cliquez sur Choisir pour sélectionner votre certificat de test.

    La boîte de dialogue Sélectionnez un certificat s’affiche.

  6. Sélectionnez le certificat que vous voulez appliquer.

    Si vous avez suivi les étapes de la section précédente, sélectionnez le certificat que vous avez créé à l’aide de SelfCert.

  7. Cliquez sur OK pour fermer la boîte de dialogue Sélectionner un certificat et cliquez sur OK une nouvelle fois pour fermer la boîte de dialogue signature numérique .

Conseils pour la signature de bases de données de versions antérieures

  • Pour empêcher les utilisateurs de votre solution de modifier accidentellement votre projet VBA et d’invalider ainsi votre signature, verrouillez-le avant de le signer.

    Remarque : Verrouiller le projet VBA n’empêche pas un autre utilisateur de remplacer la signature numérique par une autre. Les administrateurs d’entreprise peuvent resigner les modèles et les macros complémentaires afin de contrôler exactement ce que les utilisateurs peuvent exécuter sur leur ordinateur.

  • Lorsque vous signez numériquement un projet VBA, envisagez d’obtenir l’horodatage de votre signature, de façon à ce que les autres utilisateurs puissent la vérifier même après l’expiration du certificat utilisé.

Haut de la page

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×