Passer directement au contenu principal

Déployer une application Access

Access fournit une plateforme riche pour développer des applications de base de données. Une application de base de données est un programme informatique qui offre un moyen de stocker et gérer des données et une interface utilisateur conçue en respectant la logique des tâches professionnelles (logique d’application). Cet article traite de la planification du déploiement de base, de l’empaquetage et de la signature, du déploiement d’applications de base de données et de l’environnement d’exécution Access.

Que voulez-vous faire ?

Planifier le déploiement

Déployer une application Access

Comprendre et télécharger le runtime Access

Créer un package d’installation

Planifier le déploiement

Avant de commencer, vous devez vous poser les questions suivantes sur comment l’application va être déployée.

Les données et la logique doivent-elles être séparées ?

Vous pouvez créer un Access application qui combine la logique d’application et la gestion des données dans un seul fichier. C’est la structure d’application par défaut dans Access. Combiner la gestion des données et la logique de l’application dans un fichier fournit la méthode de déploiement la plus simple, mais cette méthode ne fonctionne que si quelques personnes utilisent l’application en même temps, et elles impliquent des risques. Par exemple, un utilisateur peut entraîner la perte de données en supprimant involontairement ou en endommageant le fichier de l’application. Dans la plupart des cas, vous devez séparer la logique d’application de la gestion des données. Cela permet d’améliorer les performances et la fiabilité.

Une manière de séparer les données et la logique est à l’aide de la commande Base de données Access (dans l’onglet Outils de base de données, dans le groupe Déplacer les données). Cette commande fractionne votre application de base de données en deux fichiers Access: l’un pour la logique (serveur frontal) et l’autre pour les données (back-end). Par exemple, une base de données nommée MySolution. accdb est divisée en deux fichiers nommés MySolution_fe. accdb et MySolution_be. accdb. Vous placez la base de données principale dans un emplacement partagé, tel qu’un dossier réseau. Vous diffusez le fichier frontal, une copie pour chaque utilisateur, sur son ordinateur. Vous pouvez même distribuer différents fichiers frontaux à différents utilisateurs. Pour plus d’informations, voir fractionner une base de données Access.

Une autre méthode pour séparer la logique de la gestion des données consiste à utiliser un programme de serveur de base de données (par exemple, Microsoft SQL Server) pour la gestion des données et Access pour la logique d’application. Pour plus d’informations, voir migrer une base de données Access vers SQL Server.

Voici d’autres raisons pour lesquelles le fractionnement des données et la logique incluent les éléments suivants:

  • Sécurité et l’intégrité des données     Si vous combinez les données et la logique dans un seul fichier, les données sont exposées aux mêmes risques que la logique d’application. Une application Access qui utilise une logique séparée et des fichiers de données peut contribuer à la protection de l’intégrité et de la sécurité des données en tirant parti de fonctionnalités de sécurité NTFS sur les dossiers réseau.

    Access les utilisateurs doivent disposer d’autorisations de lecture, d’écriture, de création et de suppression sur le dossier où se trouve le fichier frontal. Toutefois, vous pouvez attribuer des autorisations différentes au fichier frontal. Par exemple, vous pouvez attribuer des autorisations en lecture seule à certains utilisateurs et des autorisations en lecture/écriture à d’autres utilisateurs.

    Votre application peut nécessiter des options de sécurité supplémentaires, telle que la possibilité de contrôler quels utilisateurs ont accès à des données spécifiques. Dans ce cas, vous pouvez utiliser SQL Server ou SharePoint pour stocker et gérer les données de votre application, et utiliser Access pour fournir la logique de l’application.

  • Extensibilité    Un fichier Access peut avoir une taille maximale de 2 gigaoctets (Go). Bien que 2 Go soit une quantité importante de données texte, cela peut être insuffisant pour certaines applications, notamment des applications qui stockent des pièces jointes dans les enregistrements de base de données. Si vous séparez les données et la logique, votre application peut accueillir plus de données. Si vous prévoyez que les utilisateurs stockent un gros volume de données, vous pouvez envisager d’utiliser plusieurs fichiers de données Access.

    Vous devez également passer en revue les spécifications de Access pour plus d’information sur l’évolutivité du programme. Pour en savoir plus sur les spécifications de Access, voir l’article spécifications d’Access.

  • Capacité réseau    Si plusieurs utilisateurs devront utiliser l’application en même temps sur un réseau, les données sont plus susceptibles d’être corrompues si les données et la logique sont combinées dans un seul fichier. Par ailleurs, si vous combinez les données et la logique dans un seul fichier Access, vous ne pouvez pas optimiser le trafic réseau qu’Access génère. Si plusieurs utilisateurs vont utiliser simultanément votre application sur un réseau, vous devez séparer les données et la logique, soit avec deux ou plusieurs fichiers Access, soit avec un produit serveur de base de données pour des données et Access pour la logique d’application.

Comment sera l’environnement réseau ?

Le choix de la solution de base de données Access appropriée pour votre environnement réseau est une étape essentielle pour réussir. Utilisez les instructions suivantes pour vous aider à optimiser votre choix en fonction de vos besoins.

Réseau domestique

Si vous n’avez que quelques utilisateurs pour partager votre base de données Access, vous pouvez utiliser une seule base de données que chaque personne ouvre et utilise sur un réseau domestique. Pour plus d’informations, reportez-vous à la section partage de fichiers sur un réseau dans Windows 10.

Réseau local (LAN)

Un réseau local (LAN) est un réseau interne qui offre généralement de meilleures performances, mais qui est limité à une petite zone géographique, par exemple une seule salle, un bâtiment ou un groupe de bâtiments. Lorsque vous avez plus de quelques utilisateurs partageant la base de données sur un réseau local, il est préférable de fractionner la base de données, de stocker la base de données principale dans un dossier réseau et de déployer une copie de la base de données frontale pour chaque utilisateur.

Réseau étendu (WAN)

Il existe de nombreuses configurations possibles pour un réseau étendu (WAN) qui couvre une vaste zone géographique. Il est possible que vous ayez plusieurs bureaux sur une ville connectée à un réseau public, une ligne louée ou même des satellites. Souvent, un réseau privé virtuel (VPN) est utilisé pour sécuriser l’accès à distance à partir de la maison ou en déplacement. Un moyen simple de comprendre un réseau WAN est que lorsque vous vous trouvez en dehors d’un réseau local mais que vous y êtes connecté, vous utilisez un réseau étendu.

AVERTISSEMENT    Évitez l’utilisation d’une base de données fractionnée dans un réseau étendu, car les performances peuvent être ralenties et les bases de données corrompues.

Il existe trois manières prises en charge d’utiliser Access dans un réseau étendu:

  • Une base de données Access avec des tables liées à des listes SharePoint.

  • Une connexion de base de données Access frontale vers une base de données SQL Server principale ou Azure SQL.

  • Services Bureau à distance (RDS) (auparavant appelé Terminal Server), qui crée un environnement de bureau Windows virtuel sur l’ordinateur client d’un utilisateur. RDS offre plusieurs avantages:

    • Il n’est pas nécessaire d’installer Access ou une base de données Access à mesure que les utilisateurs exécutent le client Bureau à distance (RD) disponible sur de nombreux appareils.

    • Le transfert des données est limité entre le client et le serveur, car la RD est un client léger qui diffuse efficacement l’interface utilisateur.

    • Les utilisateurs peuvent toujours copier et coller des données et imprimer des rapports localement à partir de l’ordinateur client.

    • Le programme RemoteApp ne peut exécuter qu’un seul programme tel qu’une application clé en main pour les fournisseurs ou les travailleurs de Frontline.

    Pour plus d’informations, voir Bienvenue dans les services Bureau à distance.

Les utilisateurs auront-ils Access?

Si tous vos utilisateurs ont Access installé sur leur ordinateur, ils peuvent ouvrir et utiliser l’application comme ils le feraient pour n’importe quel Access fichier de base de données.

Si certains ou l’ensemble de vos utilisateurs ne disposent pas de Access installés sur leur ordinateur, vous pouvez également déployer le logiciel Access Runtime auprès de ces utilisateurs lorsque vous déployez votre application. Pour plus d’informations, voir comprendre et télécharger le runtime Access.

Haut de la page

Déployer une application Access

Pour déployer une application Access, vous devez effectuer les tâches suivantes.

Préparer la base de données en tant que solution de l’application

Pour verrouiller votre solution, pour contrôler la navigation et le démarrage et définir d’autres options importantes, procédez comme suit:

Tâche

Informations complémentaires

Déterminer la façon dont les utilisateurs naviguent dans l’interface utilisateur: utiliser un formulaire par défaut, créer un menu général, utiliser un formulaire de navigation ou utiliser des liens hypertexte et des boutons de commande.

Définir le formulaire qui s’affiche par défaut à l’ouverture d’une base de données Access

Créer un formulaire de navigation

Personnaliser le volet de navigation

Afficher ou masquer des onglets Objet

Modèles Access proposés

Qu'est devenu le Menu Général ?

Décidez si vous voulez personnaliser le ruban et les menus de commandes Office

Créer un ruban personnalisé dans Access

Créer des menus et des menus contextuels personnalisés à l’aide de macros

Utiliser les barres d’outils et paramètres de démarrage personnalisés de versions antérieures d’Access

Appliquer un thème et un arrière-plan Office cohérents

Ajouter un arrière-plan Office

Changer le thème Office

Démarrer le démarrage d’une base de données

Ajout d’un titre personnalisé ou d’une icône à une base de données

Contournement des options de démarrage lorsque vous ouvrez une base de données

Créer une macro qui s’exécute à l’ouverture d’une base de données

Commutateurs de ligne de commande pour les produits Microsoft Office

Définir des propriétés et des options importantes

Définissez les propriétés de démarrage et les options dans lehttps://docs.microsoft.com/en-us/office/vba/access/concepts/settings/set-startup-properties-and-options-in-codede code

Afficher ou modifier les propriétés d’un fichier Office

Modifier les paramètres régionaux

Modifier les paramètres régionaux de Windows pour modifier l’apparence de certains types de données

Conseil    Pour être complet, parcourez la boîte de dialogue Options Access ( optionsde > defichier ), puis cliquez sur aide pour chaque onglet. Vous aurez peut-être d’autres options que vous voulez contrôler pour votre solution d’application.

Avant de procéder au déploiement

Avant de déployer la base de données frontale, tenez compte des recommandations suivantes:

Décidez du format de fichier à utiliser

Il existe quatre formats de fichiers Access que vous pouvez utiliser lorsque vous déployez une application :

  • .accdb    Il s’agit du format de fichier par défaut pour Access. Lorsque vous déployez une application dans ce format, les utilisateurs ont la plupart des options pour personnaliser et parcourir l’application comme ils le préfèrent. Si vous voulez vous assurer que les utilisateurs ne modifient pas la conception de votre application, vous devez utiliser le format de fichier .accde. En outre, un utilisateur ne peut pas déterminer facilement si un fichier .accdb a été modifié une fois que vous l’avez compilé : pour rendre cela évident, utilisez le format de fichier .accdc.

  • .accdc    Ce format est également connu comme fichier de déploiement Access. Un fichier de déploiement Access est constitué d’un fichier d’application et d’un fichier de signature numérique qui est associé à ce fichier. Ce format de fichier garantit aux utilisateurs que personne n’a changé le fichier d’application une fois que vous l’avez compilé. Vous pouvez appliquer ce format à une fichier Access de format par défaut (.accdb) ou à un fichier compilé binaire (.accde) Access. Pour plus d’informations, voir afficher la relation de confiance en ajoutant une signature numérique.

    Vous ne pouvez placer qu’un seul fichier d’application dans un fichier de déploiement Access. Si votre application a des fichiers logique et fichiers de données distincts, vous pouvez les compiler séparément.

  • .accde    Ce format est également connu comme fichier binaire compilé. Dans Access, un fichier binaire compilé est un fichier d’application de base de données qui a été enregistré avec tout le code VBA compilé. Aucun code source VBA ne reste dans un fichier binaire compilé Access. Un fichier. accde empêche la modification de la conception et du code, réduit la taille de la base de données et contribue à améliorer les performances. Pour plus d’informations, reportez-vous à la section masquage du code VBA pour les utilisateurs.

    Vous pouvez utiliser le runtime Access pour ouvrir un fichier binaire compilé Access. Si le runtime ne reconnaît pas l’extension de nom de fichier. accde, ouvrez le fichier binaire en créant un raccourci qui pointe vers le runtime, puis incluez le chemin d’accès au fichier binaire compilé pour lequel le raccourci doit être ouvert.

    Important   Les utilisateurs ne peuvent pas ouvrir un fichier binaire compilé en utilisant une version antérieure d’Access que la version dans laquelle il a été compilé si la version antérieure ne prend pas en charge une fonctionnalité ajoutée à la version ultérieure. Pour résoudre ce problème, compilez le fichier binaire dans la version d’Access installée par vos utilisateurs.

  • .accdr    Ce format vous permet de déployer une application qui s’ouvre en mode runtime. Déployer une application runtime peut vous aider à contrôler la façon dont elle est utilisée, bien que ce ne soit pas pas un moyen de sécuriser une application. Pour plus d’informations sur le mode runtime, voir la section Comprendre Access Runtime.

Installer et mettre à jour une base de données frontale Access

Lorsque vous adoptez une conception de base de données fractionnée, vous devez distribuer la base de données frontale à chaque utilisateur. Pour faire dérouler les choses en toute transparence, tenez compte des recommandations suivantes:

  • Vérifiez que chaque utilisateur dispose de la version correcte d’Access et que la base de données frontale s’ouvre dans la version correcte. Access possède également des versions 32 bits et 64 bits. L’exécution du nombre de bits incorrect peut affecter les appels d’API Windows, les références de la bibliothèque DLL et les contrôles ActiveX. Pour plus d’informations, voir choisir entre les versions 64 ou 32 bits d’Office.

  • Créez un package d’installation pour les autres fichiers nécessaires, y compris les pilotes de base de données, les fichiers de commandes pour l’installation et la configuration, ainsi que les fichiers liés à l’application. Pour plus d’informations, consultez créer un package d’installation.

  • Fournissez un raccourci sur le bureau Windows afin que l’utilisateur puisse rapidement exécuter la solution Access. Incluez dans le raccourci l’emplacement du dossier, un nom de raccourci explicite, une description et une icône. Pour plus d’informations, voir créer un raccourci Bureau pour un programme ou un fichier Office.

    Conseil    Invitez vos utilisateurs à épingler des applications au menu Démarrer.

  • Déterminez le mode de redéploiement et de remplacement de la base de données frontale pour les mises à jour nécessaires, et conservez des versions de fichiers pour effectuer le suivi des modifications. Par exemple, vous pouvez ajouter du code VBA pour rechercher de nouvelles versions et effectuer une mise à niveau automatique, même avant que les utilisateurs démarrent l’application.

  • Lorsque vous créez une connexion ODBC à l’aide d’un fichier DSN contenant la chaîne de connexion, ce fichier DSN doit également être installé sur chaque ordinateur client. Une autre approche consiste à créer une connexion «sans DSN» dans du code VBA pour éliminer la nécessité d’utiliser un fichier DSN. Pour plus d’informations, reportez-vous à utilisation de connexions sans DSN.

Haut de la page

Comprendre et télécharger le Access Runtime

Pour déployer des applications Access qui peuvent être exécutées sans installation de Access sur l’ordinateur d’un utilisateur, vous pouvez les distribuer avec le runtime Access, disponible gratuitement dans le centre de téléchargement Microsoft. Lorsque vous ouvrez une base de données Access à l’aide du Runtime Access, la base de données s’ouvre en mode version exécutable.

Le mode runtime est un mode d’exploitation de Access où certaines fonctionnalités Access ne sont pas disponibles par défaut. Certaines de ces fonctionnalités indisponibles peuvent toutefois être rendue disponibles en mode runtime.

Quelles fonctionnalités ne sont pas disponibles en mode runtime ?

Quelles fonctionnalités Access ne sont pas disponibles en mode runtime ?

  • Touches spéciales    Les touches telles que CTRL + ATTN, CTRL + G et la touche Maj pour ignorer les options de démarrage dans la base de données.

  • Volet de navigation    Le volet de navigation n’est pas disponible en mode runtime. Cela permet d’empêcher les utilisateurs d’accéder à des objets arbitraires dans votre application de base de données. Seuls les objets que vous exposez aux utilisateurs (par exemple, en fournissant un formulaire de navigation) peuvent être ouverts en utilisant le mode d’exécution. Le volet de navigation n’est jamais disponible en mode runtime.

  • Le ruban    Par défaut, le ruban n’est pas disponible en mode runtime. Cela permet d’empêcher les utilisateurs de créer ou modifier des objets de base de données et d’effectuer d’autres actions dangereuse, par exemple, connexion à de nouvelles sources de données ou l’exportation de données d’une manière non attendue. Vous ne pouvez pas exposer les onglets du ruban par défaut en mode runtime. Toutefois, vous pouvez créer un ruban personnalisé, puis associer ce ruban à un formulaire ou à un État. Pour plus d’informations, voir créer un ruban personnalisé dans Access.

  • Mode Création et mode Page    Les modes Création et Page ne sont pas disponibles pour tous les objets de base de données en mode runtime. Cela permet d’empêcher que les utilisateurs accèdent à des objets arbitraires dans votre application de base de données. Vous ne pouvez pas activer le mode Création ou Page en mode runtime.

  • Aide    Par défaut, l’aide intégrée n’est pas disponible en mode runtime. Étant donné que vous contrôlez quelles fonctionnalités sont disponibles dans votre application en mode runtime, certaines rubriques d’aide intégrée Access peuvent ne pas être utiles aux personnes qui utilisent votre application et peuvent potentiellement être source de confusion ou de frustration. Vous pouvez créer votre propre fichier d’aide personnalisé pour compléter votre application en mode exécutable.

Comment simuler le mode d’exécution?

Vous pouvez exécuter toute base de données Access en mode runtime sur un ordinateur sur lequel la version complète de Access est installée. Pour exécuter une base de données Access en mode runtime, effectuez l’une des opérations suivantes :

  • Modifier l’extension de nom de fichier du fichier de base de données de .accdb à .accdr.

  • Créer un raccourci vers la base de données à l’aide du commutateur de ligne de commande /Runtime .

    1. Sur votre ordinateur de bureau Windows, cliquez avec le bouton droit, puis sélectionnez nouveau > raccourci.

    2. Entrez l’emplacement de MSAccess. exe, l’emplacement de votre base de données et le qualificateur de commande /Runtime . Par exemple :

      "C:\Program Files\Microsoft Office\MSACCESS.EXE" "C:\MyDB.accdb" /runtime

    Pour plus d’informations, voir créer un raccourci Bureau pour un programme ou un fichier Office.

Est-ce que le mode runtime rend ma base de données plus sûre ?

Bien que le mode runtime limite la disponibilité des fonctionnalités de création et de navigation, vous ne devez pas utiliser le mode runtime en tant qu’outil principal de sécurisation d’une application de base de données. Sur un ordinateur sur lequel la version complète de Access installée, un utilisateur peut ouvrir le runtime d’une application de base de données comme une application de base de données normale (autrement dit, avec toutes les fonctionnalités disponibles), puis modifier la conception ou effectuer d’autres actions indésirables.

Même si vous déployez votre application de base de données uniquement sur des ordinateurs qui n’ont pas la version complète de Access, il est toujours possible pour un utilisateur de transférer l’application sur un ordinateur qui dispose de la version complète de Access, puis d’ouvrir le runtime de l’application de base de données comme une application de base de données normale.

Haut de la page

Télécharger le runtime Access

Pour télécharger le runtime Access pendant l’exécution depuis le centre de téléchargement Microsoft, cliquez sur le lien correspondant à votre version :

Aucun achat n’est nécessaire pour télécharger, utiliser ou redistribuer le Runtime Access, et il n’y a pas de limite au nombre d’utilisateurs auxquels vous pouvez distribuer le runtime.

Haut de la page

Créer un package d’installation

Vous pouvez effectuer plusieurs méthodes en fonction de la version d’Access.

Utiliser un package d’installation général (Access 2013 ou version ultérieure)

pour Access versions 2013 ou ultérieures, vous pouvez utiliser le programme d’installation Windows ou effectuer une recherche dans un programme tiers qui crée des packages d’installation.

Empaqueter et signer une base de données de Access (Access 2007 et 2010)

Dans Access 2007 ou 2010, il est plus facile et plus rapide de signer et distribuer une base de données. Lorsque vous créez un fichier .accdb ou .accde, vous pouvez compiler le fichier, appliquer une signature numérique au package créé, puis envoyer le package signé à d’autres utilisateurs. La fonctionnalité compiler et signer place la base de données dans un fichier de déploiement Access (.accdc), signe le fichier, puis place le package signé dans un emplacement que vous choisissez. Les autres utilisateurs peuvent ensuite extraire la base de données du package et travailler directement dans la base (et pas dans le package). Pour plus d’informations, consultez vue d’ensemblede l’Assistant Déploiement de solution.

Remarque : La fonction décrite dans cette section permet de compiler un fichier Access et d’appliquer une signature numérique au package, qui permet d’indiquer aux utilisateurs que le fichier est digne de confiance.

N’oubliez pas ces informations pour créer et signer un package :

  • Créer un package et le signer est une technique permettant d’étendre la sécurité. Lorsque vous ou vos utilisateurs reçoivent le package, la signature confirme que la base de données n’a pas été falsifiée. Si vous faites confiance à l’auteur, vous pouvez activer le contenu.

  • La fonctionnalité de compilation et de signature s’applique uniquement aux bases de données ayant un format de fichier .accdb.

  • Vous ne pouvez ajouter qu’une seule base de données à un package.

  • Lorsque vous créez un package et signez une base de données, tous les objets dans le fichier de base de données sont signés et encodés, pas seulement des macros ou modules de code. Le fichier de package est compressé lors du processus de compilation et de signature pour réduire les temps de téléchargement.

  • Une fois que la base de données est extraite du package, il n’y a plus de connexion entre le package signé et la base de données extraite.

  • Si vous utilisez un certificat signé automatiquement pour signer un package de base de données, puis cliquez sur Approuver tous à partir de l’éditeur quand vous ouvrez ce package, les packages signés à l’aide de vos certificats signés automatiquement seront toujours approuvés.

  • Si vous procédez à l’extraction de la base de données sur un emplacement approuvé, son contenu sera automatiquement activé dès que vous l’ouvrirez. Si vous choisissez un emplacement non approuvé, certains contenus de la base de données peuvent être désactivés par défaut.

Les sections suivantes expliquent comment créer un fichier de package signé, et comment utiliser une base de données dans un fichier de package signé. Pour effectuer ces étapes, vous devez disposer d’au moins un certificat de sécurité disponible. Si vous n’avez pas de certificat installé sur votre ordinateur, vous pouvez en créer un à l’aide de l’outil SelfCert ou obtenir un certificat commercial. Pour plus d’informations sur les certificats de sécurité, voir afficher le niveau de confiance en ajoutant une signature numérique.

Créer un package signé

  1. Ouvrez la base de données dont vous voulez faire un package signé.

  2. Cliquez sur l’onglet Fichier, puis cliquez sur Enregistrer sous.

  3. Dans Types de fichiers de base de données, cliquez sur Créer fichier de package et le signer puis Enregistrer sous.

  4. Dans la boîte de dialogue Sélectionnez un certificat, sélectionnez un certificat numérique, puis cliquez sur OK.

    La boîte de dialogue Créer un package signé Microsoft Office Access apparaît.

  5. Dans la liste Enregistrer dans, sélectionnez un emplacement pour votre package de base de données signé.

  6. Tapez un nom pour le package signé dans la zone Nom de fichier, puis cliquez sur Créer.

    Access crée le fichier .accdc et le place à l’endroit que vous avez choisi.

Extraire et utiliser un package signé

  1. Cliquez sur Fichier > Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez Packages signés Microsoft Office Access (*.accdc) comme type de fichier.

  3. Dans la liste Rechercher dans, localisez le dossier qui contient votre fichier .accdc, sélectionnez le fichier, puis cliquez sur Ouvrir.

  4. Effectuez l’une des opérations suivantes :

    • Si vous avez décidé de faire confiance au certificat numérique utilisé pour signer le package de déploiement, la boîte de dialogue Extraire la base de données dans s’affiche. Passez à l’étape 5.

    • Si vous n’avez pas encore accepté le certificat numérique, ce message conseil s’affiche.

      Message consultatif

      Si vous avez confiance dans la base de données, cliquez sur Ouvrir. Si vous avez confiance dans tous les certificats de ce fournisseur, cliquez sur Approuver tous à partir de l’éditeur. La boîte de dialogue Extraire la base de données vers s’affiche.

  5. Sinon, dans la liste Enregistrer dans, sélectionnez un emplacement pour la base de données extraite puis, dans la zone Nom de fichier, tapez un autre nom pour la base de données extraite.

Si vous n’êtes pas certain de pouvoir faire confiance à un certificat, l’article Comment savoir si une signature numérique est digne de confiance fournit des informations générales sur la vérification des dates et autres éléments d’un certificat pour permettre de s’assurer de sa validité.

Haut de la page

Remarque :  Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez vous nous dire si les informations vous ont été utiles ? Voici l’article en anglais pour référence.

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×