Créer une table et ajouter des champs

Créer une table et ajouter des champs

Lorsque vous créez une base de données Access, vous stockez vos données dans des tables, listes d’objets contenant des lignes et colonnes. Par exemple, vous pouvez créer une table Contacts pour stocker une liste de noms, adresses et numéros de téléphone, ou une table Produits pour stocker des informations sur des produits. Cet article explique la procédure de création d’une table, d’ajoute de champs à une table, de définition de la clé primaire d’une table et définition des propriétés de champ et de table.

Avant de créer des tables et d’ajouter des champs, vous devez en comprendre les concepts sous-jacents. Pour plus d’informations, voir présentation des tables.

Contenu de cet article

Création d’une table
Créer une table dans une nouvelle base de données
Créer une table dans une base de données existante
Importation ou liaison
— — Utiliser des données externes
— — Utiliser un site SharePoint
— — Utiliser un service web
Définir les propriétés d’une table
Enregistrer une table

Définition d’une clé primaire
Déterminer les champs à utiliser
Définir ou modifier une clé primaire
Supprimer une clé primaire

Déplacer un champ

Ajout de champs
Ajouter en entrant des données
Ajouter en utilisant un modèle de champ
Définition des propriétés d’un champ
Définir en mode Feuille de données
— — Renommer un champ
— — Modifier un type de données
— — Modifier une mise en forme
— — Définir d’autres propriétés
Définir des propriétés en mode Création
— — Modifier un type de données
— — Définir d’autres propriétés

Création d’une table

Une base de données simple telle qu’une liste de contacts peut utiliser une seule table. Toutefois, de nombreuses bases de données utilisent plusieurs tables. Lorsque vous créez une base de données, vous créez sur votre ordinateur un fichier faisant office de conteneur pour tous les objets figurant dans votre base de données, dont vos tables.

Vous pouvez créer une base de données en insérant une table dans une base de données existante, ou en important ou liant une table d’une autre source de données (telle qu’un classeur Microsoft Excel, un document Microsoft Word, un fichier texte ou une autre base de données). Lorsque vous créez une base de données vide, une nouvelle table vide est insérée automatiquement. Vous pouvez ensuite entrer des données dans cette table pour commencer à définir vos champs.

Haut de la page

Créer une table dans une nouvelle base de données

  1. Cliquez sur Fichier > Nouveau, puis sélectionnez Base de données de bureau vide.

  2. Dans la zone Nom de fichier, tapez un nom de fichier pour la nouvelle base de données.

  3. Pour accéder à un autre emplacement pour enregistrer la base de données, cliquez sur l’icône de dossier.

  4. Cliquez sur Créer.

    La nouvelle base de données s’ouvre, et une nouvelle table nommée Table1 est créée et s’ouvre en mode Feuille de données.

Haut de la page

Créer une table dans une base de données existante

  1. Cliquez sur Fichier > Ouvrir, puis cliquez sur la base de données si elle est répertoriée sous Récent. Dans le cas contraire, sélectionnez l’une des options de navigation pour localiser la base de données.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données que vous voulez ouvrir, puis cliquez sur Ouvrir.

  3. Sous l’onglet Création, dans le groupe Tables, cliquez sur Table.

    Une nouvelle table est insérée dans la base de données, qui s’ouvre en mode Feuille de données.

Haut de la page

Importation ou liaison pour créer une table

Vous pouvez créer une table en important des données stockées ailleurs ou en créant un lien avec ces données. Vous pouvez importer ou lier les données d’une feuille de calcul Excel, d’une liste SharePoint, d’un fichier XML, d’une autre base de données Access, d’un dossier Microsoft Outlook et de bien d’autres éléments.

Lorsque vous importez des données, vous créez une copie de ces données dans une nouvelle table de la base de données active. Les modifications apportées ultérieurement aux données sources n’auront aucun effet sur les données importées et les modifications apportées aux données importées n’affectent pas les données sources. Après vous être connecté à une source de données et avoir importé ses données, vous pouvez utiliser les données importées sans vous connecter à la source. Vous pouvez modifier la structure d’une table importée.

Lorsque vous liez à des données, vous créez une table liée dans la base de données active, qui représente un lien direct aux informations existantes stockées ailleurs. Lorsque vous modifiez des données dans une table liée, vous les modifiez dans la source. Lorsque des données changent dans la source, cette modification est reflétée dans la table liée. Vous devez être en mesure de vous connecter à la source de données chaque fois que vous utilisez une table liée. Vous ne pouvez pas modifier la conception d’une table liée.

Remarque : Vous ne pouvez pas modifier les données d’une feuille de calcul Excel au moyen d’une table liée. Une solution de contournement consiste à importer les données sources dans une base de données Access, puis à établir un lien à la base de données à partir d’Excel.

Haut de la page

Créer une table en important ou en liant des données externes

  1. Cliquez sur Fichier > Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez et ouvrez la base de données dans laquelle vous voulez créer une table.

  3. Sous l’onglet Données externes, dans le groupe Importer et lier, cliquez sur l’une des sources de données disponibles. 

    Image du ruban Access

  4. Suivez les instructions fournies par les boîtes de dialogue qui s’affichent à chaque étape.

    Access crée la nouvelle table et l’affiche dans le volet de navigation.

Haut de la page

Utiliser un site SharePoint pour créer une table

Vous pouvez créer une table dans votre base de données, qui importe ou lie une liste SharePoint. Vous pouvez également créer une liste SharePoint au moyen d’un modèle prédéfini. Les modèles prédéfinis dans Access sont Contacts, Tâches, Problèmes et Événements.

  1. Cliquez sur Fichier > Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données dans laquelle vous voulez créer la table, puis cliquez sur Ouvrir.

  3. Sous l’onglet Création, dans le groupe Tables, cliquez sur Listes SharePoint.

  4. Vous pouvez effectuer l’une des opérations suivantes :

    Créer une liste SharePoint basée sur un modèle

    1. Cliquez sur Contacts, Tâches, Problèmes ou Événements.

    2. Dans la boîte de dialogue Créer une nouvelle liste, tapez l’URL du site SharePoint sur lequel vous souhaitez créer la liste.

    3. Entrez un nom et une description pour la nouvelle liste dans les zones Spécifiez le nom de la nouvelle liste et Description.

    4. Pour ouvrir la table liée après sa création, activez la case à cocher Ouvrir la liste une fois l’opération terminée (activée par défaut).

    Créer une liste personnalisée

    1. Cliquez sur Personnalisé.

    2. Dans la boîte de dialogue Créer une nouvelle liste, tapez l’URL du site SharePoint sur lequel vous souhaitez créer la liste.

    3. Entrez un nom et une description pour la nouvelle liste dans les zones Spécifiez le nom de la nouvelle liste et Description.

    4. Pour ouvrir la table liée après sa création, activez la case à cocher Ouvrir la liste une fois l’opération terminée (activée par défaut).

    Importer des données dans une liste existante

    1. Cliquez sur Liste SharePoint existante.

    2. Dans la boîte de dialogue Données externes, tapez l’URL du site SharePoint qui contient les données à importer.

    3. Cliquez sur Importer les données sources dans une nouvelle table de la base de données active, puis sur Suivant.

    4. Activez la case à cocher en regard de chaque liste SharePoint que vous souhaitez importer.

    Lier à une liste

    1. Cliquez sur Liste SharePoint existante.

    2. Dans la boîte de dialogue Données externes - Site SharePoint, tapez l’URL du site SharePoint qui contient la liste vers laquelle vous souhaitez établir un lien.

    3. Cliquez sur Lier à la source de données en créant une table attachée, puis sur Suivant.

    4. Activez la case à cocher en regard de chaque liste SharePoint vers laquelle vous souhaitez établir un lien.

Haut de la page

Utiliser un service web pour créer une table

Vous pouvez créer une table dans votre base de données qui établit une connexion à des données sur un site web qui fournit une interface de service web. Les tables de service web sont en lecture seule.

  1. Sous l’onglet Données externes, dans le groupe Importer et lier, cliquez sur Plus, puis sur Services de données.

  2. Si la connexion à utiliser a déjà été installée, passez à l’étape 5. Sinon, continuez à l’étape suivante.

  3. Cliquez sur Installer une nouvelle connexion.

  4. Sélectionnez le fichier de connexion à utiliser, puis cliquez sur OK.

  5. Dans la boîte de dialogue Créer une liaison aux données de service web, développez la connexion à utiliser.

  6. Sélectionnez la table à lier. Access affiche les champs sur le côté droit de la boîte de dialogue.

  7. Si vous le souhaitez, tapez un nom pour la table liée dans la zone Spécifiez le nom de la liaison. Access utilisera ce nom pour la table liée dans le volet de navigation.

  8. Cliquez sur OK. Access crée la table liée.

Haut de la page

Définir les propriétés d’une table

En plus de définir des champs de propriétés, vous pouvez définir des propriétés qui s’appliquent à une table ou à des enregistrements entiers.

  1. Sélectionnez la table dont vous souhaitez définir les propriétés.

  2. Sous l’onglet Accueil, dans le groupe Affichages, cliquez sur Affichage, puis sur Mode Création.

  3. Sous l’onglet Création, dans le groupe Afficher/Masquer, cliquez sur Feuille de propriétés.

    Groupe Afficher/Masquer sous l’onglet Création dans Access

    La feuille de propriétés de la table s’affiche.

  4. Dans la feuille de propriétés, cliquez sur l’onglet Général.

  5. Cliquez sur la zone à gauche de la propriété que vous voulez définir, puis entrez un paramètre pour la propriété.

    N’oubliez pas d’appuyer sur CTRL + S pour enregistrer vos modifications.

    Utilisez cette propriété de table

    Pour

    Afficher les vues sur un site SharePoint

    Spécifier si les affichages basés sur la table peuvent être affichés sur un site SharePoint.

    Remarque : Les effets de ce paramètre dépendent du paramètre de la propriété de base de données Afficher les vues sur un site SharePoint.

    Sous-feuille données étendue

    Développer toutes les sous-feuilles de données lorsque vous ouvrez la table.

    Hauteur sous-feuille données

    Effectuez l’une des opérations suivantes :

    • Si vous souhaitez que la fenêtre de sous-feuille de données soit étendue de façon à afficher toutes les lignes, affectez la valeur 0" à cette propriété.

    • Si vous souhaitez contrôler la hauteur de la sous-feuille de données, entrez la hauteur souhaitée en pouces.

    Orientation

    Définir l’orientation de l’affichage en fonction du sens de votre écriture, de gauche à droite ou de droite à gauche.

    Description

    Fournir une description de la table. Cette description sera affichée dans les info-bulles pour la table.

    Affichage par défaut

    Définir Feuille de données, Tableau croisé dynamique ou Graphique croisé dynamique comme affichage par défaut lorsque vous ouvrez la table. Les options Tableau croisé dynamique et Graphique croisé dynamique ont été supprimées du démarrage d’Access depuis Access 2013.

    Règle de validation

    Entrer une expression qui doit être vraie lorsque vous ajoutez ou modifiez un enregistrement.

    Message si erreur

    Entrer un message qui s’affiche lorsqu’un enregistrement n’est pas conforme à l’expression dans la propriété Valide si.

    Filtre

    Définir des critères pour afficher uniquement certaines lignes en mode Feuille de données.

    Tri par

    Sélectionner un ou plusieurs champs pour spécifier l’ordre de tri par défaut des lignes en mode Feuille de données.

    Nom sous-feuille données

    Spécifier si une sous-feuille doit s’afficher en mode Feuille de données et, si oui, la table ou la requête qui doit fournir les lignes dans la sous-feuille.

    Champs fils

    Répertorier les champs dans la table ou la requête qui sont utilisés pour la sous-feuille de données et qui correspondent à la propriété Champs pères spécifiée pour la table.

    Champs pères

    Répertorier les champs dans la table qui correspondent à la propriété Champs fils spécifiée pour la table.

    Filtrer au chargement

    Appliquer automatiquement les critères de filtre dans la propriété Filtrer (en spécifiant la valeur Oui) lorsque la table est ouverte en mode Feuille de données.

    Trier au chargement

    Appliquer automatiquement les critères de tri dans la propriété Tri par (en spécifiant la valeur Oui) lorsque la table est ouverte en mode Feuille de données.

    Conseil    Pour disposer de davantage d’espace pour la saisie ou la modification d’un paramètre dans la zone de propriété, appuyez sur Maj+F2 pour afficher la zone Zoom. Si vous affectez la propriété Valide si à une expression et souhaitez obtenir de l’aide, cliquez sur Bouton Générateur en regard de la zone de propriété Valide si pour afficher le Générateur d’expression.

Haut de page

Enregistrer une table

Après avoir créé ou modifié une table, vous devez enregistrer sa conception. Lorsque vous enregistrez une table pour la première fois, donnez-lui un nom descriptif des données qu’elle contient. Vous pouvez utiliser jusqu'à 64 caractères alphanumériques, y compris des espaces. Par exemple, vous pouvez nommer une table Clients, Inventaire pièces ou Produits.

Access vous offre une grande latitude pour nommer vos tables. Il convient toutefois d’être informé de quelques restrictions. Un nom de table peut comprendre un maximum de 64 caractères, peut inclure une combinaison de lettres, de nombres, d’espaces et de caractères spéciaux à l’exception d’un point (.), d’un point d’exclamation (!), de crochets ([]), d’un espace de début, d’un signe égal de début (=) ou d’un caractère non imprimable tel qu’un retour chariot. De même, le nom ne peut pas contenir les caractères suivants :` / \ : ; * ? " ' < > | # <TAB> { } % ~ &.

Conseil : Vous devez établir une convention d’affectation de noms pour les objets dans votre base de données et l’utiliser de manière cohérente.

  1. Sélectionnez Fichier > Enregistrer, ou appuyez sur CTRL+S.

  2. Si vous enregistrez la table pour la première fois, tapez un nom, puis cliquez sur OK.

Haut de la page

Définition d’une clé primaire

Sauf si vous avez un motif spécifique ne pas le faire, vous devez spécifier une clé primaire pour une table. Access crée automatiquement un index pour la clé primaire, qui peut contribuer à améliorer les performances de la base de données. Access vérifie également que chaque enregistrement a une valeur dans le champ de clé primaire, et que cette valeur est toujours unique. Il est essentiel que les valeurs soient uniques car, dans le cas contraire, il n’existe aucun moyen fiable de distinguer une ligne particulière des autres.

Lorsque vous créez une table en mode Feuille de données, Access crée automatiquement une clé primaire à laquelle il affecte le nom de champ ID et le type de données NuméroAuto.

En mode Création, vous pouvez modifier ou supprimer la clé primaire, ou définir la clé primaire pour une table qui n’en a pas.

Haut de la page

Déterminer les champs à utiliser comme clé primaire

Il peut arriver que vous ayez déjà des données que vous voulez utiliser comme clé primaire. Par exemple, vous avez peut-être des numéros d’ID existants pour vos employés. Si vous créez une table pour effectuer le suivi des informations des employés, vous pouvez décider d’utiliser l’ID d’employé comme clé primaire pour cette table. Ou peut-être que l’ID d’employé n’est unique que combiné avec l’ID du service, de sorte que vous devez utiliser les deux champs conjointement comme clé primaire. Une bonne clé primaire présente les caractéristiques suivantes :

  • Chaque enregistrement a une valeur unique pour le champ ou la combinaison de champs.

  • Le champ ou la combinaison des champs ne sont jamais vides ou null. Ils contiennent toujours une valeur.

  • Les valeurs ne changent pas.

S’il n’existe aucune donnée appropriée utilisable comme clé primaire, vous pouvez créer un champ à utiliser comme clé primaire. Lorsque vous créez un champ à utiliser comme clé primaire, définissez le type de données NuméroAuto pour être certain qu’il présente les trois caractéristiques énoncées ci-dessus.

Haut de la page

Définir ou modifier la clé primaire

  1. Sélectionnez la table dont vous voulez définir ou modifier la clé primaire.

  2. Sous l’onglet Accueil, dans le groupe Affichages, cliquez sur Affichage, puis sur Mode Création.

  3. Dans la grille de création de table, sélectionnez le ou les champs à utiliser comme clé primaire.

    Pour sélectionner un seul champ, cliquez sur le sélecteur de ligne correspondant au champ souhaité.

    Pour sélectionner plusieurs champs, maintenez la touche CTRL enfoncée, puis cliquez sur le sélecteur de ligne de chacun d’eux.

  4. Sous l’onglet Création, dans le groupe Outils, cliquez sur Clé primaire.

    Groupe Outils sous l’onglet Création

    Un indicateur de clé s’affiche à gauche du ou des champs spécifiés comme clé primaire.

Haut de la page

Supprimer la clé primaire

  1. Sélectionnez la table dont vous voulez supprimer la clé primaire.

  2. Sous l’onglet Accueil, dans le groupe Affichages, cliquez sur Affichage, puis sur Mode Création.

  3. Cliquez sur le sélecteur de ligne correspondant à la clé primaire actuelle. Si la clé primaire est constituée de plusieurs champs, maintenez la touche CTRL enfoncée, puis cliquez sur le sélecteur de ligne correspondant à chaque champ.

  4. Sous l’onglet Création, dans le groupe Outils, cliquez sur Clé primaire.

    Groupe Outils sous l’onglet Création

    L’indicateur de clé est alors supprimé du ou des champs spécifiés comme clé primaire.

Lorsque vous enregistrez une nouvelle table sans définir de clé primaire, Access vous invite à créer un champ pour la clé primaire. Si vous cliquez sur Oui, Access crée un champ ID qui utilise le type de données NuméroAuto afin de fournir une valeur unique pour chaque enregistrement. Si votre table contient déjà un champ NuméroAuto, Access l’utilise comme clé primaire. Si vous cliquez sur Non, Access n’ajoute pas de champ, et aucune clé primaire n’est définie.

Haut de la page

Ajout de champs

Pour stocker de nouvelles données associées à un élément pour lequel vous disposez déjà d’une table Access, vous pouvez ajouter un champ à cette table. Supposons, par exemple, que vous ayez une table contenant le nom de famille, le prénom, l’adresse électronique, le numéro de téléphone et l’adresse postale de chacun de vos clients. Pour commencer à effectuer le suivi du moyen de communication favori de chaque client, vous pouvez ajouter un champ pour stocker ces données.

Vous stockez chaque donnée dont vous souhaitez assurer le suivi dans un champ. Par exemple, dans une table de contacts, vous créez des champs pour le Nom de famille, le Prénom, le Numéro de téléphone et l’Adresse. Dans une table de produits, vous créez des champs pour le Nom du produit, l’ID de produit et le Prix.

Chaque champ présente certaines caractéristiques essentielles, telles qu’un nom identifiant de manière unique le champ dans une table, un type de données définissant la nature des données, les opérations réalisables sur les données et l’espace disque requis pour le stockage de chaque valeur.

Avant de créer des champs, essayez de séparer les données sous leur plus petite forme. Il est beaucoup plus simple de combiner ultérieurement des données que de les séparer. Par exemple, au lieu d’un champ Nom, créez des champs Nom de famille et Prénom. Par la suite, il sera très facile de rechercher ou trier par Prénom, Nom de famille ou les deux. Si vous prévoyez d’exécuter un état, un tri, une recherche ou un calcul sur un élément de données, placez cet élément dans son propre champ.

Après avoir créé un champ, vous pouvez également définir des propriétés de champ afin de contrôler son apparence et son comportement. Par exemple, la propriété Format définit le mode d’affichage des données dans une feuille de calcul ou dans un formulaire contenant ce champ.

Haut de la page

Ajouter un champ en entrant des données

Lorsque vous créez une table ou ouvrez une table existante en mode Feuille de données, vous pouvez ajouter un champ à la table en tapant des données dans la colonne Ajouter un nouveau champ de la feuille de données(1). Access attribue automatiquement au champ un type de données en fonction des données entrées. Si votre entrée n’implique aucun autre type de données, Access sélectionne le type Texte, mais vous pouvez le modifier.

Feuille de données dans Access avec la colonne Ajouter un nouveau champ

Pour entrer des données dans la colonne Ajouter un nouveau champ :

  1. Créez ou ouvrez une table en mode Feuille de données en cliquant avec le bouton droit sur la table souhaitée dans le volet de navigation, puis en cliquant sur Mode Feuille de données dans le menu contextuel.

  2. Dans la colonne Ajouter un nouveau champ, entrez le nom du champ que vous voulez créer.

    Utilisez un nom descriptif pour faciliter l’identification du champ.

  3. Entrez des données dans le nouveau champ.

Haut de page

Ajouter un champ en utilisant un modèle de champ

Parfois, il est plus facile d’opérer un choix dans une liste prédéfinie de champs correspondant à vos besoins que de créer un champ manuellement. Vous pouvez utiliser la liste Plus de champs pour opérer un choix dans une liste de modèles de champ. Un modèle de champ est un ensemble prédéfini de caractéristiques et propriétés qui décrivent un champ. La définition d’un modèle de champ inclut un nom de champ, un type de données, un paramètre pour la propriété Format du champ, et d’autres propriétés de champ.

  1. Sous l’onglet Accueil, dans le groupe Affichages, cliquez sur Affichage, puis sur Mode Feuille de données.

  2. Sous l’onglet Champs, dans le groupe Ajouter et supprimer, cliquez sur Plus de champs.

    Capture d’écran du groupe Ajouter et supprimer sous l’onglet de ruban Champs.

  3. Pour insérer la nouvelle colonne, sélectionnez un champ dans la liste Plus de champs. Access insère le champ à droite de la colonne dans laquelle votre curseur est actuellement positionné. Si vous choisissez, sous le titre Démarrage rapide, une option de champ telle que Adresse, Access crée plusieurs champs dans votre table pour accueillir les différentes parties d’une adresse.

Haut de la page

Définition des propriétés d’un champ

Après avoir créé un champ, vous pouvez définir des propriétés de champ afin de contrôler son apparence et son comportement.

En définissant des propriétés de champ, vous pouvez par exemple :

  • contrôler l’apparence des données dans un champ ;

  • aider à prévenir la saisie de données incorrectes dans un champ ;

  • spécifier des valeurs par défaut pour un champ ;

  • aider à accélérer les opérations de recherche et de tri sur un champ.

Vous pouvez définir une partie des propriétés de champ disponibles pendant que vous travaillez en mode Feuille de données. En revanche, pour avoir accès à la liste complète des propriétés de champ et définir toutes les propriétés de champ, vous devez utiliser le mode Création.

Les propriétés que vous pouvez définir dépendent du type de données du champ.

Haut de la page

Définir des propriétés de champ en mode Feuille de données

Vous pouvez renommer un champ, modifier son type de données, modifier sa propriété Format, et modifier certaines de ses autres propriétés pendant que vous travaillez en mode Feuille de données.

  1. Dans le volet de navigation, cliquer avec le bouton droit sur la table que vous souhaitez ouvrir.

  2. Dans le menu contextuel, cliquez sur Mode Feuille de données.

Haut de la page

Renommer un champ

Lorsque vous ajoutez un champ en entrant des données en mode Feuille de données, Access affecte automatiquement un nom générique au champ. Access affecte le nom Champ1 au premier nouveau champ, Champ2 au deuxième nouveau champ, et ainsi de suite. Par défaut, le nom d’un champ est utilisé en guise d’étiquette partout où le champ est affiché (comme dans l’en-tête de colonne sur une feuille de données). L’attribution de noms descriptifs aux champs facilite leur utilisation lors de l’affichage ou de la modification d’enregistrements.

  1. Cliquez avec le bouton droit sur l’en-tête du champ à renommer (par exemple, Champ1).

  2. Dans le menu contextuel, cliquez sur Renommer le champ.

  3. Entrez le nouveau nom dans l’en-tête du champ.

    Les noms de champs peuvent compter au maximum 64 caractères (lettres ou nombres), y compris les espaces.

Haut de la page

Modifier le type de données d’un champ

Lorsque vous créez un champ en entrant des données en mode Feuille de données, Access examine ces données afin de déterminer le type de données approprié pour le champ. Par exemple, si vous entrez 1/1/2017, Access reconnaît qu’il s’agit d’une date et affecte le type de données Date/heure au champ. Si Access n’est pas en mesure de déterminer le type de données avec certitude, le type de données Texte est utilisé par défaut (Texte court si vous utilisez Access 2016).

Le type de données du champ détermine les autres propriétés de champ que vous pouvez définir. Par exemple, vous pouvez définir la propriété Ajouter uniquement seulement pour un champ dont le type de données est Lien hypertexte ou Mémo (Texte long si vous utilisez Access 2016).

Il peut arriver que vous souhaitiez modifier manuellement le type de données d’un champ. Par exemple, supposez que vous avez des numéros de salles qui ressemblent à des dates, tels que 10/2017. Si vous entrez 10/2017 dans un nouveau champ en mode Feuille de données, la fonctionnalité de détection automatique de type de données sélectionne le type de données Date/heure pour le champ. Les numéros de salles étant des étiquettes, et non des dates, ils doivent utiliser le type de données Texte. Pour modifier le type de données d’un champ, appliquez la procédure suivante.

  1. Dans le ruban, cliquez sur l’onglet Champs.

  2. Dans la liste Type de données, dans le groupe Mise en forme, sélectionnez le type de données souhaité.

    Image du groupe Type de données et Mise en forme dans le ruban Access

    Quels sont les types de données disponibles ?

    Pour une liste complète des types de données disponibles dans les bases de données Access, voir Types de données pour les bases de données Access de bureau.

    Conseils sur les types de données

    • La taille maximale d’un fichier de base de données Access est de 2 Go.

    • Pour optimiser les performances, vous devez utiliser la Taille du champ la plus appropriée lorsque vous créez un champ Texte ou Nombre. Par exemple, si vous prévoyez de stocker des codes postaux d’une longueur prévisible, spécifiez-la en tant que la taille du champ. Vous pouvez spécifier la taille du champ en définissant une valeur dans la zone de propriété Taille du champ. Pour plus d’informations, voir la section Définir d’autres propriétés de champ.

    • Pour les numéros de téléphone, numéros de pièce et autres nombres que vous ne comptez utiliser pour des calculs mathématiques, vous devez sélectionner le type de données Texte plutôt que le type de données Nombre. Une valeur numérique stockée en tant que texte peut être triée et filtrée de façon plus logique.

Haut de la page

Modifier le format d’un champ

En plus de déterminer le type de données d’un nouveau champ, Access peut définir la propriété Format en fonction de ce que vous avez tapé. Par exemple, si vous entrez 10:50 a.m., Access affecte le type de données Date/heure et affecte à la propriété Format la valeur Heure, réduit. Pour modifier manuellement la propriété Format d’un champ, procédez comme suit :

  1. Dans le ruban, cliquez sur l’onglet Champs

  2. Dans la liste Format, dans le groupe Mise en forme, entrez le format souhaité. 

    Remarque : La liste Format peut ne pas être disponible pour certains champs (par exemple les champs Texte) ; tout dépend du type de données du champ.

Haut de la page

Définir d’autres propriétés de champ

  1. En mode Feuille de données, cliquez sur le champ dont vous souhaitez définir la propriété.

  2. Sous l’onglet Champs, dans le groupe Propriétés, Mise en forme ou Validation de champ, sélectionnez les propriétés souhaitées.

Haut de la page

Définir des propriétés de champ en mode Création

Vous pouvez définir toute propriété de champ lorsque vous travaillez avec une table en mode Création. En mode Création, vous définissez le type de données d’un champ dans la grille de création de table, et d’autres propriétés dans le volet Propriétés du champ.

  1. Dans le volet de Navigation, cliquez avec le bouton droit sur la table.

  2. Dans le menu contextuel, cliquez sur Mode Création.

Haut de la page

Modifier le type de données d’un champ

Vous pouvez modifier plusieurs aspects d’un champ que vous venez de créer.

Avertissement : Vous pouvez également modifier ces aspects d’un autre champ que celui que vous venez de créer. Cependant, si le champ contient déjà des données, certaines actions seront indisponibles, ou présenteront un risque de perte de données.

  1. Dans la grille de création de table, recherchez le champ dont vous voulez définir le type de données.

  2. Dans la colonne Type de données, choisissez un type de données dans la liste.

    Quels sont les types de données disponibles ?

    Pour une liste complète des types de données disponibles dans les bases de données Access, voir Types de données pour les bases de données Access de bureau.

    Conseils sur les types de données

    • La taille maximale d’un fichier de base de données Access est de 2 Go.

    • Pour les numéros de téléphone, numéros de pièce et autres nombres que vous ne comptez utiliser pour des calculs mathématiques, vous devez sélectionner le type de données Texte plutôt que le type de données Nombre. Une valeur numérique stockée en tant que texte peut être triée et filtrée de façon plus logique, mais n’est pas facilement utilisable dans des calculs.

    • Pour les types de données Texte et Nombre, vous pouvez spécifier la taille ou le type de données du champ plus précisément en définissant une valeur dans la zone de propriété Taille du champ.

Haut de la page

Définir d’autres propriétés de champ

Remarque : Tous les formats ne sont pas disponibles pour tous les types de données. Définissez d’abord le premier type de données, puis, le cas échéant, définissez le format.

  1. Dans la grille de création de table, sélectionnez le champ dont vous voulez définir les propriétés. Access affiche les propriétés de ce champ dans le volet Propriétés du champ.

    Le type de données du champ détermine les propriétés que vous pouvez définir.

  2. Dans le volet Propriétés du champ, entrez les paramètres souhaités pour chaque propriété, ou appuyez sur F6 et utilisez les touches de direction pour sélectionner une propriété.

    Quelles sont les propriétés de champ disponibles ?

    Pour une liste complète des propriétés de champ disponibles pour chaque type de données dans les bases de données Access, voir Présentation des types de données et des propriétés de champ.

    Remarque : Certaines propriétés ne sont pas disponibles pour tous les champs. Le type de données d’un champ détermine les propriétés de celui-ci.

  3. Pour fournir davantage d’espace pour la saisie ou la modification d’un paramètre de propriété dans la zone de propriété, appuyez sur MAJ+F2 pour afficher la zone Zoom.

    Conseil : Si vous entrez un masque de saisie ou une expression de validation, et souhaitez obtenir de l’aide pour la création de ceux-ci, cliquez sur Bouton Générateur en regard de la zone de propriété pour afficher le générateur approprié.

  4. Pour enregistrer vos modifications, Appuyez sur CTRL+S.

Haut de la page

Déplacer un champ

Pour déplacer un champ, faites-le glisser vers la position souhaitée. Pour sélectionner plusieurs champs contigus à déplacer, cliquez sur le premier champ, maintenez la touche Maj enfoncée, puis cliquez sur le dernier champ. Vous pouvez ensuite faire glisser le groupe de champs sélectionné vers sa nouvelle position.

Le déplacement d’un champ modifie sa position sur la feuille de données mais ne modifie pas l’ordre des champs de la création de table. Si vous accédez aux champs par programme, l’ordre initial s’applique. Par exemple, si vous modifiez la position d’un champ sur la feuille de calcul par glisser-déplacer, puis que vous créez un formulaire dans la table à l’aide du bouton Formulaire, le champ conservera sa position d’origine.

Haut de la page

Voir aussi

Ajouter un champ calculé à une table

Ajouter un champ à un formulaire ou un état

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×