Créer un diagramme du visualiseur de données

Remarque :  Nous faisons de notre mieux pour vous fournir le contenu d’aide le plus récent aussi rapidement que possible dans votre langue. Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez-vous nous indiquer en bas de page si ces informations vous ont aidé ? Voici l’article en anglais à des fins de référence aisée.

Vous cherchez à créer automatiquement un organigramme Visio détaillé et soigné à partir d’un classeur Excel ? Vous pouvez y parvenir en utilisant les modèles du visualiseur de données. Chaque modèle est associé à un classeur Excel qui permet de convertir les données de processus en organigramme dans Visio. Vous pouvez également utiliser votre propre modèle Excel, mapper des données Excel à des formes dans l’Assistant Créer un diagramme à partir des données et créer automatiquement le diagramme. Vous pouvez même ajouter des colonnes de données dans Excel afin de les convertir en données de forme Visio.

Visio prend également en charge la synchronisation bidirectionnelle entre le diagramme Visio et le classeur Excel. Vous pouvez d’une part créer l’organigramme en modifiant des données dans Excel et en actualisant le diagramme dans Visio, et d’autre part apporter des modifications au diagramme Visio, puis mettre à jour les données Excel à partir du diagramme. 

Vue d’ensemble du visualiseur de données

La possibilité d’utiliser les modèles du visualiseur de données est uniquement disponible dans Visio Online (plan 2) sur le canal Version actuelle. Si vous ne savez pas quelle version de Visio vous utilisez, sélectionnez Fichier > Compte > À propos de Visio. Pour en savoir plus sur la version par abonnement de Visio, voir Visio Online (plan 2).

Si vous ne voyez pas les modèles du Visualiseur de données ou si vous avez d’autres questions concernant la prise en main, visitez la page FAQ du visualiseur de données.

Remarque : Pour utiliser cette fonctionnalité, vous devez avoir souscrit un abonnement Office 365. Si vous avez souscrit un abonnement à Office 365, vérifiez que vous utilisez la dernière version d’Office. Si vous êtes un informaticien gérant le processus de mise à jour d’Office 365, consultez la page Publications des canaux de mise à jour du client Office 365 pour en savoir plus sur les mises à jour fournies via chaque canal.

Contenu de cet article

Créer un diagramme du visualiseur de données

Avant de commencer

Rassemblez vos idées et retravaillez-les sous forme de brouillon, sur papier ou via la saisie manuscrite. Cette ébauche peut vous aider à gagner du temps et à vous simplifier les étapes suivantes.

Pour créer un diagramme du visualiseur de données, vous pouvez travailler simultanément dans Excel et Visio. Travailler dans deux fenêtres peut vous paraître plus simple sur un appareil Windows ou dans un environnement multi-écran. De plus, vous pouvez comparer le travail que vous avez effectué dans Excel et Visio afin de confirmer que vous êtes sur le bon chemin.

Recommandé    Regardez cette vidéo de Microsoft Office pour découvrir cette fonctionnalité : Visualiseur de données : démonstration.

Étape 1 : choisir un modèle du visualiseur de données

  1. Ouvrez Visio ou sélectionnez Fichier > Nouveau si vous modifiez un diagramme.

  2. Sélectionnez MODÈLES.

    La commande de modèles
  3. Sélectionnez Diagramme de flux.

    La commande de diagramme de flux
  4. Sélectionnez diagramme de flux simple - données visualiseur, croisées diagramme de flux fonctionnel - visualiseur de données ou de diagramme d’Audit - visualiseur de données.

    Les modèles de données visualiseur

    Un modèle de Visualiseur de données affiche une icône Excel dans l’angle supérieur gauche.

Pour plus d’informations sur les diagrammes de flux et leurs formes, voir Créer un diagramme de flux simple et Créer un diagramme de flux fonctionnel croisé.

Étape 2 : créer un classeur Excel

  1. Dans l’aperçu du modèle, sélectionnez Modèle de données Excel.

    Sélection du modèle de données Excel

    Remarque    Si vous voulez utiliser les modèles Excel présentés dans cet article à titre de référence, vous pouvez les télécharger à partir des liens suivants :

  2. Sélectionnez Fichier > Enregistrer. Spécifiez un ordinateur, un serveur réseau ou une bibliothèque de documents SharePoint. Entrez un nom de fichier, puis sélectionnez Enregistrer.

  3. Pour ajouter une nouvelle feuille de calcul, au bas de la fenêtre du classeur, sélectionnez Nouvelle feuille Bouton Nouvelle feuille .

  4. Créez un tableau Excel. Pour plus d’informations sur l’utilisation des tableaux Excel, voir Présentation des tableaux Excel, Création ou suppression d’un tableau Excel et Redimensionner un tableau en ajoutant ou en supprimant des lignes et des colonnes.

  5. Ajoutez des colonnes et des lignes au tableau, lesquelles serviront à créer le diagramme Visio. Il existe des exigences spécifiques pour les en-têtes et valeurs des colonnes des tableaux Excel. Utilisez la section Comment les colonnes Excel interagissent avec des composants de diagramme de flux Visio ? en tant que guide graphique.

Étape 3 : ajouter des données de forme supplémentaires au tableau Excel (facultatif)

  1. Examinez l’onglet Diagramme de processus du modèle Excel. Les colonnes du tableau Excel sont colorées en bleu et en vert. La couleur donne un indice visuel permettant de différencier les colonnes.

    Les colonnes bleues servent à créer le diagramme de flux dans le diagramme Visio. Toutes les colonnes sont également ajoutées en tant que données de forme.

  2. Pour ajouter des données de forme supplémentaires, ajoutez une ou plusieurs colonnes à votre tableau Excel.

    Les colonnes vertes signalent des données de forme supplémentaires que vous pouvez ajouter à chaque forme. Vous pouvez ajouter le nombre de colonnes supplémentaires que vous souhaitez. Par défaut, ces données ne sont pas visibles dans le diagramme, sauf si vous ajoutez des graphiques de données. Pour afficher les données de forme dans le diagramme Visio, sélectionnez Données > Fenêtre Données de forme. Pour plus d’informations sur les données de forme et les graphiques de données, voir Ajouter des données à des formes et Vue d’ensemble : graphiques de données.

Étape 4 : créer un diagramme Visio avec l’Assistant

  1. Revenez à Visio. Dans l’aperçu du modèle, sélectionnez votre unité de mesure, puis sélectionnez Créer.

  2. Dans la première page de l’Assistant Créer un diagramme à partir des données, procédez comme suit :

    1. Sous Quel diagramme voulez-vous créer à partir de vos données ?, sélectionnez un modèle : Diagramme de flux simple, Diagramme de flux fonctionnel croisé (horizontal) ou Diagramme de flux fonctionnel croisé (vertical).

    2. Sous Sélectionnez un classeur Excel, sélectionnez un classeur à partir de la liste des classeurs utilisés récemment, ou sélectionnez Parcourir pour rechercher le classeur que vous avez créé au cours de l’étape 2.

    3. Sous Sélectionnez un tableau ou une plage personnalisée dans le classeur, sélectionnez le tableau contenant vos données de processus Excel.

    4. Sélectionnez Terminer. Cette action a pour effet d’accepter toutes les valeurs par défaut que Visio remplit dans les autres pages de l’Assistant.

Le diagramme est ensuite automatiquement créé à l’intérieur d’un conteneur. Des pages Visio supplémentaires sont ajoutées en fonction de la taille du diagramme de processus.

Étape 5 : enregistrer le diagramme Visio

  • Sélectionnez Fichier > Enregistrer, recherchez un emplacement, entrez un nom de fichier, puis sélectionnez Enregistrer.

Nous vous conseillons de conserver les fichiers Excel et Visio dans le même emplacement, car ils vont de pair.

Étape 6 : synchroniser les données et le diagramme

Après avoir créé un diagramme avec le visualiseur de données, vous souhaiterez peut-être y apporter des modifications. Visio prend en charge la synchronisation bidirectionnelle entre les données sources et le diagramme.

Conseil    Gardez les deux fichiers synchronisés et à jour après avoir terminé de travailler sur l’un d’entre eux. Lorsque vous modifiez les données dans Excel, actualisez le diagramme ; lorsque vous modifiez le contenu du diagramme, mettez à jour les données Excel.

Pour modifier les données dans Excel et actualiser le diagramme

  1. Apportez des modifications aux données sources dans le tableau Excel. Vous pouvez ajouter, mettre à jour ou supprimer des lignes.

  2. Enregistrez le classeur Excel.

  3. Dans Visio, cliquez dans le conteneur de diagramme pour activer l’onglet Création - Outils de données dans le ruban, puis sélectionnez Actualiser le diagramme.

Les modifications que vous apportez au classeur Excel s’affichent ensuite dans le diagramme Visio. Tenez compte des éléments suivants :

  • Si vous avez apporté des modifications au diagramme pouvant être perdues suite à l’actualisation, Visio affiche une boîte de dialogue Conflit d’actualisation du diagramme.

  • L’actualisation a pour effet de modifier uniquement les formes et les connexions au sein du conteneur.

  • Les modifications que vous apportez au niveau de la mise en forme des connecteurs ou des formes situés à l’intérieur du conteneur sont conservées.

  • Faites en sorte de garder toutes les formes de diagramme et les lignes de connexion dans les limites du conteneur. Tout autre objet dans la page se trouvant en dehors du conteneur n’est pas affecté. Pour plus d’informations sur les conteneurs, voir Clarifier la structure des diagrammes à l’aide de conteneurs et de listes.

Pour modifier le contenu du diagramme et mettre à jour les données dans Excel

  1. Apportez les modifications au diagramme Visio. Vous pouvez ajouter, mettre à jour ou supprimer des modifications et des connecteurs.

  2. Si le classeur Excel se trouve sur un ordinateur de bureau ou un serveur de fichiers réseau, vérifiez qu’il a été enregistré et qu’il est fermé.

  3. Cliquez dans le conteneur de diagramme pour activer l’onglet Création - Outils de données dans le ruban, puis sélectionnez Mettre à jour les données sources.

Les modifications que vous avez apportées dans le diagramme Visio sont mises à jour dans le classeur Excel. Si des données risquent d’être perdues dans Excel, Visio affiche la boîte de dialogue Conflit de mise à jour des données. Pour éviter tout problème, utilisez les recommandations suivantes :

  • Enregistrez une sauvegarde des données Excel avant de remplacer les modifications.

  • Dans le classeur Excel, utilisez un tableau Excel en tant que source de données plutôt qu’une plage personnalisée. Après avoir sélectionné Remplacer dans la boîte de dialogue Mettre à jour les données sources, Visio convertit la plage personnalisée en tableau Excel.

  • N’utilisez pas de formules dans la source de données Excel. Après avoir sélectionné Remplacer dans la boîte de dialogue Mettre à jour les données sources, Visio convertit la formule en résultat de formule.

  • Vous avez créé le diagramme à l’aide de l’option suivante dans l’Assistant Créer un diagramme à partir des données, où des colonnes de données sont mappées à des fonctions et phases : Mappage > Autres options > Conservez l’ordre des valeurs de colonne de vos données pour créer > sélectionnez Fonction ou Couloir ou sélectionnez Phase ou Barre de planning. Dans ce cas, Visio nécessite une colonne supplémentaire dans vos données pour représenter la connexion entre les formes. Après avoir sélectionné Remplacer dans la boîte de dialogue Mettre à jour les données sources, la colonne supplémentaire est ajoutée.

  • Vous avez créé un diagramme de flux fonctionnel croisé avec les couloirs et phases en respectant l’ordre des valeurs de données dans Excel. Vous avez créé le diagramme à l’aide de l’option suivante dans l’Assistant Créer un diagramme à partir des données, où des colonnes de données sont connectées à des activités et étapes de processus : Mappage > Indiquez comment vous voulez connecter les étapes de processus/activités > Connecter de manière séquentielle. Dans ce cas, Visio nécessite une colonne supplémentaire dans vos données pour représenter la connexion entre les formes. Si vous modifiez l’ordre des couloirs ou des phases dans le diagramme, l’ordre est également modifié dans la source de données. Après avoir sélectionné Remplacer dans la boîte de dialogue Mettre à jour les données sources, les couloirs et phases dans le diagramme ne suivent plus l’ordre des données du classeur Excel.

Étape 7 : personnaliser l’interaction entre le tableau Excel et le diagramme Visio (facultatif)

Parfois, vous souhaiterez peut-être personnaliser la création de vos diagrammes du visualiseur de données. Par exemple, vous souhaiterez peut-être utiliser différentes formes afin de respecter des normes en vigueur au sein de votre organisation ou pour effectuer un mappage vers différents noms de colonnes dans le tableau Excel.

  1. Lorsque vous sélectionnez Créer et démarrez l’Assistant Créer un diagramme à partir des données, puis que vous entrez des valeurs dans la première page (cf. l’étape 4), sélectionnez Suivant ou Précédent pour afficher chaque page de l’Assistant.

  2. Sélectionnez Aide (?) pour obtenir davantage d’informations sur la manière dont vous pouvez personnaliser chaque option dans la page. Pour plus d’informations, voir Utiliser l’Assistant Créer un diagramme à partir des données.

Haut de la page

Comment les colonnes Excel interagissent avec des composants de diagramme de flux Visio ?

Utilisez la procédure pas à pas décrite dans l’image suivante afin de comprendre comment chaque colonne du tableau Excel permet de créer le diagramme Visio.

ID d’étape de processus   Nombre qui identifie chaque forme faisant partie du diagramme de flux. Cette colonne est requise, et chaque valeur du tableau Excel doit être unique et non vide. Cette valeur n’apparaît pas dans le diagramme de flux.

Interaction du diagramme de processus Excel avec le diagramme de flux Visio : ID d’étape de processus

Description de l’étape de processus   Texte ajouté à chaque forme faisant partie du diagramme de flux.

Interaction du diagramme de processus Excel avec le diagramme de flux Visio : Description de l’étape de processus

ID d’étape suivante   ID d’étape de processus de la forme suivante dans la séquence. Une forme d’embranchement est suivie de deux étapes suivantes. Elle est représentée par des nombres séparés par une virgule, par exemple, 4,5. Vous pouvez utiliser plus de deux étapes suivantes.

Interaction du diagramme de processus Excel avec le diagramme de flux Visio : ID d’étape suivante

Étiquette du connecteur   Pour les formes d’embranchement, les étiquettes des connecteurs sont représentées par du texte séparé par une virgule, par exemple, Oui,Non. Dans l’exemple, Oui correspond à 4 et Non correspond à 5.

Interaction du diagramme de processus Excel avec le diagramme de flux Visio : Étiquette du connecteur

Type de forme   Type de forme que vous voulez représenter dans le diagramme Visio, par exemple, Processus ou Décision. Microsoft vous recommande d’utiliser les listes déroulantes pour la validation de vos choix.

Interaction du diagramme de processus Excel avec le diagramme de flux Visio : Type de forme

Fonction et phase   Fonction (ou couloir) et phase (ou chronologie) auxquelles appartient chaque forme. Cette colonne ne s’applique qu’à un diagramme de flux fonctionnel croisé. Elle est ignorée par un diagramme de flux simple.

Interaction du diagramme de processus Excel avec le diagramme de flux Visio : Fonction et phase

Haut de la page

Utiliser d’autres gabarits pour créer un diagramme de Visualiseur de données

Outre les modèles de données visualiseur, vous pouvez également utiliser des gabarits dans d’autres modèles lorsque vous créez un diagramme visualiseur de données. Par exemple, créer des diagrammes de processus pour les transactions financières ou gestion des stocks. Il existe d’autres gabarits orientée processus, y compris des modèles de base BPMN et objets de flux de travail. Vous pouvez même ajouter des formes personnalisées à l’aide du gabarit Formes de poste. Pour plus d’informations, voir créer, enregistrer et partager des gabarits personnalisés.

  1. Ouvrez un diagramme du visualiseur de données (un diagramme de flux simple ou un diagramme de flux fonctionnel croisé) que vous avez déjà créé.

  2. Sélectionnez Créer pour entrer dans l’Assistant Créer un diagramme à partir des données. Après avoir entré des valeurs dans la première page, sélectionnez Suivant jusqu’à ce que la page Mappage de forme s’affiche dans l’Assistant.

  3. Ajoutez un ou plusieurs gabarits à l’aide de l’option Autres formes.

  4. Sélectionnez une forme et mappez-la aux valeurs de données de votre colonne Type de forme en la faisant glisser.

Haut de la page

Appliquer des graphiques de données à votre diagramme

Vous pouvez améliorer votre diagramme en ajoutant des graphiques de données. Ceux-ci vous aideront à visualiser les données de forme sur le diagramme. Concrètement, vous pouvez convertir votre diagramme en tableau de bord de processus, dans lequel les graphiques de données affichent des indicateurs de performance clés (KPI) via les icônes de graphiques de données d’après vos données de forme.

  1. Ouvrez le diagramme du visualiseur de données.

    Sélectionnez le conteneur pour lequel vous souhaitez appliquer des graphiques de données.

  2. Sélectionnez Données > Champs de graphiques de données.

  3. Sélectionnez les champs de graphiques de données à ajouter à votre diagramme.

    Appliquer des graphiques de données à un diagramme du visualiseur de données Visio

    Les graphiques de données sont appliqués à l’intégralité du diagramme. Si vous souhaitez masquer les graphiques de données pour certaines formes, n’entrez aucune valeur dans les colonnes de données correspondant à ces lignes dans le classeur Excel.

  4. Si vous le souhaitez, vous pouvez définir des options supplémentaires dans l’onglet Données. Pour plus d’informations, voir Vue d’ensemble : graphiques de données.

Haut de la page

Étapes suivantes

Voici quelques tâches que vous souhaiterez peut-être effectuer après avoir créé un diagramme du visualiseur de données.

  • Thèmes    Dans Visio, un thème est un ensemble de couleurs et d’effets que vous pouvez appliquer en un seul clic à un dessin. Les thèmes constituent un moyen rapide de donner un aspect professionnel à vos dessins. Pour plus d’informations, voir Appliquer un aspect professionnel à vos dessins avec des thèmes.

  • Disposition    Visio dispose de repères manuels et d’outils automatiques permettant de s’assurer que les formes de votre diagramme sont alignées et espacées correctement. Cela vous permet de créer des dessins aussi clairs que possible et de leur donner un aspect organisé. Pour plus d’informations, voir Aligner et positionner des formes dans un diagramme.

  • Exporter    Exportez un diagramme du visualiseur de données et le classeur Excel associé vers un package de modèle Visio (.vtpx). Un package de modèle Visio enregistre les paramètres, les gabarits et les données du diagramme afin que d’autres personnes puissent les utiliser comme point de départ rapide pour créer leur propre diagramme de visualiseur de données. D’autres utilisateurs peuvent installer le package de modèle sur leur ordinateur. Pour plus d’informations, voir Exporter et installer un package de modèle du visualiseur de données.

Haut de la page

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×