Créer ou modifier des vues dans les diagrammes de modèle de base de données

Vous pouvez considérer un affichage comme une requête enregistrée. Les affichages sont particulièrement utiles si vous souhaitez accéder aux mêmes informations à partir de plusieurs tables ou laisser les utilisateurs accéder aux données sans leur permettre de modifier les tables proprement dites.

Remarque : Le diagramme de modèle de base de données est uniquement disponible dans certaines versions de Visio. Voir Vous ne trouvez pas les fonctionnalités de modèle de base de données? pour plus d’informations.

Ajouter un affichage à un diagramme de modèle de base de données

  • À partir du gabarit Entité-relation ou Relationnel objet, faites glisser une forme Affichage vers la page de dessin.

Attribuer des colonnes à un affichage à partir de tables

  1. Ouvrez le diagramme de modèle de base de données qui contient l’affichage que vous souhaitez ajouter aux colonnes.

  2. Double-cliquez sur l’affichage, puis dans la fenêtrePropriétés de Base de Données, dans la liste deCatégories, cliquez sur lesColonnes.

  3. Effectuez l’une des opérations suivantes :

    • Cliquez sur le champnom physique d’une ligne vide et tapez le nom de la colonne. Répétez pour chaque colonne où vous souhaitez ajouter à l’affichage.

    • Cliquez surAjouter. Le nom par défaut pour la nouvelle colonne suit les conventions d’appellation spécifiées dans la boîte de dialogue dePréférences de Modélisation. Pour modifier le nom de la colonne, cliquez sur le nom de la colonne par défaut et tapez un nouveau nom. Répétez pour chaque colonne où vous souhaitez ajouter à l’affichage.

  4. Cliquez sur le nom de la colonne dont vous souhaitez définir les propriétés, puis cliquez surModifier.

  5. Dans la boîte de dialogueAfficher les Propriétés de Colonnesur l’ongletSource , cliquez surColonne connue dans une autre tableau ou afficher, puis cliquez sur Modifier.

  6. Dans la boîte de dialogue Choisir une Colonne, sélectionnez une colonne à partir de la liste des tableaux et des affichages dans votre diagramme de modèle de base de données, puis cliquez surOK.

  7. Lorsque les paramètres vous conviennent, cliquez sur OK.

  8. Répétez les étapes 4 à 7 pour chacune des colonnes ajoutées à l’étape 3.

Modifier les propriétés d’une colonne dans un affichage

  1. Ouvrez le diagramme de modèle de base de données.

  2. Double-cliquez sur l’affichage qui contient les colonnes que vous souhaitez modifier, puis cliquez surColonnes dans la liste desCatégoriesdans la fenêtrePropriétés de la Base de Données.

  3. Cliquez sur le nom de la colonne que vous souhaitez modifier, puis cliquez surModifier.

  4. Dans la boîte de dialogueAfficher les Propriétés de Colonne, cliquez sur l’onglet contenant les informations que vous souhaitez modifier, puis apportez vos modifications.

  5. Lorsque les paramètres vous conviennent, cliquez sur OK.

Modifier les propriétés d’un affichage

  1. Ouvrez le diagramme de modèle de base de données.

  2. Double-cliquez sur les propriétés de l’affichage que vous souhaitez modifier pour ouvrir la fenêtrePropriétés de la Base de Données.

  3. Dans la fenêtrePropriétés de Base de Données, cliquez sur la catégorie contenant les informations que vous souhaitez modifier, puis apportez vos modifications.

Le diagramme de modèle de base de données est automatiquement mis à jour.

Supprimer un affichage

  1. Ouvrez le diagramme de modèle de base de données.

  2. Sur la page de dessin, cliquez sur l’affichage que vous souhaitez supprimer, puis appuyez sur SUPPR.

  3. Dans la boîte de dialogueObjet Supprimé, effectuez l’une des opérations suivantes :

    • Cliquez surOui pour supprimer l’affichage de la page de dessin, ainsi que du modèle et la fenêtreTableaux et Affichages.

    • Cliquez surNon pour supprimer l’affichage de la page de dessin, mais pas à partir du modèle ou de la fenêtreTableaux et Affichages.

Remarque : Si vous ne voyez pas la boîte de dialogueSupprimer l’Objetlorsque vous supprimez un objet à partir du diagramme sur le menuBase de Données, pointez surOptions, cliquez surModélisation, puis, sur l’ongletDiagramme Logiquedans la boîte de dialoguePréférences de Modélisation de Base de DonnéessousLors de la suppression d’un objet à partir du diagramme, cliquez sur Demander à un Utilisateur Ce Qu’Il Faut Faire. Pour supprimer l’affichage du modèle, vous pouvez également cliquer sur l’affichage dans la fenêtreTables et vues, puis appuyer sur la touche SUPPR.

Réorganiser les affichages dans la fenêtre Code

  1. Si la fenêtreCode n’est pas déjà ouverte, dans le menuBase de Données, pointez surAffichagepuis cliquez surCodepour ouvrir la fenêtre.

    Remarque : Cette commande est disponible uniquement dans le modèleDiagramme de modèle de Base de Données.

  2. Faites glisser l’affichage que vous souhaitez réorganiser vers sa nouvelle position dans la fenêtre.

Définir une valeur d’espace nom pour une entité ou un affichage

  1. Ouvrez le diagramme de modèle de base de données.

  2. Double-cliquez sur l’entité ou l’affichage dont l’espace nom que vous souhaitez modifier pour ouvrir la fenêtrePropriétés de la Base de Données.

  3. Dans la listeCatégories, cliquez surDéfinition, puis tapez le texte distinctif dans la boîteNommer espace.

Le modèle de base de données est automatiquement mis à jour.

Créer du code pour les affichages

  1. Faites glisser une formeAffichage soit à partir du gabaritRelation EntitésoitRelationnel Objet.

  2. Double-cliquez sur la forme pour ouvrir la fenêtrePropriétés de la Base de Données.

  3. SousCatégories, cliquez surSQL.

  4. Entrez votre code dans la fenêtre SQL.

Vous ne trouvez pas les fonctionnalités de modèle de base de données?

Il se peut que votre édition de Visio n’inclue pas les fonctionnalités que vous recherchez. Pour savoir quelle édition de Visio vous utilisez, cliquez sur À propos de Microsoft Office Visio dans le menu Aide. Le nom de l’édition apparaît sur la ligne de texte supérieure de la boîte de dialogue.

Visio Standard n’inclut pas le modèle Diagramme de modèle de base de données.

Les éditions Visio Professionnel et Premium prennent en charge les fonctionnalités de rétroconception du modèle Diagramme de modèle de base de données (à savoir l’utilisation d’une base de données existante pour créer un modèle dans Visio), mais pas l'ingénierie en amont (à savoir l’utilisation d’un modèle de base de données Visio pour générer du code SQL).

Remarque : Vous trouverez la suite complète des fonctionnalités de modélisation de base de données, avec la rétroconception et l'ingénierie en amont, dans Visio pour Enterprise Architects. Visio pour Enterprise Architects est inclus dans l’abonnement PremiumMSDN, qui est disponible avec Visual Studio Professional et les éditions basées sur les rôles de Visual Studio Team System.

Si vous utilisez Visio Online Plan 2 et souhaitez en savoir plus sur la conception d’une base de données existante dans un modèle de base de données, consultez la rubrique Rétroconcevoir une base de données existante.

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×