Passer directement au contenu principal

Créer, exécuter, modifier ou supprimer une macro dans Office pour Mac

Remarque : Nous faisons de notre mieux pour vous fournir le contenu d’aide le plus récent aussi rapidement que possible dans votre langue. Cette page a été traduite automatiquement et peut donc contenir des erreurs grammaticales ou des imprécisions. Notre objectif est de faire en sorte que ce contenu vous soit utile. Pouvez-vous nous indiquer en bas de page si ces informations vous ont aidé ? Voici l’article en anglais à des fins de référence aisée.

Pour gagner du temps sur les tâches que vous effectuez souvent, vous pouvez enregistrer les étapes de ces tâches sous forme de macro. Ensuite, lorsque vous voulez effectuer l'une de ces tâches enregistrées, vous pouvez activer la macro pour effectuer ces étapes pour vous.

Word

Dans Word 2016 pour Mac, vous pouvez créer une macro avec un raccourci clavier, exécuter une macro et supprimer une macro dont vous n'avez plus besoin.

  1. Cliquez sur Affichage > Macros > Enregistrer une macro.

    Sous l’onglet Affichage, cliquez sur Macro, puis sur Enregistrer une macro pour commencer à créer une macro.
  2. Tapez un nom pour la macro, ou acceptez la valeur par défaut fournie par Word.

    Entrez un nom pour votre macro dans Nom de la macro, ou acceptez le nom générique proposé par Word.
  3. Pour utiliser cette macro dans tous les nouveaux documents que vous créez, vérifiez que l'option tous les documents (normal) est sélectionnée dans la liste enregistrer la macro dans .

  4. Cliquez sur clavier pour affecter une combinaison de touches à votre macro.

    Word affiche la boîte de dialogue personnaliser le clavier .

  5. Tapez une combinaison de touches dans la zone Appuyez sur un nouveau raccourci clavier .

    Word affiche la commande ou la macro éventuellement affectée à une combinaison de touches lorsque vous appuyez sur cette combinaison.

    Lorsque vous appuyez sur une combinaison de touches, Word affiche la commande ou l'action actuellement affectée à cette combinaison de touches, le cas échéant.

  6. Si la combinaison de touches que vous avez choisie est déjà affectée, supprimez-la de la zone Appuyez sur un nouveau raccourci clavier , puis choisissez une nouvelle combinaison de touches.

    Passez à l'étape suivante, une fois que vous avez trouvé une combinaison de touches non affectée.

    Word détecte la sélection d’une combinaison de touches non affectée à une commande ou une macro.
  7. Pour utiliser ce raccourci clavier dans tous les nouveaux documents, assurez-vous que normal. dotm, le modèle global, est sélectionné dans la liste enregistrer les modifications dans .

    Sélectionnez Normal.dotm pour qu’une macro soit disponible dans les nouveaux documents que vous créez.
  8. Cliquez sur Attribuer.

  9. Lorsque vous êtes prêt à enregistrer la macro, cliquez sur OK.

  10. Cliquez sur les commandes ou appuyez sur les touches de chaque étape de la tâche.

    Word enregistre vos clics et les séquences de touches, mais n'enregistre pas le texte que vous avez sélectionné à l'aide de la souris. Pour sélectionner du texte lors de l'enregistrement d'une macro, utilisez le clavier.

  11. Pour arrêter l’enregistrement, cliquez sur Affichage > Macros > Arrêter l’enregistrement.

    Cliquez sur Arrêter l’enregistrement dans le menu Macros pour arrêter l’enregistrement d’une macro.

Pour exécuter une macro, appuyez sur le raccourci clavier qui lui est affecté ou exécutez la macro à partir de la liste des macros.

  1. Cliquez sur Affichage > Macros > Afficher les macros.

    Cliquez sur Afficher les macros pour afficher et modifier les macros associées au document actif.
  2. Dans la liste sous nomde la macro, sélectionnez la macro que vous souhaitez exécuter.

  3. Cliquez sur Exécuter.

    Après avoir sélectionné une macro sous Nom de macro, cliquez sur Exécuter pour l’exécuter.

  1. Cliquez sur Affichage > Macros > Afficher les macros.

    Cliquez sur Afficher les macros pour afficher et modifier les macros associées au document actif.
  2. Vérifiez que l'emplacement spécifié par macros dans inclut l'emplacement de la macro que vous voulez supprimer.

    Sélectionnez l’emplacement des macros à afficher dans la liste des macros.

    La liste inclut le document ouvert dans la fenêtre active, ainsi que les commandes de modèle global et Word.

  3. Sous nomde la macro, sélectionnez la macro que vous voulez supprimer, puis cliquez sur le signe moins en dessous de la liste.

    Sélectionnez la macro à supprimer, puis cliquez sur le signe moins se trouvant sous la liste.
  4. Lorsque Word vous invite à confirmer que vous souhaitez supprimer la macro, cliquez sur Oui.

Excel

Dans Excel 2016 pour Mac, vous pouvez créer une macro avec un raccourci clavier, exécuter une macro et supprimer une macro dont vous n'avez plus besoin.

Lorsque vous enregistrez une macro, l’enregistreur de macro enregistre toutes les étapes requises pour effectuer les actions que votre macro doit réaliser. Ces étapes peuvent consister à taper du texte ou des chiffres, à cliquer sur des cellules ou des commandes du ruban ou dans des menus, à appliquer une mise en forme, à sélectionner des cellules, des lignes ou des colonnes, à faire glisser la souris pour sélectionner des cellules dans la feuille de calcul.

Remarque : Les commandes d'enregistrement, de création et de suppression de macros ainsi que d'autres fonctionnalités avancées sont également disponibles sous l'onglet développeur dans le ruban. Pour plus d'informations sur l'utilisation de l'onglet Développeur, voir utiliser l'onglet Développeur pour créer ou supprimer une macro dans Excel 2016 pour Mac.

  1. Sélectionnez Outils > macro > enregistrement nouveau.

    Sélectionnez Outils, puis macro, puis enregistrer une nouvelle macro

  2. Dans la zone Nom de la macro, entrez un nom pour la macro.

    Entrer un nom de macro, un emplacement et une touche de raccourci

  3. Pour créer un raccourci clavier pour la macro, tapez une lettre dans la zone option + cmd .

  4. Dans la liste déroulante, sélectionnez un emplacement pour la macro.

    Pour enregistrer la macro

    Cliquez sur

    Dans le document dans lequel vous créez une macro

    Ce classeur

    Dans tous les documents ouverts

    Nouveau classeur

    Pour qu’elle soit disponible chaque fois que vous utilisez Excel

    Classeur de macros personnelles

  5. Facultatif Ajoutez une description de la macro.

  6. Lorsque vous êtes prêt à enregistrer, cliquez sur OK.

  7. Cliquez sur les commandes ou appuyez sur les touches de chaque étape de la tâche.

  8. Pour arrêter l'enregistrement, sélectionnez Outils > macro > arrêter l'enregistrement. (Cette étape n'est pas enregistrée dans votre macro.)

    Sélectionner arrêter l'enregistrement

Pour exécuter une macro, appuyez sur le raccourci clavier qui lui est affecté ou exécutez la macro à partir de la boîte de dialogue Macros.

  1. Sous l’onglet Affichage, cliquez sur Afficher les macros.

  2. Dans le menu contextuel, cliquez sur macros, puis sélectionnez ce classeur.

  3. Sélectionnez la macro dans la liste, puis cliquez sur Exécuter.

    Boîte de dialogue Macro dans Excel pour Mac

  1. Sélectionnez Outils > macro > macros.

    Sélectionner une macro, puis sélectionner des macros

  2. Sélectionnez la macro à supprimer, puis appuyez sur le signe moins.

    Sélectionnez le nom de la macro, puis cliquez sur le signe moins.

  3. Un message de confirmation s'affiche. Cliquez sur Oui pour confirmer la suppression.

    Confirmer la suppression

Vous pouvez également supprimer une macro de l'onglet développeur .

  1. Sous l’onglet Développeur, cliquez sur Macros.

  2. Dans la liste, cliquez sur la macro que vous voulez supprimer, puis sur le bouton Supprimer.

    Sélectionnez une macro et cliquez sur le signe Moins pour la supprimer

Word

Pour automatiser une tâche répétitive, vous pouvez créer rapidement une macro dans Word. Vous pouvez également utiliser Visual Basic Editor dans Microsoft Visual Basic pour Applications pour écrire votre propre script macro ou copier toute ou partie d’une macro dans une nouvelle macro.

Lorsque vous enregistrez une macro, toutes les étapes nécessaires à l'exécution des actions que vous souhaitez que votre macro effectue sont enregistrées. Cependant, la navigation de retour à l’onglet pour arrêter l’enregistrement n’est pas incluse dans les étapes enregistrées.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Enregistrer.

    Onglet Développeur Word, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la zone Nom de la macro, entrez un nom pour la macro.

  3. Dans le menu contextuel Enregistrer la macro dans, effectuez l’une des opérations suivantes :

    Pour enregistrer la macro

    Cliquez sur

    Dans le document dans lequel vous créez la macro dans

    [nom du document] (document)

    Dans tous les documents ouverts

    Tous les documents (Normal)

  4. Cliquez sur OK, puis exécutez les actions que vous voulez enregistrer.

  5. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Arrêter.

Vous pouvez utiliser Visual Basic Editor inclus pour créer une macro.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Éditeur.

    Onglet Développeur Word, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Si vous devez insérer un module, dans Visual Basic Editor, dans le menu Insérer, cliquez sur Module.

  3. Dans la fenêtre de code du module, tapez ou collez le code de la macro que vous voulez utiliser.

  4. Lorsque vous avez terminé, dans le menu Word, cliquez sur Fermer et revenir à Microsoft Word.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Macros.

    Onglet Développeur Word, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la liste, cliquez sur la macro que vous voulez exécuter, puis sur Exécuter.

Pour modifier une macro, utilisez Visual Basic Editor.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Macros.

    Onglet Développeur Word, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la liste, cliquez sur la macro que vous voulez modifier, puis sur Modifier.

    Visual Basic Editor s’ouvre.

  3. Apportez les modifications souhaitées.

  4. Lorsque vous avez terminé, dans le menu Word, cliquez sur Fermer et revenir à Microsoft Word.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Macros.

    Onglet Développeur Word, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la liste, cliquez sur la macro que vous voulez copier, puis sur Modifier.

    Visual Basic Editor s’ouvre.

  3. Dans la fenêtre de code de Visual Basic Editor, sélectionnez les lignes de la macro à copier.

    Conseil : Pour copier la totalité de la macro, incluez les lignes Sub et End Sub dans la sélection.

  4. Dans le menu Edition, cliquez sur Copier.

  5. Dans la zone Procédure de la fenêtre de code, cliquez sur le module dans lequel vous voulez placer le code.

  6. Dans le menu Edition, cliquez sur Coller.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Macros.

    Onglet Développeur Word, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la liste, cliquez sur la macro que vous voulez supprimer, puis sur Supprimer.

PowerPoint

Pour automatiser une tâche répétitive, vous pouvez utiliser Visual Basic pour applications pour créer un macro dans PowerPoint.

Vous pouvez utiliser Visual Basic Editor inclus pour créer une macro.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Éditeur.

    Onglet Développeur PowerPoint, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Si vous devez insérer un module, dans Visual Basic Editor, dans le menu Insérer, cliquez sur Module.

  3. Dans la fenêtre de code du module, tapez ou collez le code de la macro que vous voulez utiliser.

  4. Lorsque vous avez terminé, dans le menu PowerPoint, cliquez sur Fermer et revenir à Microsoft PowerPoint.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Macros.

    Onglet Développeur PowerPoint, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la liste, cliquez sur la macro que vous voulez exécuter, puis sur Exécuter.

Pour modifier une macro, utilisez Visual Basic Editor.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Macros.

    Onglet Développeur PowerPoint, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la liste, cliquez sur la macro que vous voulez modifier, puis sur Modifier.

    Visual Basic Editor s’ouvre.

  3. Apportez les modifications souhaitées.

  4. Lorsque vous avez terminé, dans le menu PowerPoint, cliquez sur Fermer et revenir à Microsoft PowerPoint.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Macros.

    Onglet Développeur PowerPoint, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la liste, cliquez sur la macro que vous voulez copier, puis sur Modifier.

    Visual Basic Editor s’ouvre.

  3. Dans la fenêtre de code de Visual Basic Editor, sélectionnez les lignes de la macro à copier.

    Conseil : Pour copier la totalité de la macro, incluez les lignes Sub et End Sub dans la sélection.

  4. Dans le menu Edition, cliquez sur Copier.

  5. Dans la zone Procédure de la fenêtre de code, cliquez sur le module dans lequel vous voulez placer le code.

  6. Dans le menu Edition, cliquez sur Coller.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Macros.

    Onglet Développeur PowerPoint, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la liste, cliquez sur la macro que vous voulez supprimer, puis sur Supprimer.

Excel

Pour automatiser une tâche répétitive, vous pouvez créer rapidement une macro dans Excel. Vous pouvez également utiliser Visual Basic Editor dans Microsoft Visual Basic pour Applications pour écrire votre propre script macro ou copier toute ou partie d’une macro dans une nouvelle macro.

Toutes les étapes requises pour terminer les actions que vous souhaitez que votre macro exécute sont enregistrées. Cependant, la navigation de retour à l’onglet pour arrêter l’enregistrement n’est pas incluse dans les étapes enregistrées.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Enregistrer.

    Onglet Développeur Excel, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la zone Nom de la macro, entrez un nom pour la macro.

    Conseil : Pour créer un raccourci clavier pour la macro, tapez une lettre dans la zone Option+Cmd+.

  3. Dans le menu contextuel Enregistrer la macro dans, effectuez l’une des opérations suivantes :

    Pour enregistrer la macro

    Cliquez sur

    Dans le document dans lequel vous créez la macro dans

    Ce classeur

    Dans tous les documents ouverts

    Nouveau classeur

    Pour qu’elle soit disponible chaque fois que vous utilisez Excel

    Classeur de macros personnelles

    Le classeur de macros personnelles se situe dans utilisateurs/ nom_utilisateur/Library/Application Support/Microsoft/Office/Excel.

  4. Cliquez sur OK, puis exécutez les actions que vous voulez enregistrer.

  5. Sous l’onglet Développeur, sous Visual Basic, cliquez de nouveau sur Enregistrer.

Vous pouvez utiliser Visual Basic Editor inclus pour créer une macro.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Éditeur.

    Onglet Développeur Excel, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Si vous devez insérer un module, dans Visual Basic Editor, dans le menu Insérer, cliquez sur Module.

  3. Dans la fenêtre de code du module, tapez ou collez le code de la macro que vous voulez utiliser.

  4. Lorsque vous avez terminé, dans le menu Excel, cliquez sur Fermer et revenir à Microsoft Excel.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Macros.

    Onglet Développeur Excel, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la liste, cliquez sur la macro que vous voulez exécuter, puis sur Exécuter.

    Conseil : Pour exécuter une macro à l’aide des raccourcis clavier, appuyez sur Option + COMMANDE + la lettre que vous avez tapée lorsque vous avez créé le raccourci clavier.

Pour modifier une macro, utilisez Visual Basic Editor.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Macros.

    Onglet Développeur Excel, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la liste, cliquez sur la macro que vous voulez modifier, puis sur Modifier.

    Visual Basic Editor s’ouvre.

  3. Apportez les modifications souhaitées.

  4. Lorsque vous avez terminé, dans le menu Excel, cliquez sur Fermer et revenir à Microsoft Excel.

Après avoir terminé cette procédure, la macro s’exécutera chaque fois que vous ouvrez le classeur qui contient la macro.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Enregistrer.

    Onglet Développeur Excel, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la zone Nom de la macro, tapez Auto_ouvrir.

  3. Dans le menu contextuel Enregistrer la macro dans, effectuez l’une des opérations suivantes :

    Pour enregistrer la macro

    Cliquez sur

    Dans le document dans lequel vous créez la macro dans

    Ce classeur

    Dans tous les documents ouverts

    Nouveau classeur

    Pour qu’elle soit disponible chaque fois que vous utilisez Excel

    Classeur de macros personnelles

  4. Cliquez sur OK, puis exécutez les actions que vous voulez enregistrer.

  5. Sous l’onglet Développeur, sous Visual Basic, cliquez de nouveau sur Enregistrer.

  6. Dans le menu Fichier, cliquez sur Enregistrer sous.

  7. Dans le menu contextuel Format, cliquez sur Classeur Excel prenant en charge les macros (.xlsm), puis sur Enregistrer.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Macros.

    Onglet Développeur Excel, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la liste, cliquez sur la macro que vous voulez copier, puis sur Modifier.

    Visual Basic Editor s’ouvre.

  3. Dans la fenêtre de code de Visual Basic Editor, sélectionnez les lignes de la macro à copier.

    Conseil : Pour copier la totalité de la macro, incluez les lignes Sub et End Sub dans la sélection.

  4. Dans le menu Edition, cliquez sur Copier.

  5. Dans la zone Procédure de la fenêtre de code, cliquez sur le module dans lequel vous voulez placer le code.

  6. Dans le menu Edition, cliquez sur Coller.

  1. Sous l’onglet Développeur, sous Visual Basic, cliquez sur Macros.

    Onglet Développeur Excel, groupe Visual Basic

    Si l’onglet Développeur n’est pas disponible

    1. Sur la droite du ruban, cliquez sur Menu contextuel Action , puis sur Préférences du ruban.

    2. Sous Personnaliser, activez la case à cocher Développeur.

  2. Dans la liste, cliquez sur la macro que vous voulez supprimer, puis sur Supprimer.

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×