Office
Se connecter

Comment corriger les erreurs dans les formules dans Excel pour Mac

#VALEUR!, #NOM! ou un problème avec RECHERCHEV. Quelle que soit l’erreur que vous rencontriez, les informations suivantes peuvent vous aider à corriger votre erreur.

RECHERCHEV

Si vous rencontrez des erreurs ou des résultats inattendus avec la fonction RECHERCHEV, téléchargez l’Aide-mémoire : conseils de dépannage pour RECHERCHEV.

Erreur #VALEUR!

Ce problème est généralement dû au fait que votre formule contient à la fois des valeurs numériques et des valeurs de texte. Pour plus d’informations, voir Corriger une erreur #VALEUR!

Erreur #NOM?

Assurez-vous que les noms entrés sont corrects, placez le texte entre guillemets ou placez les noms des feuilles entre des guillemets simples ('). Pour connaître les autres causes et solutions, voir Erreur #NOM?

Erreur #NOMBRE!

Cette situation peut se produire si vous avez tapé des caractères supplémentaires dans une formule. Par exemple, ne tapez pas 1 000 € dans une formule, mais 1000. Pour connaître les autres causes et solutions, voir Corriger une erreur #NOMBRE!

Erreur #N/A

Si une formule ne parvient pas à trouver une valeur référencée, elle renvoie l’erreur #N/A. Pour plus d’informations, voir Corriger une erreur #N/A.

Erreur #REF!

Excel affiche cette erreur lorsqu’une formule contient une référence de cellule incorrecte. Pour plus d’informations, voir Corriger une erreur #REF!

Erreur #DIV/0!

Cette erreur se produit lorsqu’un nombre est divisé par (0), ou quand une formule fait référence à une cellule qui comporte la valeur 0 ou qui est vide. Pour plus d’informations, voir Erreur #DIV/0!

Faire référence à d’autres feuilles ou classeurs

Si vous faites référence au nom d’une autre feuille de calcul, tapez ! après le nom, puis tapez une cellule ou une plage. Si le nom de la feuille comporte des espaces, placez-le entre des guillemets simples ('). Par exemple : =SOMME('Rapport des ventes'!A1:A8).

Lorsque vous faites référence à un autre classeur externe :

  • Placez le nom du classeur entre crochets [ ].

  • Tapez le chemin d’accès complet au fichier.

  • Utilisez des guillemets simples (au début du chemin d’accès et après le nom de la feuille de calcul, avant le point d’exclamation).

    Exemple : =SOMME('/Utilisateurs/votre_nom/Bureau/[Opérations T2.xlsx]Ventes'!A1:A8)

Autres solutions rapides qui peuvent vous aider

  • Précédez chaque formule du signe égal (=). Exemple : =SOMME(A1:A8)

  • Utilisez le symbole * pour multiplier des nombres, et non la lettre X. Exemple : =A1*A8

  • Faites correspondre toutes les parenthèses ouvrantes et fermantes. Cet exemple inclut 2 paires : =SI(40>50;SOMME(G2:G5);0)

  • Tapez tous les arguments requis. Le Concepteur de formule peut vous aider à rédiger les formules. Commencez à taper une formule en saisissant un nom de fonction, puis appuyez sur Ctrl+A pour afficher le Concepteur de formule.

  • Utilisez des guillemets autour du texte dans les formules. Exemple : =SI(A2>B2;"Dépasse le budget";"OK")

  • Modifiez le type de données d’une cellule référencée. Pour ce faire, appuyez sur Cmd +1, puis sélectionnez Nombre.

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×