Utiliser un classeur partagé pour collaborer

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Vous pouvez créer un classeur partagé et le placer à un emplacement réseau, à partir duquel plusieurs personnes peuvent modifier son contenu simultanément. Par exemple, si chaque personne de votre groupe de travail gère plusieurs projets et doit connaître le statut des projets de chacune d’entre elles, le groupe peut utiliser un classeur partagé pour suivre le statut des projets et mettre à jour les informations.

En tant que propriétaire du classeur partagé, vous pouvez le gérer en contrôlant l’accès des utilisateurs au classeur partagé et en résolvant les modifications conflictuelles. Lorsque toutes les modifications ont été intégrées, vous pouvez arrêter de partager le classeur.

Partage de données Excel

Que voulez-vous faire ?

Partager un classeur

Modifier un classeur partagé

Déconnecter un utilisateur travaillant dans un classeur partagé

Résoudre les modifications contradictoires apportées dans un classeur partagé

Arrêter de partager un classeur

Partager un classeur

Pour partager un classeur, créez-en un ou ouvrez un classeur existant que vous définissez comme classeur modifiable par plusieurs utilisateurs.

Remarque    Toutes les fonctionnalités ne sont pas entièrement prises en charge dans un classeur partagé. Si vous souhaitez inclure les fonctionnalités ci-dessous, vous devez les ajouter avant d’enregistrer le classeur comme classeur partagé. Vous ne pouvez pas apporter de modifications à ces fonctionnalités après avoir partagé le classeur.

Fonctionnalités non prises en charge dans un classeur partagé   

Opérations impossibles :

Toutefois, cette fonctionnalité est disponible :

Créer un tableau Excel

Insérer ou supprimer des blocs de cellules

Vous pouvez insérer des lignes et des colonnes entières.

Supprimer des classeurs

Fusionner des cellules ou fractionner des cellules fusionnées

Trier ou filtrer par mise en forme

Vous pouvez effectuer un tri ou un filtrage par nombre, texte ou date, appliquer des filtres intégrés et effectuer un filtrage à l’aide de la zone Rechercher.

Ajouter ou modifier des formats conditionnels

Vous pouvez utiliser les formats conditionnels existants lorsque les valeurs de cellule changent.

Ajouter ou modifier une validation de données

Vous pouvez faire appel à la validation des données lorsque vous entrez de nouvelles valeurs.

Créer ou modifier des graphiques ou des rapports de graphique croisé dynamique

Vous pouvez afficher des graphiques et des rapports existants.

Insérer ou modifier des images ou d’autres objets

Vous pouvez afficher des images et des objets existants.

Insérer ou modifier des liens hypertexte

Vous pouvez utiliser des liens hypertexte existants.

Utiliser des outils de dessin

Vous pouvez afficher des dessins et des graphiques existants.

Affecter, modifier ou supprimer des mots de passe

Vous pouvez utiliser les mots de passe existants.

Protéger des feuilles de calcul ou un classeur, ou annuler leur protection

Vous pouvez utiliser la protection existante.

Créer, modifier ou afficher des scénarios

Grouper des données ou définir un plan de données

Vous pouvez utiliser des plans existants.

Insérer des sous-totaux automatiques

Vous pouvez afficher des sous-totaux existants.

Créer des tables de données

Vous pouvez afficher des tables de données existantes.

Créer ou modifier des rapports de tableau croisé dynamique

Vous pouvez afficher des rapports existants.

Créer ou appliquer des segments

Les segments existants d’un classeur sont visibles une fois le classeur partagé, mais ne peuvent pas être modifiés en segments autonomes, ni réappliqués à des données de tableau croisé dynamique ou fonctions de Cube. Tout filtrage appliqué au segment reste inchangé, que ce dernier soit autonome, ou utilisé par des données de tableau croisé dynamique ou des fonctions de Cube dans le classeur partagé.

Créer ou modifier des graphiques sparkline

Les graphiques sparkline existants dans un classeur sont affichés une fois que le classeur est partagé, et sont modifiés pour refléter les données mises à jour. Cependant, vous ne pouvez pas en créer de nouveaux, modifier leur source de données ni leurs propriétés.

Écrire, enregistrer, modifier, afficher ou affecter des macros

Vous pouvez exécuter des macros existantes qui n’accèdent pas aux fonctionnalités non disponibles. Vous pouvez également enregistrer des opérations de classeur partagé dans une macro stockée dans un autre classeur qui n’est pas partagé.

Ajouter ou modifier des feuilles de boîtes de dialogue Microsoft Excel 4

Modifier ou supprimer des formules matricielles

Excel calcule correctement les formules matricielles existantes.

Utiliser des données XML, notamment :

  • Importer, actualiser et exporter des données XML

  • Ajouter, renommer ou supprimer des mappes XML

  • Mapper des cellules vers des éléments XML

  • Utiliser le volet Office Source XML, la barre d’outils XML ou les commandes XML du menu Données

Utiliser un formulaire de données pour ajouter de nouvelles données

Vous pouvez utiliser un formulaire de données pour rechercher un enregistrement.

Partager le classeur

  1. Dans le groupe Modifications de l’onglet Révision, cliquez sur Partager le classeur.
    Groupe Modifications de l’onglet Révision

  2. Dans l’onglet Modification de la boîte de dialogue Partager le classeur, activez la case à cocher Permettre une modification multi-utilisateur. Ceci permet également de fusionner des classeurs.

  3. Dans l’onglet Avancé, sélectionnez les options à utiliser pour suivre et actualiser les modifications, puis cliquez sur OK.

  4. Effectuez l’une des opérations suivantes :

    • S’il s’agit d’un nouveau classeur, entrez un nom dans le champ Nom de fichier.

    • S’il s’agit d’un classeur existant, cliquez sur OK pour l’enregistrer.

  5. Sur un ordinateur exécutant Windows Vista   

    • Dans la barre d’adresse, sélectionnez un emplacement réseau accessible par tous les utilisateurs prévus, puis cliquez sur Enregistrer.

      Sur un ordinateur exécutant Microsoft Windows XP   

    • Dans la zone Enregistrer dans, sélectionnez un emplacement réseau accessible par tous les utilisateurs prévus, puis cliquez sur Enregistrer.

      Remarque    Vous devez utiliser un dossier réseau partagé, et non pas un serveur Web.

  6. Si le classeur contient des liaisons vers d’autres classeurs ou documents, vérifiez les liaisons et actualisez-les si elles sont rompues.

  7. Cliquez sur l’onglet Fichier, puis sur Enregistrer Image du bouton .

    Raccourci clavier  Appuyez sur Ctrl+S pour enregistrer le classeur.

Vérifier et actualiser les liaisons vers d’autres classeurs ou documents

  1. Dans l’onglet Données, dans le groupe Connexions, cliquez sur Modifier les liens.
    Groupe Connexions dans l’onglet Données
    Remarque    La commande Modifier les liens n’est pas disponible si votre fichier ne contient pas d’informations liées.

  2. Cliquez sur Vérifier l’état pour vérifier le statut de tous les liens de la liste.

    Remarque    Cela peut prendre quelques minutes si le nombre de liaisons est important ou si le classeur source pour les liaisons se trouve sur un réseau dont les performances sont lentes.

  3. Vérifiez l’état dans la colonne Statut, sélectionnez la liaison, puis réalisez l’action nécessaire.

Si le statut est :

Effectuez cette action :

OK

Aucune action n’est requise, la liaison fonctionne et est à jour.

Inconnu

Cliquez sur Vérifier l’état pour mettre à jour l’état de toutes les liaisons de la liste.

N/A

N/A. La liaison utilise la technologie OLE (Object Linking and Embedding) ou DDE (Dynamic Data Exchange). Excel ne peut pas vérifier l’état de ces types de liaisons.

Erreur : source introuvable

Cliquez sur Modifier la source, puis sélectionnez un autre classeur.

Erreur : feuille introuvable

Cliquez sur Modifier la source, puis sélectionnez une autre feuille de calcul. La source a peut-être été déplacée ou renommée.

Avertissement : valeurs non mises à jour

Cliquez sur Mettre à jour les valeurs. La liaison n’a pas été mise à jour lors de l’ouverture du classeur.

Avertissement : cliquez sur Ouvrir la source et calculez le classeur à l’aide de la touche F9

Définissez le classeur en mode de calcul automatique. Procédez comme suit :

  1. Cliquez sur l’onglet Fichier, puis cliquez sur Options.

  2. Dans la catégorie Formules, dans l’onglet Mode de calcul, cliquez sur Automatique.

Avertissement : certains noms ne peuvent pas être résolus tant que le classeur source est ouvert

Cliquez sur Ouvrir la source, revenez au classeur de destination et cliquez sur Vérifier l’état. Si le problème persiste, assurez-vous que le nom n’est pas mal orthographié ou manquant. Passez au classeur source, puis, dans l’onglet Formules, dans le groupe Cellules nommées, cliquez sur Gestionnaire de noms et recherchez le nom.

Avertissement : cliquez sur Ouvrir la source

N/A. La liaison ne peut pas être mise à jour tant que la source est ouverte.

La source est ouverte

N/A. Il est impossible de vérifier l’état de la liaison.

Valeurs mises à jour à partir de nom de fichier

Aucune action requise. Les valeurs ont été mises à jour.

Avertissement : Excel ne peut pas déterminer le statut de la liaison

Mettre à jour les valeurs. La source ne contient peut-être pas de feuille de calcul ou a été enregistrée dans un format non pris en charge. Cliquez sur Mettre à jour les valeurs.

Remarques    

  • Tous les utilisateurs ayant accès au partage réseau ont un accès total au classeur partagé sauf si vous verrouillez des cellules et que vous protégez la feuille de calcul pour restreindre l’accès. Pour aider à protéger un classeur partagé, dans l’onglet Révision, dans le groupe Modifications, cliquez sur Protéger et partager le classeur. Lorsque vous protégez un classeur partagé, vous pouvez définir un mot de passe que tous les utilisateurs doivent entrer pour ouvrir le classeur.

  • Les fonctionnalités Excel ne sont pas toutes prises en charge dans un classeur partagé. Pour plus d’informations, voir la section Fonctionnalités non prises en charge dans un classeur partagé ci-dessus.

Haut de la page

Modifier un classeur partagé

Après avoir ouvert un classeur partagé, vous pouvez entrer et modifier les données comme dans n’importe quel classeur standard.

Ouvrir le classeur partagé

  1. Cliquez sur l’onglet Fichier, puis sur Ouvrir.

  2. Sur un ordinateur exécutant Windows Vista   

    • Dans la barre d’adresse, recherchez le nouvel emplacement de stockage du classeur partagé, puis cliquez sur le classeur partagé.

      Sur un ordinateur exécutant Microsoft Windows XP   

    • Dans le champ Rechercher dans, recherchez le nouvel emplacement de stockage du classeur partagé, puis cliquez sur le classeur partagé.

  3. Cliquez sur Ouvrir.

    Conseil    Vous pouvez également accéder à l’emplacement réseau de stockage du classeur partagé et l’ouvrir.

  4. Cliquez sur l’onglet Fichier, puis cliquez sur Options.

  5. Dans la catégorie Général, sous Personnaliser votre copie d’Office, dans la zone Nom d’utilisateur, entrez le nom d’utilisateur à utiliser pour identifier votre travail dans le classeur partagé, puis cliquez sur OK.

Modifier le classeur

  1. Entrez et modifier les données dans les feuilles de calcul comme d’habitude.

    Remarque    Vous ne pourrez pas ajouter ou modifier les éléments suivants : cellules fusionnées, mises en forme conditionnelles, validation des données, graphiques, images, objets (notamment les objets dessins), liens hypertexte, scénarios, contours, sous-totaux, tables de données, rapports de tableau croisé dynamique, protection des classeurs et des feuilles de calcul, et macros.

    Les fonctionnalités Excel ne sont pas toutes prises en charge dans un classeur partagé. Pour plus d’informations, voir la section Fonctionnalités non prises en charge dans un classeur partagé ci-dessus.

  2. Définissez tous les paramètres de filtre et d’impression souhaités pour votre utilisation personnelle. Par défaut, les paramètres de chaque utilisateur sont enregistrés individuellement.

    Conseil    Vous pouvez également utiliser les paramètres de filtre ou d’impression créés par le propriétaire du classeur chaque fois que vous ouvrez le classeur.

    Pour utiliser les paramètres de filtre et d’impression initiaux   

    1. Dans le groupe Modifications de l’onglet Révision, cliquez sur Partager le classeur.
      Groupe Modifications de l’onglet Révision

    2. Dans l’onglet Avancé, sous Inclure dans une vue personnelle, désactivez la case à cocher Paramètres d’impression ou Paramètres du filtre, puis cliquez sur OK.

  3. Pour enregistrer les modifications que vous avez apportées au classeur et afficher celles que d’autres utilisateurs ont enregistrées depuis votre dernier enregistrement, cliquez sur Enregistrer Image du bouton dans la barre d’outils Accès rapide ou appuyez sur Ctrl+S.

    Si la boîte de dialogue Résolution des conflits s’affiche, résolvez les conflits.

    Conseil    Pour résoudre des conflits, voir Résoudre les modifications contradictoires apportées dans un classeur partagé plus loin dans cet article.

Remarques    

  • Vous pouvez voir les autres personnes qui ont ouvert le classeur dans l’onglet Modification de la boîte de dialogue Options de partage du fichier (onglet Révision, groupe Modifications, bouton Partager le classeur).

  • Vous pouvez choisir d’obtenir périodiquement des mises à jour automatiques des modifications des autres utilisateurs, avec ou sans enregistrement, sous l’option Mise à jour des modifications de l’onglet Avancé de la boîte de dialogue Options de partage du fichier.

Haut de la page

Déconnecter un utilisateur travaillant dans un classeur partagé

Si nécessaire, vous pouvez déconnecter des utilisateurs d’un classeur partagé.

Important    Avant de déconnecter des utilisateurs, assurez-vous qu’ils ont terminé leur travail dans le classeur. Si vous supprimez un utilisateur actif, le travail qui n’a pas été enregistré est perdu.

  1. Dans le groupe Modifications de l’onglet Révision, cliquez sur Partager le classeur.

  2. Dans l’onglet Modification, dans la liste Ce classeur est ouvert par les utilisateurs suivants, vérifiez les noms des utilisateurs.

    • Sélectionnez le nom de l’utilisateur à déconnecter, puis cliquez sur Supprimer.
      Remarque    Même si cette action déconnecte l’utilisateur du classeur partagé, cela n’empêche pas cet utilisateur de modifier le classeur partagé de nouveau.

  3. Pour supprimer les paramètres d’affichage personnels de l’utilisateur supprimé :

    1. Dans le groupe Affichages classeur de l’onglet Affichage, cliquez sur Affichages personnalisés.
      Image du ruban Excel

    2. Dans la liste Affichages, vous pouvez sélectionner les vues d’autres utilisateurs, puis cliquer sur Supprimer pour les supprimer.

Haut de la page

Résoudre les modifications contradictoires apportées dans un classeur partagé

Un conflit se produit lorsque deux utilisateurs qui modifient le même classeur partagé essaient d’enregistrer des modifications qui affectent la même cellule. Excel ne peut conserver qu’une seule modification dans cette cellule. Lorsque le second utilisateur enregistre le classeur, Excel affiche la boîte de dialogue Résolution des conflits.

  1. Dans la boîte de dialogue Résolution des conflits, lisez les informations relatives à chaque modification et les modifications contradictoires apportées par un autre utilisateur.

  2. Pour conserver votre modification ou la modification apportée par l’autre utilisateur et passer à la modification conflictuelle suivante, cliquez sur Accepter la mienne ou sur Accepter l’autre.
    Pour conserver toutes vos autres modifications ou toutes les modifications apportées par les autres utilisateurs, cliquez sur Accepter toutes les miennes ou sur Accepter toutes les autres.

  3. Pour que vos modifications remplacent toutes les autres modifications sans afficher de nouveau la boîte de dialogue Résolution des conflits :

    1. Dans le groupe Modifications de l’onglet Révision, cliquez sur Partager le classeur.

    2. Dans l’onglet Avancé, sous En cas de modifications contradictoires, cliquez sur Conserver celles déjà enregistrées, puis sur OK.

  4. Pour voir comment vous, ou d’autres utilisateurs, avez résolu les anciens conflits :

    1. Dans le groupe Modifications de l’onglet Révision, cliquez sur Suivi des modifications, puis sur Afficher les modifications.

    2. Dans la liste Quand, sélectionnez Tous.

    3. Désactivez les cases à cocher Par et Dans.

    4. Activez la case à cocher Lister les modifications dans une autre feuille, puis cliquez sur OK.

    5. Dans la feuille de calcul Historique, faites défiler vers la droite pour afficher les colonnes Type d’action et Perte d’action.

      Les modifications conflictuelles finalement conservées sont signalées par la valeur Gagnant dans la colonne Type d’action. Les numéros de ligne affichés dans la colonne Perte d’action identifient les lignes contenant des informations relatives à des modifications conflictuelles qui n’ont pas été conservées, y compris les données supprimées.

      Conseil    Pour enregistrer une copie du classeur avec toutes les modifications que vous lui avez apportées, cliquez sur Annuler dans la boîte de dialogue Résoudre les conflits. Enregistrez ensuite une nouvelle copie du fichier en tapant un nouveau nom.

Haut de la page

Arrêter de partager un classeur

Avant d’arrêter le partage du classeur, assurez-vous que tous les autres utilisateurs ont terminé leur travail. Les modifications qui n’ont pas été enregistrées seront perdues. Comme l’historique des modifications va lui aussi être supprimé, commencez par imprimer ou copier la feuille de calcul Historique dans un autre classeur.

Conserver une copie des informations de l’historique des modifications

  1. Dans le groupe Modifications de l’onglet Révision, cliquez sur Suivi des modifications, puis sur Afficher les modifications.

  2. Dans la liste Quand, sélectionnez Tous.

  3. Désactivez les cases à cocher Par et Dans.

  4. Activez la case à cocher Lister les modifications dans une autre feuille, puis cliquez sur OK.

  5. Effectuez l’une des opérations suivantes ou les deux :

    • Imprimez la feuille de calcul Historique.

    • Copiez l’historique dans un autre classeur en procédant comme suit :

      1. Sélectionnez les cellules à copier, puis cliquez sur Copier Image du bouton dans le groupe Presse-papiers de l’onglet Accueil.

      2. Utilisez un autre classeur où vous souhaitez positionner les données copiées, puis cliquez sur Coller Image du bouton dans le groupe Presse-papiers de l’onglet Accueil.

Remarque    Il est conseillé d’enregistrer ou d’imprimer la version actuelle du classeur, car ces données d’historique pourraient ne pas s’appliquer à des versions ultérieures du classeur. Par exemple, il est possible que les emplacements de cellules, notamment les numéros de lignes, enregistrés dans l’historique copié ne soient plus valables.

Annuler le partage d’un classeur

  1. Dans le classeur partagé, dans l’onglet Révision, dans le groupe Modifications, cliquez sur Partager le classeur.

  2. Dans l’onglet Modification, vérifiez que vous êtes le seul utilisateur répertorié dans la zone Le classeur est ouvert par les utilisateurs suivants.

    Conseil    Pour supprimer d’autres utilisateurs, voir Déconnecter un utilisateur travaillant dans un classeur partagé.

  3. Désactivez la case à cocher Permettre une modification multi-utilisateur. Ceci permet également de fusionner des classeurs..

    Remarque    Si cette case à cocher n’est pas disponible, vous devez d’abord désactiver la protection du classeur. Pour supprimer la protection d’un classeur partagé :

    1. Cliquez sur OK pour fermer la boîte de dialogue Options de partage du fichier.

    2. Dans le groupe Modifications de l’onglet Révision, cliquez sur Ôter la protection de partage.

    3. Entrez le mot de passe si vous y êtes invité, puis cliquez sur OK.

    4. Dans le groupe Modifications de l’onglet Révision, cliquez sur Partager le classeur.

    5. Dans l’onglet Modification, désactivez la case à cocher Permettre une modification multi-utilisateur. Ceci permet également de fusionner des classeurs.

    6. Lorsqu’un message vous avertit des conséquences de cette opération pour les autres utilisateurs, cliquez sur le bouton Oui.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Ces informations vous ont-elles été utiles ?

Très bien ! Vous avez d’autres commentaires ?

Comment pouvons-nous l’améliorer ?

Nous vous remercions pour vos commentaires.

×