Utiliser le publipostage pour créer et imprimer des lettres

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Lorsque vous avez le courrier en nombre à envoyer aux personnes figurant dans votre liste de diffusion, vous pouvez utiliser le publipostage pour créer un lot de lettres personnalisées. Chaque lettre est produit a même disposition, mise en forme, texte et des graphiques. Uniquement les sections spécifiques de la lettre varient et sont personnalisées.

Le processus de fusion et publipostage contient comme suit :

  1. Configurer le document principal. Le document principal contient le texte et les graphiques qui sont les mêmes pour chaque version du document fusionné, par exemple, l’adresse de l’expéditeur ou formule de salutation dans une lettre type.

  2. Connecter le document à une source de données. Une source de données est un fichier qui contient les informations à fusionner dans un document. Par exemple, les noms et adresses des destinataires d’une lettre.

  3. Affiner la liste des destinataires ou des éléments. Microsoft Office Word génère une copie du document principal pour chaque élément, ou enregistrement, dans votre fichier de données. Si votre fichier de données est une liste de diffusion, ces éléments sont probablement les destinataires de votre publipostage. Si vous souhaitez générer des copies que pour certains éléments dans votre fichier de données, vous pouvez choisir les éléments (enregistrements) à inclure.

  4. Ajouter des espaces réservés, appelés champs de fusion et publipostage, dans le document. Lorsque vous effectuez un publipostage, les champs de fusion sont renseignés avec les informations de votre fichier de données.

  5. Aperçu et terminer la fusion. Vous pouvez afficher un aperçu de chaque copie du document avant d’imprimer le lot complet.

Les commandes de l’onglet Publipostage vous permettent de lancer un processus de fusion et publipostage.

Important : Si vous prévoyez d’utiliser les champs personnalisés de contact avec la liste des Contacts dans Microsoft Office Outlook, vous devez commencer le processus de fusion et publipostage dans Outlook.

Remarque : 

Vous pouvez également effectuer un publipostage à l’aide du volet fusion et publipostage, qui explique comment procéder étape par étape à travers le processus. Pour utiliser le volet Office, dans le groupe Démarrer le publipostage sous l’onglet publipostage, cliquez sur Démarrer la fusion, puis cliquez sur Assistant Fusion et publipostage étape par étape.

Image du ruban Word

Étape 1 : Configurer le document principal

  1. Démarrez Word.

    Un document vide s’ouvre par défaut. Laissez-le ouvert. Si vous le fermez, vous n’aurez pas accès aux commandes de l’étape suivante.

  2. Dans le groupe Démarrer la fusion et le publipostage sous l’onglet Publipostage, cliquez sur Démarrer la fusion et le publipostage.

    Image du ruban Word

  3. Cliquez sur lettres.

Vous pouvez également utiliser le publipostage pour créer :

  • Un catalogue ou un répertoire    Le même type d’informations, telles que nom et une description, est affiché pour chaque élément, mais le nom et description de chaque élément est unique. Cliquez sur annuaire pour créer ce type de document.

  • Un ensemble d’enveloppes     L’adresse de retour est identique sur toutes les enveloppes, mais l’adresse de destination est unique sur chacun d’eux. Pour plus d’informations, voir créer et imprimer des enveloppes pour un publipostage massif.

  • Un ensemble d’étiquettes de publipostage    Chaque étiquette affiche le nom et l’adresse d’une personne, mais le nom et l’adresse sur chaque étiquette est unique. Pour plus d’informations, voir créer et imprimer des étiquettes pour un publipostage massif.

  • Un ensemble de messages électroniques     Le contenu de base est le même dans tous les messages, mais chaque message est envoyé à chaque destinataire et chaque message contient des informations spécifiques à ce destinataire, par exemple le nom du destinataire ou toute autre information. Pour plus d’informations, voir utiliser le publipostage pour envoyer des messages électroniques personnalisés à votre liste d’adresses de messagerie.

Remarque : 

Si vous avez besoin d’interrompre le publipostage, vous pouvez enregistrer le document principal et reprendre la fusion ultérieurement. Microsoft Office Word conserve les informations de source et le champ de données. Si vous utilisez le volet fusion et publipostage, Word renvoie là où vous étiez dans le volet Office lorsque vous reprenez la fusion.

  1. Lorsque vous êtes prêt à reprendre le processus de fusion et publipostage, ouvrez le document.

    Word affiche un message vous invitant à confirmer si vous souhaitez ouvrir le document, qui exécutée une commande SQL.

  2. Étant donné que ce document est connecté à une source de données, pour accéder aux données, cliquez sur Oui. Si vous avez ouvert un document sans remarquer qu’il était connecté à une source de données, vous pouvez cliquer sur Non pour éviter un accès aux données dans un but malveillant.

    Le texte du document s’affiche, ainsi que les champs que vous avez éventuellement insérés.

  3. Cliquez sur l’onglet Publipostage et reprenez votre travail.

Haut de la page

Étape 2 : Connecter le document à une source de données

Pour fusionner les informations dans votre document principal, vous devez vous connecter le document à une source de données ou un fichier de données. Si vous n’avez pas déjà un fichier de données, vous pouvez créer un au cours du processus de fusion et publipostage.

Important : Si vous utilisez une liste existante, assurez-vous qu’elle contient les informations que vous souhaitez utiliser, y compris toutes les colonnes et les lignes. Vous pouvez apporter des modifications au cours de la fusion, mais vous ne pouvez pas ouvrir votre source de données séparément lors de la fusion. Le processus de fusion est plus facile si votre source de données est prête avant de vous connecter à celle-ci.

Choisir un fichier de données

  1. Sous l’onglet publipostage, dans le groupe Démarrer la fusion, cliquez sur Sélection des destinataires.

    Image du ruban Word

  2. Effectuez l’une des actions suivantes :

    • Utiliser des Contacts Outlook    Si vous souhaitez utiliser votre liste de Contacts dans Outlook, cliquez sur Sélectionner dans les Contacts Outlook.

      Pour plus d’informations sur l’utilisation de la liste des Contacts, voir conseils pour travailler avec une liste de Contacts Outlook.

    • Utiliser un fichier de source de données existant    Si vous disposez d’une feuille de calcul Excel, une base de données Microsoft Office Access ou un autre type de fichier de données, cliquez sur Utiliser la liste existante et puis recherchez le fichier dans la boîte de dialogue Sélectionner la Source de données.

      Avec Excel, vous pouvez sélectionner des données de n’importe quelle feuille de calcul ou plage nommée à l’intérieur d’un classeur. Avec Access, vous pouvez sélectionner des données de n’importe quelle table ou requête définie dans la base de données.

      Pour obtenir des conseils sur la mise en forme les données dans votre feuille de calcul Excel pour le publipostage, voir conseils pour la mise en forme des données dans Excel.

      Pour les autres types de fichiers de données, sélectionnez le fichier dans la boîte de dialogue Sélectionner la source de données. Si le fichier n’est pas repris dans la liste, sélectionnez le type de fichier approprié ou sélectionnez Tous les fichiers dans la zone Type de fichiers. Dans un processus de fusion et publipostage, vous pouvez utiliser les types de fichiers de données suivants :

      • Fichiers provenant de programmes de base de données à un niveau, basé sur le fichier pour lequel vous avez installé un fournisseur OLE DB ou un pilote ODBC (un certain nombre de qui est inclus avec Microsoft Office).

      • Un fichier HTML qui comporte un tableau unique. La première ligne du tableau doit contenir des noms de colonnes et les autres lignes doivent contenir des données.

      • Carnets d’adresses électronique :

        • Carnet d’adresses Microsoft Outlook

        • Liste de contacts Microsoft Schedule + 7.0

        • Listes d’adresses similaires qui ont été créées avec un MAPI-système de messagerie compatible, tel que Microsoft Outlook.

      • Un document Microsoft Word. Le document doit comporter une seule table. La première ligne du tableau doit contenir des titres, et les autres lignes doivent contenir les enregistrements que vous souhaitez fusionner. Vous pouvez également utiliser un source d’en-tête comme source de données.

      • Tout fichier texte qui comporte des champs de données séparés (ou délimités) par tabulation caractères ou des virgules et des données des enregistrements séparés par des marques de paragraphe.

    • Créer un nouveau fichier de données dans Word    Si vous ne disposez pas encore d’un fichier de données, cliquez sur Entrer une nouvelle liste et puis utilisez le formulaire qui s’ouvre pour créer votre liste. La liste est enregistrée sous forme de fichier de base de données (.mdb) que vous pouvez réutiliser. Pour plus d’informations, voir à taper une nouvelle liste.

Si vous avez installé Microsoft Office System 2007 (au lieu de l’installation de Microsoft Word seul), vous pouvez également utiliser Microsoft Query pour créer un requête et récupérer les données souhaitées à partir d’un source de données externe.

Si vous êtes prêt à poursuivre, passez à l’étape suivante.

Si vous avez des questions sur l’utilisation d’une liste de Contacts Outlook, mise en forme des données dans Excel, ou à taper une nouvelle liste, accédez à conseils et procédures supplémentaires.

Étape 3 : Affiner la liste des destinataires ou des éléments

Lorsque vous vous connectez à un fichier de données, vous souhaiterez pas fusionner les informations provenant de tous les enregistrements de ce fichier de données dans votre document principal.

Si vous envisagez d’utiliser la liste entière, vous pouvez passer directement à l’étape suivante.

Pour affiner la liste des destinataires ou utiliser un sous-ensemble des éléments dans votre fichier de données, procédez comme suit :

  1. Sous l’onglet publipostage, dans le groupe Démarrer la fusion, cliquez sur Modifier la liste de destinataires.

    Image du ruban Word

  2. Dans la boîte de dialogue Fusion et publipostage  Destinataires, effectuez l’une des opérations suivantes :

    • Sélectionner des enregistrements individuels    Cette méthode est particulièrement utile si votre liste est courte. Activez les cases à cocher en regard des destinataires à inclure et désactivez les cases à cocher en regard des destinataires à exclure.

      Si vous savez que vous souhaitez inclure uniquement quelques enregistrements dans la fusion, vous pouvez désactivez la case à cocher dans la ligne d’en-tête, puis sélectionnez uniquement les enregistrements que vous voulez. De même, si vous souhaitez inclure la majeure partie de la liste, activez la case à cocher dans la ligne d’en-tête et désactivez les cases à cocher pour les enregistrements que vous ne souhaitez pas inclure.

    • Trier des enregistrements    Cliquez sur l’en-tête de colonne de l’élément que vous voulez trier. La liste est triée par ordre alphabétique croissant (de A à Z). Cliquez sur l’en-tête de colonne pour trier la liste par ordre alphabétique décroissant (de Z à A).

      Si vous voulez plus complexe le tri, cliquez sur Trier sous affiner la liste de destinataires et définissez vos préférences de tri sous l’onglet Trier les enregistrements de la boîte de dialogue filtrer et trier. Par exemple, vous pouvez utiliser ce type de tri si vous souhaitez que les adresses des destinataires par ordre alphabétique en fonction du nom au sein de chaque code postal et les codes postaux dans l’ordre numérique.

    • Filtrer les enregistrements    Ceci est utile si la liste contient les enregistrements que vous ne voulez pas voir ou inclure dans la fusion. Une fois que vous filtrez la liste, vous pouvez utiliser les cases à cocher pour inclure ou exclure des enregistrements.

      Pour filtrer des enregistrements, procédez comme suit :

      un.

      Sous Affiner la liste de destinataires, cliquez sur Filtrer.

      b.

      Sous l’onglet Filtrer les enregistrements de la boîte de dialogue filtrer et trier, choisissez le critère que vous souhaitez utiliser pour le filtre.

      Par exemple, pour générer des copies de votre document principal uniquement pour les adresses qui ont l’Australie pour le pays/région, cliquez sur pays ou région dans la liste champ, égal à dans la liste comparaison et Australiecomparer dans la liste à.

      c.

      Pour affiner davantage le filtre, cliquez sur et ou ou, puis spécifiez des critères supplémentaires.

      Par exemple, pour générer des copies de votre document principal uniquement pour les entreprises situées à Munich, filtrez les enregistrements dont le champ Ville contienne Munich et dont le champ Nom de la société n’est pas vide. Si vous utilisez ou plutôt que et dans ce filtre, votre publipostage inclut toutes les adresses à Munich ainsi que toutes les adresses incluant un nom de société, indépendamment de la ville.

    • Ajouter des destinataires    Pour ajouter des destinataires à la liste, procédez comme suit :

      un.

      Sous l’onglet publipostage, dans le groupe Démarrer la fusion, cliquez sur Modifier la liste de destinataires.

      b.

      Sous Source de données, cliquez sur le nom de votre fichier de données.

      c.

      Cliquez sur Modifier.

      d.

      Dans la boîte de dialogue Modifier la source de données, cliquez sur Nouvelle entrée, puis tapez les informations relatives à ce destinataire.

      Conseil : Selon le type de source de données que vous utilisez, certains processus ne peuvent pas être disponibles. Si possible, assurez-vous que votre fichier de données est terminée avant de vous connectez à votre document principal d’étiquette.

    • Rechercher un destinataire

      Vous pouvez rechercher un destinataire ou un groupe de destinataires qui partagent un attribut commun. Pour identifier les destinataires ou groupes de personnes qui partagent des attributs communs (par exemple, un nom, code postal ou mois de naissance), vous pouvez rechercher la liste.

      un.

      Dans la boîte de dialogue Fusion et publipostage destinataires, cliquez sur Rechercher un destinataire.

      b.

      Dans la boîte de dialogue Rechercher une entrée, entrez l’attribut que vous souhaitez rechercher dans la zone de texte Rechercher , spécifiez l’ou les champs que vous souhaitez rechercher, puis sur Suivant.

Si vous avez installé un logiciel de validation d’adresses, vous pouvez cliquer sur Valider les adresses dans la boîte de dialogue Fusion et publipostage  Destinataires pour valider les adresses de vos destinataires.

Haut de la page

Étape 4 : Ajouter des espaces réservés, appelés champs de fusion et publipostage, dans le document

Après avoir connecté votre document principal vers un fichier de données, vous êtes prêt à taper le texte du document et ajouter des espaces réservés indiquant où les informations uniques apparaîtront dans chaque copie du document.

Si vous êtes habitué à l’utilisation des champs de fusion et publipostage, lisez on.you pouvez passer directement à mappage et la fusion.

Si vous voulez en savoir plus sur le fonctionnement des champs de fusion, accédez à des conseils pour l’utilisation de champs de fusion.

Faire correspondre les champs de fusion à votre fichier de données

Pour vérifier si Word peut trouver, dans votre fichier de données, une colonne correspondant à chaque élément d’adresse ou de formule d’appel, vous devrez peut-être faire correspondre les champs de fusion de Word aux colonnes de votre fichier de données.

Pour faire correspondre les champs, cliquez sur Faire correspondre les champs dans le groupe Champs d’écriture et d’insertion de l’onglet Publipostage.

Dans Word, sous l’onglet publipostage, le groupe champs d’écriture et insérer

La boîte de dialogue Faire correspondre les champs s’affiche.

Boîte de dialogue Faire correspondre les champs

Les éléments d’une adresse et d’une formule d’appel s’affichent sur la gauche. Les en-têtes de colonnes du fichier de données s’affichent sur la droite.

Word recherche la colonne correspondant à chaque élément. Dans l’illustration, Word a procédé à une mise en correspondance automatique des données de la colonne Nom du fichier de données vers la colonne Nom. Mais Word ne pouvait faire correspondre les autres éléments. Dans ce fichier de données, par exemple, Word n’a pu faire correspondre les éléments Prénom.

Dans la liste sur la droite, vous pouvez sélectionner la colonne à partir de votre fichier de données qui correspond à l’élément sur la gauche. Dans l’illustration, la colonne nom correspond désormais à prénom. Il est évident que titre, Identificateur Unique et deuxième prénom ne correspondent pas. Votre document de fusion et publipostage n’a pas besoin d’utiliser tous les champs. Si vous ajoutez un champ qui ne contient-elle pas de données à partir de votre fichier de données, il apparaît dans le document fusionné comme un espace réservé vide, en règle générale, une ligne vide ou un champ masqué.

Boîte de dialogue Faire correspondre les champs

Taper le contenu et ajouter les espaces réservés ou les champs

  1. Dans le document de base, tapez le contenu devant apparaître dans chaque copie du document.

    Pour ajouter une image, telle qu’un logo, cliquez sur image dans le groupe Illustrations sous l’onglet accueil.

  2. Cliquez à l’endroit où vous souhaitez insérer le champ.

  3. Utilisez le groupe Champs d’écriture et d’insertion de l’onglet Publipostage.

    Dans Word, sous l’onglet publipostage, le groupe champs d’écriture et insérer

  4. Ajoutez un des éléments suivants :

    Bloc d’adresse avec nom, adresse et autres informations

    1. Cliquez sur Bloc d’adresse.

    2. Dans la boîte de dialogue Insertion du bloc d’adresse, sélectionnez les éléments d’adresse à inclure, ainsi que les formats souhaités, puis cliquez sur OK.

    3. Si la boîte de dialogue Correspondance des champs s’affiche, il se peut que Word n’ait pas pu trouver certaines des informations nécessaires au bloc d’adresse. Cliquez sur la flèche située en regard de (sans correspondance) et sélectionnez, dans votre source de données, le champ qui correspond au champ requis pour le processus de fusion et publipostage.

    Formule d’appel

    1. Cliquez sur Formule d’appel.

    2. Sélectionnez le format de formule d’appel, à savoir la salutation, le format de nom et la ponctuation qui suit.

    3. Sélectionnez le texte à afficher dans le cas où Microsoft Word ne parviendrait pas à interpréter le nom du destinataire. Cela peut se produire lorsque, par exemple, un destinataire répertorié dans la source de données ne comporte pas de prénom ou de nom de famille, mais seulement un nom de société.

    4. Cliquez sur OK.

    5. Si la boîte de dialogue Correspondance des champs s’affiche, il se peut que Microsoft Word n’ait pas pu trouver certaines des informations nécessaires à la formule d’appel. Cliquez sur la flèche située en regard de (sans correspondance) et sélectionnez, dans votre source de données, le champ qui correspond au champ requis pour le processus de fusion et publipostage.

    Champs individuels

    Vous pouvez insérer individuellement des informations émanant de certains champs comme le prénom, le numéro de téléphone ou le montant d’une aide d’une liste de donateurs. Pour ajouter rapidement un champ de votre fichier de données dans le document principal, cliquez sur la flèche en regard de Insérer un champ de fusion, puis cliquez sur le nom du champ.

    Pour accéder aux options supplémentaires d’insertion de champs individuels dans le document, procédez comme suit :

    1. Sous l’onglet Publipostage, dans le groupe Champs d’écriture et d’insertion, cliquez sur Insérer un champ de fusion.

    2. Dans la boîte de dialogue Insérer un champ de fusion, effectuez l’une des opérations suivantes :

      • Pour sélectionner des champs d’adresse qui correspondent automatiquement aux champs de votre source de données, même si les champs de la source de données ne possèdent pas le même nom que vos champs, cliquez sur Champs d’adresse.

      • Pour sélectionner des champs dont les données sont toujours directement extraites d’une colonne de votre fichier de données, cliquez sur Champs de base de données.

    3. Dans la zone Champs, cliquez sur le champ souhaité.

    4. Cliquez sur Insérer, puis sur Fermer.

    5. Si la boîte de dialogue Correspondance des champs s’affiche, il se peut que Microsoft Word n’ait pas pu trouver certaines des informations dont il a besoin pour insérer le champ. Cliquez sur la flèche en regard de (sans correspondance), puis sélectionnez le champ de votre source de données correspondant au champ requis pour la fusion.

      Remarque : Si, après avoir inséré un champ de la liste Champs de base de données, vous passez à une source de données qui ne possède pas de colonne du même nom, Word ne peut pas insérer les informations de ce champ dans le document fusionné.

Champs personnalisés provenant des contacts d’Outlook

Le seul moyen pour inclure les champs personnalisés de contact dans votre document principal est de commencer le publipostage depuis Outlook. Commencez par définir l’affichage de vos contacts avec les champs que vous souhaitez utiliser dans la fusion. Ensuite, démarrez le publipostage. Après avoir choisi les paramètres de votre choix, Word s’ouvrent automatiquement et vous pouvez terminer la fusion.

Définir l’affichage des contacts avec des champs personnalisés

  1. Dans les Contacts Outlook, dans le menu affichage, pointez sur Affichage actuel, puis cliquez sur Liste téléphonique.

  2. Cliquez avec le bouton droit sur un en-tête de colonne, puis cliquez sur Sélecteur de champs.

  3. Dans la liste déroulante située dans la partie supérieure de la boîte de dialogue Sélecteur de champs, sélectionnez Champs définis par l’utilisateur dans le dossier.

  4. Faites glisser le champ que vous souhaitez ajouter depuis la boîte de dialogue sur les en-têtes de colonnes. Une petite flèche rouge vous aide à positionner le champ à l’emplacement souhaité.
    Champ déplacé depuis le sélecteur de champs dans l’affichage du dossier Contacts

    Vous pouvez ajouter un nouveau champ dans la boîte de dialogue Sélecteur de champs en cliquant sur Nouveau dans la partie inférieure de la boîte de dialogue.

  5. Après avoir ajouté tous les champs personnalisés souhaités à l’affichage, fermez la boîte de dialogue Sélecteur de champs.

  6. Pour supprimer un champ que vous ne souhaitez pas inclure dans le processus de fusion et publipostage, cliquez sur le nom de champ dans l’en-tête de colonne de la section Liste téléphonique, et faites-le glisser en-dehors de l’en-tête de colonne.

  7. Pour exécuter le publipostage depuis Outlook, dans les Contacts Outlook, sélectionnez les contacts en appuyant sur MAJ et cliquez sur pour sélectionner une plage ou en appuyant sur CTRL et en cliquant pour sélectionner des personnes. Si vous voulez inclure tous les contacts actuellement visibles dans la vue, ne cliquez pas sur tous les contacts.

  8. Dans le menu Outils, cliquez sur Fusion et publipostage.

  9. Si vous avez sélectionné des contacts individuels à inclure dans la fusion, cliquez sur Seulement les contacts sélectionnés. Si vous souhaitez inclure tous les contacts actuellement visibles dans l’affichage, cliquez sur Tous les contacts dans l’affichage en cours.

  10. Si vous avez défini l’affichage de la liste téléphonique de manière à présenter exactement les champs à utiliser dans la fusion, cliquez sur Champs des contacts dans l’affichage en cours. Dans le cas contraire, cliquez sur Tous les champs Contact pour rendre tous les champs Contact disponibles dans le processus de fusion et publipostage.

  11. Si vous souhaitez générer un nouveau document de base pour la fusion, cliquez sur Nouveau document. Dans le cas contraire, cliquez sur Document existant, puis sur le bouton Parcourir pour rechercher le document à utiliser comme document de base.

  12. Si vous souhaitez enregistrer les contacts et les champs sélectionnés de manière à pouvoir les réutiliser, activez la case à cocher Fichier permanent, puis cliquez sur Parcourir pour enregistrer le fichier. Les données sont enregistrées dans un document Word sous forme de données dont les éléments sont séparés par des virgules.

  13. Sélectionnez les options de fusion souhaitées :

    • Publipostages      Préparer un lot de lettres pour un publipostage massif.

    • Étiquettes de publipostage     Configurer les étiquettes d’adresse pour un publipostage massif.

    • Enveloppes     Configurer des enveloppes pour un publipostage massif.

    • Catalogue     Créer un document unique qui contient la liste catalogue ou l’adresse.

    • Nouveau Document     Générer des documents fusionnés, que vous pouvez modifier individuellement dans Word.

    • Imprimante     Envoyer les documents fusionnés directement à l’imprimante par défaut.

    • Courrier électronique     Générer des documents fusionnés à utiliser comme messages électroniques. Lorsque vous êtes prêt à lancer la fusion dans Word, sous l’onglet publipostage, dans le groupe Terminer, cliquez sur Terminer et fusionner, puis cliquez sur Envoyer des Messages électroniques. La ligne d’objet est remplie avec le texte que vous avez tapés dans la boîte de dialogue Fusion des Contacts dans Outlook.

  14. Cliquez sur OK. Lorsque le document s’ouvre dans Word, sous l’onglet publipostage, dans le groupe d’écriture et d’insertion de champs , cliquez sur la flèche en regard de Insérer un champ de fusion, puis cliquez sur les champs que vous souhaitez ajouter le document.

  • Vous ne pouvez pas taper les caractères de champ de fusion (« « » ») manuellement ou utiliser la commande symbole dans le menu Insertion. Vous devez utiliser le publipostage.

  • Si les champs de fusion apparaissent entre accolades, tels que { MERGEFIELD Ville }, Microsoft Word affiche les codes de champ au lieu de résultats de champs. Cela n’affecte pas la fusion, mais si vous voulez afficher les résultats à la place, cliquez sur le code de champ, puis cliquez sur Basculer les Codes de champ dans le menu contextuel.

Mettre en forme les données fusionnées

Programmes de base de données et de feuille de calcul, tels que Microsoft Office Access et Microsoft Office Excel, stockent les informations que vous tapez dans les cellules en tant que données brutes. Mise en forme que vous appliquez dans Access ou Excel, tels que les polices et les couleurs, n’est pas stocké avec les données brutes. Lorsque vous fusionnez des informations à partir d’un fichier de données dans un document Word, vous fusionnez les données brutes sans la mise en forme appliquée.

  1. Sélectionnez le champ de publipostage. Assurez-vous de sélectionner également les guillemets (« ») qui entourent le champ.

  2. Sous l’onglet Accueil, dans le groupe Police, appliquez la mise en forme souhaitée. Ou, cliquez sur le lanceur de boîte de dialogue Police pour plus d’options.

Important : Pour réduire l’espace supplémentaire entre les lignes dans les adresses dans vos étiquettes, vous devez sélectionner les lignes, cliquez sur le Lanceur de boîte de dialogue paragraphe sous l’onglet accueil, puis tapez 0 dans l’avant et après les zones d’espacement. Si vous utilisez le champ de fusion bloc d’adresse, sélectionnez l’intégralité du champ, y compris les chevrons (« »), puis ajustez l’espacement.

Haut de la page

Étape 5 : Afficher un aperçu, terminer la fusion et imprimer les documents

Après avoir ajouté des champs dans votre document principal, vous êtes prêt à afficher un aperçu des résultats de la fusion. Lorsque vous êtes satisfait de l’aperçu, vous pouvez terminer la fusion.

Afficher un aperçu de la fusion

Vous pouvez afficher un aperçu de vos documents fusionnés et apporter des modifications avant de terminer la fusion.

Pour afficher un aperçu, effectuez l’une des opérations suivantes dans le groupe Aperçu des résultats de l’onglet Publipostage :

Image du ruban Word

  • Cliquez sur Aperçu des résultats.

  • Faites défiler chaque document fusionné en utilisant les boutons Enregistrement suivant et Enregistrement précédent dans le groupe Aperçu des résultats.

  • Affichez l’aperçu d’un document spécifique en cliquant sur Rechercher un destinataire.

Cliquez sur Modifier la liste de destinataires dans le groupe Démarrer la fusion et le publipostage, sous l’onglet Publipostage, pour accéder à la boîte de dialogue Fusion et publipostage  Destinataires, dans laquelle vous pouvez filtrer la liste ou supprimer des destinataires, si vous voyez le nom de destinataires que vous ne souhaitez pas inclure.

Image du ruban Word

Terminer la fusion

Vous pouvez imprimer les documents fusionnés ou les modifier individuellement. Vous pouvez imprimer ou modifier tout ou uniquement un sous-ensemble des documents.

Si vous voulez imprimer un sous-ensemble des documents, vous pouvez spécifier l’ensemble par une plage de numéros d’enregistrement. Si vous voulez imprimer des pages au lieu de spécifier les numéros d’enregistrement, suivez les instructions dans la section Modifier les copies individuelles du document .

Imprimer les documents fusionnés
  1. Sous l’onglet Publipostage, dans le groupe Terminer, cliquez sur Terminer et fusionner, puis cliquez sur Imprimer des documents.

    Image du ruban Word

  2. Choisissez si vous souhaitez imprimer l’ensemble de documents, uniquement la copie visible ou un sous-ensemble du jeu, que vous spécifiez par numéro d’enregistrement.

Modifier des copies individuelles du document
  1. Sous l’onglet Publipostage, dans le groupe Terminer, cliquez sur Terminer et fusionner, puis cliquez sur Modifier des documents individuels.

    Image du ruban Word

  2. Choisissez si vous souhaitez modifier l’ensemble de documents, uniquement la copie visible ou un sous-ensemble du jeu, que vous spécifiez par numéro d’enregistrement. Word enregistre les copies que vous souhaitez modifier dans un seul fichier, avec un saut de page entre chaque copie du document.

Une fois que vous avez terminé de modifier le nouveau fichier d’étiquettes, vous pouvez imprimer les étiquettes en cliquant sur le Bouton Microsoft Office Image du bouton Office puis sur Imprimer.

Enregistrez le document principal

N’oubliez pas que les documents fusionnés que vous enregistrez sont différents du document principal. Il est recommandé d’enregistrer le document principal lui-même si vous envisagez d’utiliser pour un autre le publipostage.

Lorsque vous enregistrez le document principal, vous enregistrez également sa connexion au fichier de données. La prochaine fois que vous ouvrez le document principal, vous êtes invité à choisir si vous souhaitez que les informations du fichier de données soient à nouveau fusionnées dans le document principal.

  • Si vous cliquez sur Oui, le document s’ouvre et affiche les informations provenant du premier enregistrement fusionné.

  • Si vous cliquez sur non, la connexion entre le document principal et le fichier de données est interrompue. Le document principal devient un document Word standard. Les champs sont remplacés par les informations provenant du premier enregistrement.

Haut de la page

Conseils et procédures supplémentaires

Pour plus d’informations sur l’utilisation d’une liste de contacts, mise en forme des données dans Excel, ou créez une nouvelle liste, sélectionnez parmi les options suivantes.

Conseils pour travailler avec une liste de Contacts Outlook

Conseils pour la mise en forme des données dans Excel

Conseils pour l’utilisation de champs de fusion

Taper une nouvelle liste

Conseils pour travailler avec une liste de Contacts Outlook

Se connecter à votre dossier Contacts Outlook est généralement un processus simple, mais vous pouvez parfois rencontrer un problème. Pour les solutions aux problèmes courants que vous pouvez rencontrer, sélectionnez un élément dans la liste déroulante.

Il se peut que vous deviez activer la propriété Afficher ce dossier sous forme de carnet d’adresses de messagerie dans Outlook, ou modifier votre profil d’utilisateur Outlook.

Pour activer l’afficher ce dossier sous forme d’une propriété de carnet d’adresses de messagerie

  1. Dans Microsoft Office Outlook, dans le menu Atteindre, cliquez sur Contacts.

  2. Cliquez sur le dossier Contacts contenant les informations que vous souhaitez utiliser pour le publipostage, puis cliquez sur Propriétés.
    Propriétés des contacts dans Outlook

  3. Sous l’onglet Carnet d’adresses Outlook, vérifiez si la case à cocher Afficher ce dossier sous forme de carnet d’adresses de messagerie est activée, puis cliquez sur OK.

Modifier votre profil utilisateur Outlook

Un profil utilisateur Outlook est un groupe de comptes et de carnets d’adresses électroniques. En règle générale, vous n’utilisez qu’un seul profil, mais si vous partagez votre ordinateur avec d’autres utilisateurs ou si vous utilisez plusieurs carnets d’adresses à des fins différentes, vous pouvez définir plusieurs profils. Si, lorsque vous démarrez le processus de fusion et publipostage, vous utilisez un profil qui n’inclut pas le dossier Contacts dont vous avez besoin, ce dossier ne sera pas disponible.

Pour basculer vers un autre profil utilisateur, redémarrez Outlook. Lorsque vous êtes invité à choisir un profil, choisissez celui qui inclut le dossier Contacts que vous souhaitez utiliser dans le processus de fusion et publipostage.

Si vous n’êtes pas invité à choisir un profil alors que vous en utilisez plusieurs, vous pouvez configurer Outlook de manière à afficher cette invite. Voici comment procéder :

  1. Fermez Outlook.

  2. Dans le panneau de configuration, basculez vers l’affichage classique, puis cliquez sur courrier.

  3. Cliquez sur Afficher les profils.

  4. Pour être invité à sélectionner un profil chaque fois que vous démarrez Outlook, cliquez sur Choisir le profil à utiliser, puis cliquez sur OK.


Retour aux conseils Outlook

Si vous tentez de vous connecter à votre dossier Contacts pendant un publipostage dans Word alors qu’Outlook n’est pas défini comme programme de messagerie par défaut dans Windows Internet Explorer, le message d’erreur suivant s’affiche :

« Soit il n’existe pas de client de messagerie par défaut, soit le client de messagerie actuel ne peut pas répondre à la demande de la messagerie. Exécutez Microsoft Office Outlook et définissez-le comme client de messagerie par défaut ».

Pour éviter ce message lors d’un processus de fusion et publipostage, procédez comme suit :

  1. Quitter Word.

  2. Dans le menu Outils d’Internet Explorer, cliquez sur Options Internet, puis cliquez sur l’onglet programmes.

  3. Sous courrier électronique, cliquez sur Microsoft Office Outlook, puis cliquez sur OK.

Redémarrez Word, ouvrez votre document de fusion et publipostage et accédez à votre dossier Outlook Contacts.

Retour aux conseils Outlook

Si vous lancez un processus de fusion et publipostage dans Word et tentez de vous connecter à un dossier Outlook Contacts sous Dossiers publics, le message d’erreur suivant s’affiche :

« Action impossible à exécuter, à cause d’un échec de boîte de dialogue ou de moteur de base de données. Veuillez réessayer ultérieurement.»

Si vous réessayez plus tard, vous obtenez le même message.

Pour utiliser un dossier Outlook Contacts provenant de Dossiers publics comme fichier de données pour votre publipostage, vous devez démarrer le processus à partir d’Outlook.

Retour aux conseils Outlook

Vous ne pouvez pas vous connecter à ce type de carnet d’adresses directement au cours d’une fusion. En revanche, exporter votre carnet d’adresses Outlook Express sous la forme d’un fichier texte .csv, puis connectez-vous à celui-ci dans ce formulaire.

Pour exporter votre carnet d’adresses Outlook Express

  1. Démarrez Microsoft Outlook Express.

  2. Dans le menu fichier, pointez sur Exporter, puis cliquez sur Carnet d’adresses.

  3. Dans la boîte de dialogue Outil d’exportation du carnet d’adresses, cliquez sur Fichier texte (valeurs séparées par des virgules), puis cliquez sur Exporter.

  4. Dans la zone Enregistrer le fichier exporté sous, tapez un nom de fichier pour votre fichier exporté, puis cliquez sur Parcourir.

  5. Dans la boîte de dialogue Enregistrer sous, dans la liste Enregistrer dans, sélectionnez l’endroit où vous voulez enregistrer le fichier, puis cliquez sur Enregistrer. Il est pratique d’enregistrer les fichiers de données dans le dossier Mes Sources de données dans votre dossier Mes Documents. Il s’agit de l’endroit où Word recherche d’abord dans les fichiers de données lorsque vous naviguez sur pour eux au cours d’une fusion.

  6. Cliquez sur suivant. Activez les cases à cocher en regard des champs que vous voulez exporter, puis cliquez sur Terminer.

    Remarque : Lorsque vous choisissez les champs à exporter, pensez aux publipostages ou les messages électroniques ou les étiquettes que vous souhaitez créer avec le publipostage. Par exemple, si vous incluez jamais surnoms ou sites Web personnels dans vos documents fusionnés, n’exporter ces champs.

  7. Lorsque vous recevez le message que l’exportation est terminée, cliquez sur OK.

  8. Pour fermer la boîte de dialogue Outil d’exportation du carnet d’adresses, cliquez sur Fermer, puis quittez Outlook Express.

Lorsque vous êtes dans Word pour réaliser votre fusion et publipostage et vous arrivez à l’étape où vous vous connectez à un fichier de données, cliquez sur l’option utiliser une liste existante et recherchez le fichier .csv que vous venez d’exporter. Avant que le fichier s’ouvre, vous devrez sélectionner le caractère de séparation pour séparer les colonnes d’une autre dans votre liste d’adresses. Cliquez sur une virgule, puis cliquez sur OK.


Retour aux conseils Outlook

Conseils pour la mise en forme de données dans Excel

Si votre fichier de données est une feuille de calcul Excel qui comprend des pourcentages, des valeurs monétaires ou des codes postaux, vous pouvez conserver la mise en forme numérique des données en utilisant l’échange dynamique de données ou DDE (Dynamic Data Exchange) pour vous connecter à la feuille de calcul Excel à partir de Word. Vous pouvez vous assurer, par exemple, que le code postal à cinq chiffres 07865, provenant de votre fichier de données, ne s’affiche pas sous la forme du nombre 7865 (sans le zéro d’en-tête).

Avant de vous connecter à la feuille de calcul, effectuez l’opération suivante dans Word :

  1. Cliquez sur le Bouton Microsoft Office Image du bouton Office , puis sur Options Word.

  2. Cliquez sur Options avancées.

  3. Dans la section Général, activez la case à cocher Confirmer la conversion du format de fichier lors de l’ouverture.

  4. Cliquez sur OK.

  5. Avec le document principal de publipostage ouvert, dans le groupe Démarrer la fusion et publipostage de l’onglet publipostage, cliquez sur Sélection des destinataires, puis cliquez sur Utiliser la liste existante.

  6. Recherchez la feuille de calcul Excel dans la boîte de dialogue Sélectionner la source de données, et double-cliquez dessus.

  7. Dans la boîte de dialogue Confirmer la Source de données, cliquez sur Feuilles de calcul MS Excel via un DDE (*.xls), puis cliquez sur OK.

    Si l’option Feuilles de calcul MS Excel via un DDE (*.xls) n’est pas visible, cochez la case Afficher tout.

  8. Dans la boîte de dialogue Microsoft Office Excel, sous Nom ou plage de cellules, sélectionnez la plage de cellules ou la feuille de calcul contenant les informations à fusionner, puis cliquez sur OK.

    Pour empêcher d’être averti chaque fois que vous ouvrez un fichier de données, vous pouvez désactiver l’option Confirmation des conversions lors de l’ouverture après que vous être connecté à la feuille de calcul.

Revenir à des conseils et des procédures supplémentaires

Conseils pour l’utilisation de champs de fusion

Les espaces réservés, tels que les adresses et les salutations sont appelés champs de fusion et publipostage. Les champs dans Word correspondent aux en-têtes de colonne dans le fichier de données que vous sélectionnez.

Fichier de données avec des colonnes (catégories) et des lignes (enregistrements)

1. Dans un fichier de données, les colonnes représentent les catégories d’informations. Les champs ajoutés au document de base sont des espaces réservés pour ces catégories.

2. Les lignes d’un fichier de données représentent les enregistrements d’informations. Lors d’un publipostage, Word génère une copie du document principal par enregistrement.

En plaçant un champ dans votre document de base, vous indiquez que vous souhaitez afficher une certaine catégorie d’informations, par exemple le nom ou l’adresse, à cet emplacement.

Champs insérés dans un document Word

Lorsque vous insérez un champ de fusion dans le document principal, le nom du champ apparaît toujours entre guillemets (« »). Ces chevrons n’apparaissent pas sur les documents fusionnés. Ils vous permettent simplement de distinguer les champs du document principal du texte proprement dit.

Que se passe-t-il lors de la fusion

Lors du processus de fusion, les informations contenues dans la première ligne du fichier de données remplacent les champs de votre document de base pour créer le premier document fusionné. Les informations contenues dans la seconde ligne du fichier de données remplacent les champs pour créer le second document fusionné, et ainsi de suite.

Fusionner les informations du fichier de données dans le document

Utilisation des champs : exemples

Vous pouvez ajouter un en-tête de colonne à partir de votre fichier de données au document principal en tant que champ. Cela vous donne une flexibilité lors de la création de lettres, des étiquettes, des messages électroniques et d’autres documents fusionnés. Par exemple :

  • Supposons que vous créez une lettre pour informer des entreprises locales qu’elles ont été choisies à inclure dans le guide annuel de ville. Si votre fichier de données comporte une colonne société avec le nom de chaque entreprise que vous voulez contacter, vous pouvez insérer le champ « Société » au lieu de taper le nom de chaque société.

  • Imaginons que vous envoyez trimestrielles messages électroniques à vos clients les avertissant de nouveaux produits et les offres spéciales. Pour personnaliser ces messages à vos meilleurs clients, vous pouvez ajouter une colonne PersonalNote à votre fichier de données dans laquelle vous pouvez taper commentaires tels que « Manquez Miller, ce nouvel accessoire correspond exactement à ce que vous avez été recherchez. ». En plaçant un champ « PersonalNote » dans le document principal, vous pouvez inclure ces notes en bas de certains messages.

  • Supposons que votre liste de diffusion est destinée aux abonnés à votre bulletin, et votre fichier de données inclut une colonne, appelée DateExpiration, pour enregistrer la date d’expiration de chaque abonnement. Si vous placez un champ « ExpireDate » dans le document principal d’étiquette avant d’exécuter le processus de fusion, abonnés chacune verront leur propre date d’expiration sur son étiquette de publipostage.

Vous pouvez combiner des champs en les séparant par des marques de ponctuation. Par exemple, pour créer une adresse, vous pouvez configurer les champs dans votre document principal à ceci :

« Prénom » « Nom »

« Adresse »

« Ville », « Pays » « Code postal »

Pour les éléments que vous utilisez fréquemment, tels que bloc d’adresse et les lignes de salutations, Word fournit des champs composites qui regroupent un certain nombre de champs solidaires. Par exemple :

  • Le champ bloc d’adresse est une combinaison de plusieurs champs, y compris le prénom, nom, adresse postale, ville et code postal.

    Éléments d'un champ Bloc d'adresse

  • Le champ formule d’appel peut inclure un ou plusieurs champs nom, selon votre formule de salutation choisie.

Vous pouvez personnaliser le contenu de chacun de ces champs. Par exemple, l’adresse, vous souhaiterez peut-être sélectionner un format de nom formel (M. Joshua Randall Duval) ; dans le message d’accueil, vous souhaiterez peut-être utiliser « À » au lieu de « Cher ».

Revenir à des conseils et des procédures supplémentaires

Taper une nouvelle liste

  1. Dans la boîte de dialogue Nouvelle liste d’adresses, tapez les informations relatives à la première adresse, ou enregistrement, que vous souhaitez inclure dans votre publipostage d’étiquette.

    Si vous souhaitez ajouter ou supprimer des colonnes, cliquez sur Personnaliser colonnes et apportez les modifications souhaitées.

  2. Une fois que vous avez tapé toutes les informations pour votre premier enregistrement, cliquez sur Nouvelle entrée et tapez les informations de l’enregistrement suivant. Continuez ainsi jusqu’à ce que vous ayez tapé les informations pour tous les enregistrements que vous souhaitez inclure.

  3. Lorsque votre nouvelle liste est finalisée, cliquez sur OK.

  4. Dans la boîte de dialogue Enregistrement de la liste d’adresses, tapez un nom pour la nouvelle liste, puis cliquez sur Enregistrer.

Revenir à des conseils et des procédures supplémentaires

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×