Utiliser l'éditeur HTML

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

La fonctionnalité Éditeur HTML de Microsoft Office SharePoint Server 2007 est un véritable éditeur de texte enrichi. Il permet d'appliquer des styles de mise en forme au texte ou aux éléments de contenu à l'aide d'un menu de la barre d'outils Éditeur HTML. Vous pouvez insérer des éléments tels que des tableaux et des listes, à l'aide des boutons de la barre d'outils. Vous pouvez faire des recherches de texte et même vérifier l'orthographe de votre contenu à l'aide de la barre d'outils. Toutes ces fonctionnalités sont également accessibles au clavier.

Que voulez-vous faire ?

Insérer et modifier du texte

Sélectionner du texte ou des éléments HTML et appliquer une mise en forme ou des styles personnalisés

Insérer et modifier des tableaux et d'autres éléments HTML

Utiliser le mode d'édition de source HTML

Insérer et modifier du texte

L’éditeur HTML peut apparaître incorporé ou qu’il peut s’afficher dans une boîte de dialogue Page Web dans une nouvelle fenêtre. Vous pouvez taper directement dans la fenêtre de l’éditeur HTML comme vous le feriez dans n’importe quel autre éditeur de texte. Votre texte s’affiche dans l’éditeur HTML la tel qu’il apparaît dans la page publiée. Certaines fonctionnalités ne sont pas disponibles lorsque l’éditeur HTML apparaît en ligne.

Copier et coller

Le copier-coller de texte fonctionne de la même manière que dans d'autres éditeurs de texte enrichi, à ceci près que l'éditeur HTML offre des options de collage.

Lorsque vous collez du texte à partir du Presse-papiers et que le texte est mis en forme, le menu Options de collage apparaît. Le menu Options de collage propose les options suivantes :

  • Supprimer des Styles intralignes      Cette option supprime tous les styles intralignes du texte collé. Mise en forme autrement dit ne faisant pas partie d’un style intraligne reste intacte.

  • Conserver uniquement le texte      Cette option supprime tous les styles intralignes et la mise en forme du texte collé.

  • Conserver les Styles intralignes      Cette option conserve tous les styles intralignes et la mise en forme intacte dans le texte collé.

Rechercher du texte dans votre contenu

Vous pouvez rechercher du texte dans votre contenu en cliquant sur le bouton Image du bouton Rechercher. Lorsque vous cliquez sur le bouton Rechercher, une zone Rechercher apparaît, ainsi qu’un bouton Rechercher suivant. Dans la zone Rechercher, tapez le texte que vous souhaitez rechercher, puis cliquez sur Suivant. Si le texte que vous avez tapée dans la zone Rechercher se trouve dans le contenu que vous modifiez, la première instance de ce texte apparaît en surbrillance dans le contenu. Cliquez sur Suivant pour rechercher l’occurrence suivante.

Remarque : Si vous déplacez le curseur en dehors de la zone Rechercher, la commande Rechercher démarre la recherche dans votre contenu à l’endroit où le curseur se trouve lorsque vous cliquez sur Rechercher suivant et ne reprend pas le contenu après avoir atteint la fin. Pour étendre la recherche à l’ensemble de votre contenu, laissez le curseur dans la zone Rechercher lorsque vous cliquez sur Suivant.

Remarque : La fonctionnalité de recherche n'est pas disponible lorsque l'éditeur HTML s'affiche en mode incorporé.

Vérifier l'orthographe de votre texte

Vous pouvez vérifier votre texte fautes d’orthographe en cliquant sur le bouton Vérifier l’orthographe de la barre d’outils image du bouton . Lorsque vous cliquez sur le bouton Vérifier l’orthographe, une nouvelle fenêtre s’ouvre et affiche les fautes d’orthographe possibles, ainsi que des suggestions pour les corriger.

Raccourci clavier pour vérifier l’orthographe, appuyez sur F7.

Remarque : La fonctionnalité de vérification de l'orthographe n'est pas disponible lorsque l'éditeur HTML s'affiche en mode incorporé.

Haut de la page

Sélectionner du texte ou des éléments HTML et appliquer une mise en forme ou des styles personnalisés

Pour changer l'apparence du texte dans votre contenu de page, vous disposez de différentes mises en forme et de styles.

Les styles sont des ensembles de mise en forme des options que vous pouvez appliquer comme s’il s’agissait d’une option de mise en forme prédéfinis. Par exemple, vous pouvez avoir un style de titre de l’Article prédéfini qui spécifie la police en gras, 14 points, à l’aide de la famille de polices Arial, avec une couleur de police marron. Lorsque vous appliquez le style de titre de l’Article à une sélection, chacune des options de mise en forme individuelles du style est appliqué à la sélection.

Vous pouvez sélectionner le contenu de deux manières : vous pouvez le sélectionner manuellement ou sélectionner les éléments HTML et leur contenu.

Haut de la page

Que voulez-vous faire ?

Utiliser la souris ou le clavier pour sélectionner le texte

Utilisez le menu Sélection pour sélectionner des éléments HTML

Appliquer des styles à l'aide du menu Styles

Appliquer une mise en forme à l'aide des boutons de barre d'outils

Utiliser la souris ou le clavier pour sélectionner le texte

Vous pouvez sélectionner un bloc de texte à l'aide de la souris ou du clavier.

Pour sélectionner un bloc de texte à l'aide de la souris, procédez comme suit :

  • Faites glisser le pointeur de souris pour sélectionner le texte souhaité.

  • Double-cliquez sur le texte pour sélectionner un mot ou triple-cliquez sur le texte pour sélectionner un paragraphe, un élément de liste ou une cellule de tableau.

Pour sélectionner un bloc de texte à l’aide du clavier, maintenez la touche MAJ ENFONCÉE et appuyez sur la touche flèche gauche ou droite pour étendre votre sélection d’un caractère à la fois. Ou maintenez la touche MAJ ENFONCÉE et appuyez sur la touche flèche haut ou vers le bas pour ajuster votre sélection d’une ligne à la fois. Vous pouvez également maintenez la touche CTRL et MAJ enfoncées pendant que vous appuyez sur la touche flèche droite ou flèche gauche pour sélectionner un mot à la fois.

Haut de la Section

Utilisez le menu Sélection pour sélectionner des éléments HTML

Pour sélectionner tout le texte contenu dans un élément HTML, utilisez le menu Sélection dans la barre d'outils.

Le menu Sélectionner étant contextuel, ses options dépendent de l’élément qui se trouve le curseur. Par exemple, si vous cliquez sur le menu sélection alors que le curseur se trouve sur un élément de liste, le menu Sélectionnez affiche les options suivantes :

  • Sélectionner le contenu mis en forme (uniquement le texte dans l'élément en cours).

  • Sélectionner le bloc de mise en forme (le texte et l'élément DIV qui contient le texte).

  • Sélectionner l'élément de liste (l'élément de liste et le bloc de mise en forme contenu dans l'élément).

  • Sélectionner la liste (tous les éléments de liste de la liste active, y compris leur texte et blocs de mise en forme).

  • Sélectionner tout le contenu (tout ce qui est contenu dans la fenêtre d'éditeur HTML en cours).

  • Avec le contenu de la page ouvert dans l'éditeur HTML, positionnez le curseur dans le texte de l'élément HTML que vous voulez sélectionner, puis cliquez sur Sélection dans la barre d'outils.

  • Cliquez sur l’élément de menu Sélectionner qui correspond le mieux à l’étendue de la sélection de votre choix. Par exemple, si le curseur se trouve dans le texte d’un élément de liste à puces et que vous voulez sélectionner la liste entière, cliquez sur Liste à puces.

Utilisez le menu sélection pour vous assurer que vous êtes mise en forme ou des styles à des éléments HTML spécifiques et pas seulement pour le texte que vous voyez mis en surbrillance dans la fenêtre de l’éditeur. Cela permet de conserver la cohérence de vos styles et mise en forme.

Haut de la Section

Appliquer des styles à l'aide du menu Styles

Que vous sélectionniez le texte à l'aide de la souris et du clavier ou que vous sélectionniez les éléments à l'aide du menu Sélection, vous pouvez utiliser le menu Styles pour appliquer les styles définis pour votre site. Plusieurs styles de ce type sont installés comme faisant partie de Office SharePoint Server 2007 ; votre administrateur de site ou un concepteur de mise en page peut définir des styles personnalisés auxquels vous pouvez accéder par le menu Styles.

Le menu Styles est contextuel. Les styles proposés varient en fonction de la sélection en cours.

Haut de section

Appliquer une mise en forme à l'aide des boutons de barre d'outils

Vous pouvez utiliser les boutons de barre d’outils pour appliquer une mise en forme à une sélection. Ces commandes sont accessibles à l’aide de la souris ou à l’aide de raccourcis clavier.

Lorsque vous appliquez une mise en forme à une sélection, celle-ci s'ajoute aux mises en forme déjà appliqués à la sélection, sauf incompatibilité entre les mises en forme. Si tel est le cas, si les mises en formes spécifient des couleurs de police différentes par exemple, la deuxième mise en forme est appliquée à la sélection.

Haut de la Section

Haut de la page

Insérer et modifier des tableaux et d'autres éléments HTML

Vous pouvez utiliser les boutons de la barre d'outils pour insérer des tableaux, des listes, des liens hypertexte, des images et du contenu réutilisable.

Contenu réutilisable se compose de blocs de texte et des éléments HTML qui peuvent être insérées dans le contenu de la page. Vous ne pouvez pas modifier le contenu ou la structure d’un contenu réutilisable à l’aide de l’éditeur HTML. Vous pouvez utiliser l’éditeur HTML pour appliquer des styles et mise en forme à un contenu réutilisable.

Haut de la page

Que voulez-vous faire ?

Insérer et modifier un tableau

Insérer une liste

Insérer un lien hypertexte

Insérer une image

Insérer un contenu réutilisable

Insérer et modifier un tableau

Vous pouvez insérer un tableau en cliquant sur le bouton Insérer un tableau Image du bouton barre d’outils. Lorsque vous cliquez sur Insérer un tableau, une nouvelle fenêtre s’ouvre dans laquelle vous pouvez choisir les propriétés du tableau suivant :

  • Propriétés Taille :

    • Lignes     Utilisez cette propriété pour choisir le nombre de lignes.

    • Colonnes      Utilisez cette propriété pour choisir le nombre de colonnes.

    • Spécifier les dimensions      Activez cette case à cocher afin de modifier la largeur et la hauteur de la table dans les zones largeur et hauteur. Désactivez cette case à cocher si vous souhaitez que les dimensions du tableau devant être gérés par le serveur.

    • Largeur et hauteur    si vous avez sélectionné la case à cocher spécifier les dimensions, vous pouvez choisir les propriétés largeur et hauteur pour contrôler les dimensions du tableau. Tapez un nombre dans la zone largeur ou la hauteur, puis cliquez sur la flèche pour sélectionner les pixels ou pourcentage. Par exemple, pour indiquer que la table doit être moitié moins large que la page, tapez 50 dans la zone largeur, puis cliquez sur pourcentage dans la liste.

  • Propriétés Format :

    • Utiliser un format de tableau prédéfini      Activez cette case à cocher pour choisir un format de tableau dans la liste déroulante. Office SharePoint Server 2007 propose plusieurs formats de tableau prédéfinis, mais votre administrateur de site peut créer des formats personnalisés et les ajouter à la liste.

      Lorsque vous choisissez un format de tableau dans la liste, un aperçu de ce format est affiché dans la zone Aperçu .

      Désactivez la case à cocher Utiliser un Format de tableau prédéfini pour désactiver les options dans la section Format. Aucun format est appliqué à la table.

    • Appliquer des formats spéciaux aux      Chaque format de tableau prédéfini peut contenir la mise en forme s’applique à la ligne d’en-tête, la dernière ligne, la première colonne et la dernière colonne. Utilisez que ces quatre ligne et options de colonne pour spécifier si la mise en forme spécifique pour cette ligne ou colonne est appliqué. Par exemple, pour indiquer que la ligne d’en-tête n’est pas mis en forme en tant que spécifié par le format de tableau prédéfini, désactivez la case à cocher Ligne d’en-tête.

      Remarque : Ces options sont disponibles uniquement lorsque la case à cocher Utiliser un format de tableau prédéfini est activée.

Vous pouvez également modifier une table pour modifier sa taille, la mise en forme et autres propriétés. La meilleure façon de modifier une table est en utilisant le Menu de cellule. Pour ouvrir le Menu de cellule, cliquez sur la flèche située à droite de la cellule du tableau que vous modifiez.

Le Menu de cellule contient les commandes suivantes :

  • Insérer une ligne au-dessus      Cette commande insère une ligne directement au-dessus de la cellule que vous modifiez.

  • Insérer une ligne ci-dessous      Cette commande insère une ligne directement au-dessous de la cellule que vous modifiez.

  • Insérer une colonne à gauche      Cette commande insère une colonne directement à gauche de la cellule que vous modifiez.

  • Insérer une colonne à droite      Cette commande insère une colonne à droite de la cellule que vous modifiez.

  • Supprimer la ligne      Cette commande supprime la ligne qui contient la cellule que vous modifiez.

  • Supprimer une colonne      Cette commande supprime la colonne qui contient la cellule que vous modifiez.

  • Fusionner les cellules      Cette commande fusionne la cellule que vous modifiez avec la cellule à sa droite ou, dans les langues s’écrivant de droite à gauche, la cellule située à sa gauche.

  • Fractionner la cellule      Cette commande fractionne la cellule que vous modifiez et place le curseur dans la cellule la plus à gauche qui résulte.

  • Hauteur et largeur      Cette commande ouvre une boîte de dialogue qui permet de modifier la largeur des colonnes et la hauteur de ligne de la ligne et la colonne qui contiennent la cellule que vous modifiez.

  • Modification d’une Table      Cette commande ouvre une boîte de dialogue qui vous permet de modifier les propriétés de la table qui contient la cellule que vous modifiez.

Vous pouvez également effectuer toutes les actions de Menu d’une cellule en utilisant les boutons de barre d’outils.

Haut de section

Insérer une liste

Vous pouvez insérer une liste en cliquant sur la Liste numérotée Image du bouton ou un bouton de barre d’outils Liste à puces Image du bouton .

Raccourci clavier pour insérer une liste numérotée, appuyez sur CTRL + MAJ + E. Pour insérer une liste à puces, appuyez sur CTRL + MAJ + L.

Haut de section

Insérer un lien hypertexte

Vous pouvez insérer un lien hypertexte en cliquant sur le bouton Insérer un lien hypertexte image du bouton barre d’outils.

Raccourci clavier pour insérer un lien hypertexte, appuyez sur CTRL + K.

Lorsque vous insérez un lien hypertexte, la boîte de dialogue Modifier les propriétés du lien hypertexte s’ouvre.

  • Dans la zone URL sélectionnée, vous pouvez taper une URL ou cliquer sur le bouton Parcourir pour naviguer jusqu'à un élément ou un document de votre site.

  • Activez la case à cocher Ouvrir le lien dans une nouvelle fenêtre pour ouvrir le lien hypertexte dans une nouvelle fenêtre. Si cette case à cocher est désactivée, le lien hypertexte s’ouvre dans la même fenêtre.

  • Activez la case à cocher Afficher un lien avec icône pour afficher une icône devant le texte du lien hypertexte. Ceci est accompli en ajoutant une balise d’image (< IMG >) au début du lien. Par défaut, l’icône qui s’affiche reflète le type de document que le lien hypertexte pointe vers, mais vous pouvez modifier ultérieurement l’image qui s’affiche en modifiant l’attribut source de la balise d’image (< IMG src = >). Si la case à cocher Afficher un lien avec icône est désactivée, le lien hypertexte est affiché comme texte du lien hypertexte.

  • Dans la zone info-bulle, vous pouvez taper du texte qui s’affiche lorsque le pointeur est placé sur le lien hypertexte. Ce texte est enregistré en tant que l’attribut title de balise d’ancrage du lien hypertexte (< un titre = >).

  • Dans la section signet, dans la zone nom, vous pouvez taper un nom pour le lien hypertexte. Ce nom est enregistré en tant que l’attribut ID de balise d’ancrage du lien hypertexte (< un id = >). Utilisez cette option pour créer un signet dans la page que vous pouvez lier à d’autres pages ou à partir d’un autre emplacement sur la même page.

Vous pouvez modifier un lien hypertexte existant à l’aide des mêmes boutons de barre d’outils ou en appuyant sur CTRL + K lorsque le lien hypertexte que vous voulez modifier est sélectionné.

Supprimer un lien hypertexte

Pour supprimer un lien hypertexte, procédez comme suit :

  1. Sélectionnez le lien que vous souhaitez supprimer à l'aide du menu Sélection.

  2. Procédez comme suit :

    • Appuyez sur SUPPR ou sur RETOUR ARRIÈRE.

    • Cliquez sur le bouton de barre d’outils image du bouton Supprimer le lien hypertexte.

Haut de section

Insérer une image

Vous pouvez insérer une image en cliquant sur le bouton Insérer une Image image du bouton barre d’outils.

Raccourci clavier pour insérer une image, appuyez sur CTRL + MAJ + G.

Lorsque vous cliquez sur le bouton Insérer une image ou appuyez sur CTRL+MAJ+G, la boîte de dialogue Modifier les propriétés de l'image s'ouvre.

  • Cliquez sur le bouton Parcourir pour parcourir les images disponibles. Lorsque vous cliquez sur Parcourir, la boîte de dialogue Sélectionner une Image de la Page Web s’ouvre et affiche les images qui sont stockées dans la bibliothèque d’Images de publication du site qui contient le contenu de la page que vous modifiez. Cliquez sur une image, puis cliquez sur OK pour insérer cette image.

  • Vous pouvez taper du texte de remplacement pour l’image dans la zone de Texte de remplacement. Texte de remplacement est lu par les lecteurs d’écran au lieu d’afficher l’image et s’affiche dans le navigateur si l’image ne peut pas être affichée par un navigateur Web.

  • Sélectionnez les options de la section Disposition pour spécifier l'alignement, l'épaisseur de bordure et l'espacement de l'image.

  • Sélectionner des options dans la section taille pour spécifier la taille de l’image. Vous pouvez spécifier que l’image s’affichera à sa taille par défaut, ou vous pouvez choisir la taille d’affichage en pixels. Si vous spécifiez la taille d’affichage, vous pouvez choisir la hauteur et la largeur de l’image ou choisir de conserver ses proportions (conserver le rapport entre hauteur et largeur).

  • Lorsque vous avez terminé de modifier les propriétés de l'image, cliquez sur OK.

Vous pouvez modifier une image existante à l’aide de la même barre d’outils ou en appuyant sur CTRL + MAJ + G lorsque l’image que vous voulez modifier est sélectionnée.

Haut de section

Insérer un contenu réutilisable

Vous pouvez insérer un contenu réutilisable en cliquant sur le bouton Insérer un contenu réutilisable image du bouton barre d’outils.

Après avoir inséré un contenu réutilisable, vous pouvez modifier sa position sur la page et sa taille et appliquer des styles et l’option de mise en forme.

Pour changer la position ou la taille du contenu réutilisable, cliquez sur le contenu et utilisez son cadre pour ajuster sa position ou sa taille.

Pour appliquer des styles ou des options de mise en forme, cliquez sur le contenu réutilisable, cliquez sur le menu Sélectionnez, puis cliquez sur Liste à puces. Vous pouvez appliquer des styles à l’aide du menu Styles et appliquer des options de mise en forme à l’aide de la barre d’outils boutons ou des raccourcis clavier.

Pour plus d’informations sur le contenu réutilisable, voir l’article Utiliser le contenu réutilisable.

Haut de la Section

Haut de la page

Utiliser le mode d'édition de source HTML

Vous pouvez passer de l’édition de texte à l’édition de source HTML à tout moment en cliquant sur le bouton Modifier la Source HTML. Source HTML en mode d’édition est utile pour modifier les attributs des éléments HTML dans votre contenu.

Lorsque vous êtes en mode d’édition de source HTML, la fenêtre Éditeur HTML affiche votre contenu en HTML, et la plupart des boutons de barre d’outils sont désactivés. Vous pouvez modifier la source HTML à l’aide des balises HTML standard et syntaxe. L’éditeur HTML prend en charge la norme de transition de version 4.01 HTML.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Ces informations vous ont-elles été utiles ?

Très bien ! Vous avez d’autres commentaires ?

Comment pouvons-nous l’améliorer ?

Nous vous remercions pour vos commentaires.

×