Utiliser des valeurs d'une base de données Access pour remplir une zone de liste, une zone de liste déroulante ou une zone de liste modifiable

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Dans un formulaire InfoPath, vous pouvez remplir une zone de liste, une zone de liste déroulante ou une zone de liste déroulante avec les données d’une connexion de données de requête à une base de données Microsoft Office Access 2007 (format .accdb) ou une base de données Access qui a été enregistré dans une version antérieure (format .mdb).

Contenu de cet article

Vue d’ensemble

Considérations relatives à la compatibilité

Avant de commencer

Étape 1 : Ajouter une connexion de données de requête

Étape 2 : Configurer le contrôle

Facultatif : Définissez un filtre pour limiter les éléments dans le contrôle

Vue d’ensemble

Une zone de liste, une zone de liste déroulante ou une zone de liste déroulante affiche les éléments que les utilisateurs peuvent sélectionner lorsqu’ils rempliront un formulaire InfoPath. Lorsque vous concevez un modèle de formulaire, vous pouvez configurer ces types de contrôles pour afficher des données à partir d’une connexion de données secondaire à une base de données Access.

Une connexion de données secondaire est une connexion de données à une source de données externe que vous ajoutez à un formulaire de données. Vous pouvez configurer les connexions de données secondaires pour récupérer des données dont vos utilisateurs ont besoin pour pouvoir remplir des formulaires qui reposent sur votre modèle de formulaire ou pour envoyer des données de formulaire vers une source de données externe, telle qu'un service Web.

Lorsque vous ajoutez une connexion de données secondaire qui demande des données à votre modèle de formulaire, InfoPath crée un secondaire source de données qui contient les champs de données et des groupes qui correspondent à la manière dont les données sont stockées dans la base de données. La connexion de données extrait les données à partir du service Web et stocke ensuite ces données dans la source de données secondaire du formulaire.

Vous pouvez configurer la connexion de données secondaire pour enregistrer les résultats de la requête sur les ordinateurs de vos utilisateurs, de façon à ce que ces utilisateurs disposent d'un accès aux données même lorsque leurs ordinateurs ne sont pas connectés à un réseau. En fonction de la nature des données, vous pouvez afficher les résultats de la requête uniquement lorsque les utilisateurs sont connectés à un réseau.

Note de sécurité : Si vous utilisez une connexion de données secondaire pour récupérer des données sensibles à partir d’une source de données externe, vous souhaiterez désactiver cette fonctionnalité pour aider à protéger les données à partir d’une utilisation non autorisée en cas de perte ou de vol de l’ordinateur. Si vous désactivez cette fonctionnalité, les données seront disponibles uniquement si l’utilisateur est connecté au réseau.

Si vous voulez limiter le nombre d’éléments dans un contrôle de zone de liste, vous pouvez utiliser un filtre. Utiliser un filtre chaque fois que vous avez besoin afficher un sous-ensemble des données qui sont retournés par une requête basée sur les critères sélectionnés par un utilisateur. Que critère peut être un élément qui est sélectionné dans un autre contrôle (par exemple, une zone de liste, zone de liste modifiable, zone de liste déroulante ou zone de texte) qui est lié à un champ dans la source de données.

Étant donné que la structure de données dans la source de données secondaire doit correspondre à la manière dont les données sont stockées dans la base de données, vous ne pouvez pas modifier des champs existants ou des groupes dans la source de données secondaire. Recherchez des liens vers des informations supplémentaires sur les connexions de données et les sources de données dans la section Voir aussi de cet article.

Haut de la Page

Considérations en matière de compatibilité

Vous pouvez ajouter une connexion de données de requête à une base de données Access uniquement si vous créez un modèle de formulaire qui n’est pas un modèle de formulaire compatible avec les navigateurs web.

Haut de la Page

Avant de commencer

Avant de pouvoir utiliser les valeurs d'une base de données Access pour remplir un contrôle sur votre modèle de formulaire, vous devez obtenir les informations suivantes auprès de votre administrateur de base de données :

  • Le nom et l'emplacement de la base de données.

    Remarque : Si d’autres utilisateurs du réseau crée des formulaires basés sur ce modèle de formulaire, assurez-vous que votre base de données est accessible à ces utilisateurs.

  • Le nom de la table ou de la requête qui fournit les valeurs pour les contrôles. Vous allez utiliser cette table ou requête en tant que table primaire lors de la configuration de la connexion de données de requête.

  • Les noms de toute autre table ou requête à partir de laquelle la table primaire ou la requête peut-être nécessiter des données. Dans la plupart des cas, les relations entre les tables sont déjà établies dans la base de données. Si vous devez définir manuellement les relations entre la table primaire ou requête et une autre table ou requête, vous devez les noms de champs associé des deux tables ou requêtes.

Haut de la Page

Étape 1 : Ajouter une connexion de demande de données

Si vous ne disposez pas d’une connexion de données existante de requête que vous pouvez utiliser dans votre modèle de formulaire, procédez comme suit pour ajouter une connexion de données secondaire qui demande des données à votre modèle de formulaire. Si votre modèle de formulaire comporte déjà une connexion de données secondaire que vous pouvez utiliser, vous pouvez ignorer cette section et accédez à étape 2 : configurer le contrôle.

  1. Dans le menu Outils, cliquez sur Connexions de données.

  2. Dans la boîte de dialogue Connexions de données, cliquez sur Ajouter.

  3. Dans l'Assistant Connexion de données, cliquez sur Créer une nouvelle connexion, puis sur Recevoir les données et enfin, sur Suivant.

  4. Dans la page suivante de l'assistant, cliquez sur Base de données (uniquement Microsoft SQL Server ou Microsoft Office Access) puis cliquez sur Suivant.

  5. Sur la page suivante, cliquez sur Sélectionner une base de données.

  6. Dans la boîte de dialogue Sélectionner la source de données, accédez à l'emplacement de votre base de données.

    Remarque : Si votre base de données est stocké dans un emplacement réseau, accédez à l’emplacement (UNC) convention d’appellation universel de l’emplacement. Ne pas naviguez jusqu'à l’emplacement réseau via un lecteur réseau mappé. Si vous utilisez un lecteur réseau mappé (qui est, attribution d’une lettre à un lecteur réseau, par exemple h : ou z), formulaires que les utilisateurs créent basés sur ce modèle de formulaire recherche la base de données sur le lecteur réseau mappé spécifique. Si l’utilisateur ne dispose pas d’un lecteur réseau mappé de la même façon, le formulaire ne trouve pas la base de données.

  7. Cliquez sur le nom de votre base de données, puis sur Ouvrir.

  8. Dans la boîte de dialogue Sélectionner une table, cliquez sur la table ou la requête principale que vous voulez utiliser, puis sur OK.

  9. Sur la page suivante de l'Assistant, activez la case à cocher Afficher les colonnes de la table.

    Par défaut, tous les champs de la table ou requête sont ajoutés à la source de données principale du modèle de formulaire.

  10. Désactivez les cases à cocher qui correspondent aux champs que vous ne souhaitez pas inclure dans la source de données principale.

  11. Ajoutez toute table ou requête supplémentaire que vous souhaitez inclure dans la connexion de données de requête.

    Procédure

    1. Cliquez sur Ajouter une table.

    2. Dans la boîte de dialogue Ajouter une Table ou requête, cliquez sur le nom de la table enfant, puis cliquez sur suivant. InfoPath tente de définir les relations en faisant correspondre les noms de champs dans deux tables. Si vous ne souhaitez pas utiliser la relation proposée, sélectionnez la relation, puis cliquez sur Supprimer la relation. Pour ajouter une relation, cliquez sur Ajouter une relation. Dans la boîte de dialogue Ajouter une relation, cliquez sur le nom de chaque champ associé dans la colonne correspondante, puis cliquez sur OK.

    3. Cliquez sur Terminer.

    4. Pour ajouter des tables enfant supplémentaires, recommencez ces étapes.

  12. Cliquez sur Suivant.

  13. Pour permettre d'accéder aux résultats de la connexion de données de requête lorsque le formulaire n'est pas connecté à un réseau, activez la case à cocher Stocker une copie des données dans le modèle de formulaire.

    Note de sécurité : Activez cette case à cocher stocke les données sur l’ordinateur de l’utilisateur lorsque le formulaire utilise cette connexion de données. Si le formulaire récupère des données sensibles à partir de cette connexion de données, vous souhaiterez peut-être désactiver cette fonctionnalité pour aider à protéger les données en cas de perte ou de vol de l’ordinateur ou dans le cas contraire pour accéder à un utilisateur non autorisé.

  14. Cliquez sur Suivant.

  15. Sur la page suivante de l'Assistant, tapez un nom descriptif pour cette connexion de données secondaire, puis vérifiez l'exactitude des informations dans la section Résumé.

  16. Pour configurer le formulaire afin de recevoir automatiquement des données lors de son ouverture, activez la case à cocher Extraire automatiquement les données à l'ouverture du formulaire.

Haut de la Page

Étape 2 : Configurer le contrôle

  1. Si le modèle de formulaire comporte plusieurs vues, cliquez sur nom de l’affichage dans le menu affichage pour accéder à la vue avec le contrôle dans lequel vous souhaitez afficher les données à partir de la source de données secondaire.

  2. Double-cliquez sur la zone de liste, la zone de liste déroulante ou la zone de liste modifiable de votre modèle de formulaire que vous souhaitez configurer.

  3. Cliquez sur l'onglet Données.

  4. Sous Entrées de la zone de liste, cliquez sur Rechercher les valeurs dans une source de données externe.

  5. Dans la liste Source de données, cliquez sur la source de données que vous souhaitez utiliser.

  6. Cliquez sur Sélectionner une expression XPath Image du bouton , en regard de la zone entrées.

  7. Dans la boîte de dialogue Sélectionner un champ ou un groupe, spécifiez le champ ou le groupe dont les champs contiennent les données qui doivent être affichées à l'utilisateur, ainsi que les données qui seront envoyées à la source de données externe en effectuant l'une des actions suivantes.

    Spécifier que les données visibles par l’utilisateur sont les mêmes données l’utilisateur doivent remettre

    • Sélectionnez un champ, puis cliquez sur OK.

    Spécifier que les données visibles par l’utilisateur sont différentes de celles qui envoie l’utilisateur

    Remarque : Dans ce scénario, les données que l'utilisateur verra proviennent de l'un des champs dans le groupe, tandis que les données que l'utilisateur soumettra sont contenues dans un autre champ du même groupe.

    1. Cliquez sur un groupe, puis sur OK.

    2. Dans la boîte de dialogue Propriétés du contrôle, cliquez sur Sélectionner une expression XPath Image du bouton , en regard de la zone valeur.

    3. Dans la boîte de dialogue Sélectionner un champ ou un groupe, sélectionnez un champ contenant les données que l'utilisateur enverra à la source de données externe, puis cliquez sur OK.

    4. Dans la boîte de dialogue Propriétés du contrôle, cliquez sur Sélectionner une expression XPath Image du bouton , en regard de la zone nom complet.

    5. Dans la boîte de dialogue Sélectionnez un champ ou un groupe, sélectionnez le champ contenant les données qui apparaîtront dans le contrôle, puis cliquez sur OK.

  8. Si le champ de la zone Nom à afficher contient des valeurs aux noms complets similaires, et si vous voulez n'afficher que des noms uniques, sélectionnez la case à cocher Afficher seulement les entrées avec des noms complets uniques.

Haut de la Page

Haut de la Page

Facultatif : Définissez un filtre pour limiter les éléments dans le contrôle

  1. Double-cliquez sur la zone de liste, la zone de liste déroulante ou la zone de liste modifiable de votre modèle de formulaire que vous souhaitez configurer.

  2. Cliquez sur l'onglet Données.

  3. Cliquez sur Sélectionner une expression XPath Image du bouton en regard de la zone entrées.

  4. Dans la boîte de dialogue Sélectionner un champ ou un groupe, sélectionnez le champ ou le groupe contenant les champs fournissant les valeurs que vous souhaitez utiliser pour le contrôle, puis cliquez sur Filtrer les données.

  5. Dans la boîte de dialogue Filtrer les données, cliquez sur Ajouter.

    Remarque : Si vous souhaitez ajouter une condition à un filtre existant, cliquez sur le filtre que vous souhaitez appliquer, puis cliquez sur Modifier.

  6. Dans la première zone de la boîte de dialogue Spécifier les conditions du filtre, cliquez sur le nom du champ dont vous voulez filtrer les données.

  7. Dans la deuxième zone, cliquez sur le type de filtre que vous voulez utiliser.

  8. Dans la troisième zone, cliquez sur le type de condition que vous souhaitez appliquer le filtre et tapez la condition.

  9. Pour configurer plusieurs conditions de filtrage, cliquez sur et, puis effectuez l’une des opérations suivantes :

    • Pour appliquer la condition existante et la nouvelle condition à votre filtre, cliquez sur et et ajoutez votre nouvelle condition.

    • Pour appliquer la condition existante ou la nouvelle condition à votre filtre, cliquez sur ou et ajoutez la condition supplémentaire.

  10. Cliquez sur OK pour fermer les boîtes de dialogue.

  11. Pour tester vos modifications, cliquez sur Aperçu dans la barre d’outils Standard, ou appuyez sur Ctrl+Maj+B.

    Le modèle de formulaire s’ouvre dans une nouvelle fenêtre.

  12. Dans la fenêtre d’aperçu, sélectionnez différentes valeurs dans le contrôle filtré pour vérifier que le filtre fonctionne correctement.

    Le filtre ne fonctionne pas correctement

    Si les valeurs dans le contrôle qui contient un filtre ne sont pas correctes, soit, car il existe des valeurs trop ou pas assez, procédez comme suit :

    • Si vous utilisez plusieurs conditions dans votre filtre, supprimez tout sauf une condition afin de vérifier que les valeurs correctes sont renvoyées à partir de cette condition unique. Si la première condition renvoie les valeurs correctes, puis ajouter une autre condition et tester.

    • Filtres de faire une distinction entre majuscules et minuscules. Si vous souhaitez afficher les données qui commencent par un caractère majuscule ou minuscule, créer un filtre avec une condition majuscule, sélectionnez ou dans la boîte de dialogue Spécifier la Condition de filtre et puis créer une condition minuscules.

    • Si les valeurs filtrées sont exactement le contraire de ce que vous attendez, par exemple les produits de tous les fournisseurs sont affichés à la place de produits à partir d’un seul fournisseur, modifiez le type de filtre dans la condition. Par exemple, si votre condition utilise le type de filtre est égal à et que vous obtenez trop de produits, essayez d’utiliser le type de filtre n’est pas égal à.

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×