Utiliser SOMMEPROD pour additionner le produit des valeurs correspondantes dans une ou plusieurs matrices

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

SOMMEPROD utilise des plages de cellules (ou des matrices) comme arguments (les parties de la formule qui lui sont nécessaires pour s’exécuter). Cette fonction multiplie les éléments des matrices, puis ajoute le résultat.

Cet exemple est une liste de courses, une matrice répertorie le prix de chaque article, et l’autre le nombre d’articles à acheter.

Prix et quantités à multiplier, puis à ajouter

  1. Pour créer la formule, tapez =SOMMEPROD(B3:B6;C3:C6) et appuyez sur Entrée.

Chaque cellule de la colonne B est multipliée par la cellule correspondante sur la même ligne dans la colonne C, et les résultats sont ajoutés. Le montant total pour les courses est de 21,60 €.

  1. Rédiger une formule plus longue que vous propose le même résultat, type = B3 * C3 + B4 * B5 + C4 * C5 + B6 * C6 et appuyez sur ENTRÉE.

Après avoir appuyé sur Entrée, le résultat est identique : 21,60 €. La cellule B3 est multipliée par la cellule C3, et son résultat est ajouté au résultat de la cellule B4 multiplié par la cellule C4, etc. Vous vous rendez bien compte, si vous avez des centaines (ou des milliers) de lignes, que l’utilisation de la fonction SOMMEPROD est beaucoup plus facile.

Remarques : 

  • Les colonnes ou les lignes (matrices) doivent avoir la même longueur.

  • Si du texte figure dans une cellule, à la place d’un chiffre, il est considéré comme un zéro.

Exemple

Si vous voulez vous exercer avec la fonction SOMMEPROD et les matrices, utilisez ce classeur Excel Online qui contient des données différentes de celles utilisées dans cet article.

Copiez les données d’exemple dans le tableau suivant, et collez-le dans la cellule A1 d’un nouveau classeur Excel. Pour que les formules affichent des résultats, sélectionnez-les, appuyez sur F2, et sur Entrée. Si nécessaire, vous pouvez modifier la largeur des colonnes pour afficher toutes les données.

un

B

D

E

3

4

2

7

8

6

6

7

1

9

5

3

Formule

Résultat

'=SOMMEPROD(A2:B4;D2:E4)

=SOMMEPROD(A2:B4;D2:E4)

Multiplie toutes les valeurs des deux matrices (A2:B4 et D2:E4), puis additionne les produits ; c’est-à-dire : 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156)

Vous pouvez également ouvrir ce classeur dans Excel. Cliquez sur l’icône Excel dans le coin inférieur droit du classeur   Icône Excel dans Excel Web App , enregistrez le fichier sur votre ordinateur, puis ouvrez-le.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×