Utiliser Microsoft Query pour extraire des données externes

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Dans Excel 2010, connexions de données externes sont plus faciles à utiliser et plus sécurisée.
Essayer Office 365!

Vous pouvez utiliser Microsoft Query pour extraire des données provenant de sources externes. À l’aide de Microsoft Query pour extraire des données à partir de vos fichiers et les bases de données d’entreprise, vous n’êtes pas obligé de retaper les données que vous voulez analyser dans Excel. Vous pouvez également actualiser vos rapports et synthèses Excel automatiquement à partir de la base de données source d’origine chaque fois que la base de données est mis à jour avec les nouvelles informations.

Que voulez-vous faire ?

Fonctionnalités de Microsoft Query

Se connecter à une source de données

Utilisation de l’Assistant Requête pour définir une requête.

Utiliser des données dans Excel

Fonctionnalités de Microsoft Query

À l’aide de Microsoft Query, vous pouvez vous connecter à des sources de données externes, sélectionner les données de ces sources externes, importer ces données dans votre feuille de calcul et actualiser les données selon vos besoins pour conserver vos données de feuille de calcul synchronisées avec les données dans les sources externes.

Types de bases de données que vous pouvez accéder à     Vous pouvez récupérer des données de plusieurs types de bases de données, y compris Microsoft Office Access, Microsoft SQL Server et Microsoft SQL Server OLAP Services. Vous pouvez également extraire des données à partir de classeurs Excel et des fichiers texte.

Microsoft Office fournit des pilotes pour vous permettre d'extraire des données des sources de données suivantes :

  • Microsoft SQL Server Analysis Services (fournisseur OLAP)

  • Microsoft Office Access 

  • dBASE

  • Microsoft FoxPro

  • Microsoft Office Excel

  • Oracle

  • Paradox

  • Bases de données de fichier texte

Vous pouvez utiliser également pilotes ODBC ou des pilotes de source de données à partir d’autres fabricants pour extraire des informations à partir de sources de données qui ne sont pas répertoriés ici, notamment d’autres types de bases de données OLAP. Pour plus d’informations sur l’installation d’un pilote ODBC ou pilote de source de données qui n’est pas répertorié ici, consultez la documentation de la base de données ou contactez votre fournisseur de base de données.

Sélection de données à partir d’une base de données     Vous récupérez des données à partir d’une base de données en créant une requête, qui est une question que vous posez concernant des données stockées dans une base de données externe. Par exemple, si vos données sont stockées dans une base de données Access, vous voudrez les chiffres de ventes pour un produit spécifique par région. Vous pouvez récupérer une partie des données en sélectionnant uniquement les données pour le produit et la région que vous souhaitez analyser.

Microsoft Query vous permet de sélectionner uniquement les colonnes de données voulues et de les importer dans Excel.

Mettre à jour une feuille de calcul en une seule opération     Une fois que les données externes sont importées dans un classeur Excel, vous pouvez actualisation celles-ci en fonction des modifications apportées à la base de données pour disposer constamment de données fiables, sans avoir besoin de recréer des rapports récapitulatifs et des graphiques. Par exemple, vous pouvez créer une synthèse mensuelle des ventes et l’actualiser chaque mois, à partir des nouveaux chiffres.

Comment Microsoft Query utilise les sources de données     Une fois que vous configurez une source de données pour une base de données particulière, vous pouvez l’utiliser à chaque fois que vous voulez créer une requête pour sélectionner et extraire les données de cette base de données — sans avoir à retaper toutes les informations de connexion. Microsoft Query utilise la source de données pour vous connecter à la base de données externes et pour afficher les données qui sont disponibles. Une fois que vous créez votre requête et renvoyez les données dans Excel, Microsoft Query fournit le classeur Excel avec les informations des sources de la requête et les données afin que vous pouvez vous reconnecter à la base de données lorsque vous souhaitez actualiser les données.

Diagramme illustrant la manière dont Query utilise les sources de données

À l’aide de Microsoft Query pour importer des données    pour importer des données externes dans Excel avec Microsoft Query, suivez ces étapes de base, chacun d'entre eux est décrit plus en détail dans les sections suivantes.

  1. Se connecter à une source de données.

  2. Utilisez l’Assistant Requête pour définir une requête.

  3. Travailler avec les données dans Excel.

Haut de la page

Se connecter à une source de données

Qu’est une source de données?     Une source de données est un ensemble d’informations qui permet à Excel et Microsoft Query pour vous connecter à une base de données externes stockées. Lorsque vous utilisez Microsoft Query pour définir une source de données, vous donnez un nom à la source de données et puis fournissez le nom et l’emplacement de la base de données ou du serveur, le type de base de données et vos informations de connexion et votre mot de passe. Ces informations comprennent également le nom d’un pilote ODBC ou un pilote de source de données, qui est un programme qui établit des connexions à un type spécifique de base de données.

Pour configurer une source de données à l’aide de Microsoft Query :

  1. Sous l’onglet Données, dans le groupe Données externes, cliquez sur À partir d’autres sources, puis sur Provenance : Microsoft Query.

  2. Effectuez l’une des opérations suivantes :

    • Pour désigner une source de données pour une base de données, un fichier texte ou un classeur Excel, cliquez sur l’onglet Bases de données.

    • Pour spécifier une source de données de cube OLAP, cliquez sur l’onglet Cubes OLAP. Cet onglet est disponible uniquement si vous avez exécuté Microsoft Query à partir d’Excel.

  3. Double-cliquez sur <Nouvelle source de données>.

    – ou –

    Cliquez sur <Nouvelle source de données>, puis sur OK.

    La boîte de dialogue Créer une nouvelle source de données s’affiche.

  4. À l’étape 1, tapez un nom pour identifier la source de données.

  5. À l'étape 2, cliquez sur un pilote pour le type de base de données que vous utilisez en tant que source de données.

    Si la base de données externes à laquelle vous voulez accéder n’est pas prise en charge par les pilotes ODBC qui sont installés avec Microsoft Query, vous devez dans ce cas vous procurer un pilote ODBC compatible avec Microsoft Office auprès d’un fabricant tiers, comme le fabricant de la base de données. Contactez le fabricant de la base de données pour obtenir des instructions pour installer le pilote.

    Remarque : Les bases de données OLAP ne nécessitent pas de pilote ODBC. Lorsque vous installez Microsoft Query, les pilotes sont installés pour les bases de données qui ont été créées à l’aide de Microsoft SQL Server Analysis Services. Pour vous connecter à d’autres bases de données OLAP, vous devez installer un pilote de source de données et un logiciel client.

  6. Cliquez sur se connecter et puis fournissez les informations nécessaires pour vous connecter à votre source de données. Pour les bases de données, les classeurs Excel et les fichiers texte, les informations que vous fournissez dépendant du type de source de données que vous avez sélectionné. Vous devrez peut-être fournir un nom d’ouverture de session, un mot de passe, la version de la base de données que vous utilisez, l’emplacement de la base de données ou d’autres informations spécifiques au type de base de données.

    Utilisez un mot de passe fort qui associe des lettres majuscules et minuscules, des nombres et des symboles. Les mots de passe faibles ne combinent pas ces éléments. Mot de passe fort : Y6dh!et5. Mot de passe faible : Maison27. Les mots de passe doivent comporter au moins 8 caractères. Nous vous conseillons d’utiliser plus de 14 caractères. Pour plus d’informations, voir Protéger vos informations personnelles avec des mots de passe forts.

    Il est très important de ne pas oublier votre mot de passe. Si cela se produit, Microsoft ne pourra pas le récupérer. Stockez les mots de passe que vous écrivez dans un endroit sûr, éloigné des informations qu’ils sont censés protéger.

  7. Après avoir entré les informations requises, cliquez sur OK ou sur Terminer pour revenir à la boîte de dialogue Créer une nouvelle source de données.

  8. Si votre base de données comporte des tables et que vous voulez qu’une table particulière s’affiche automatiquement dans l’Assistant Requête, cliquez sur la zone à l’étape 4, puis cliquez sur la table que vous souhaitez.

  9. Si vous ne souhaitez pas taper votre nom de connexion et votre mot de passe à chaque utilisation de la source de données, activez la case à cocher Enregistrer l'identité et le mot de passe de l'utilisateur. Le mot de passe enregistré n'est pas chiffré. Si la case à cocher n'est pas disponible, contactez l'administrateur de votre base de données pour savoir s'il est possible d'y accéder.

    Note de sécurité : Avoid saving logon information when connecting to data sources. This information may be stored as plain text, and a malicious user could access the information to compromise the security of the data source.

À la fin de cette procédure, le nom de la source de données apparaît dans la boîte de dialogue Choisir une source de données.

Haut de la page

Utilisation de l’Assistant Requête pour définir une requête.

Utilisez l’Assistant Requête pour la plupart des requêtes     L’Assistant Requête facilite la sélectionner et rassembler des données issues de différentes tables et les champs dans votre base de données. À l’aide de l’Assistant Requête, vous pouvez sélectionner les tables et les champs que vous souhaitez inclure. Une jointure interne (une opération de requête qui spécifie que les lignes des deux tables sont combinées en fonction des valeurs de champ identiques) est créée automatiquement lorsque l’Assistant reconnaît un champ de clé primaire dans une table et un champ du même nom dans une seconde table.

Vous pouvez également utiliser l’Assistant pour trier les résultats et pour effectuer un filtrage simple. Dans l’étape finale de l’Assistant, vous pouvez choisir entre exporter les données dans Excel et affiner la requête dans Microsoft Query. Une fois la requête créée, vous pouvez l’exécuter dans Excel ou dans Microsoft Query.

Pour démarrer l’Assistant Requête, procédez comme suit :

  1. Sous l’onglet Données, dans le groupe Données externes, cliquez sur À partir d’autres sources, puis sur Provenance : Microsoft Query.

  2. Dans la boîte de dialogue Choisir une source de données, assurez-vous que la case à cocher Utiliser l’Assistant Requête pour créer et/ou modifier vos requêtes est activée.

  3. Double-cliquez sur la source de données que vous voulez utiliser.

    – ou –

    Cliquez sur la source de données que vous utilisez, puis sur OK.

Travaillez directement dans Microsoft Query pour d’autres types de requêtes     Si vous voulez créer une requête plus complexe que l’Assistant Requête permet, vous pouvez travailler directement dans Microsoft Query. Vous pouvez utiliser Microsoft Query pour afficher et modifier des requêtes que vous commencez à créer dans l’Assistant Requête, ou vous pouvez créer de nouvelles requêtes sans utiliser l’Assistant. Travaillez directement dans Microsoft Query lorsque vous voulez créer des requêtes qui, procédez comme suit :

  • sélectionner des données spécifiques dans un champ       Il peut arriver que, dans le cas d’une base de données volumineuse, vous n’ayez besoin que de certaines données d’un champ. Par exemple, si vous avez besoin de données pour deux des produits d’un champ contenant des informations sur de nombreux produits, utilisez des critères afin de sélectionner des données uniquement pour les deux produits souhaités.

  • récupérer des données en fonction de divers critères chaque fois que vous exécutez la requête       Si vous devez créer le même rapport ou la même synthèse Excel pour plusieurs zones des mêmes données externes (par exemple un rapport sur les ventes distinct pour chaque région), créez pour cela une requête avec paramètres. Lorsque vous exécutez une requête Paramètre, vous devez préciser la valeur à utiliser comme critère pour la sélection des enregistrements, par exemple, une région spécifique ; vous pouvez ensuite réutiliser cette requête pour créer des rapports de ventes pour les autres régions.

  • Joindre des données de différentes manières     Les jointures internes que crée l’Assistant requête sont les plus couramment de jointure utilisée pour créer des requêtes. Parfois, cependant, vous souhaitez utiliser un autre type de jointure. Par exemple, si vous avez une table des informations de ventes de produits et une table des informations sur le client, une jointure interne (type créé par l’Assistant Requête) empêchera l’extraction des enregistrements de client pour les clients qui n’ont effectué un achat. À l’aide de Microsoft Query, vous pouvez joindre ces tables afin que tous les enregistrements de client sont récupérés, ainsi que des données de ventes pour les clients qui ont effectué des achats.

Pour démarrer Microsoft Query, procédez comme suit :

  1. Sous l’onglet Données, dans le groupe Données externes, cliquez sur À partir d’autres sources, puis sur Provenance : Microsoft Query.

  2. Dans la boîte de dialogue Choisir une source de données, assurez-vous que la case à cocher Utilisez l’Assistant Requête pour créer et/ou modifier vos requêtes est désactivée.

  3. Double-cliquez sur la source de données que vous voulez utiliser.

    – ou –

    Cliquez sur la source de données que vous utilisez, puis sur OK.

Réutilisation et partage des requêtes     Dans l’Assistant requête et dans Microsoft Query, vous pouvez enregistrer vos requêtes sous forme de fichier .dqy que vous pouvez modifier, réutiliser et partager. Excel peut ouvrir des fichiers .dqy directement, qui permet de vous ou autres utilisateurs de créer des plages de données externes supplémentaires à partir de la même requête.

Pour ouvrir une requête enregistrée à partir d’Excel :

  1. Sous l’onglet Données, dans le groupe Données externes, cliquez sur À partir d’autres sources, puis sur Provenance : Microsoft Query. La boîte de dialogue Choisir une source de données s’affiche.

  2. Dans la boîte de dialogue Choisir une source de données, cliquez sur l’onglet Requêtes.

  3. Double-cliquez sur la requête enregistrée que vous voulez ouvrir. La requête s’affiche dans Microsoft Query.

Si vous souhaitez ouvrir une requête enregistrée et si Microsoft Query est déjà ouvert, cliquez sur le menu Fichier de Microsoft Query, puis cliquez sur Ouvrir.

Si vous double-cliquez sur un fichier .dqy, Excel s’ouvre, exécute la requête et puis insère les résultats dans une feuille de calcul.

Pour partager une synthèse ou un rapport Excel créé à partir de données externes, vous pouvez fournir à d’autres utilisateurs un classeur qui contient une plage de données externes ou créer un modèle. Ce dernier vous permet d’enregistrer la synthèse ou le rapport sans enregistrer les données externes afin de réduire la taille du fichier. Les données externes sont extraites lorsqu’un utilisateur ouvre le modèle de rapport.

Haut de la page

Exploiter des données dans Excel.

Après avoir créé une requête dans l’Assistant Requête ou Microsoft Query, vous pouvez exporter les données dans une feuille de calcul Excel. Les données sont alors présentées dans une plage de données externes ou dans un rapport de tableau croisé dynamique que vous pouvez mettre en forme et actualiser.

Mise en forme des données extraites     Dans Excel, vous pouvez utiliser des outils, tels que des graphiques ou des sous-totaux automatiques, pour présenter et synthétiser les données extraites par Microsoft Query. Vous pouvez mettre en forme les données et la mise en forme est conservée lorsque vous actualisez les données externes. Vous pouvez utiliser vos propres étiquettes de colonne au lieu des noms de champs et ajouter automatiquement des numéros de ligne.

Excel peut automatiquement mettre en forme les données que vous ajoutez à la fin d’une plage pour qu’elles respectent la mise en forme des lignes précédentes ; il peut également copier automatiquement des formules qui ont été répétées dans les lignes précédentes et les étendre à d’autres lignes.

Remarque : Pour que les mises en forme et les formules soient étendues aux nouvelles lignes de la plage, elles doivent apparaître dans au moins trois des cinq lignes précédentes.

Vous pouvez activer cette option (ou la désactiver) à tout moment :

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , sur Options Excel, puis sur la catégorie Options avancées.

  2. Dans la section Édition, activez la case à cocher Étendre les formules et formats de plage de données pour désactiver cette option. Pour désactiver de nouveau la mise en forme automatique des plages de données, désactivez cette case à cocher.

Actualisation des données externes     Lorsque vous actualisez les données externes, vous exécutez la requête pour extraire des données nouvelles ou modifiées correspondant à vos critères. Vous pouvez actualiser une requête dans Microsoft Query et Excel. Excel propose plusieurs options d’actualisation des requêtes, notamment l’actualisation des données chaque fois que vous ouvrez le classeur et l’actualisation automatique à intervalles réguliers. Vous pouvez continuer à travailler dans Excel pendant l’actualisation des données, et vous pouvez également vérifier l’état de l’actualisation de données. Pour plus d’informations, voir l’actualisation des données connectées (importées).

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Ces informations vous ont-elles été utiles ?

Très bien ! Vous avez d’autres commentaires ?

Comment pouvons-nous l’améliorer ?

Nous vous remercions pour vos commentaires.

×