Utilisation de l’argument table_matrice dans une fonction de recherche

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Lorsque vous créez une formule qui utilise les fonctions RECHERCHEV ou RECHERCHEH, vous entrez un argument table_matrice, qui est une plage de cellules, par exemple, D2:F39. La fonction recherche dans cette plage les données que vous recherchez.

L’argument table_matrice est toujours le deuxième argument dans une fonction RECHERCHEV ou RECHERCHEH (le premier est la valeur que vous recherchez). Ces fonctions sont inutilisables sans cet argument.

Votre premier argument peut être une valeur spécifique, comme « 41 » ou « dupont », ou une référence de cellule, par exemple, F2. Le premier argument se présente comme suit :

=RECHERCHEV(F2,...

L’argument table_matrice suit toujours la valeur de recherche, comme suit :

=RECHERCHEV(F2,B4:D39, ...

La plage de cellules figurant dans l’argument table_matrice peut utiliser des références de cellule relatives ou absolues. Si vous copiez votre formule dans d’autres cellules, vous devez utiliser les références de cellule absolues (signes $), comme suit :

=RECHERCHEV(F2,$B$2:BD$39, ...

Si les cellules de l’argument table_matrice sont situées dans une autre feuille de calcul de votre classeur, l’argument doit inclure le nom de la feuille, suivi d’un point d’exclamation. La syntaxe doit ressembler à ce qui suit :

=RECHERCHEV(F2,Feuil2!$C$14:E$42, ...

La colonne contenant les valeurs que vous recherchez est le troisième argument que vous devez entrer. Il s’agit de la colonne de recherche. Si les valeurs que vous souhaitez afficher sont situées dans la colonne D (troisième colonne de table_matrice), le dernier argument est un 3.

=RECHERCHEV(F2;B4:D39;3)

Bien que cela soit facultatif, nous vous recommandons d’utiliser un quatrième argument : Faux ou Vrai. Utilisez Faux si vous recherchez une correspondance exacte.

=RECHERCHEV(F2,B4:D39,3,Faux)

Si vous utilisez Vrai ou que vous laissez le quatrième argument vide, la fonction renvoie une correspondance approximative de la valeur figurant dans votre premier argument. Si votre premier argument est « dupont » et que vous utilisez Vrai, la fonction RECHERCHEV renvoie « dupont », « dupontel », etc. Mais si vous utilisez Faux, la fonction renvoie uniquement « dupont », qui est la correspondance exacte et qui correspond à ce que les utilisateurs veulent la plupart du temps.

Pour rendre l’utilisation de Vrai encore plus compliquée, si votre colonne de recherche (la colonne que vous spécifiez dans votre troisième argument) n’est pas triée dans l’ordre croissant (de A à Z ou du nombre le plus bas au plus élevé), vous risquez d’obtenir un résultat incorrect.

Pour plus d’informations sur les fonctions RECHERCHEV et RECHERCHEH, voir Fonctions de recherche et de référence (référence).

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×