Tâches basiques dans Access 2010

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Voici quelques tâches de base de la base de données que vous pouvez faire pour vous aider à découvrir comment utiliser Microsoft Access 2010.

 

Dans cet article

Nouveautés d'Access ?

Bases de données relationnelles dans Access

À l’ouverture d’Access

Trouver et appliquer un modèle

Créer une base de données entièrement nouvelle

Ouvrir une base de données Access

Commencer à utiliser votre nouvelle base de données

Ajouter un tableau

Coller des données d’une autre source dans une table Access

Importer ou lier des données issues d’une source externe

Étapes suivantes

Importer des données depuis un tableur ou un autre programme

Importer une feuille de calcul Excel dans Access

Importer une feuille de calcul Excel sous la forme d’une table dans une nouvelle base de données

Utiliser l’Assistant Analyseur de table pour organiser des données

Utiliser des données provenant d’autres programmes

Utiliser une base de données de version antérieure dans plusieurs versions d’Access

Utiliser un fichier de base de données Access dans plusieurs versions d’Access

Étape 1 : créer une copie de la base de données existante, puis l’enregistrer dans un nouveau format

Étape 2 : fractionner la base de données de copie, puis utiliser le fichier d’origine comme base de données principale

Étape 3 : connecter la nouvelle base de données frontale à la base de données d’origine

Utiliser une application frontale/principale dans plusieurs versions d’Access

Nouveautés d'Access ?

Access 2010 est un outil de conception et de déploiement d'application de base de données que vous pouvez utiliser pour effectuer le suivi des informations importantes. Vous pouvez conserver vos données sur votre ordinateur, ou vous pouvez publier sur le Web, afin que d'autres personnes peuvent utiliser votre base de données avec un navigateur web.

De nombreuses personnes commencent à utiliser Access lorsque le programme auquel elles recourent pour effectuer le suivi des données convient de moins en moins pour cette tâche. Par exemple, supposons que vous êtes planificateur d’événements et que vous souhaitez effectuer le suivi de tous les détails à gérer pour le bon déroulement des événements. Si vous utilisez un traitement de texte ou un tableur pour cette tâche, vous pouvez facilement être confronté à des données en double ou incohérentes. Vous pouvez utiliser un logiciel de gestion d’agenda, mais le suivi d’informations financières dans un calendrier n’est pas une solution idéale.

Bases de données relationnelles dans Access

Parfois, vous avez besoin d’une base de données relationnelle pour effectuer le suivi d’informations de ce type  : une base de données relationnelle est un magasin de données subdivisé en collections de données (appelées tables) qui permettent d’éliminer les redondances et qui sont reliées en fonction de bribes d’informations communes (appelées champs). Par exemple, une base de données relationnelle de planification d’événement peut contenir une table décrivant les clients, une table décrivant les fournisseurs et une table décrivant les événements. La table décrivant les événements peut contenir un champ permettant de la lier à la table des clients, ainsi qu’un champ permettant de la lier à la table des fournisseurs. Ainsi, si le numéro de téléphone d’un fournisseur change, cette information peut être modifiée une seule fois dans la table des fournisseurs, ce qui évite d’effectuer cette opération dans chaque événement impliquant le fournisseur.

Access est un outil grâce auquel vous pouvez développer rapidement et facilement des applications de bases de données relationnelles qui facilitent la gestion des informations. Vous pouvez créer une base de données pour effectuer le suivi de pratiquement n’importe quel type d’informations, telles qu’un inventaire, des contacts professionnels ou des processus d’entreprise. De fait, Access comprend des modèles que vous pouvez utiliser directement pour le suivi d’un large éventail d’informations, même si vous êtes débutant.

À l’ouverture d’Access

Lorsque vous démarrez Access 2010, vous voyez le Microsoft Office Backstage, où vous pouvez obtenir des informations sur la base de données active, créer une nouvelle base de données, ouvrez une base de données existante, et affichage proposée du contenu provenant de Office.com.

Mode Backstage dans Access 2010

En outre, le mode Backstage contient de nombreuses autres commandes qui vous permettent d’ajuster, de gérer ou de partager vos bases de données. Les commandes du mode Backstage s’appliquent généralement à la totalité d’une base de données, pas à des objets contenus dans celle-ci.

Remarque : Vous pouvez activer le mode Backstage à tout moment en cliquant sur l’onglet Fichier.

Haut de la page

Trouver et appliquer un modèle

Access fournit de nombreux modèles accélérant la création de vos bases de données. Un modèle est une base de données prête à l’emploi contenant la totalité des tables, des requêtes, des formulaires et des états requis pour effectuer une certaine tâche. Par exemple, vous pouvez avoir recours à des modèles pour assurer le suivi des problèmes, pour gérer vos contacts ou pour enregistrer vos notes de frais. Certains modèles contiennent plusieurs exemples d’enregistrements dans un but illustratif. Vous pouvez utiliser ces modèles de base de données tels quels ou les personnaliser en fonction de vos besoins.

Pour rechercher et appliquer un modèle à votre base de données, procédez comme suit :

  1. Sous l’onglet Fichier, cliquez sur Nouveau.

  2. Sous Modèles disponibles, effectuez l’une des actions suivantes :

    • Pour réutiliser un modèle que vous avez utilisé récemment, cliquez sur Modèles récents et sélectionnez le modèle que vous voulez.

    • Pour utiliser un modèle que vous avez déjà installés, cliquez sur Mes modèles, puis sur le modèle que vous voulez.

    • Pour trouver un modèle sur Office.com, sous Modèles Office.com, cliquez sur une catégorie de modèle, sélectionnez le modèle de votre choix, puis cliquez sur Télécharger pour télécharger le modèle .com Office sur votre ordinateur.

      Remarque : Vous pouvez également rechercher des modèles sur Office.com directement à partir d'Access. Dans la zone Rechercher sur Office.com des modèles, tapez une ou plusieurs termes de recherche, puis cliquez sur la flèche pour rechercher.

  3. Si vous le souhaitez, cliquez sur l’icône de dossier en regard de la zone Nom de fichier pour accéder à un emplacement où vous souhaitez créer la base de données. Si vous n’indiquez pas d’emplacement spécifique, Access crée la base de données à l’emplacement par défaut affiché sous la zone Nom de fichier.

  4. Cliquez sur Créer.

Access crée et ouvre la base de données.

Haut de la page

Créer une base de données entièrement nouvelle

Remarque : Si vous souhaitez une présentation plus détaillée des concepts sur la création d’une base de données à l’aide d’Access, voir l’article Concepts de base sur la conception d’une base de données.

Si aucun modèle ne vous satisfait ou si vous souhaitez utiliser dans Access des données provenant d’un autre programme, vous préférerez peut-être créer une toute nouvelle base de données. Dans Access 2010, vous avez le choix entre une base de données de bureau standard ou une base de données Web.

Remarque : Pour plus d’informations sur les bases de données Web, voir l’article Créer une base de données à partager sur le Web.

Pour créer une nouvelle base de données, procédez comme suit :

  1. Démarrez Access.

  2. Dans l’onglet Nouveau du mode Backstage, cliquez sur Base de données vide ou sur Base de données Web vide.

    Important : Le choix que vous opérez ici détermine les fonctionnalités disponibles dans la base de données. Les bases de données de bureau ne peuvent pas être publiées sur le Web et les bases de données Web ne prennent pas en charge certaines fonctionnalités de bureau, telles que les requêtes Totaux.

  3. À droite, tapez un nom de fichier dans la zone Nom de fichier.

    Pour modifier l’emplacement auquel vous créez le fichier, cliquez sur le bouton Parcourir Image du bouton en regard de la zone Nom de fichier, accédez au nouveau dossier et sélectionnez-le, puis cliquez sur OK.

  4. Cliquez sur Créer.

    Access crée la base de données, puis ouvre une table vide (intitulée Table1) en mode Feuille de données.

  5. Access place le curseur dans la première cellule vide de la colonne Cliquer pour ajouter de la nouvelle table.

    Pour ajouter des données, commencez à taper ; vous pouvez aussi coller des données à partir d’une autre source, comme décrit dans la section Coller des données d’une autre source dans une table Access, plus loin dans cet article.

    Remarques : 

    • L’entrée de données en mode Feuille de données est très semblable à l’entrée de données dans une feuille de calcul Excel. La principale contrainte est qu’il est obligatoire d’entrer les données dans des lignes et des colonnes contiguës, en commençant par l’angle supérieur gauche de la feuille de données. N’essayez pas de mettre en forme vos données en insérant des lignes ou des colonnes vides, comme vous le feriez dans une feuille de calcul Excel. En effet, cette opération se soldera par une perte d’espace dans la table. La table ne contient que les données. Toute la présentation visuelle de ces dernières sera appliquée dans les formulaires et les états créés ultérieurement.

    • La structure de table est créée pendant que vous entrez des données. Chaque fois que que vous ajoutez une nouvelle colonne à la feuille de données, un nouveau champ est défini dans la table. Access définit la type de données du champ en fonction du type de données que vous entrez. Par exemple, si vous avez une colonne dans laquelle vous avez entré uniquement les valeurs de date, Access définir le type de données de ce champ Date/heure. Si vous essayez plus tard Entrez une valeur non date (par exemple, un nom ou un numéro de téléphone) dans ce champ, Access affiche un message vous informant que la valeur ne correspond pas le type de données de la colonne. Si possible, vous devez planifier votre table afin que chaque colonne contienne le même type de données, qu'il s'agisse de texte, des dates, des nombres ou un autre type. Cela rend beaucoup plus facile de créer des requêtes, formulaires et états qui sélectionnent uniquement les données souhaitées.

Si vous ne souhaitez pas entrer de données dans l’immédiat, cliquez sur le bouton Fermer Image du bouton.

Remarque : Access supprimera la table 1 si vous la fermez sans l’enregistrer.

Haut de la page

Ouvrir une base de données Access existante

Conseil : Pour ouvrir rapidement l’une des dernières bases de données ouvertes, sous l’onglet Fichier, cliquez sur Récent, puis cliquez sur le nom de fichier.

  1. Sous l’onglet Fichier, cliquez sur Ouvrir.

  2. Cliquez sur un raccourci dans la boîte de dialogue Ouvrir ou, dans la zone Regarder dans, cliquez sur le lecteur ou sur le dossier contenant la base de données souhaitée.

  3. Dans la liste de dossiers, double-cliquez sur les dossiers l’un après l’autre jusqu’à parvenir au dossier contenant la base de données.

  4. Lorsque vous avez trouvé la base de données, effectuez l’une des opérations suivantes :

    • Pour ouvrir la base de données en mode d’ouverture par défaut, double-cliquez dessus.

    • Pour ouvrir la base de données pour un accès partagé dans un environnement multi-utilisateur, afin que vous et autres utilisateurs peuvent lire et écrire dans la base de données en même temps, cliquez sur Ouvrir.

    • Pour ouvrir la base de données en lecture seule afin de pouvoir la consulter mais pas de la modifier, cliquez sur la flèche en regard du bouton Ouvrir, puis sur Ouvrir en lecture seule.

    • Pour ouvrir la base de données en mode exclusif, empêchant ainsi toute autre personne de l’ouvrir au même moment que vous, cliquez sur la flèche en regard du bouton Ouvrir et puis sur Ouvrir en exclusif.

    • Pour ouvrir la base de données en mode lecture seule, cliquez sur la flèche à côté du bouton Ouvrir, puis sur Ouvrir en mode lecture seule exclusif. D’autres utilisateurs peuvent ouvrir la base de données, mais en lecture seule uniquement.

Si la base de données que vous souhaitez ouvrir est introuvable   

  1. Dans la boîte de dialogue Ouvrir, cliquez sur le raccourci Poste de travail ou, dans la zone Regarder dans, cliquez sur Poste de travail.

  2. Dans la liste de lecteurs, cliquez avec le bouton droit sur le lecteur qui contient en principe la base de données, puis cliquez sur Rechercher.

  3. Entrez vos critères de recherche puis appuyez sur la touche ENTRÉE pour rechercher la base de données.

  4. Si vous trouvez la base de données, ouvrez-la en double-cliquant dessus dans la boîte de dialogue Résultats de la recherche.

    Remarque : Étant donné que la recherche a été lancée dans la boîte de dialogue Ouvrir, cliquez sur le bouton Annuler de cette boîte de dialogue pour que la base de données s'ouvre.

Vous pouvez ouvrir directement un fichier de données dans un format de fichier externe (tel que dBASE, Paradox, Microsoft Exchange ou Microsoft Excel). Vous pouvez également ouvrir directement n'importe quelle source de données ODBC, comme Microsoft SQL Server ou Microsoft FoxPro. Access crée automatiquement une base de données Access dans le même dossier que le fichier de données, puis ajoute des liens vers chaque table de la base de données externe.

Haut de la page

Commencer à utiliser votre nouvelle base de données

Selon le modèle que vous avez utilisé, il se peut que vous deviez effectuer l’une ou plusieurs des opérations suivantes pour rendre la nouvelle base de données opérationnelle :

  • Si Access affiche une boîte de dialogue Connexion avec une liste vide d’utilisateurs, appliquez la procédure suivante :

    1. Cliquez sur Nouvel utilisateur.

    2. Renseignez le formulaire Détails utilisateur.

    3. Cliquez sur Enregistrer et fermer.

    4. Sélectionnez le nom d’utilisateur que vous venez d’entrer, puis cliquez sur Connexion.

  • Si Access affiche une feuille de données vide, vous pouvez commencer à taper des données directement dans cette feuille de données, ou cliquer sur d’autres boutons et onglets pour explorer la base de données.

  • Si Access affiche une page Mise en route, vous pouvez cliquer sur des liens sur cette page pour en savoir plus sur la base de données, ou cliquer sur d’autres boutons et onglets pour explorer la base de données.

  • Si Access affiche un message Avertissement de sécurité dans la barre des messages et que vous faites confiance à la source du modèle, cliquez sur Activer le contenu. Si la base de données requiert une connexion, vous devrez vous connecter à nouveau.

Pour les bases de données de bureau et web, vous souhaitez également commencer une de ces étapes :

Haut de la page

Ajouter une table

Vous pouvez ajouter une nouvelle table à une base de données existante en utilisant les outils du groupe Tables sous l’onglet Créer.

Groupe Tables de l’onglet Créer

Remarque : Dans une base de données Web, seule la commande Table est disponible dans le groupe Tables.

Quel que soit le mode utilisé en premier lieu, vous pouvez basculer de l’un à l’autre grâce aux boutons de modes d’affichage situés dans la barre d’état de la fenêtre Access.

Créer une table vide en mode Feuille de données    En mode Feuille de données, vous pouvez entrer des données immédiatement et laisser Access générer une structure de table en arrière-plan. Les noms sont attribués aux champs par incréments numériques (Champ1, Champ2, etc.) et Access définit leur type de données en fonction du type de données que vous y entrez.

  1. Sous l'onglet créer, dans le groupe tableaux, cliquez sur tableau Image du bouton.

  2. Access crée la table, puis place le curseur dans la première cellule vide de la colonne Cliquer pour ajouter.

  3. Pour ajouter des données, commencez à les taper dans la première cellule vide ; vous pouvez également les coller à partir d’une autre source, comme décrit plus loin dans cet article.

    • Pour renommer une colonne (un champ), double-cliquez sur l’en-tête de colonne, puis tapez le nouveau nom.

      Conseil : Attribuez un nom descriptif à chaque champ, de manière à pouvoir identifier son contenu sans consulter les données.

    • Pour déplacer une colonne, sélectionnez-la en cliquant sur son en-tête avant de la faire glisser à l’emplacement souhaité. Vous pouvez également sélectionner plusieurs colonnes contiguës et toutes les faire glisser vers une nouvelle destination.

      Pour ajouter des champs à la table, vous pouvez commencer à taper des informations dans la colonne Cliquer pour ajouter en mode Feuille de données ou recourir aux commandes du groupe Ajouter et supprimer de l’onglet Champs.

Créer une table en mode Création    En mode Création, vous devez d’abord créer la structure de la nouvelle table. Vous pouvez ensuite basculer en mode Feuille de données pour entrer des données, ou bien vous pouvez entrer des données à l’aide d’une autre méthode telle qu’un formulaire.

Remarque : Le mode Création n’est pas disponible pour les tables d’une base de données Web.

  1. Sous l’onglet Créer, dans le groupe Tables, cliquez sur Création de table. Image du bouton

  2. Pour chaque champ de votre table, tapez un nom dans la colonne Nom du champ puis sélectionnez un type de données dans la liste Type de données.

  3. Vous pouvez entrer des informations supplémentaires sur chaque champ dans la colonne Description. Cette description s’affiche dans la barre d’état lorsque le point d’insertion se trouve dans ce champ et lorsqu’il est utilisé comme texte de la barre d’état pour tous les contrôles que vous créez en faisant glisser le champ du volet Liste des champs vers un formulaire ou un état, ainsi que pour tous les contrôles créés pour ce champ par le biais de l’Assistant Formulaire ou État.

  4. Après avoir ajouté tous les champs, enregistrez la table.

    • Sous l’onglet Fichier, cliquez sur Enregistrer.

  5. Vous pouvez commencer à entrer des données dans la table à tout moment en basculant en mode Feuille de données, en cliquant sur la première cellule vide puis en tapant les données. Vous pouvez par ailleurs coller des données à partir d’une autre source, comme décrit dans la section suivante.

Créer une table à partir d’une liste SharePoint    Avec une liste SharePoint, vos données peuvent être utilisées par des personnes qui ne possèdent pas Access. En outre, les données de la liste sont stockées sur un serveur, qui offre généralement une meilleure protection contre les pertes de données que les fichiers stockés sur un ordinateur de bureau. Vous pouvez commencer avec une nouvelle liste ou lier une liste existante. Vous devez disposer d’autorisations suffisantes sur le site SharePoint sur lequel vous souhaitez créer la liste ; ces autorisations pouvant varier d’un site à l’autre, contactez votre administrateur SharePoint pour plus d’informations sur les options vous concernant.

Remarque : Cette fonctionnalité n'est pas disponible dans une base de données Web.

  1. Sous l’onglet Créer, dans le groupe Tables, cliquez sur Listes SharePoint.

  2. Vous pouvez utiliser l’un des modèles de liste pour créer une liste SharePoint standard, comme Contacts ou Événements.

    Vous pouvez également choisir de créer une liste personnalisée, ou de lier ou d’importer une liste existante. Cliquez sur l’option de votre choix.

  3. Si vous choisissez l’un des modèles de liste pour créer une liste personnalisée, la boîte de dialogue Créer une nouvelle liste s’ouvre afin de vous guider tout au long du processus. Si vous choisissez d’utiliser une liste existante, la boîte de dialogue Données externes s’ouvre.

Pour plus d’informations sur les tables, voir l’article Présentation des tables.

Haut de la page

Coller des données d’une autre source dans une table Access

Si les données qui vous intéressent sont stockées dans un autre programme, par exemple dans Excel, vous pouvez les copier puis les coller dans une table Access. En règle générale, les résultats sont optimisés si les données sont déjà séparées en colonnes, comme c’est le cas dans une feuille de calcul Excel. Si les données se trouvent dans un programme de traitement de texte, vous devez les séparer à l’aide de tabulations ou les convertir en tableau dans le programme de traitement de texte, puis les copier. Si vous devez modifier ou manipuler les données (par exemple, séparer des noms complets en prénoms et noms de famille), faites-le avant de les copier, en particulier si vous ne connaissez pas très bien les fonctionnalités d’Access.

Lorsque vous collez des données dans une table vide, Access définit le type de données de chaque champ en analysant le genre de données que ce dernier contient. Par exemple, si un champ collé ne contient que des valeurs de date, Access applique les données Date/Heure à ce champ. Si le champ collé ne contient que les termes « oui » et « non », Access applique le type Oui/Non au champ.

Access nomme les champs en fonction de ce qu’il détecte dans la première ligne des données collées. Si son type est comparable aux lignes qui suivent, Access détermine que la première ligne fait partie des données et attribue des noms génériques aux champs (Champ1, Champ2, etc.). Si la première ligne de données collées n’est pas comparable aux lignes qui suivent, Access utilise la première ligne comme noms de champs et exclut la première ligne des données réelles.

Si Access affecte des noms de champ génériques, vous devez renommer les champs dès que possible pour éviter toute confusion. Utilisez la procédure suivante :

  1. Sous l'onglet fichier, cliquez sur Enregistrer pour enregistrer la table.

  2. En mode Feuille de données, double-cliquez sur l’en-tête de chaque colonne, puis tapez un nom pour la colonne.

  3. Enregistrez de nouveau la table.

Haut de la page

Importer ou lier des données issues d’une source externe

Il se peut que vous ayez collecté des données dans un autre programme et que vous souhaitiez les utiliser dans Access. Il se peut également que vous collaboriez avec des personnes qui stockent leurs données dans d’autres programmes et que vous souhaitiez manipuler leurs informations dans Access. Autre éventualité : vous possédez plusieurs sources de données disparates et avez besoin d’un « réceptacle » permettant de les regrouper en vue d’une analyse approfondie.

Access facilite l’importation ou la liaison de données à partir d’autres programmes. Vous pouvez récupérer des données provenant d’une feuille de calcul Excel, d’une table appartenant à une autre base de données Access, d’une liste SharePoint ou de tout un éventail d’autres sources. Le processus varie légèrement en fonction de la source de données, mais les instructions ci-dessous faciliteront la mise en route :

  1. Sous l’onglet Données externes, dans le groupe Importer et lier, cliquez sur la commande correspondant au type de fichier à importer.

    Par exemple, si vous importez des données d’une feuille de calcul Excel, cliquez sur Excel. Si le type de programme correct n’est pas affiché, cliquez sur Plus.

    Remarque : Si vous ne trouvez pas le type de format approprié dans le groupe Importer et lier, vous devrez peut-être démarrer le programme dans lequel vous avez créé les données, puis utiliser ce programme pour enregistrer les données dans un format de fichier Access prend en charge (par exemple, un fichier texte délimité ) et puis importez ou créer un lien vers les données.

  2. Dans la boîte de dialogue Données externes, cliquez sur le bouton Parcourir pour accéder au fichier de données sources ou tapez le chemin d’accès complet de ce fichier dans la zone Nom du fichier.

  3. Cliquez sur l’option souhaitée dans la zone Spécifiez le mode et l’emplacement de stockage des données dans la base de données active. Vous pouvez créer une table en utilisant les données importées ou créer une table attachée qui conserve un lien avec la source de données.

  4. Cliquez sur OK.

    Suivant l’option que vous avez choisie, la boîte de dialogue Link Objects ou Importer des objets s’ouvre.

  5. Utilisez la boîte de dialogue pour terminer le processus. La procédure exacte dépend de l’option d’importation ou de liaison choisie.

  6. Dans la dernière page de l’Assistant, cliquez sur Terminer.

    Si vous optez pour l’importation, vous devez indiquer si vous souhaitez enregistrer le détail de l’importation à peine terminée.

  7. Si vous pensez renouveler cette importation, cliquez sur Enregistrer les étapes d’importation, puis entrez les détails.

    Vous pouvez ensuite facilement reproduire l’opération d’importation en cliquant successivement sur Importations enregistrées dans le groupe Importer de l’onglet Données externes, sur la spécification d’importation, puis sur Exécuter.

  8. Si vous ne souhaitez pas enregistrer les détails de cette opération, cliquez sur Fermer.

Access importe les données dans une nouvelle table, qu’il affiche ensuite sous Tables dans le volet de navigation.

Pour en savoir plus la procédure d’importation des données dans Access, suivez les liens dans la section Voir aussi de cet article.

Haut de la page

Étapes suivantes

Le reste du processus de conception dépend de vos objectifs, mais il est probable que vous envisagiez la création de requêtes, de formulaires, d’états et de macros. Cet article ne fournit pas d’informations sur la création d’objets de base de données supplémentaires.

Pour plus d’informations, voir les articles suivants :

Haut de la page

Importer des données depuis un tableur ou un autre programme

Si vous êtes habitué avec d'autres programmes de base de données ou une feuille de calcul, vous savez probablement les notions de base du fonctionnement de ces applications et les bases de données sont utilisées pour. Contrairement à de nombreuses autres applications de base de données Access en vous permettant de créer des bases de données relationnelles, et il diffère supplémentaires à partir de la plupart des programmes de feuille de calcul en offrant des outils de développement de rapports, des formulaires et requêtes complexes. Access fournit également de nombreuses options pour travailler avec d'autres programmes de base de données, telles que SQL Server.

Importer une feuille de calcul Excel dans Access

Nombreux sont ceux qui se mettent à explorer Access après avoir généré une liste dans Excel. Si Excel se prête idéalement à la création initiale d’une liste, plus cette dernière s’étoffe et plus son organisation et sa mise à jour deviennent délicates. Généralement, le transfert de cette liste vers Access constitue l’étape logique suivante.

La structure d’une table de base de données ressemble à celle d’une feuille de calcul, en cela que les données sont stockées dans des lignes et des colonnes. Par conséquent, l’importation d’une feuille de calcul dans une table de base de données est en général une opération simple. C’est au niveau du mode d’organisation des données que l’on constate la principale différence selon que les données sont stockées dans une feuille de calcul ou dans une base de données. Il ne suffit pas d’importer une feuille de calcul complète dans une nouvelle table d’une base de données pour résoudre les problèmes associés à l’organisation et à la mise à jour des données, en particulier si des données redondantes sont présentes dans votre feuille de calcul. Pour résoudre ces problèmes, vous devez séparer les données de la feuille de calcul en plusieurs tables, chacune contenant des données associées. Pour plus d’informations sur l’organisation des données dans les tables, voir l’article Notions fondamentales sur la conception d’une base de données.

Accès aux fonctionnalités de l'Assistant Analyseur de Table, qui peuvent vous aider à effectuer cette procédure. Après avoir importé vos données dans un tableau, l'Assistant vous aide à fractionner la table en tables distinctes, chacun d'entre eux contient des données qui ne sont pas dupliquées dans une autre table. L'Assistant crée également les relations entre les tables nécessaires.

Haut de la page

Importer une feuille de calcul Excel sous la forme d’une table dans une nouvelle base de données

  1. Sous l’onglet Fichier, cliquez sur Nouveau, puis cliquez sur Base de données vide.

  2. Tapez un nom pour la nouvelle base de données dans la zone Nom du fichier puis cliquez sur le bouton Créer.

    La nouvelle base de données s’ouvre et Access crée une table vide, Table1.

  3. Fermez la table Table1.

    Lorsque vous êtes invité à enregistrer les modifications apportées à la conception de Table1, cliquez sur Non.

  4. Sous l’onglet Données externes, dans le groupe Importer et lier, cliquez sur Excel.Image du bouton

  5. Dans la boîte de dialogue Données externes, cliquez sur Parcourir.

  6. Utilisez la boîte de dialogue Ouvrir pour accéder au fichier.

  7. Sélectionnez le fichier puis cliquez sur Ouvrir.

  8. Dans la boîte de dialogue Données externes, vérifiez que l’option Importer les données sources dans une nouvelle table de la base de données active est sélectionnée.

  9. Cliquez sur OK.

    L’Assistant Importation de feuille de calcul démarre ; répondez aux questions qui vous sont posées sur les données.

  10. Suivez les instructions en cliquant sur le bouton Suivant ou Précédent pour parcourir les pages. Sur la dernière page de l’Assistant, cliquez sur le bouton Terminer.

    Remarque : Vous devez indiquer si vous souhaitez enregistrer le détail de l’importation à peine terminée. Si vous pensez renouveler cette importation, cliquez sur Oui puis entrez les détails. Vous pouvez alors facilement reproduire l’importation en cliquant sur Importations enregistrées dans le groupe Importer de l’onglet Données externes. Si vous ne souhaitez pas enregistrer les détails de cette opération, cliquez sur le bouton Fermer.

Access importe les données dans une nouvelle table, qu’il affiche ensuite sous Toutes les tables dans le volet de navigation.

Haut de la page

Utiliser l’Assistant Analyseur de table pour organiser des données

Après l’importation de données dans une table Access, vous pouvez recourir à l’Assistant Analyseur de table pour identifier rapidement les données redondantes. Cet Assistant simplifie l’organisation des données en tables séparées, de façon à optimiser leur stockage. Access sauvegarde une copie de la table initiale, puis crée de nouvelles tables sur lesquelles s’appuiera votre application de base de données.

  1. Ouvrez la base de données Access contenant la table que vous souhaitez analyser.

  2. Sous l’onglet Outils de base de données, dans le groupe Analyser, cliquez sur Analyse table.

    L’Assistant Analyseur de table démarre.

    Les deux premières pages de l’Assistant comportent un court didacticiel comprenant des boutons sur lesquels vous pouvez cliquer pour afficher des exemples. Si les pages d’introduction ne s’affichent pas, activez la case à cocher Afficher les pages d’introduction et cliquez deux fois sur le bouton Précédent pour revenir à l’introduction. Si, après avoir lu l’introduction, vous ne souhaitez plus voir apparaître ces pages, vous pouvez désactiver la case à cocher Afficher les pages d’introduction.

  3. Sur la page Quelle table contient des champs dont les valeurs sont répétées dans plusieurs enregistrements, sélectionnez la table que vous souhaitez analyser, puis cliquez sur Suivant.

  4. L’Assistant peut organiser les champs dans les tables automatiquement, ou vous pouvez effectuer ces choix vous-même. Si vous suivez les suggestions de l’Assistant, vous pouvez toujours modifier la disposition des tables à la page suivante.

    Remarque : Les choix effectués par l’Assistant lorsqu’il organise les champs dans les tables ne sont pas toujours appropriés, en particulier si le volume de données est faible. Vérifiez donc minutieusement les résultats obtenus avec l’Assistant. Néanmoins, il est possible que ce dernier recommande une meilleure organisation que la vôtre, c’est pourquoi il est judicieux de l’exécuter au moins une fois. Si ces suggestions ne vous conviennent pas, vous pouvez toujours réorganiser les champs manuellement et cliquer sur le bouton Précédent pour revoir la disposition des champs vous-même.

  5. Cliquez sur le bouton Suivant. Cette page permet de spécifier les tables et les champs qu’elles contiennent. Si vous aviez opté pour l’organisation déterminée par l’Assistant, vous devriez voir plusieurs tables connectées par des lignes de jointure. Sinon, Access crée une seule table contenant tous les champs. Quoi qu’il en soit, vous pouvez apporter les modifications souhaitées sur cette page.

    • Vous pouvez faire glisser des champs d’une table vers une zone vide de la page pour créer une nouvelle table les contenant. Vous êtes invité à entrer un nom de table.

    • Vous pouvez faire glisser les champs d’une table à une autre si vous pensez que cela peut optimiser leur stockage.

    • Un champ ID ou Numéro unique généré est octroyé à la plupart des tables. Pour en savoir plus sur les champs d’identification, cliquez sur Conseils dans le coin supérieur droit de l’Assistant.

    • Pour annuler une modification, cliquez sur le bouton Annuler.

    • Pour renommer une table, double-cliquez sur sa barre de titre, tapez le nouveau nom puis cliquez sur OK.

  6. Après avoir organisé les champs comme vous le souhaitez, cliquez sur Suivant.

  7. Si l’Assistant identifie des enregistrements aux valeurs très similaires, il les considère comme d’éventuelles erreurs typographiques et affiche un écran où vous pouvez confirmer la conduite à tenir face à ces enregistrements. Faites défiler la liste pour trouver les enregistrements avec des valeurs dans la colonne Correction puis cliquez sur l’élément approprié dans la liste déroulante. Sélectionnez (Laisser tel quel) pour que l’Assistant ne modifie pas la valeur. Une fois terminé, cliquez sur Suivant.

  8. L’Assistant vous demande si vous souhaitez créer une requête qui ressemble à la table initiale. Si vous avez déjà généré des formulaires et des états fondés sur la table initiale, la création d’une telle requête est une idée judicieuse. Si vous sélectionnez Oui, créer la requête, l’Assistant renomme la table initiale en ajoutant le suffixe « _ANCIEN » au nom de la table. Il octroie alors un nom à la nouvelle requête en reprenant celui de la table initiale. Les formulaires et les états reposant sur cette table utilisent à présent la requête pour leurs données et fonctionnent comme auparavant.

  9. Cliquez sur Terminer.

    L’Assistant crée les nouvelles tables, comme indiqué, avant de les ouvrir. Fermez-les lorsque vous en avez fini avec l’inspection des résultats.

Haut de la page

Utiliser des données provenant d’autres programmes

Access 2010 offre des fonctionnalités permettant d’utiliser des données stockées dans d’autres programmes.

Créer une nouvelle base de données Access liée aux données dans un autre format de fichier    Vous pouvez utiliser Access pour ouvrir un fichier dans un autre format de fichier, comme un fichier texte ou dBASE ou une feuille de calcul. Access crée automatiquement une base de données Access et lie le fichier à votre place.

  1. Démarrez Access.

  2. Sous l’onglet Fichier, cliquez sur Ouvrir.

  3. Dans la boîte de dialogue Ouvrir, cliquez sur le type de fichier que vous souhaitez ouvrir dans la liste. Si vous ne savez pas quel type choisir, cliquez sur Tous les fichiers (*.*).

  4. Le cas échéant, accédez au dossier contenant le fichier à ouvrir. Le fichier localisé, double-cliquez dessus pour l’ouvrir.

  5. Suivez les instructions de l’Assistant. Dans la dernière page de l’Assistant, cliquez sur Terminer.

Importer ou lier des données à une base de données Access existante    Vous pouvez importer des données provenant d’autres sources et programmes vers des tables Access, afin que ces données soient comprises dans ce fichier Access. Une autre option consiste à créer dans Access une liaison vers ces données, qui de cette façon demeureront dans leur fichier initial (en dehors du fichier Access).

  1. Dans l’onglet Données externes, dans le groupe Importer et lier, cliquez sur le format utilisé pour stocker les données.

    Vous pouvez importer ou lier des données à partir des sources suivantes :

    • Excel    Vous pouvez récupérer des données d’une feuille de calcul ou d’une plage nommée dans un classeur Excel. Chaque feuille de calcul ou plage nommée doit être importée ou liée séparément.

    • Access    Ce format est très pratique pour séparer le processus des données, car elle permet de créer une base de données fractionnée. En d’autres termes, vous pouvez utiliser une base de données pour le stockage de l’ensemble des formulaires, des états et des macros, et une autre pour le stockage des données. Vous pouvez ensuite apporter des améliorations sans interrompre le travail d’un autre utilisateur. Vous pouvez également combiner des données provenant de diverses bases de données Access en une seule base de données, ce qui facilite la récapitulation de données concernant plusieurs départements ou partenaires commerciaux.

    • Base de données ODBC    De nombreux programmes prennent en charge ce format, notamment de nombreux serveurs de bases de données. Cela vous permet de créer des bases de données pouvant accueillir des données en provenance de différents systèmes.

    • Fichier texte    Vous pouvez vous connecter à un simple fichier texte et même utiliser Access pour modifier le contenu de ce fichier. Cela facilite l’utilisation de données Access par un large éventail de programmes.

    • Fichier XML    En outre, ce format est compatible avec de nombreux autres programmes, y compris avec certains serveurs Web.

    • Liste SharePoint    Ce format permet d’utiliser les données avec un navigateur Web, procédure standard pour recourir à une liste SharePoint.

    • Services de données    Vous pouvez vous connecter à des services de données Web au sein de votre entreprise.

    • Document HTML   

    • Dossier Outlook    Vous pouvez vous connecter à des dossiers Outlook, ce qui facilite l’intégration des informations de contact au reste des données.

    • Fichier dBASE    dBASE est un système de base de données alternatif courant pris en charge par Access

      La boîte de dialogue Données externes s’affiche.

  2. Suivez les instructions affichées dans la boîte de dialogue.

    Access importe les données dans votre base de données ou lie les données à votre base de données. Pour la plupart des formats de fichier, vous devez spécifier l’emplacement des données puis indiquer la façon dont celles-ci seront stockées dans la base de données.

Haut de la page

Utiliser une base de données de version antérieure dans plusieurs versions d’Access

Si votre base de données ou projet Access a été créé dans Access version 2000 ou ultérieure, vous pouvez l’utiliser dans la version d’Access qui a servi à sa création ou dans une version ultérieure, même si la sécurité du fichier est activée. Par exemple, les fichiers Access 2000 sont utilisables dans Access 2000, Access 2002, Access 2003, Access 2007 et Access 2010.

Dans certaines situations, vous souhaitez conserver vos données dans une version antérieure d'Access, mais des utilisateurs disposant d'une version ultérieure d'Access souhaitent se lier à ces données tout en bénéficiant de certaines fonctionnalités de la version ultérieure. La solution consiste à créer une nouvelle base de données "frontale" dans la version ultérieure (contenant formulaires, états, requêtes, macros, mais aucune table) et de la lier aux tables du fichier de la version précédente. Utilisez l'une des procédures suivantes, selon que votre base de données est contenue dans le seul fichier ou déjà fractionnée en une application frontale/principale.

Utiliser un fichier de base de données Access dans plusieurs versions d’Access

Si toutes les tables, formulaires et autres objets de votre base de données Access de version antérieure sont contenus dans un seul fichier et si vous voulez utiliser la base de données dans plusieurs versions d’Access, vous pouvez créer une nouvelle base de données frontale dans une version ultérieure et la lier au fichier d’origine. Les utilisateurs qui possèdent la version antérieure d’Access peuvent toujours utiliser la base de données d’origine. Les utilisateurs qui possèdent la version plus récente peuvent utiliser la nouvelle base de données frontale pour se lier aux mêmes données. Vous pouvez créer plusieurs versions frontales si vous devez prendre en charge plusieurs versions d’Access.

Haut de la page

Étape 1 : créer une copie de la base de données existante, puis l’enregistrer dans un nouveau format

Utilisez la procédure suivante pour convertir la base de données dans l'un des trois formats plus récentes : Access 2000, Access 2002-2003 ou Access 2007. Cette commande conserve la base de données d'origine dans son format d'origine et crée une copie dans le format que vous spécifiez.

  1. Fermez le fichier Access. S’il s’agit d’une base de données Access multi-utilisateur située sur un serveur ou dans un dossier partagé, assurez-vous qu’elle n’est pas ouverte par un autre utilisateur.

  2. Démarrage d'Access 2010.

  3. Sous l’onglet Fichier, cliquez sur Ouvrir.

  4. Parcourez l’arborescence jusqu’à accéder au fichier à convertir et double-cliquez dessus pour l’ouvrir.

    Remarque : Si la boîte de dialogue Amélioration de la base de données s’affiche vous demandant si vous souhaitez améliorer la base de données, cliquez sur Non.

  5. Si un formulaire s’ouvre au démarrage de la base de données, fermez-le.

  6. Sous l’onglet Fichier, cliquez sur Enregistrer la base de données sous.

  7. Dans la boîte de dialogue Enregistrer sous, tapez le nom de la nouvelle base de données.

    Remarque : À moins que vous sera enregistré la nouvelle base de données dans un autre emplacement, son nom doit être différent de celle de la base de données d'origine. Dans les deux cas, il est conseillé d'utiliser un nom différent, afin que vous pouvez facilement faire la distinction entre la base de données frontale et la base de données principale. Toutefois, si vous convertissez au format Access 2007, l'extension de nom de fichier .mdb est modifiée par .accdb, afin que vous pouvez utiliser le même nom de fichier.

  8. Cliquez sur Enregistrer.

Haut de la page

Étape 2 : fractionner la base de données de copie, puis utiliser le fichier d’origine comme base de données principale

Fractionnez la base de données convertie en utilisant la procédure suivante :

  • Sous l’onglet Outils de base de données, dans le groupe Déplacer les données, cliquez sur Base de données Access. Image du bouton

  • Dans la boîte de dialogue Assistant Fractionnement de base de données, cliquez sur Fractionner la base de données.

    Remarque : Vous pouvez effectuer une sauvegarde si vous le souhaitez, mais vous pouvez également vous contenter de recréer la copie à l’aide de la base de données d’origine.

  • Tapez le nom de la base de données principale, puis cliquez sur Fractionner.

Haut de la page

Étape 3 : connecter la nouvelle base de données frontale à la base de données d’origine

  1. Supprimez la base de données principale que l’Assistant Fractionnement de base de données a créée tout en veillant à ne pas supprimer la base de données d’origine.

  2. Liez la nouvelle base de données frontale aux tables de la base de données d’origine : sous l’onglet Données externes, dans le groupe Importer et lier, cliquez sur Gestionnaire d’attaches. Image du bouton

  3. Cliquez sur Sélectionner tout puis activez la case à cocher Toujours demander un nouvel emplacement.

  4. Cliquez sur OK, accédez à la base de données de version antérieure et double-cliquez dessus.

    Si l’opération se passe bien, Access affiche un message indiquant que toutes les tables attachées sélectionnées ont été actualisées correctement.

Vous pouvez à présent optimiser la nouvelle base de données frontale afin qu’elle prenne en charge de nouvelles fonctionnalités pour les utilisateurs qui possèdent des versions plus récentes d’Access. Les utilisateurs dotés d’une version antérieure du programme peuvent continuer à utiliser la base de données d’origine.

Haut de la page

Utiliser une application frontale/principale dans plusieurs versions d’Access

Si votre base de données Access est déjà une application frontale/principale, vous pouvez convertir le serveur frontal vers le nouveau format de fichier. Aucune modification n'est nécessaire pour la base de données principale.

La procédure suivante vous montre comment utiliser la commande Enregistrer la base de données sous pour convertir la base de données frontale à l'un des trois formats plus récentes : Access 2000, Access 2002-2003 ou Access 2007. Cette commande conserve la base de données d'origine dans son format d'origine et crée une copie dans le format que vous spécifiez.

  1. Fermez la base de données frontale. S’il s’agit d’une base de données Access multi-utilisateur située sur un serveur ou dans un dossier partagé, assurez-vous qu’elle n’est pas ouverte par un autre utilisateur.

  2. Démarrage d'Access 2010.

  3. Sous l’onglet Fichier, cliquez sur Ouvrir.

  4. Parcourez l’arborescence jusqu’à accéder à la base de données frontale, puis double-cliquez sur celle-ci pour l’ouvrir.

    Remarque : Si la boîte de dialogue Amélioration de la base de données s’affiche vous demandant si vous souhaitez améliorer la base de données, cliquez sur Non.

  5. Si un formulaire s’affiche à l’ouverture de la base de données, fermez-le.

  6. Sous l’onglet Fichier, cliquez sur Enregistrer la base de données sous.

  7. Dans la boîte de dialogue Enregistrer sous, tapez le nom de la nouvelle base de données.

  8. Cliquez sur Enregistrer.

Vous pouvez à présent optimiser la nouvelle base de données frontale afin qu’elle prenne en charge de nouvelles fonctionnalités.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Ces informations vous ont-elles été utiles ?

Comment pouvons-nous nous améliorer ?

Comment pouvons-nous nous améliorer ?

Afin de protéger votre vie privée, n’indiquez aucune information de contact dans vos commentaires. Lisez notre déclaration de confidentialité.

Nous vous remercions pour vos commentaires.