Signer numériquement votre projet macro

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Cet article explique comment signer numériquement un projet macro à l’aide d’un certificat. Si vous ne possédez pas encore de certificat numérique, procurez-vous-en un. Pour tester des projets macro sur votre ordinateur, vous pouvez créer votre propre certificat de signature automatique à l’aide de l’outil Selfcert.exe.

Contenu de cet article

Obtenir un certificat numérique de signature

Vos projets macro et Microsoft Office

Créer un certificat auto-signé

Signer numériquement un projet macro dans Excel, PowerPoint, Publisher, Visio ou Word

Obtenir un certificat numérique de signature

Vous pouvez obtenir un certificat numérique auprès d’une autorité de certification ou auprès de l’administrateur de la sécurité informatique de votre entreprise.

Pour en savoir plus sur les autorités de certification qui proposent des services pour les produits Microsoft, consultez la liste des membres du programme de certificat racine Microsoft.

Haut de la page

Vos projets macro et Microsoft Office

Étant donné qu’un certificat numérique que vous créez n’est pas émis par une autorité de certification approuvée formel, projets de macro qui sont connectés à l’aide de ce type de certificat sont appelés projets auto-signé. Microsoft Office approuve un certificat auto-signé uniquement sur un ordinateur qui comporte le certificat d’auto-signature ajouté à la banque de dossiers de Certification racine de confiance dans les certificats - utilisateur actuel.

Pour apprendre à créer un certificat d’auto-signature, consultez la section suivante.

Créer un certificat auto-signé

Windows 7, Windows Vista ou Windows XP

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, cliquez sur Microsoft Office, sur Outils Microsoft Office, puis sur Certificat numérique pour les projets VBA.
    La boîte de dialogue Créer un certificat numérique apparaît.

  2. Dans le champ Nom de votre certificat, entrez un nom descriptif pour le certificat.

  3. Cliquez sur OK.

  4. Lorsque le message Succès de SelfCert s’affiche, cliquez sur OK.

Boîte de dialogue Créer un certificat numérique

Afficher le certificat à l’aide d’Internet Explorer

Pour afficher le certificat placé dans le magasin de certificats personnels :

  1. Ouvrez Internet Explorer.

  2. Dans le menu Outils, cliquez sur Options Internet, puis sur l’onglet Contenu.

  3. Cliquez sur Certificats, puis sur l’onglet Personnel.

Haut de la page

Signer numériquement un projet macro dans Excel, PowerPoint, Publisher, Visio, Outlook ou Word

  1. Ouvrez le fichier qui contient le projet macro à signer.

  2. Sous l’onglet Développeur, dans le groupe Code, cliquez sur Visual Basic.

    Remarque : Si l’onglet Développeur n’est pas disponible : cliquez sur l’onglet Fichier, sur Options, puis sur Personnaliser le ruban. Dans la liste Personnaliser le ruban, cliquez sur Développeur, puis sur OK.

  3. Dans Visual Basic, dans le menu Outils, cliquez sur Signature numérique.

  4. La boîte de dialogue Signature numérique s’affiche.

  5. Sélectionnez un certificat et cliquez sur OK.

    Remarque : Si vous n’avez pas sélectionné de certificat numérique ou si vous voulez en utiliser un autre, cliquez sur Choisir, sélectionnez le certificat et cliquez sur OK.

    Remarques : 

    • Il est recommandé de ne signer les macros qu’après que votre solution soit testée et prête à être distribuée, car toute modification du code d’un projet macro signé entraîne la suppression de sa signature numérique. Toutefois, si vous disposez sur votre ordinateur du certificat numérique valide précédemment utilisé pour signer le projet, le projet macro est automatiquement resigné lors de l’enregistrement.

    • Pour empêcher que les utilisateurs de votre solution ne modifient accidentellement votre projet macro et ainsi n’invalident votre signature, verrouillez-le avant de le signer. Votre signature numérique garantit que le projet n’a pas été falsifié depuis sa signature ; elle ne prouve aucunement que vous avez rédigé le projet. Verrouiller le projet macro n’empêche toutefois pas un autre utilisateur de remplacer la signature numérique par une autre. Les administrateurs d’entreprise peuvent resigner les modèles et les compléments afin de contrôler ce que les utilisateurs exécutent sur leur ordinateur.

    • Si vous créez un complément qui ajoute du code à un projet macro, votre code doit déterminer si le projet est signé numériquement et indiquer aux utilisateurs les conséquences de la modification d’un projet signé avant de continuer.

    • Lorsque vous signez numériquement des macros, il est important d’obtenir un horodatage afin que les autres utilisateurs puissent vérifier votre signature si le certificat utilisé pour la signature est arrivé à expiration ou a été révoqué après signature. Si vous signez des macros sans horodatage, la signature reste valide uniquement pour la période de votre certificat.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×