Signer numériquement votre projet macro

Cet article explique comment signer numériquement un projet macro à l’aide d’un certificat. Si vous ne possédez pas encore de certificat numérique, procurez-vous-en un. Pour tester des projets macro sur votre ordinateur, vous pouvez créer votre propre certificat de signature automatique à l’aide de l’outil Selfcert.exe.

Vous pouvez obtenir un certificat numérique auprès d’une autorité de certification ou auprès de l’administrateur de la sécurité informatique de votre entreprise.

Pour en savoir plus sur les autorités de certification qui proposent des services pour les produits Microsoft, consultez la liste des Membres du programme de certificat racine Microsoft.

Haut de la page

Dans la mesure où les certificats numériques que vous créez ne sont pas émis par une autorité de certification approuvée officielle, les projets macro signés à l’aide de ce type de certificat sont appelés projets auto-signés. Microsoft Office n’approuve les certificats auto-signés que sur les ordinateurs où le certificat d’auto-signature est ajouté au dossier Autorités de certification racines de confiance dans le magasin de certificats de l’utilisateur actuel.

Pour apprendre à créer un certificat d’auto-signature, reportez-vous à la section suivante.

  1. Accédez à C:\Program Files (x86)\Microsoft Office\root\.

  2. Cliquez sur SelfCert.exe. La boîte de dialogue Créer un certificat numérique s’affiche.

  3. Dans le champ Nom de votre certificat, entrez un nom descriptif pour le certificat.

  4. Cliquez sur OK.

  5. Lorsque le message Succès de SelfCert s’affiche, cliquez sur OK.

  1. Accédez à C:\Program Files\Microsoft Office\<version d’Office>\.

  2. Cliquez sur SelfCert.exe. La boîte de dialogue Créer un certificat numérique s’affiche.

  3. Dans le champ Nom de votre certificat, entrez un nom descriptif pour le certificat.

  4. Cliquez sur OK.

  5. Lorsque le message Succès de SelfCert s’affiche, cliquez sur OK.

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, puis cliquez sur Microsoft Office, Outils Microsoft Office et Certificat numérique pour les projets VBA.
    La boîte de dialogue Créer un certificat numérique s’affiche.

  2. Dans le champ Nom de votre certificat, entrez un nom descriptif pour le certificat.

  3. Cliquez sur OK.

  4. Lorsque le message Succès de SelfCert s’affiche, cliquez sur OK.

Boîte de dialogue Créer une signature numérique

Pour afficher le certificat placé dans le magasin de certificats personnels :

  1. Ouvrez Internet Explorer.

  2. Dans le menu Outils, cliquez sur Options Internet, puis sur l’onglet Contenu.

  3. Cliquez sur Certificats, puis sur l’onglet Personnel.

Haut de la page

  1. Ouvrez le fichier qui contient le projet macro à signer.

  2. Sous l’onglet Développeur, dans le groupe Code, cliquez sur Visual Basic.

    Remarque : Si l’onglet Développeur n’est pas disponible : cliquez sur l’onglet Fichier, sur Options, puis sur Personnaliser le ruban. Dans la liste Personnaliser le ruban, cliquez sur Développeur, puis sur OK.

  3. Dans Visual Basic, dans le menu Outils, cliquez sur Signature numérique.

  4. La boîte de dialogue Signature numérique s’affiche.

  5. Sélectionnez un certificat et cliquez sur OK.

    Remarque : Si vous n’avez pas sélectionné de certificat numérique ou si vous voulez en utiliser un autre, cliquez sur Choisir, sélectionnez le certificat et cliquez sur OK.

    Remarques : 

    • Il est recommandé de ne signer les macros qu’après que votre solution soit testée et prête à être distribuée, car toute modification du code d’un projet macro signé entraîne la suppression de sa signature numérique. Toutefois, si vous disposez sur votre ordinateur du certificat numérique valide précédemment utilisé pour signer le projet, le projet macro est automatiquement resigné lors de l’enregistrement.

    • Pour empêcher que les utilisateurs de votre solution ne modifient accidentellement votre projet macro et ainsi n’invalident votre signature, verrouillez-le avant de le signer. Votre signature numérique garantit que le projet n’a pas été falsifié depuis sa signature ; elle ne prouve aucunement que vous avez rédigé le projet. Verrouiller le projet macro n’empêche toutefois pas un autre utilisateur de remplacer la signature numérique par une autre. Les administrateurs d’entreprise peuvent resigner les modèles et les compléments afin de contrôler ce que les utilisateurs exécutent sur leur ordinateur.

    • Si vous créez un complément qui ajoute du code à un projet macro, votre code doit déterminer si le projet est signé numériquement et indiquer aux utilisateurs les conséquences de la modification d’un projet signé avant de continuer.

    • Lorsque vous signez numériquement des macros, il est important d’obtenir un horodatage afin que les autres utilisateurs puissent vérifier votre signature si le certificat utilisé pour la signature est arrivé à expiration ou a été révoqué après signature. Si vous signez des macros sans horodatage, la signature reste valide uniquement pour la période de votre certificat.

Haut de la page

Vous pouvez vous procurer un certificat numérique auprès d’une autorité de certification commerciale ou de votre administrateur sécurité.

Pour en savoir plus sur les autorités de certification qui proposent des services pour les produits Microsoft, consultez la liste des Membres du programme de certificat racine Microsoft.

Haut de page

Puisqu’un certificat numérique que vous créez n’est pas émis par une autorité de certification formelle, les projets de macro qui sont signés à l’aide de ce type de certificat sont appelés « projets auto-signés ». Microsoft Office approuve un certificat auto-signé uniquement sur un ordinateur possédant un certificat dans le magasin de certificats personnels.

  1. Cliquez sur le bouton Démarrer, pointez sur Tous les programmes, puis cliquez sur Microsoft Office, Outils Microsoft Office et Certificat numérique pour les projets VBA. Dans le champ Nom de votre certificat, entrez un nom descriptif pour le certificat.

  2. Lorsque le message de confirmation du certificat s’affiche, cliquez sur OK.

Pour afficher le certificat placé dans le magasin de certificats personnels :

  1. Ouvrez Internet Explorer.

  2. Dans le menu Outils, cliquez sur Options Internet, puis sur l’onglet Contenu.

  3. Cliquez sur Certificats, puis sur l’onglet Personnel.

Haut de page

  1. Cliquez sur le bouton Démarrer, pointez successivement sur Tous les programmes, Microsoft Office et Outils Microsoft Office, puis cliquez sur Certificat numérique pour les projets VBA. Dans le champ Nom de votre certificat, entrez un nom descriptif pour le certificat.

  2. Lorsque le message de confirmation du certificat s’affiche, cliquez sur OK.

Pour afficher le certificat placé dans le magasin de certificats personnels :

  1. Ouvrez Windows Internet Explorer.

  2. Dans le menu Outils, cliquez sur Options Internet, puis sur l’onglet Contenu.

  3. Cliquez sur Certificats, puis sur l’onglet Personnel.

Haut de page

  1. Ouvrez le fichier contenant le projet macro à signer.

    • Dans l’onglet Développeur, accédez au groupe Code et cliquez sur Visual Basic.

      Si l’onglet Développeur n’est pas disponible, cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Options Excel. Cliquez ensuite sur Standard, puis cochez la case Afficher l’onglet Développeur dans le ruban.

      Remarque : Le ruban est un composant de l’Interface utilisateur Microsoft Office Fluent

  2. Dans l’Explorateur de projets de Visual Basic, sélectionnez le projet à signer.

  3. Dans le menu Outils, cliquez sur Signature numérique.

  4. Effectuez l’une des opérations suivantes :

    • Si vous n’avez sélectionné aucun certificat numérique ou si vous souhaitez en utiliser un autre, cliquez sur Choisir, sélectionnez le certificat, puis cliquez sur OK à deux reprises.

    • Pour utiliser le certificat actuel, cliquez sur OK.

      Remarques : 

      • Ne signez les macros qu’une fois votre solution testée et prête à être distribuée, car toute modification du code d’un projet macro signé entraîne la suppression de sa signature numérique. Toutefois, si vous disposez sur votre ordinateur du certificat numérique valide précédemment utilisé pour signer le projet, une nouvelle signature du projet macro interviendra automatiquement lors de l’enregistrement.

      • Pour éviter que les utilisateurs de votre solution ne modifient accidentellement votre projet macro et n’invalident votre signature, verrouillez-le avant de le signer. Votre signature numérique garantit que le projet n’a pas été falsifié depuis que vous l’avez signé, mais elle ne prouve aucunement que vous avez rédigé le projet. Ainsi, le verrouillage du projet macro n’empêche pas un autre utilisateur de remplacer la signature numérique par une autre. Les administrateurs d’entreprise peuvent à nouveau signer les modèles et les compléments afin de déterminer avec précision ce que les utilisateurs peuvent exécuter sur leur ordinateur.

      • Si vous créez un complément qui ajoute du code à un projet macro, votre code doit déterminer si le projet est signé numériquement et indiquer aux utilisateurs les conséquences de la modification d’un projet signé avant de continuer.

      • Lorsque vous signez numériquement des macros, il est important d’obtenir un horodatage afin que les autres utilisateurs puissent vérifier votre signature, même si le certificat utilisé pour la signature est arrivé à expiration. Si vous signez des macros sans horodatage, la signature n’est valide que pour la période de validité de votre certificat.

  1. Ouvrez le fichier contenant le projet macro à signer.

    • Dans le menu Outils, pointez sur Macro, puis cliquez sur Visual Basic Editor.

  2. Dans l’Explorateur de projets de Visual Basic, sélectionnez le projet à signer.

  3. Dans le menu Outils, cliquez sur Signature numérique.

  4. Effectuez l’une des opérations suivantes :

    • Si vous n’avez sélectionné aucun certificat numérique ou si vous souhaitez en utiliser un autre, cliquez sur Choisir, sélectionnez le certificat, puis cliquez sur OK à deux reprises.

    • Pour utiliser le certificat actuel, cliquez sur OK.

      Remarques : 

      • Ne signez les macros qu’une fois votre solution testée et prête à être distribuée, car toute modification du code d’un projet macro signé entraîne la suppression de sa signature numérique. Toutefois, si vous disposez sur votre ordinateur du certificat numérique valide précédemment utilisé pour signer le projet, une nouvelle signature du projet macro interviendra automatiquement lors de l’enregistrement.

      • Pour éviter que les utilisateurs de votre solution ne modifient accidentellement votre projet macro et n’invalident votre signature, verrouillez-le avant de le signer. Votre signature numérique garantit que le projet n’a pas été falsifié depuis que vous l’avez signé, mais elle ne prouve aucunement que vous avez rédigé le projet. Ainsi, le verrouillage du projet macro n’empêche pas un autre utilisateur de remplacer la signature numérique par une autre. Les administrateurs d’entreprise peuvent à nouveau signer les modèles et les compléments afin de déterminer avec précision ce que les utilisateurs peuvent exécuter sur leur ordinateur.

      • Si vous créez un complément qui ajoute du code à un projet macro, votre code doit déterminer si le projet est signé numériquement et indiquer aux utilisateurs les conséquences de la modification d’un projet signé avant de continuer.

      • Lorsque vous signez numériquement des macros, il est important d’obtenir un horodatage afin que les autres utilisateurs puissent vérifier votre signature, même si le certificat utilisé pour la signature est arrivé à expiration. Si vous signez des macros sans horodatage, la signature n’est valide que pour la période de validité de votre certificat.

Haut de page

  1. Ouvrez le fichier qui contient le projet macro à signer.

    • Sous l’onglet Développeur, dans le groupe Code, cliquez sur Visual Basic.

      Si l’onglet Développeur n’est pas disponible, cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Options PowerPoint. Cliquez ensuite sur Standard, puis cochez la case Afficher l’onglet Développeur dans le ruban.

      Remarque : Le ruban est un composant de l’Interface utilisateur Microsoft Office Fluent

  2. Dans l’Explorateur de projets de Visual Basic, sélectionnez le projet à signer.

  3. Dans le menu Outils, cliquez sur Signature numérique.

  4. Effectuez l’une des opérations suivantes :

    • Si vous n’avez sélectionné aucun certificat numérique ou si vous souhaitez en utiliser un autre, cliquez sur Choisir, sélectionnez le certificat, puis cliquez sur OK à deux reprises.

    • Pour utiliser le certificat actuel, cliquez sur OK.

      Remarques : 

      • Ne signez les macros qu’une fois votre solution testée et prête à être distribuée, car toute modification du code d’un projet macro signé entraîne la suppression de sa signature numérique. Toutefois, si vous disposez sur votre ordinateur du certificat numérique valide précédemment utilisé pour signer le projet, une nouvelle signature du projet macro interviendra automatiquement lors de l’enregistrement.

      • Pour éviter que les utilisateurs de votre solution ne modifient accidentellement votre projet macro et n’invalident votre signature, verrouillez-le avant de le signer. Votre signature numérique garantit que le projet n’a pas été falsifié depuis que vous l’avez signé, mais elle ne prouve aucunement que vous avez rédigé le projet. Ainsi, le verrouillage du projet macro n’empêche pas un autre utilisateur de remplacer la signature numérique par une autre. Les administrateurs d’entreprise peuvent à nouveau signer les modèles et les compléments afin de déterminer avec précision ce que les utilisateurs peuvent exécuter sur leur ordinateur.

      • Si vous créez un complément qui ajoute du code à un projet macro, votre code doit déterminer si le projet est signé numériquement et indiquer aux utilisateurs les conséquences de la modification d’un projet signé avant de continuer.

      • Lorsque vous signez numériquement des macros, il est important d’obtenir un horodatage afin que les autres utilisateurs puissent vérifier votre signature, même si le certificat utilisé pour la signature est arrivé à expiration. Si vous signez des macros sans horodatage, la signature n’est valide que pour la période de validité de votre certificat.

Haut de page

  1. Ouvrez le fichier contenant le projet macro à signer.

    • Dans le menu Outils, pointez sur Macro, puis cliquez sur Visual Basic Editor.

  2. Dans l’Explorateur de projets de Visual Basic, sélectionnez le projet à signer.

  3. Dans le menu Outils, cliquez sur Signature numérique.

  4. Effectuez l’une des opérations suivantes :

    • Si vous n’avez sélectionné aucun certificat numérique ou si vous souhaitez en utiliser un autre, cliquez sur Choisir, sélectionnez le certificat, puis cliquez sur OK à deux reprises.

    • Pour utiliser le certificat actuel, cliquez sur OK.

      Remarques : 

      • Ne signez les macros qu’une fois votre solution testée et prête à être distribuée, car toute modification du code d’un projet macro signé entraîne la suppression de sa signature numérique. Toutefois, si vous disposez sur votre ordinateur du certificat numérique valide précédemment utilisé pour signer le projet, une nouvelle signature du projet macro interviendra automatiquement lors de l’enregistrement.

      • Pour éviter que les utilisateurs de votre solution ne modifient accidentellement votre projet macro et n’invalident votre signature, verrouillez-le avant de le signer. Votre signature numérique garantit que le projet n’a pas été falsifié depuis que vous l’avez signé, mais elle ne prouve aucunement que vous avez rédigé le projet. Ainsi, le verrouillage du projet macro n’empêche pas un autre utilisateur de remplacer la signature numérique par une autre. Les administrateurs d’entreprise peuvent à nouveau signer les modèles et les compléments afin de déterminer avec précision ce que les utilisateurs peuvent exécuter sur leur ordinateur.

      • Si vous créez un complément qui ajoute du code à un projet macro, votre code doit déterminer si le projet est signé numériquement et indiquer aux utilisateurs les conséquences de la modification d’un projet signé avant de continuer.

      • Lorsque vous signez numériquement des macros, il est important d’obtenir un horodatage afin que les autres utilisateurs puissent vérifier votre signature, même si le certificat utilisé pour la signature est arrivé à expiration. Si vous signez des macros sans horodatage, la signature n’est valide que pour la période de validité de votre certificat.

Haut de page

  1. Ouvrez le fichier contenant le projet macro à signer.

    • Dans le menu Outils, pointez sur Macro, puis cliquez sur Visual Basic Editor.

  2. Dans l’Explorateur de projets de Visual Basic, sélectionnez le projet à signer.

  3. Dans le menu Outils, cliquez sur Signature numérique.

  4. Effectuez l’une des opérations suivantes :

    • Si vous n’avez sélectionné aucun certificat numérique ou si vous souhaitez en utiliser un autre, cliquez sur Choisir, sélectionnez le certificat, puis cliquez sur OK à deux reprises.

    • Pour utiliser le certificat actuel, cliquez sur OK.

      Remarques : 

      • Ne signez les macros qu’une fois votre solution testée et prête à être distribuée, car toute modification du code d’un projet macro signé entraîne la suppression de sa signature numérique. Toutefois, si vous disposez sur votre ordinateur du certificat numérique valide précédemment utilisé pour signer le projet, une nouvelle signature du projet macro interviendra automatiquement lors de l’enregistrement.

      • Pour éviter que les utilisateurs de votre solution ne modifient accidentellement votre projet macro et n’invalident votre signature, verrouillez-le avant de le signer. Votre signature numérique garantit que le projet n’a pas été falsifié depuis que vous l’avez signé, mais elle ne prouve aucunement que vous avez rédigé le projet. Ainsi, le verrouillage du projet macro n’empêche pas un autre utilisateur de remplacer la signature numérique par une autre. Les administrateurs d’entreprise peuvent à nouveau signer les modèles et les compléments afin de déterminer avec précision ce que les utilisateurs peuvent exécuter sur leur ordinateur.

      • Si vous créez un complément qui ajoute du code à un projet macro, votre code doit déterminer si le projet est signé numériquement et indiquer aux utilisateurs les conséquences de la modification d’un projet signé avant de continuer.

      • Lorsque vous signez numériquement des macros, il est important d’obtenir un horodatage afin que les autres utilisateurs puissent vérifier votre signature, même si le certificat utilisé pour la signature est arrivé à expiration. Si vous signez des macros sans horodatage, la signature n’est valide que pour la période de validité de votre certificat.

  1. Ouvrez le fichier qui contient le projet macro à signer.

    • Sous l’onglet Développeur, dans le groupe Code, cliquez sur Visual Basic.

      Si l’onglet Développeur n’est pas disponible, cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Options Word. Cliquez ensuite sur Standard, puis cochez la case Afficher l’onglet Développeur dans le ruban.

      Remarque : Le ruban est un composant de l’Interface utilisateur Microsoft Office Fluent

  2. Dans l’Explorateur de projets de Visual Basic, sélectionnez le projet à signer.

  3. Dans le menu Outils, cliquez sur Signature numérique.

  4. Effectuez l’une des opérations suivantes :

    • Si vous n’avez sélectionné aucun certificat numérique ou si vous souhaitez en utiliser un autre, cliquez sur Choisir, sélectionnez le certificat, puis cliquez sur OK à deux reprises.

    • Pour utiliser le certificat actuel, cliquez sur OK.

      Remarques : 

      • Ne signez les macros qu’une fois votre solution testée et prête à être distribuée, car toute modification du code d’un projet macro signé entraîne la suppression de sa signature numérique. Toutefois, si vous disposez sur votre ordinateur du certificat numérique valide précédemment utilisé pour signer le projet, une nouvelle signature du projet macro interviendra automatiquement lors de l’enregistrement.

      • Pour éviter que les utilisateurs de votre solution ne modifient accidentellement votre projet macro et n’invalident votre signature, verrouillez-le avant de le signer. Votre signature numérique garantit que le projet n’a pas été falsifié depuis que vous l’avez signé, mais elle ne prouve aucunement que vous avez rédigé le projet. Ainsi, le verrouillage du projet macro n’empêche pas un autre utilisateur de remplacer la signature numérique par une autre. Les administrateurs d’entreprise peuvent à nouveau signer les modèles et les compléments afin de déterminer avec précision ce que les utilisateurs peuvent exécuter sur leur ordinateur.

      • Si vous créez un complément qui ajoute du code à un projet macro, votre code doit déterminer si le projet est signé numériquement et indiquer aux utilisateurs les conséquences de la modification d’un projet signé avant de continuer.

      • Lorsque vous signez numériquement des macros, il est important d’obtenir un horodatage afin que les autres utilisateurs puissent vérifier votre signature, même si le certificat utilisé pour la signature est arrivé à expiration. Si vous signez des macros sans horodatage, la signature n’est valide que pour la période de validité de votre certificat.

Haut de page

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×