SOMMEPROD (SOMMEPROD, fonction)

Cet article décrit la syntaxe de la formule et l’utilisation de la fonctionSOMMEPROD dans Microsoft Excel.

Description

Multiplie les valeurs correspondantes des matrices spécifiées et calcule la somme de ces produits.

Syntaxe

SOMMEPROD(matrice1, [matrice2], [matrice3], ...)

La syntaxe de la fonction SOMMEPROD contient les argument suivants :

  • matrice1     Obligatoire. Représente le premier argument de matrice dont vous voulez multiplier les valeurs pour ensuite additionner leur produit.

  • matrice2; matrice3;...     Facultatif. Arguments de matrices 2 à 255 dont vous voulez multiplier les valeurs pour ensuite additionner leur produit.

Notes

  • Les matrices spécifiées comme arguments doivent avoir la même dimension. Si tel n’est pas le cas, SOMMEPROD renvoie la valeur d’erreur #VALEUR!.

  • SOMMEPROD affecte aux entrées de matrice non numériques la valeur zéro.

Exemple

Le classeur ci-dessous montre des exemples de cette fonction. Consultez-les, modifiez les formules existantes ou entrez vos propres formules pour apprendre à maîtriser le fonctionnement de la formule.

Copiez les données d’exemple dans le tableau suivant, et collez-le dans la cellule A1 d’un nouveau classeur Excel. Pour que les formules affichent des résultats, sélectionnez-les, appuyez sur F2, et sur Entrée. Si nécessaire, vous pouvez modifier la largeur des colonnes pour afficher toutes les données.

Matrice 1

Matrice 2

3

4

2

7

8

6

6

7

1

9

5

3

Formule

Description

Résultat

=SOMMEPROD(A2:B4;D2:E4)

Multiplie toutes les valeurs des deux matrices, puis additionne les produits ; c’est-à-dire : 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156)

156

Pour travailler de manière approfondie avec les données d’exemple dans Excel, téléchargez le classeur incorporé sur votre ordinateur, puis ouvrez-le dans Excel.

S’applique à : Excel 2013, Excel Online



Ces informations vous ont-elles été utiles ?

Oui Non

Comment pouvons-nous nous améliorer ?

255 caractères restants

Afin de protéger votre vie privée, n’indiquez aucune information de contact dans vos commentaires. Lisez notre déclaration de confidentialité.

Nous vous remercions pour vos commentaires.

Ressources de support

Changer la langue