SIERREUR (SIERREUR, fonction)

Cet article décrit la syntaxe de la formule et l’utilisation de la fonction SIERREUR dans Microsoft Excel.

Description

Renvoie une valeur que vous spécifiez si une formule génère une erreur ; sinon, elle renvoie le résultat de la formule. La fonction SIERREUR permet d’intercepter et de gérer des erreurs présentes dans une formule.

Syntaxe

SIERREUR(valeur;valeur_si_erreur)

La syntaxe de la fonction SIERREUR contient les arguments suivants :

  • Valeur    Obligatoire. Représente l’argument vérifié.

  • Valeur_si_erreur    Obligatoire. Représente la valeur à renvoyer si une formule génère une erreur. Les types d’erreur suivants sont évalués : #N/A, #VALEUR!, #REF!, #DIV/0!, #NOMBRE!, #NOM?, ou #NUL!.

Remarques

  • Si l’argument valeur ou valeur_si_erreur est une cellule vide, la fonction SIERREUR la considère comme une valeur de chaîne vide ("").

  • Si l’argument valeur est une formule matricielle, la fonction SIERREUR renvoie une matrice de résultats pour chaque cellule de la plage spécifiée dans l’argument valeur. Voir le second exemple ci-dessous.

Exemples

Copiez les données d’exemple dans le tableau suivant, et collez-le dans la cellule A1 d’un nouveau classeur Excel. Pour que les formules affichent des résultats, sélectionnez-les, appuyez sur F2, et sur Entrée. Si nécessaire, vous pouvez modifier la largeur des colonnes pour afficher toutes les données.

Quota

Unités vendues

210

35

55

0

23

Formule

Description

Résultat

=SIERREUR(A2/B2, "Erreur de calcul")

Recherche une erreur dans le premier argument de la formule (divise 210 par 35), ne trouve aucune erreur, puis renvoie le résultat de la formule.

6

=SIERREUR(A3/B3, "Erreur de calcul")

Recherche une erreur dans le premier argument de la formule (divise 55 par 0), trouve une erreur de division par 0, puis renvoie l’argument valeur_si_erreur.

Erreur de calcul

=SIERREUR(A4/B4, "Erreur de calcul")

Recherche une erreur dans le premier argument de la formule (divise "" par 23), ne trouve aucune erreur, puis renvoie le résultat de la formule.

0

Exemple 2

Quota

Unités vendues

Rapport

210

35

6

55

0

Erreur de calcul

23

0

Formule

Description

Résultat

=C2

Recherche une erreur dans le premier argument du premier élément de la matrice de la formule (A2/B2 ou divise 210 par 35), ne trouve aucune erreur, puis renvoie le résultat de la formule.

6

=C3

Recherche une erreur dans le premier argument du second élément de la matrice de la formule (A3/B3 ou divise 55 par 0), trouve une erreur de division par 0, puis renvoie l’argument valeur_si_erreur.

Erreur de calcul

=C4

Recherche une erreur dans le premier argument du troisième élément de la matrice de la formule (A2/B4 ou divise "" par 35), ne trouve aucune erreur, puis renvoie le résultat de la formule.

0

Remarque : la formule de cet exemple doit être entrée en tant que formule matricielle. Après avoir copié l’exemple dans une feuille de calcul vide, sélectionnez la plage C2:C4, appuyez sur F2, puis sur Ctrl+Maj+Entrée.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×