Sélection et utilisation des modèles Access 2007

Contenu de cet article

Vue d’ensemble

Étape 1: Sélection d’un modèle

Étape 2 : Personnalisation d’un modèle

Étape 3 : Ajout de données à votre nouvelle base de données

Étape 4 : Localisation d’enregistrements


Vue d’ensemble

Pour faciliter la création d’une base de données efficace, Microsoft Office Access propose divers modèles de base de données professionnels. Chaque modèle constitue une solution de bout en bout complète que vous pouvez utiliser sans modification ou personnaliser pour l’adapter à vos besoins. Chaque modèle contient des tables prédéfinies, des formulaires, des états, des requêtes, des macros et des relations qui peuvent vous inspirer pour personnaliser votre propre base de données.

En outre, vous pouvez facilement télécharger d’autres modèles de base de données Access à partir du site Web Microsoft Office Online en cliquant sur les liens correspondants dans Access. Après avoir sélectionné un modèle et l’avoir personnalisé en fonction de vos besoins, vous pouvez ajouter des données et commencer à explorer les enregistrements.

Étape 1: Sélection d’un modèle

Vous pouvez sélectionner un modèle installé avec Access ou rechercher un modèle en ligne.

Sélection d’un modèle installé

  1. Dans la fenêtre Prise en main de Microsoft Office Access, sous Catégories de modèles, cliquez sur Mes modèles.

    Liste des modèles disponibles    

Modèle

Pour

Biens

Assurer le suivi des biens, y compris les détails et propriétaires de ces biens. Vous pouvez placer les biens dans des catégories et enregistrer leur condition, leur date d’acquisition, leur emplacement et leur propriétaire.

Contacts

Gérer des informations sur les personnes avec lesquelles votre équipe travaille, telles que des clients et des partenaires. Vous pouvez assurer le suivi de leur nom et adresse, numéro de téléphone, adresse de messagerie, et même joindre une image.

Événements

Assurer le suivi des réunions prévues, des délais et d’autres événements importants. Enregistrez un titre, un emplacement, des heures de début et de fin et une description et joignez également une image.

Enseignants

Gérer des informations importantes sur les enseignants, comme les numéros de téléphone, les adresses, les personnes à contacter en cas d’urgence et les données d’emploi.

Problèmes

Gérer et assurer le suivi des problèmes. Vous pouvez affecter, définir les priorités, et suivre la progression des problèmes du début à la fin.

Projets de marketing

Gérer les détails d’un projet de marketing et planifier, puis surveiller les livrables de projet.

Projets

Gérer les tâches et assurer le suivi du budget d’un ou plusieurs projets.

Pipeline des ventes

Suivre la progression des ventes à venir au sein d’un petit groupe de professionnels de la vente.

Étudiants

Assurer le suivi des informations sur les étudiants, comme les personnes à contacter en cas d’urgence, les informations sur les tuteurs ou d’ordre médical.

Tâches

Assurer le suivi d’un groupe de tâches que vous ou votre équipe doit réaliser.

Northwind 2007

Créer un système de suivi des factures. Vous devez supprimer les données incluses à titre d’exemple.

  1. Cliquez sur le modèle sur lequel vous voulez modéliser votre base de données.

  2. Dans la zone Nom du fichier, tapez un nom pour votre base de données.

  3. Pour sélectionner un emplacement spécifique pour la nouvelle base de données, cliquez sur l’icône de fichier à côté de la zone Nom du fichier.

    Conseil : Pour lier la base de données à un site Windows SharePoint Services, activez la case à cocher Crée et lie votre base de données à un site Windows SharePoint Services.

  4. Cliquez sur Créer.

Votre nouvelle base de données est maintenant prête à l’utilisation et vous pouvez la personnaliser comme vous le souhaitez.

Sélection d’un modèle en ligne

  1. Dans la fenêtre Prise en main de Microsoft Office Access, procédez comme suit :

    • Pour afficher tous les modèles en ligne proposés, cliquez sur À la une sous Catégories de modèles, puis sélectionnez le modèle de votre choix.

    • Pour sélectionner un modèle en ligne basé sur un thème, cliquez sur un thème À partir de Microsoft Office Online, puis sélectionnez le modèle de votre choix.

  2. Dans la zone Nom du fichier, tapez un nouveau nom pour le modèle, puis cliquez sur l’icône du fichier en regard de la zone de texte pour sélectionner un emplacement spécifique pour la nouvelle base de données.

  3. Cliquez sur le bouton Télécharger.

Conseil : Pour lier la base de données à un site Microsoft Windows SharePoint Services, activez la case à cocher Crée et lie votre base de données à un site Windows SharePoint Services.

Votre nouvelle base de données est maintenant prête à l’utilisation et vous pouvez la personnaliser comme vous le souhaitez.

Haut de la page

Étape 2 : Personnalisation d’un modèle

Après avoir sélectionné votre modèle de base de données, vous pouvez le personnaliser pour l’adapter à vos besoins. Une base de données créée à partir d’un modèle contient plusieurs tables, formulaires et états préconçus que vous pouvez utiliser immédiatement. Lorsque vous créez une base de données à partir d’un modèle, Access crée les tables et autres objets vous permettant d’atteindre l’objectif visé lors de la conception du modèle. Dans certains cas, la structure de la base de données du modèle est complexe et vous devrez en personnaliser certains aspects. Si vous modifiez la conception des tables fournies, veillez à ne pas invalider les relations existantes. Si vous devez apporter des modifications importantes à la structure d’un modèle, il sera sans doute préférable d’utiliser une base de données vide.

Lorsque vous personnalisez un modèle, évitez de renommer les champs ou tables. Ils risquent d’être utilisés par d’autres objets de la base de données, comme des formulaires et des états et toute modification de leur nom risque d’empêcher le bon fonctionnement d’autres objets de base de données qui font référence à ou dépendent de ces noms de tables et de champs. Avant de renommer une table dans le volet de navigation ou un champ en mode Feuille de données ou Création, activez la fonctionnalité Correction automatique de nom. Cette fonctionnalité propage automatiquement les modifications apportées aux noms de champs, tables, formulaires ou états d’autres objets dans la base de données. Le paramètre Correction automatique de nom est habituellement activé par défaut pour toutes les nouvelles bases de données.

Personnalisation d’un modèle ou d’un état

Vous pouvez personnaliser un modèle de formulaire ou d’état de plusieurs façons. Par exemple, vous pouvez modifier le format d’un formulaire en l’ouvrant en mode Page et en choisissant un nouveau format dans le groupe Format automatique (onglet Format). Vous pouvez également personnaliser un formulaire ou un état en ajoutant de nouveaux champs. Lorsque vous ajoutez un champ à un formulaire ou un état, vous créez un contrôle sur ce formulaire ou cet état. Si vous voulez personnaliser des contrôles d’un modèle, vous pouvez modifier leurs propriétés.

Ajout d’un nouveau contrôle à un formulaire ou un état

  1. Dans le volet de navigation, cliquez avec le bouton droit sur le formulaire ou l’état dans lequel vous souhaitez ajouter le contrôle, puis cliquez sur Mode création.

  2. Cliquez sur l’onglet Créer.

  3. Dans le groupe Contrôles, cliquez sur le contrôle que vous souhaitez ajouter, puis cliquez sur Utiliser les Assistants contrôle.

    Utilisation de la commande Utiliser les Assistants contrôle du groupe Contrôles

  4. Suivez les étapes de l’Assistant pour créer et personnaliser le nouveau contrôle.

Pour plus d’informations sur la création de formulaires et d’états, voir les liens de la section Voir aussi.

Modification d’un contrôle

Vous pouvez personnaliser l’apparence d’un contrôle existant dans un formulaire ou un état. Pour modifier le format d’affichage, modifiez la propriété Format d’un champ. La propriété Format est alors héritée automatiquement par les contrôles basés sur ce champ dans tous les nouveaux formulaires et états que vous créez.

Définition du format d’affichage en mode Feuille de données

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, ouvrez la base de données qui contient le contrôle à modifier.

  3. Dans le volet de navigation, double-cliquez sur la table qui contient le champ dont vous souhaitez définir le format.

    La table s’ouvre en mode Feuille de données.

  4. Cliquez sur le champ dont vous souhaitez définir le format d’affichage.

  5. Sous l'onglet Feuille de données, dans le groupe Type de données et mise en forme, cliquez sur la flèche de la liste déroulante en regard de Format, puis sélectionnez un type de données. Image du ruban Access, groupe Type de données et mise en forme

    Le champ s’affiche dans le nouveau format d’affichage appliqué.

Définition du format d’affichage en mode Création

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, ouvrez la base de données qui contient le contrôle à modifier.

  3. Dans le volet de navigation, cliquez avec le bouton droit sur la table qui contient le champ dont vous souhaitez modifier le format d’affichage, puis cliquez sur Mode Création.

    La table s’ouvre en mode Création.

  4. Cliquez sur le champ dont vous souhaitez définir le format d’affichage.

  5. Sous Propriétés du champ, dans l’onglet Général, sélectionnez un format d’affichage dans la liste Format.

  6. Pour enregistrer vos modifications, cliquez sur Enregistrer dans la barre d’outils Accès rapide.

Haut de la page

Étape 3 : Ajout de données à votre nouvelle base de données

Lorsque vous avez sélectionné un modèle et que vous l’avez personnalisé, vous pouvez ajouter des données à votre base de données en procédant à une importation ou à une liaison avec des données externes.

Importation de données

Vous pouvez importer des données dans plusieurs formats, y compris des classeurs Excel, des listes Windows SharePoint Services 3.0, des carnets d’adresses Outlook ou d’autres bases de données Access.

  • Pour importer des données, cliquez sur la commande correspondant au type de fichier à importer dans l’onglet Données externes du groupe Importer.

    Boutons de commande dans le groupe Importer

    Remarques : 

    • Si aucune icône ne s’affiche pour le type de données que vous voulez importer, cliquez sur Plus et suivez les instructions de la boîte de dialogue Données externes.

    • Si vous ne trouvez toujours pas de commande pour importer vos données externes, vous devrez sans doute démarrer le programme dans lequel vous avez créé les données à l’origine (cette opération n’a pas lieu dans Access), puis enregistrer les données dans un format de fichier courant (comme fichier texte délimité). Rouvrez ensuite Access et utilisez une des commandes de données externes pour importer ces données.

  • Sur la dernière page de l’Assistant, vous serez sans doute invité à enregistrer les détails de ces étapes d’importation. Il convient d’enregistrer les détails si vous prévoyez d’importer des données à partir de la même source de données. Activez la case à cocher Enregistrer les étapes d’importation, entrez les détails et cliquez sur Enregistrer l’importation. Vous pouvez alors renouveler la même importation à tout moment en cliquant sur Importations enregistrées dans le groupe Importer de l’onglet Données externes. Si vous ne souhaitez pas enregistrer les détails de cette importation, cliquez sur Fermer.

Liaison vers des données

Lorsque vous établissez un lien vers des données, celles-ci continuent à être stockées à leur emplacement d’origine et elles apparaissent sous la forme d’une table liée dans votre nouvelle base de données. Pour la plupart des formats de fichier, vous pouvez afficher et modifier les données dans Access ou le programme d’origine dans lequel vous les avez créées, car ce deux programmes manipulent les mêmes données physiques. Toutefois, si les données sont stockées dans un classeur Excel, vous pouvez uniquement afficher les données liées dans Access, sans pouvoir les modifier. Pour modifier les données d’un classeur lié, vous devez utiliser Excel.

    1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

    2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données et ouvrez-la.

    3. Sous l’onglet Données externes du groupe Importer, cliquez sur la commande correspondant au type de fichier à lier. Par exemple, pour établir une liaison avec les données d’un classeur Excel, cliquez sur Excel. Si aucune icône ne s’affiche pour le type de données à lier, cliquez sur Plus.

      La boîte de dialogue Données externes s’affiche.

      Remarque : Si vous ne trouvez toujours pas de commande pour lier vos données externes, vous devrez sans doute démarrer le programme dans lequel vous avez créé les données à l’origine (cette opération n’a pas lieu dans Access), puis enregistrer les données dans un format de fichier courant (comme fichier texte délimité). Ouvrez ensuite Access et utilisez une des commandes de données externes pour lier ces données.

    4. Dans la boîte de dialogue Données externes, cliquez sur Parcourir pour rechercher le fichier de données source ou tapez le chemin d'accès complet de ce fichier dans la zone Nom de fichier.

    5. Cliquez sur l’option de votre choix sous Spécifiez le mode et l’emplacement de stockage des données dans la base de données active.

      Un Assistant démarre pour la plupart des formats de fichiers. Toutefois, si vous liez les données dans une base de données Access, la boîte de dialogue Importer des objets apparaît. Faites vos choix dans la boîte de dialogue Attacher les tables, puis passez à l’étape 7. Sinon, passez à l’étape 6.

    6. Suivez les étapes de l’Assistant. Les options que vous aurez choisies détermineront la procédure exacte à suivre.

Haut de la page

Étape 4 : Localisation d’enregistrements

Une fois les données importées dans votre base de données, vous devrez être en mesure de localiser rapidement des enregistrements spécifiques. Pour ce faire, vous pouvez utiliser la barre d’outils figurant dans la partie inférieure de votre base de données.

Boutons de navigation

Utilisez les boutons de navigation pour trouver des enregistrements dans une table ou vue (objet).

Bouton de navigation

Pour accéder à l’élément suivant :

1.

Premier enregistrement

2.

Enregistrement précédent

3.

Enregistrement spécifique : cliquez dans la zone de texte, tapez le numéro de l’enregistrement, puis appuyez sur ENTRÉE pour afficher cet enregistrement. Les numéros d’enregistrements sont comptés en séquence à partir du premier dans le formulaire ou la feuille de données.

4.

Enregistrement suivant

5.

Dernier enregistrement

6.

Nouvel enregistrement (vide)

7.

Filtre : il est possible grâce à cet indicateur de savoir si un filtre a été appliqué. Si ce n’est pas le cas ou si tous les filtres ont été supprimés, l’indicateur Aucun filtre est affiché.

8.

Zone Rechercher : entrez du texte dans la zone Rechercher et la première valeur correspondante apparaît en surbrillance en temps réel à mesure que vous entrez chaque caractère. Cette fonctionnalité vous permet de trouver rapidement un enregistrement.

Options supplémentaires de localisation d’enregistrements

Vous pouvez également localiser des enregistrements grâce à une des méthodes suivantes.

Accès à un enregistrement spécifique

Recherche d’un enregistrement spécifique

Filtrage pour afficher uniquement un jeu d’enregistrements spécifique

Recherche personnalisée à l’aide d’une requête

Accès à un enregistrement spécifique

Certains modèles contiennent des formulaires permettant d’afficher un enregistrement spécifique via une liste déroulante Atteindre. Par exemple, le formulaire Détails du contact du modèle Contacts et le formulaire Projets et tâches du modèle Projets de marketing intègrent cette option. Vous pouvez utiliser cette option pour afficher un enregistrement spécifique provenant d’une liste déroulante. Si elle est disponible, la zone Atteindre se trouve dans la section supérieure gauche du formulaire.

  1. Cliquez sur la flèche en regard de la liste Atteindre.

    Zone Atteindre

  2. Cliquez sur l’enregistrement que vous souhaitez afficher.

Recherche d’un enregistrement spécifique

L’onglet Rechercher de la boîte de dialogue Rechercher et remplacer permet de rechercher des enregistrements spécifiques. Vous pouvez effectuer cette recherche dans un champ particulier ou dans une table ou une vue entière.

Remarque : Vous ne pouvez utiliser la boîte de dialogue Rechercher et remplacer que si la table ou la vue affiche des données.

  1. Ouvrez la table que vous souhaitez explorer et cliquez dans le champ qui contient l’enregistrement que vous recherchez.

  2. Dans l’onglet Accueil du groupe Rechercher, cliquez sur Rechercher.

    Bouton de commande Rechercher

  3. Dans la boîte de dialogue Rechercher et remplacer, entrez votre critère de recherche dans la zone Rechercher.

  4. Dans la liste Rechercher, sélectionnez Tout, puis Suivant.

Pour plus d’informations sur l’utilisation de la boîte de dialogue Rechercher et remplacer, voir les liens de la section Voir aussi.

Filtrage pour afficher uniquement un jeu d’enregistrements spécifique

Vous pouvez activer ou désactiver un filtre de sorte à pouvoir facilement passer d’une vue filtrée à une vue non filtrée des mêmes données.

Vous pouvez appliquer un filtre pour limiter les enregistrements affichés à ceux qui correspondent à vos critères uniquement. L’application d’un filtre facilite la recherche d’enregistrements. Par exemple, pour limiter les enregistrements affichés, cliquez avec le bouton droit dans un champ contenant une valeur avec laquelle vous souhaitez établir une correspondance, puis sélectionnez une des options du menu de sélection Égal à, Différent de, Contient ou Ne contient pas.

  • Ouvrez la table ou le formulaire auquel vous souhaitez ajouter un filtre.

  • Pour vous assurer que la table ou le formulaire n’a pas déjà été filtré, cliquez sur Options avancées dans l’onglet Accueil du groupe Trier et filtrer, puis cliquez sur Effacer tous les filtres. Si cette commande n’est pas disponible (estompée), aucun filtre n’a été appliqué.

    Groupe Trier et filtrer

  • Pour appliquer un filtre, cliquez sur le champ sur lequel vous souhaitez appliquer un filtre, puis, dans l’onglet Accueil du groupe Trier et filtrer, cliquez sur Filtrer et sélectionnez une option de filtrage.

  • Pour appliquer un filtre basé sur une sélection, ouvrez une table ou un formulaire et accédez à l’enregistrement qui contient la valeur qui fera partie du filtre. Cliquez ensuite sur le champ. Sous l'onglet Accueil, dans le groupe Trier et filtrer, cliquez sur Sélection, puis sur le filtre que vous souhaitez appliquer.

  • Pour appliquer un filtre basé sur une sélection partielle, sélectionnez les caractères de votre choix. Sous l'onglet Accueil, dans le groupe Trier et filtrer, cliquez sur Sélection, puis sur le filtre que vous souhaitez appliquer.

Pour plus d’informations sur l’application d’un filtre, voir les liens de la section Voir aussi.

Recherche personnalisée à partir d’une requête

Vous pouvez utiliser des requête pour effectuer des recherches personnalisées, appliquer des filtres personnalisés et trier des enregistrements. Il est possible d’enregistrer des requêtes et de les réutiliser, et elles peuvent servir à générer des formulaire et des état. Vous pouvez également utiliser une requête pour ne rechercher que les enregistrements qui vous intéressent dans une table. Le type de requête que vous créez varie selon les enregistrements que vous souhaitez obtenir et si vous souhaitez qu’Access exploite ou non les résultats.

  1. Dans l’onglet Créer du groupe Autre, cliquez sur Assistant Requête.

    Commande Assistant Requête du groupe Autre

  2. Suivez les étapes de l’Assistant Requête.

Pour plus d’informations sur la création de requêtes, voir les liens de la section Voir aussi.

Haut de la page

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×