Rechercher des valeurs au moyen de la fonction RECHERCHEV, d’INDEX ou EQUIV

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Pour rechercher une valeur dans une longue liste, vous pouvez utiliser une fonction de recherche. La fonction RECHERCHEV est employée couramment, mais la fonction RECHERCHEH et l’utilisation conjointe des fonctions INDEX et EQUIV peuvent s’avérer efficace.

Voici une présentation de la fonction RECHERCHEV et les arguments qu’elle utilise :

=RECHERCHEV(<valeur de recherche>,<plage de recherche>,<colonne>,<correspondance approximative>)

Par exemple ; =RECHERCHEV(21500,C2:E7,3,FAUX)

  • Le premier argument, un élément dont la fonction a besoin pour fonctionner, correspond à la valeur à trouver. Il peut s’agir d’une référence de cellule comme B2 ou d’une valeur telle que « dupont » ou 21500.

  • Le deuxième argument est la plage de cellules que vous pensez contenir la valeur recherchée.

    Important : Avec RECHERCHEV, la colonne contenant la valeur ou la référence de cellule que vous recherchez doit être la colonne la plus à gauche de la plage.

  • Le troisième argument est la colonne dans la plage de recherche de cellules qui contient la valeur que vous voulez voir.

Si le quatrième argument est facultatif, la plupart des personnes entrent faux (ou 0). Pourquoi ? Étant donné que cela force la fonction pour trouver une correspondance exacte dans la recherche. Vous pouvez n'entrer aucun argument ou vrai, mais si aucune correspondance exacte n'est pas trouvée, la fonction renvoie le plus procheapproximative— et en règle générale, la plupart des personnes ne voulez pas qu'une correspondance approximative.

Pour afficher la façon dont une correspondance approximative peut être un problème grave, supposons que vous avez besoin pour le prix d'un composant avec 2345768 ID, mais vous changez de deux nombres et dont l'orthographe incorrecte dans la formule comme suit : =VLOOKUP(2345678,A1:E7,5). la formule renvoie le prix pour le composant incorrect, car RECHERCHEV trouvé le nombre le plus proche inférieure ou égale au numéro que vous avez spécifié (2345678). Vous pouvez vous retrouver facturation incorrectement un client en raison de cette erreur.

Si vous spécifiez FAUX ou 0 pour l’argument Correspondance approximative, et il qu’il n’existe aucune correspondance exacte, la formule renvoie #N/A dans la cellule au lieu d’une valeur incorrecte, ce qui s’avère un meilleur scénario. Dans ce cas, #N/A ne signifie pas que vous avez entré une formule erronée (à l’exception de votre nombre) : cela signifie que ce nombre (2345678) est introuvable, car l’identifiant correct est 2345768.

Cet exemple illustre le fonctionnement de cette fonction. Lorsque vous entrez une valeur dans la cellule B2 (le premier argument), RECHERCHEV recherche les cellules C2:E7 (le deuxième argument) et renvoie la correspondance approximative la plus proche à partir de la troisième colonne dans la plage, la colonne E (le troisième argument).

Utilisation classique de la fonction RECHERCHEV

Dans cet exemple, le quatrième argument est laissé vide, de sorte que la fonction renvoie une correspondance approximative.

Utilisation de la fonction RECHERCHEH

Lorsque vous serez à l’aise avec la fonction RECHERCHEV, la fonction RECHERCHEH ne vous posera pas trop de problèmes. Vous entrez les mêmes arguments, mais la fonction RECHERCHEH recherche des valeurs dans des lignes plutôt que dans des colonnes.

Utilisation conjointe des fonctions INDEX et EQUIV

Lorsque vous ne voulez pas limiter votre recherche à la colonne de gauche, vous pouvez utiliser une combinaison des fonctions INDEX et EQUIV. Une formule qui utilise ces fonctions ensemble sera un peu plus complexe qu’une formule contenant une fonction RECHERCHEV, mais elle sera probablement plus efficace. Certains utilisateurs préfèrent nettement utiliser conjointement les fonctions INDEX et EQUIV plutôt que la fonction RECHERCHEV.

Par exemple, prenons le cas d’une liste réduite où la valeur à rechercher, Rennes n’est pas dans la colonne de gauche. Nous ne pouvons donc pas utiliser RECHERCHEV. Au lieu de cela, nous utiliserons la fonction EQUIV pour trouver Rennes dans la plage B1:B11. Cette valeur se trouve dans la ligne 4. Puis, la fonction INDEX utilise cette valeur comme argument de recherche et estime la population de Rennes dans la 4e colonne (colonne D). La formule utilisée est affichée dans la cellule A14.

Utilisation des fonctions INDEX et EQUIV pour rechercher une valeur

Informations supplémentaires sur les fonctions de recherche

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×