Rechercher des valeurs au moyen de la fonction RECHERCHEV, d’INDEX ou EQUIV

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Vous disposez d’une liste de numéros de bureau et vous souhaitez savoir quels employés se trouvent dans chaque bureau. Cependant, la feuille de calcul est très volumineuse. Que pouvez-vous faire ? Utilisez une fonction de recherche. Les fonctions RECHERCHEV et RECHERCHEH sont deux des fonctions les plus utiles, avec les fonctions INDEX et EQUIV.

Remarque :  Si vous essayez de trouver l’Assistant Liste de choix, sachez que cette fonctionnalité ne figure plus dans Excel.

Voici un bref rappel de la façon d’utiliser RECHERCHEV.

=RECHERCHEV(B2;C2:E7;3;VRAI)

Le premier argument, à savoir les données dont la fonction a besoin pour fonctionner, correspond à la valeur à trouver. Il peut s’agir d’une référence de cellule ou d’une valeur concrète, telle que "dupont" ou 21 000. Le deuxième argument est la plage de cellules que vous pensez contenir la valeur recherchée. Dans notre exemple, il s’agit de C2-C7. Le troisième argument est la colonne dans cette plage de cellules qui contient la valeur que vous voulez voir.

Le quatrième argument est facultatif. Vous pouvez entrer Vrai ou Faux. Si vous entrez VRAI, ou que vous laissez l’argument vide, la fonction renvoie une correspondance approximative de la valeur que vous spécifiez dans le premier argument. Si vous entrez FAUX, la fonction recherchera la valeur fournie par le premier argument. En d’autres termes, si vous laissez le quatrième argument vide, ou que vous entrez VRAI, vous disposez de davantage de flexibilité.

Cet exemple vous montre le fonctionnement de cette fonction. Lorsque vous entrez une valeur dans la cellule B2 (le premier argument), RECHERCHEV recherche les cellules C2-E7 (le deuxième argument) et renvoie la correspondance approximative la plus proche à partir de la troisième colonne dans la plage, la colonne E (le troisième argument).

Utilisation classique de la fonction RECHERCHEV

Le quatrième argument est vide, de sorte que la fonction renvoie une correspondance approximative. Si ce n’est pas le cas, vous devez entrer une des valeurs dans les colonnes C ou D pour obtenir un résultat.

Une fois que vous serez à l’aise avec la fonction RECHERCHEV, la fonction RECHERCHEH ne devrait pas vous poser trop de problèmes. Vous entrez les mêmes arguments, mais la fonction recherche des valeurs dans des lignes plutôt que dans des colonnes.

Exercices pratiques

Si vous souhaitez vous exercer avec des formules de recherche avant de les utiliser sur vos données, voici des exemples de données. Certaines personnes aiment utiliser RECHERCHEV et RECHERCHEH, tandis que d’autres préfèrent INDEX et EQUIV. Essayez toutes ces fonctions pour déterminer celles que vous préférez.

RECHERCHEV en action

Copiez toutes les cellules du tableau, puis collez-les dans la cellule A1 d’une feuille de calcul vierge dans Excel.

Conseil    Avant de coller les données dans Excel, définissez la largeur des colonnes A à C sur 250 pixels, puis cliquez surRenvoyer à la ligne automatiquement (onglet Accueil, groupe Alignement).

Densité

Viscosité

Température

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Formule

Description

Résultat

'=RECHERCHEV(1;A2:C10;2)

Recherche, en correspondance proche, la valeur 1 dans la colonne A, trouve la valeur immédiatement inférieure ou égale à 1 dans la colonne A (0,946), puis renvoie la valeur de la même ligne dans la colonne B.

=RECHERCHEV(1;A2:C10;2)

'=RECHERCHEV(1;A2:C10;3;VRAI)

Recherche, en correspondance proche, la valeur 1 dans la colonne A, trouve la valeur immédiatement inférieure ou égale à 1 dans la colonne A (0,946), puis renvoie la valeur de la même ligne dans la colonne C.

=RECHERCHEV(1;A2:C10;3;VRAI)

'=RECHERCHEV(0,7;A2:C10;3;FAUX)

Recherche, en correspondance exacte, la valeur 0,7 dans la colonne A. Étant donné que la colonne A ne contient aucune correspondance exacte, une erreur est renvoyée.

=RECHERCHEV(0,7;A2:C10;3;FAUX)

'=RECHERCHEV(0,1,A2:C10,2,VRAI)

Recherche, en correspondance proche, la valeur 0,1 dans la colonne A. Étant donné que 0,1 est une valeur inférieure à la valeur la plus petite de la colonne A, une erreur est renvoyée.

=RECHERCHEV(0,1;A2:C10;2;VRAI)

'=RECHERCHEV(2,A2:C10,2,VRAI)

Recherche, en correspondance proche, la valeur 2 dans la colonne A, trouve la valeur immédiatement inférieure ou égale à 2 dans la colonne A (1,29), puis renvoie la valeur de la même ligne dans la colonne B.

=RECHERCHEV(2,A2:C10,2,VRAI)

RECHERCHEH en action

Copiez toutes les cellules dans ce tableau, puis collez-le dans la cellule A1 d’une feuille de calcul vierge dans Excel.

Conseil    Avant de coller les données dans Excel, définissez la largeur des colonnes A à C sur 250 pixels, puis cliquez surRenvoyer à la ligne automatiquement (onglet Accueil, groupe Alignement).

Axes

Roulements

Boulons

4

4

9

5

7

10

6

8

11

Formule

Description

Résultat

'=RECHERCHEH("Axes";A1:C4;2;VRAI)

Recherche « Axes » dans la ligne 1 et renvoie la valeur de la ligne 2 qui est comprise dans la même colonne (colonne A).

=RECHERCHEH("Axes";A1:C4;2;VRAI)

'=RECHERCHEH("Roulements";A1:C4;3;FAUX)

Recherche « Roulements » dans la ligne 1 et renvoie la valeur de la ligne 3 qui est comprise dans la même colonne (colonne B).

=RECHERCHEH("Roulements";A1:C4;3;FAUX)

'=RECHERCHEH("B";A1:C4;3;VRAI)

Recherche « B » dans la ligne 1 et renvoie la valeur de la ligne 3 qui est comprise dans la même colonne. Étant donné qu’une correspondance exacte de « B » est introuvable, la valeur la plus élevée de la ligne 1 qui est inférieure à « B » est utilisée : « Axes » dans la colonne A.

=RECHERCHEH("B";A1:C4;3;VRAI)

'=RECHERCHEH("Boulons";A1:C4;4)

Recherche « Boulons » dans la ligne 1 et renvoie la valeur de la ligne 4 qui est comprise dans la même colonne (colonne C).

=RECHERCHEH("Boulons";A1:C4;4)

'=RECHERCHEH(3;{1;2;3;"a","b","c";"d","e","f"};2;VRAI)

Recherche le nombre 3 dans la constante de matrice à trois lignes et renvoie la valeur de la ligne 2 qui est comprise dans la même colonne (la troisième dans cet exemple). Il existe trois lignes de valeurs dans la constante de matrice, chacune étant séparée par un point-virgule (;). Étant donné que « c » se trouve dans la ligne 2 et dans la même colonne que 3, « c » est renvoyé.

=RECHERCHEH(3;{1;2;3;"a","b","c";"d","e","f"};2;VRAI)

INDEX et EQUIV en action

Cet exemple utilise les fonctions INDEX et EQUIV ensemble pour retourner le numéro de facture la plus ancienne et la date correspondante pour chacune des cinq villes. La date retournée étant au format nombre, nous utilisons la fonction TEXTE pour lui appliquer un format de date. La fonction INDEX utilise en fait le résultat de la fonction EQUIV comme argument. La combinaison des fonctions INDEX et EQUIV est utilisée deux fois dans chaque formule : la première fois pour retourner le numéro de facture et la seconde pour retourner la date.

Copiez toutes les cellules du tableau, puis collez-les dans la cellule A1 d’une feuille de calcul vierge dans Excel.

Conseil    Avant de coller les données dans Excel, définissez la largeur des colonnes A à D sur 250 pixels, puis cliquez surRenvoyer à la ligne automatiquement (onglet Accueil, groupe Alignement).

Facture

Ville

Date de facturation

Facture la plus ancienne par ville, avec la date

3115

Nantes

7/4/12

="Nantes = "&INDEX($A$2:$C$33;EQUIV("Nantes";$B$2:$B$33;0);1)& "; Date de facturation : " & TEXTE(INDEX($A$2:$C$33;EQUIV("Nantes";$B$2:$B$33;0);3);"d/m/yy")

3137

Nantes

9/4/12

="Lyon = "&INDEX($A$2:$C$33;EQUIV("Lyon";$B$2:$B$33;0);1)& "; Date de facturation : " & TEXTE(INDEX($A$2:$C$33;EQUIV("Lyon";$B$2:$B$33;0);3);"d/m/yy")

3154

Nantes

11/4/12

="Bordeaux = "&INDEX($A$2:$C$33;EQUIV("Bordeaux";$B$2:$B$33;0);1)& "; Date de facturation : " & TEXTE(INDEX($A$2:$C$33;EQUIV("Bordeaux";$B$2:$B$33;0);3);"d/m/yy")

3191

Nantes

21/4/12

="Brest = "&INDEX($A$2:$C$33;EQUIV("Brest";$B$2:$B$33;0);1)& "; Date de facturation : " & TEXTE(INDEX($A$2:$C$33;EQUIV("Brest";$B$2:$B$33;0);3);"d/m/yy")

3293

Nantes

25/4/12

="Nice = "&INDEX($A$2:$C$33;EQUIV("Nice";$B$2:$B$33;0);1)& "; Date de facturation : " & TEXTE(INDEX($A$2:$C$33;EQUIV("Nice";$B$2:$B$33;0);3);"d/m/yy")

3331

Nantes

27/4/12

3350

Nantes

28/4/12

3390

Nantes

1/5/12

3441

Nantes

2/5/12

3517

Nantes

8/5/12

3124

Lyon

9/4/12

3155

Lyon

11/4/12

3177

Lyon

19/4/12

3357

Lyon

28/4/12

3492

Lyon

6/5/12

3316

Bordeaux

25/4/12

3346

Bordeaux

28/4/12

3372

Bordeaux

1/5/12

3414

Bordeaux

1/5/12

3451

Bordeaux

2/5/12

3467

Bordeaux

2/5/12

3474

Bordeaux

4/5/12

3490

Bordeaux

5/5/12

3503

Bordeaux

8/5/12

3151

Brest

9/4/12

3438

Brest

2/5/12

3471

Brest

4/5/12

3160

Nice

18/4/12

3328

Nice

26/4/12

3368

Nice

29/4/12

3420

Nice

1/5/12

3501

Nice

6/5/12

Informations supplémentaires sur les fonctions de recherche

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×