Publier un classeur dans une bibliothèque SharePoint

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Dans Microsoft Excel 2013, vous pouvez publier un classeur dans une bibliothèque SharePoint de sorte que d’autres utilisateurs puissent le visualiser ou le modifier dans un navigateur web sans qu’Excel soit installé sur leur ordinateur. La publication équivaut plus ou moins à un enregistrement, mais offre en plus certaines options intégrées qui vous permettent de contrôler ce que les utilisateurs voient quand ils ouvrent le classeur dans un navigateur.

L’adoption d’une pratique à l’échelle de l’organisation consistant à enregistrer ou publier un classeur dans un site SharePoint central peut aider à s’assurer que des versions légèrement différentes du même classeur ne circulent pas dans votre organisation lorsque ce classeur est transmis par courrier électronique.

En définissant certaines options de publication, vous pouvez mettre l’accent sur des parties spécifiques de votre classeur, telles que des graphiques, ou empêcher l’affichage d’autres parties dans le navigateur. Vous pouvez par exemple afficher un graphique mais pas ses données sous-jacentes, ou encore afficher uniquement certaines feuilles de calcul aux personnes qui ont besoin de les voir et masquer les autres feuilles de calcul.

Cet article explique comment publier un classeur à partir du programme bureautique Excel 2013 ; il ne traite pas de la connexion d’un classeur ou de données d’un classeur à un composant WebPart Excel Web Access dans une page SharePoint. Pour plus d’informations sur les composants WebPart, voir l’article intitulé Connecter un composant WebPart Excel Web Access à un classeur Excel.

Lorsque vous publiez un classeur sur un site SharePoint, le classeur entier est enregistré dans SharePoint. Un utilisateur disposant des autorisations SharePoint requises peut visualiser et travailler avec le classeur entier dans le navigateur ou dans le programme bureautique Excel.

Si les applications Office Online sont déployées sur SharePoint, l’expérience d’affichage et de manipulation de vos données dans le navigateur est très semblable à celle que vous auriez dans le programme de bureau Excel. En fait, contrairement à ce dernier, plusieurs utilisateurs peuvent modifier simultanément un classeur dans la grille de navigateur. Lorsque vous affichez un classeur dans le navigateur, si le bouton Modifier dans Excel Online est visible, cela signifie qu’Office Online est prêt à être utilisé.

Modifier dans Excel Online dans le menu Modifier le classeur

Pour plus d’informations, voir l’article intitulé Différences entre l’utilisation d’un classeur dans Excel et dans Excel Services.

Préparer le classeur

Avant de publier le classeur, vous pouvez choisir de sélectionner uniquement les feuilles de calcul ou éléments que vous souhaitez rendre visibles dans le navigateur. Souvenez-vous que bien qu’il soit possible de limiter ce qui est affichable dans ce mode, le contenu entier du classeur est toujours enregistré sur le serveur SharePoint.

Si vous souhaitez inclure des feuilles de calcul entières comme élément en plus d’autres éléments, tels que des graphiques ou des tableaux croisés dynamiques, définissez l’intégralité de la feuille de calcul en tant que plage nommée. Sélectionnez toute la feuille de calcul, puis définissez une plage nommée. Celle-ci apparaîtra comme élément disponible dans la boîte de dialogue Options de publication lorsque vous serez prêt à effectuer la publication.

Pour permettre aux utilisateurs d’entrer une valeur dans une cellule afin de travailler avec une formule dans une autre cellule, définissez cette cellule comme nom défini dans Excel avant de publier le classeur. Vous pouvez ensuite ajouter ce nom défini en tant que paramètre sous l’onglet Paramètres de la boîte de dialogue Options d’affichage du navigateur.

Par exemple, le graphique suivant montre une cellule D2 qui a le nom défini « Rate ». Dans le navigateur, un utilisateur entre une valeur (5,625) dans la zone dans le volet Paramètres et clique sur Appliquer. Cette valeur apparaît alors dans la cellule D2 et la formule en A2 utilise la valeur indiquée en D2. Le résultat de la formule est recalculé, comme illustré en A2 : $1 151,31.

Pour plus d’informations sur la façon de définir des plages, voir l’aide d’Excel.

L’entrée d’un paramètre dans le volet permet de l’utiliser dans la cellule D2

Remarque : Si vous créez des segments pour un tableau Excel et que vous définissez un nom pour la plage de cellules contenant le tableau et les segments, vous ne pourrez pas utiliser les segments pour filtrer le tableau dans le navigateur si vous publiez la plage définie. Si vous publiez le tableau, la feuille de calcul entière ou son classeur, les segments fonctionneront comme prévu dans le navigateur.

Publier le classeur

  1. Cliquez sur Fichier > Enregistrer sous > SharePoint.

  2. Si vous voyez votre dossier SharePoint sousdossier actif ou dossiers récents, cliquez sur le dossier souhaité. Dans le cas contraire, cliquez sur Parcourir, puis entrez l'adresse web du site SharePoint. Ensuite, accédez au dossier où vous souhaitez publier le classeur. La boîte de dialogue Enregistrer sous s'affiche.

  3. Pour sélectionner certaines feuilles de calcul ou certains éléments spécifiques à publier à partir du classeur, cliquez sur Options d’affichage du navigateur. Des onglets Afficher et Paramètres apparaîtront. Si vous souhaitez simplement publier le classeur entier, cliquez sur Enregistrer. Autrement, effectuez l’une des opérations suivantes :

  • Pour afficher le classeur entier dans le navigateur, sous l’onglet Afficher, sélectionnez Classeur entier dans la zone de liste.

  • Pour afficher uniquement des feuilles de calcul spécifiques dans le navigateur, sous l’onglet Afficher, sélectionnez Feuilles dans la zone de liste, puis désactivez les cases à cocher des feuilles que vous ne voulez pas masquer dans le navigateur.

    Par défaut, toutes les feuilles sont sélectionnées. Pour rendre rapidement toutes les feuilles visibles après avoir désactivé certaines cases à cocher, activez la case à cocher Toutes les feuilles.

  • Pour n’afficher que certains éléments dans le navigateur (tels que des plages nommées, des graphiques, des tableaux ou des tableaux croisés dynamiques), sous l’onglet Afficher, sélectionnez Éléments du classeur dans la zone de liste, puis activez les cases à cocher des éléments que vous souhaitez afficher.

  • Sous l’onglet Paramètres, ajoutez les noms définis que vous souhaitez utiliser pour spécifier les cellules qui sont modifiables lorsque les utilisateurs affichent le classeur dans le navigateur. Ensuite, cliquez sur OK pour fermer la boîte de dialogue.

  1. Enregistrez le classeur.

Remarques : 

  • Si vous sélectionnez des éléments de même nom (par exemple un graphique et son tableau de données sous-jacent), un seul de ces éléments sera disponible dans le navigateur. Pour afficher tous les éléments, assurez-vous que chaque élément du classeur possède un nom unique.

  • Si vous sélectionnez des éléments de même nom (par exemple un graphique et son tableau de données sous-jacent), un seul de ces éléments sera disponible dans le navigateur. Pour afficher tous les éléments, assurez-vous que chaque élément du classeur possède un nom unique.

  • Vous pouvez renommer les tableaux dans le groupe Propriétés de l’onglet Création, renommer les tableaux croisés dynamiques dans le groupe Tableau croisé dynamique de l’onglet Options et renommer les graphiques ou les graphiques croisés dynamiques dans le groupe Propriétés de l’onglet Disposition. Vous pouvez renommer d’autres éléments dupliqués, tels que des plages nommées, dans le groupe Noms définis sous l’onglet Formules.

  • Vous pouvez renommer les tableaux dans le groupe Propriétés de l’onglet Création, renommer les tableaux croisés dynamiques dans le groupe Tableau croisé dynamique de l’onglet Options et renommer les graphiques ou les graphiques croisés dynamiques dans le groupe Propriétés de l’onglet Disposition. Vous pouvez renommer d’autres éléments dupliqués, tels que des plages nommées, dans le groupe Noms définis sous l’onglet Formules.

En savoir plus sur Excel Services et l’utilisation de données dans le navigateur

Fonctionnalités d’aide à la décision dans Excel Services

Utiliser des données externes dans Excel Services

Actualisation des données dans un classeur affiché dans une fenêtre de navigateur

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×