Prise en main de SharePoint Designer 2010

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Microsoft SharePoint Designer 2010 est un site Web et programme de conception d’application utilisés pour concevoir, générer et personnaliser des sites Web s’exécutant sur SharePoint Foundation 2010 et Microsoft SharePoint Server 2010. Avec SharePoint Designer 2010, vous pouvez créer des pages Web riches en données, créer des solutions puissantes compatibles avec les flux de travail et créer l’apparence de votre site.

Utilisez les liens ci-dessous pour en savoir plus sur SharePoint Designer 2010 via des articles, des vidéos et autres ressources de formation. Utilisez les procédures suivantes pour en savoir plus sur les tâches de base que vous effectuez dans SharePoint Designer 2010.

Logo Mise en route

Ce que vous wan t

Vers quels numéros g o

Souhaitez-vous savoir uniquement ce qui a été modifié ?   

Découvrir les nouvelles fonctionnalités de cette version et la manière d’en tirer le meilleur parti.

Nouveautés dans SharePoint Designer2010

À la recherche des menus et commandes 2007 ?   

Consulter un tableau des commandes de menu et de barre d’outils de la version 2007 et découvrir leurs nouveaux emplacements.

Guides de correspondances p our les applications Microsoft Office

Jamais utilisé SharePoint Designer auparavant ?   

Découvrez quels SharePoint Designer 2010 est une question et comment tirer pleinement parti de dans votre organisation.

Présentation de SharePoint Designer2010

À la recherche d’une formation pour vous et d’autres membres de votre équipe ?   

Devenir plus productif dans cette version grâce à la formation sur SharePoint Designer 2010.

Formations Microsoft Office

Tâches de base dans SharePoint Designer 2010

Ouvrir et créer des sites SharePoint

Créer des listes, des bibliothèques et des connexions à des sources de données

Créer des affichages et des formulaires personnalisés

Créer des flux de travail personnalisés

Concevoir des pages de site, des pages maîtres et des mises en page

Enregistrer en tant que modèle

Ouvrir et créer des sites SharePoint

Dans SharePoint Designer 2010, vous pouvez ouvrir des sites SharePoint existants sur le serveur et les personnaliser de début, et vous pouvez créer de nouveaux sites en fonction de modèles de site SharePoint ou sites vide que vous personnalisez à partir de zéro.

Ouvrir des sites

Pour ouvrir un site existant, cliquez sur l’onglet Fichier, choisissez Sites et effectuez l’une des opérations suivantes :

  • Cliquez sur Ouvrir le site pour parcourir les sites disponibles sur le serveur.

  • Cliquez sur Personnaliser le site Mon site pour ouvrir et personnaliser votre site Mon Site.

  • Sous Sites récents, sélectionnez un site que vous avez précédemment utilisé.

Créer des sites

Pour créer un nouveau site, cliquez sur l’onglet Fichier, choisissez Sites et effectuez l’une des opérations suivantes :

  • Cliquez sur Nouveau site Web vide pour créer un site vierge et vide.

  • Cliquez sur Ajouter le sous-site au site Mon site pour créer un nouveau site sous votre site Mon Site.

  • Sous Modèles de sites, sélectionnez un modèle pour créer un site basé sur un modèle de SharePoint.

Remarque : Outre l’ouverture et la création de sites à partir SharePoint Designer 2010, vous pouvez ouvrir un site SharePoint à l’aide de votre navigateur et ouvrez ce site dans SharePoint Designer 2010 en utilisant les liens disponibles dans le menu Actions du Site, le ruban et d’autres emplacements dans SharePoint.

Haut de la page

Créer des listes, des bibliothèques et des connexions à des sources de données

Dans SharePoint Designer 2010, vous pouvez créer des listes et bibliothèques, fréquemment utilisées comme source de données pour les sites SharePoint, et vous pouvez créer des connexions de source de données aux fichiers XML, les bases de données externes et les services Web.

Listes et bibliothèques SharePoint

Pour créer une liste ou bibliothèque SharePoint, cliquez sur Listes et bibliothèques dans le volet Navigation, puis choisissez l’une des options suivantes sous l’onglet Listes et bibliothèques :

  • Cliquez sur Liste personnalisée pour créer une liste vide ex nihilo.

  • Cliquez sur Liste SharePoint pour créer une liste basée sur un modèle de liste SharePoint.

  • Cliquez sur Bibliothèque de documents pour créer une bibliothèque basée sur un modèle de bibliothèque SharePoint.

  • Cliquez sur Liste externe pour créer une liste externe basée sur un type de contenu externe. (Les types de contenu externes sont décrits ci-dessous.)

  • Cliquez sur Liste de la feuille de calcul pour créer une liste basée sur une feuille de calcul importée.

Connexions de source de données

Pour créer une connexion de source de données, cliquez sur Sources de données dans le volet Navigation, puis choisissez l’une des options suivantes sous l’onglet Sources de données.

  • Cliquez sur Source de données liée pour créer une connexion de données à plusieurs sources de données.

  • Cliquez sur Connexion à la base de données pour créer une connexion de données à une base de données qui prend en charge le protocole OLE DB ou ODBC.

  • Cliquez sur Connexion au service SOAP pour créer une connexion à un service Web XML à l’aide du protocole SOAP (Simple Object Access Protocol).

  • Cliquez sur Connexion de services REST pour créer une connexion à un script côté serveur à l’aide de services REST (Representational State Transfer).

  • Cliquez sur Connexion de fichiers XML pour créer une connexion à un fichier source XML.

Types de contenu externes

À l’aide de types de contenu externes, vous pouvez vous connecter à des sources de données externes et intégrer ces sources à votre site SharePoint et à vos applications clientes prises en charge. Une fois que vous avez créé un type de contenu externe, vous pouvez créer des listes externes qui permettent aux utilisateurs d’interagir avec les données comme s’il s’agissait d’une liste ou bibliothèque SharePoint.

Pour créer un type de contenu externe, procédez comme suit.

  1. Cliquez sur Types de contenu externes dans le volet Navigation.

  2. Sous l’onglet Types de contenu externes, cliquez sur Type de contenu externe, puis créez les opérations, les champs, etc. de votre type de contenu externe.

Haut de la page

Créer des affichages et des formulaires personnalisés

Dans SharePoint Designer 2010, vous pouvez créer des vues et formulaires personnalisés pour vos données sources, devient réellement l’interface pour lire et écrire des données à ces sources de données.

Affichages

Une vue est un affichage personnalisable live d’une source de données qui peut être ajouté à n’importe quelle page de SharePoint. Dans SharePoint Designer 2010 vous pouvez créer des affichages de liste (qui utilisent le composant WebPart Affichage de liste XSLT) et des vues de données (qui utilisent le composant WebPart Formulaire de données). Effectuez l’une des opérations suivantes pour créer un affichage de liste ou de données.

  • Dans le volet Navigation, cliquez sur Listes et bibliothèques, sélectionnez la liste pour laquelle vous souhaitez créer un affichage, puis sous l’onglet Paramètres de la liste, cliquez sur Mode Liste.

    Remarque : Cette étape crée un affichage qui est associé à la liste ou bibliothèque. Par conséquent, les utilisateurs voient l’affichage et peuvent le personnaliser à l’aide du groupe Gérer les affichages du Ruban SharePoint.

  • Dans le volet Navigation, cliquez sur Pages du site, modifiez la page dans laquelle vous souhaitez créer l’affichage, cliquez sur l’onglet Insertion, choisissez Vue de données, puis choisissez la liste ou bibliothèque SharePoint que vous souhaitez utiliser pour l’affichage.

Formulaires

Un formulaire est un affichage personnalisable d’une source de données que vous utilisez pour envoyer ou répondre à la source de données. Dans SharePoint Designer 2010 vous pouvez créer des formulaires de liste et les formulaires de données (à savoir utilisent le composant WebPart Formulaire de données). Effectuez l’une des opérations suivantes pour créer un formulaire de liste ou de données.

  • Dans le volet Navigation, cliquez sur Listes et bibliothèques, sélectionnez la liste pour laquelle vous souhaitez créer un formulaire, puis sous l’onglet Paramètres de la liste, cliquez sur Formulaire de liste.

  • Dans le volet Navigation, cliquez sur Pages du site, modifiez la page dans laquelle vous souhaitez créer le formulaire, cliquez sur l’onglet Insertion, choisissez Nouveau formulaire d’élément, Modifier le formulaire d’élément ou Afficher le formulaire d’élément et sélectionnez la source de données que vous souhaitez utiliser pour le formulaire.

Remarque : Outre les outils de création de formulaire dans SharePoint Designer 2010, vous pouvez créer et personnaliser des formulaires SharePoint à l’aide de Microsoft InfoPath 2010.

Haut de la page

Créer des flux de travail personnalisés

Dans SharePoint Designer 2010, vous pouvez gérer les processus d’entreprise à l’aide de flux de travail personnalisés. Flux de travail peut servir à gérer les processus d’application, ainsi que des processus collaboratifs humaines. Vous avez un certain nombre d’options lors de la création de flux de travail.

Créer des flux de travail dans SharePoint Designer 2010

Pour créer un flux de travail, vous pouvez le baser sur une liste ou une bibliothèque SharePoint ; vous pouvez créer un flux de travail réutilisable que vous pouvez appliquer à n’importe quelle liste ou bibliothèque et vous pouvez créer un flux de travail de site qui fonctionne au niveau du site.

Pour créer ces flux de travail, cliquez sur Flux de travail dans le volet Navigation, puis sous l’onglet Flux de travail, effectuez l’une des étapes suivantes :

  • Cliquez sur Flux de travail de liste et choisissez la liste à laquelle vous souhaitez associer le flux de travail.

  • Cliquez sur Flux de travail réutilisable pour créer un flux de travail réutilisable que vous pouvez associer à n’importe quelle liste ou bibliothèque.

  • Cliquez sur Flux de travail de site pour créer un flux de travail applicable au niveau du site.

Une fois que vous avez créé le flux de travail, utilisez le concepteur de flux de travail pour structurer les conditions, les actions et les étapes du flux de travail. Utilisez le concepteur de tâches pour gérer les événements associés à chaque tâche.

Importer des flux de travail à partir de Microsoft Visio 2010

Outre la création de flux de travail dans SharePoint Designer 2010, vous pouvez importer un flux de travail dans Microsoft Visio 2010 à l’aide de flux de travail fourni gabarits et modèles.

Pour importer un flux de travail, cliquez sur Flux de travail dans le volet Navigation, puis sous l’onglet Flux de travail, procédez comme suit :

  1. Cliquez sur Importer à partir de Visio, puis parcourez votre système de fichiers ou bibliothèque de documents SharePoint pour rechercher le fichier d’échange de flux de travail Visio (.vwi).

  2. Choisissez d’associer le flux de travail à une liste ou de le rendre réutilisable et cliquez sur Terminer.

  3. Commencez à personnaliser le flux de travail dans SharePoint Designer.

Haut de la page

Concevoir des pages de site, des pages maîtres et des mises en page

Dans SharePoint Designer 2010, vous pouvez créer et personnaliser des pages du site, pages maîtres et mises en page. Tandis que chacune de ces pages remplit des fonctions différentes, la page expérience d’édition est similaire. Vous pouvez ajouter et supprimer du texte, des images, des liens, tables, composants WebPart, les contrôles serveur et plus. Appliquer des définitions de style et feuilles de Style en cascade à vos pages maîtres et mises en page pour modifier l’apparence de votre site ou de la marque pour rechercher votre identité d’entreprise.

Pages de site

Pour créer une page de site, cliquez sur Pages du site dans le volet Navigation, puis sous l’onglet Pages, effectuez l’une des étapes suivantes :

  • Cliquez sur Page de composants WebPart pour créer une page qui contient des composants WebPart d’en-tête et de corps. En outre, elle sera associée à la page maître de votre site.

  • Cliquez sur Page et choisissez ASPX ou HTML pour créer une page de site vide, non associée à la page maître de votre site.

Pages maîtres

  • Cliquez sur Pages maîtres dans le volet Navigation, puis sous l’onglet Pages maîtres, cliquez sur Page maître vide.

Mises en page

  • Cliquez sur Mises en page dans le volet Navigation, puis sous l’onglet Mises en page, cliquez sur Nouvelle mise en page et choisissez le groupe et le nom du type de contenu sur lequel baser la mise en page.

Remarque : Pages maîtres et mises en page sont désactivées par défaut pour tous les utilisateurs à l’exception des administrateurs de collections de site. Si vous ne voyez pas l’option pour afficher ou modifier les pages maîtres ou mises en page dans SharePoint Designer 2010, contactez votre administrateur de site sur l’activation de ces options.

Haut de la page

Enregistrer en tant que modèle

Lorsque vous avez terminé de personnaliser votre site, vous pouvez en enregistrer l’intégralité ou certaines parties en tant que modèle afin que d’autres utilisateurs de votre organisation puissent utiliser ce modèle pour créer des listes, des affichages, des flux de travail, des pages de site, etc.

Vous pouvez également utiliser le modèle pour personnaliser davantage votre site dans un autre environnement ou par l’intermédiaire d’autres utilisateurs, comme dans le navigateur ou dans Microsoft Visual Studio.

Recherchez l’option Enregistrer en tant que modèle dans SharePoint Designer 2010 tirer parti de cette fonctionnalité.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Ces informations vous ont-elles été utiles ?

Comment pouvons-nous nous améliorer ?

Comment pouvons-nous nous améliorer ?

Afin de protéger votre vie privée, n’indiquez aucune information de contact dans vos commentaires. Lisez notre déclaration de confidentialité.

Nous vous remercions pour vos commentaires.